使用文件导出器以在 CAD 应用程序中创建原生 Autodesk Navisworks 文件

Autodesk Navisworks 提供了文件导出器，可用于在 CAD 应用程序中直接创建原生的 Autodesk Navisworks 文件。

当前，可以从 AutoCAD、MicroStation、Revit、ArchiCAD 和 Max 应用程序导出 NWC 文件。

可以在以下条件下使用文件导出器：

  • Autodesk Navisworks 无法读取原生的 CAD 文件格式。当前不支持下列原生文件格式：MAX、ArchiCAD。
  • Autodesk Navisworks 已经转换原生的 CAD 文件，但出现诸如缺少某个几何图形等情况，而您想要提高文件质量。

本节内容

  • AutoCAD 文件导出器
  • MicroStation 文件导出器
  • Revit 文件导出器
  • Max 文件导出器
  • ArchiCAD 文件导出器
请将您关于此页内容的评论发送给我们


AutoCAD 文件导出器

Autodesk Navisworks 提供的 ARX 插件适用于任何基于 AutoCAD™ 的产品（例如，Architectural Desktop™），使您可以将文件导出为 NWC 文件格式。

文件导出器仅适用于 AutoCAD 2019。早期版本必须使用相同的版本号，例如，基于 AutoCAD 2016 的产品必须使用 Navisworks 2016。

注意如果安装了带有导出器插件的 Autodesk Navisworks 软件，并在安装 Autodesk Navisworks 之后安装任何基于 AutoCAD 的软件，则需要使用适当的 ARX 插件更新导出器插件安装，然后才能进行使用。

请参见

  • DWG 文件导出器选项

本节内容

  • 添加 ARX 插件以与基于 AutoCAD 的应用程序一起使用
  • 使用 ARX 插件从基于 AutoCAD 的应用程序中导出文件
  • “消隐选项”对话框


添加 ARX 插件以与基于 AutoCAD 的应用程序一起使用

您既可以将 ARX 插件添加到导出器插件安装，也可以在基于 AutoCAD 的软件中手动载入它。

将 ARX 插件添加到 Autodesk Navisworks 导出器插件安装的步骤

  1. 在“控制面板”中，双击“添加/删除程序”。
  2. 在“添加或删除程序”对话框中，单击“Autodesk Navisworks 导出器插件”，然后单击“卸载/更改”（对于 Windows 7）。
  3. 在安装向导中，单击“添加或删除功能”。
  4. 在“选择要安装的导出器”页面上的“从其他应用程序导出”节点中，选中所需插件旁边的复选框。
  5. 单击“下一步”。
  6. 在“Autodesk Navisworks 更新导出器插件”页面中，单击“下一步”。
  7. 在“更新完成”页面上，执行更新后系统将通知用户。单击“完成”。

在基于 AutoCAD 的应用程序中加载 ARX 插件的步骤

  1. 在命令行上键入 ARX。
  2. 按回车键。
  3. 在命令行上，键入字母 L（表示“载入”）。
  4. 按回车键。
  5. 在“选择 ARX/DBX 文件”对话框中，浏览到 ARX 插件。
    注意对于基于 AutoCAD 20xx 的应用程序，该插件位于 C:\Program Files\Common Files\Autodesk Shared\Navisworks\2019\NWExport20xx\nwexport20xx.crx 下。例如，对于基于 AutoCAD 2015 的应用程序，该插件位于 C:\Program Files\Common Files\Autodesk Shared\Navisworks\2019\nwexport2015\nwexport2015.crx 下，依此类推。
  6. 单击“确定”载入 ARX 插件。


使用 ARX 插件从基于 AutoCAD 的应用程序中导出文件

您可以从命令行或使用 Autodesk Navisworks 菜单导出来自基于 AutoCAD 的应用程序的文件。

在可以使用 Autodesk Navisworks 菜单之前，需要先载入它。默认情况下，Autodesk Navisworks 菜单将添加到菜单浏览器中。在某些程序中，也可以将其添加到菜单栏。

使用命令行导出文件的步骤

  1. 要导出 NWC 文件，请在命令行上键入 NWCOUT。
  2. 按回车键。
  3. 在“另存为”对话框中，输入 Autodesk Navisworks 文件的名称，然后浏览到所需的存储位置。
  4. 单击“确定”导出文件，或单击“取消”返回到应用程序而不导出该文件。

加载 Autodesk Navisworks“导出”菜单的步骤

  1. 在命令行上，键入 MENULOAD。
  2. 按回车键。
  3. 在“载入/卸载自定义”对话框中，单击“浏览”。
  4. 在“选择自定义文件”对话框中，将“文件类型”更改为“原有菜单模板 (*.mnu)”，然后浏览到 Autodesk Navisworks 菜单文件。
    注意对于基于 AutoCAD 20xx 的应用程序，此文件位于 C:\Program Files\Common Files\Autodesk Shared\Navisworks\2019\NWExport20xx\lwnw_export.mnu 下。因此，例如对于基于 AutoCAD 2015 的应用程序，此文件位于 C:\Program Files\Common Files\Autodesk Shared\Navisworks\2019\NWExport2015\lwnw_export.mnu 下，依此类推。
  5. 单击“打开”。
  6. 在“载入/卸载自定义”对话框中，单击“载入”。

    载入的菜单将显示在“已载入的自定义组”中。

  7. 单击“关闭”。

使用 Autodesk Navisworks 菜单导出文件的步骤

  1. 单击位于应用程序窗口左上角的菜单浏览器按钮。
  2. 若要导出 NWC 文件，请在 Autodesk Navisworks 菜单中单击 Autodesk Navisworks 缓存”。
  3. 在“另存为”对话框中，输入 Autodesk Navisworks 文件的名称，然后浏览到所需的存储位置。
  4. 单击“确定”导出文件，或单击“取消”返回到应用程序而不导出该文件。

调整 DWG 文件导出器的选项的步骤

  1. 单击位于应用程序窗口左上角的菜单浏览器按钮。
  2. 在 Autodesk Navisworks 菜单中单击 Autodesk Navisworks“导出选项”。
  3. 展开“选项编辑器”中的“文件导出器”节点，然后单击“DWG”页面。使用此页面上的选项调整设置，以便将来从基于 AutoCAD 的应用程序导出 NWC 文件。
  4. 单击“确定”保存更改。
命令条目:


“消隐选项”对话框

在 AutoCAD 应用程序中安装了“AutoCAD 文件导出器”插件之后，在“导航器面板”中导航模型时，可以使用“消隐选项”对话框调整几何图形消隐。

区域
启用

指定是否使用区域消隐。

消隐以下对象的像素数

为屏幕区域指定一个像素值，低于该值就会消隐对象。例如，将该值设置为 100 像素意味着在该模型内绘制的大小小于 10x10 像素的任何对象会被丢弃。

背面

为所有对象打开背面消隐。从以下选项中选择：

  • 关闭。关闭背面消隐。
  • 实体。仅为实体对象打开背面消隐。这是默认选项。
  • 打开。为所有对象打开背面消隐。
近剪裁平面
最远的距离

指定相机与“近剪裁平面”位置之间的最远距离。

自动生成

指定 Autodesk Navisworks 是否自动控制“近剪裁平面”位置以提供模型的最佳视图。

远剪裁平面
最近的距离

指定相机与“远剪裁平面”位置之间最近的距离。

自动生成

指定 Autodesk Navisworks 是否自动控制“远剪裁平面”位置以提供模型的最佳视图。

提示如果要恢复默认值，请单击“默认值”按钮。


MicroStation 文件导出器

Autodesk Navisworks 提供了用于 MicroStation™ V8i 的 MDL 插件，使您可以将文件导出为 NWC 文件格式。

注意如果安装了带有导出器插件的 Autodesk Navisworks 软件，并在安装 Autodesk Navisworks 之后安装 MicroStation 软件，则需要使用适当的 ARX 插件更新导出器插件安装，然后才能进行使用。

请参见

  • DGN 文件导出器选项

将 MDL 插件添加到 Autodesk Navisworks 导出器插件安装的步骤

  1. 在“控制面板”中，双击“添加/删除程序”。
  2. 在“添加或删除程序”对话框中，单击“Autodesk Navisworks 导出器插件”，然后单击“卸载/更改”（对于 Windows 7）。
  3. 在安装向导中，单击“添加或删除功能”。
  4. 在“选择要安装的导出器”页面上的“从其他应用程序导出”节点中，选中所需插件旁边的复选框。
  5. 单击“下一步”。
  6. 在“Autodesk Navisworks 更新导出器插件”页面中，单击“下一步”。
  7. 在“更新完成”页面上，执行更新后系统将通知用户。单击“完成”。

本节内容

  • 载入 MDL 插件
  • 从键入命令行导出文件
  • 从命令行导出文件
  • 自定义 DGN 文件导出器选项


载入 MDL 插件

在可以使用 MDL 插件之前，需要先载入它。

既可以只对当前任务载入 MDL 插件，也可以将插件添加到默认配置，在后一种情况下，将针对所有将来任务载入 MDL 插件。

仅对当前任务载入 MDL 插件的步骤

  1. 单击“实用程序” [image] “键入”。
  2. 在“键入”对话框中，键入 mdl load nwexport12。
  3. 按回车键。

针对所有将来任务载入 MDL 插件的步骤

  1. 单击“工作空间” [image] “配置”。
  2. 在“配置”对话框的“类别”字段中，单击“设计应用程序”。
  3. 单击“可用应用程序”字段中的“NWEXPORT12”。
  4. 单击“添加”按钮。
  5. 单击“确定”，并确认您要将 NWEXPORT MDL 插件添加到默认配置。


从键入命令行导出文件

可以从键入命令行单独或成批导出文件。

还可以将命令添加到“键入”菜单以加快该过程。

使用键入命令行导出文件的步骤

  1. 单击“实用程序” [image] “键入”以打开“键入”对话框。
  2. 要导出 NWC 文件，请键入 nwcout。
    注意要快速导出当前设计文件，可以使用 batchnwcout 命令。浏览器在导出文件时将设计文件扩展名（通常为 .dgn）替换为 .nwc。使用此命令时，系统不会提示您覆盖任何现有文件，并且不显示导出对话框。
  3. 在 Autodesk Navisworks 的“导出文件”对话框中，浏览到所需的存储位置。

    导出器会自动提供文件名和视图号，如有必要，可以修改它们。选定的视图号可确定 Autodesk Navisworks 中的初始模型视图。

  4. 单击“确定”导出文件。

将 Autodesk Navisworks 导出命令添加到“键入”菜单的步骤

  1. 单击“工作空间” [image] “自定义”。
  2. 在“自定义”对话框的“菜单栏”选项卡中，展开“编辑菜单栏”字段中的“实用程序”选项。
  3. 单击“键入”选项，然后单击“插入”按钮。
  4. 在“插入菜单项”对话框中，输入“标签”，例如“导出 Autodesk Navisworks 缓存文件”。
  5. 在“键入”字段中，键入相应的命令，例如“nwcout”。
  6. 单击“确定”。
  7. 根据需要添加多个菜单项，然后单击“保存”。

    现在，添加的选项将出现在“实用程序” [image] “键入”菜单中。


从命令行导出文件

还可以使用 msbatch.bat 文件从命令行导出文件。当要设置自动脚本以导出文件时，msbatch.bat 文件将很有用。

注意要从命令行导出文件，请先将 MicroStation 程序目录添加到 Path 环境变量。

命令行导出器的格式为

msbatch nwexport12 [-f] FILE [OUTPUT]

FILE 是要导出的 MicroStation 文件的名称。这是唯一的必需选项。使用 OUTPUT 参数可以指定输出文件的名称。

默认情况下，导出器只转换那些自上次导出以来已经更改的文件。这对于加快大量文件的导出速度很有用。如果要强制导出器转换所有文件，请使用 -f 选项。

修改 Path 环境变量的步骤

  1. 在“控制面板”中，双击“系统”。
  2. 在“系统特性”对话框的“高级”选项卡中，单击“环境变量”按钮。
  3. 在“环境变量”对话框中，双击“系统变量”下的“Path”。
  4. 在“编辑系统变量”对话框中，将 MicroStation 应用程序的路径添加到“变量值”字段。
    注意必须用分号 (;) 分隔路径。
  5. 单击“确定”保存更改并关闭对话框。

使用命令行导出文件的步骤

  1. 对于 Windows 7，在键盘上按 Windows + R。
  2. 输入包含相应参数的文件导出命令，例如 msbatch nwexport11 file。
  3. 按 Enter 键。
  4. 在“MicroStation 管理器”对话框中，选择要导出的文件、文件扩展名 (NWC) 和存储位置。
  5. 单击“确定”。


自定义 DGN 文件导出器选项

该文件导出器仅从三维 DGN 文件导出 - 不支持二维文件。

Autodesk Navisworks 颜色源自 MicroStation 单元颜色或 MicroStation 材质，具体取决于选定的导出选项。Publisher 中对象的外观与 MicroStation 着色渲染器的外观匹配。

调整 DGN 文件导出器的选项的步骤

  1. 单击“实用程序” [image] “键入”以打开“键入”对话框。
  2. 键入 nwopt，然后按 Enter 键。
  3. 展开“选项编辑器”中的“文件导出器”节点，然后单击“DGN”页面。使用此页面上的选项调整设置，以便将来从 MicroStation 导出 NWC 文件。
  4. 单击“确定”保存更改。


Revit 文件导出器

Autodesk Navisworks 可以直接读取原生 Revit (RVT) 文件。或者，可以使用文件导出器以 NWC 格式保存文件。

文件导出器适用于 Revit 2019。

从 Revit 中导出 NWC 文件的步骤

  1. 在 Revit 中，单击“附加模块” [image] “外部工具” [image] Autodesk Navisworks。
    注意该选项在演示/观察器模式下不可用。如果未处于演示模式下，但无法访问 Autodesk Navisworks 菜单，请检查是否将编辑视图设置为“正常”，以及是否选择了修改工具（“编辑” [image] “修改”）。
  2. 在“导出场景为”对话框中，输入 Autodesk Navisworks 文件的名称，然后浏览到所需的存储位置。
  3. 单击“保存”导出文件，或单击“取消”返回到应用程序而不导出该文件。

调整 Revit 文件导出器的选项的步骤

  1. 在 Revit 中，单击“附加模块” [image] “外部工具” [image] Autodesk Navisworks。
  2. 在“导出场景为”对话框中，单击Autodesk Navisworks 设置”按钮。
  3. 展开“选项编辑器”中的“文件导出器”节点，然后单击“Revit”页面。使用该页面上的选项调整设置，以便将来从 NWC 导出 NWC 文件。
  4. 单击“确定”保存更改，然后返回到“将场景导出为”对话框。
  5. 单击“取消”关闭该对话框。


Max 文件导出器

Autodesk Navisworks 无法直接读取原生的 Max 文件。使用文件导出器以 NWC 格式保存文件，这种格式的文件可以在 Autodesk Navisworks 中打开。

文件导出器适用于 Max 2019。

注意如果安装了带有导出器插件的 Autodesk Navisworks 软件，并在安装 Autodesk Navisworks 之后安装了 Max 软件，则需要使用适当的 ARX 插件更新导出器插件安装，然后才能使用。

请参见

  • Max 文件导出器选项

从 Max 中导出 NWC 文件的步骤

  1. 单击“文件” [image] “导出”。
  2. 在“选择要导出的文件”对话框的“保存类型”字段中，选择“Autodesk Navisworks 缓存(*.nwc)”。
  3. 输入 Autodesk Navisworks 文件的名称，然后浏览到所需的存储位置。
  4. 单击“保存”导出文件，或单击“取消”返回到应用程序而不导出该文件。

添加 Autodesk Navisworks 实用程序菜单的步骤

  1. 单击“实用程序”面板上的“更多”按钮。
  2. 在“实用程序”对话框中，选择“Autodesk Navisworks”选项，然后单击“确定”。

自定义 3DS 文件导出器选项的步骤

  1. 在“实用程序”面板上的Autodesk Navisworks菜单上单击“选项编辑器”按钮。
  2. 展开“选项编辑器”中的“文件导出器”节点，然后单击“Max”页面。使用此页面上的选项调整设置，以便将来从 Max 应用程序导出 NWC 文件。


ArchiCAD 文件导出器

Autodesk Navisworks 无法直接读取原生的 ArchiCAD 文件。使用文件导出器以 NWC 格式保存文件，这种格式的文件可以在 Autodesk Navisworks 中打开。

文件导出器适用于 ArchiCAD v16 至 v19。

可以从二维和三维窗口中使用用于 ArchiCAD 的导出载入项。所有标准的 ArchiCAD 元素和库零件均可以导出，只要它们具有三维表示，而任何其他元素和库零件都将被忽略。该文件导出器可保存标准材质和自定义 GDL 脚本材质。

注意只能导出可见图层。

ArchiCAD 剖切平面设置不设定 Autodesk Navisworks 剖面；它用于导出由平面实际减少的项目。

支持的实体
  • 全局唯一标识符 (GUID)
  • 由 GDL 脚本定义的库零件的自定义参数
  • 层
  • 库零件实例
  • 相机
  • 热链接
  • 阳光属性
  • 材质
不支持的实体
  • 剖面
  • 点
  • 直线
  • 纹理

从二维窗口导出的步骤

  1. 单击“文件” [image] “另存为”。
  2. 在“另存为”对话框的“保存类型”字段中，选择“Autodesk Navisworks (*.nwc)”。
  3. 输入 Autodesk Navisworks 文件的名称，然后浏览到所需的存储位置。
  4. 单击“保存”开始导出过程。
  5. 在“导出”对话框中，调整文件导出器选项：
    • 导出 GUID - 选中该复选框可以将全局唯一标识符作为特性附加到模型中的每个项目。在 Autodesk Navisworks Manage 中，Clash Detective 使用 GUID 追踪碰撞。
    • 启用库零件实例 - 选中该复选框可以创建库零件实例而不创建新项目。仅当 ArchiCAD 模型中的多个库零件元素具有完全相同的特性时，才能执行此操作。创建这些零件的实例意味着 NWC 文件更小，导出时间更短。
      注意在剖分的模型中，选中此复选框后，所有实例均会显示与原始项目（通常情况下，文件中的第一个库零件）相同的剖面。如果获得某些意外的结果，请清除此复选框。
    • 导出库零件参数 - 选中该复选框可将库零件参数（包括用户定义的自定义参数）另存为 Autodesk Navisworks 中的项目特性。
    • 只导出当前层 - 选中该复选框可以只导出当前层。

      清除该复选框可以导出整个模型。默认视图由模型的边界框确定。

  6. 单击“确定”。

从三维窗口导出的步骤

  1. 单击“文件” [image] “另存为”。
  2. 在“另存为”对话框的“保存类型”字段中，选择“Autodesk Navisworks (*.nwc)”。
  3. 输入 Autodesk Navisworks 文件的名称，然后浏览到所需的存储位置。
  4. 单击“保存”开始导出过程。
  5. 在“导出”对话框中，调整文件导出器选项：
    • 导出 GUID - 选中该复选框可以将全局唯一标识符作为特性附加到模型中的每个项目。在 Autodesk Navisworks Manage 中，Clash Detective 使用 GUID 追踪碰撞。
    • 启用库零件实例 - 选中该复选框可以创建库零件实例而不创建新项目。仅当 ArchiCAD 模型中的多个库零件元素具有完全相同的特性时，才能执行此操作。创建这些零件的实例意味着 NWC 文件更小，导出时间更短。
      注意在剖分的模型中，选中此复选框后，所有实例均会显示与原始项目（通常情况下，文件中的第一个库零件）相同的剖面。如果获得某些意外的结果，请清除此复选框。
    • 导出库零件参数 - 选中该复选框可将库零件参数（包括用户定义的自定义参数）另存为 Autodesk Navisworks 中的项目特性。
    • 只导出当前层 - 不使用该选项，导出视图中包含的所有内容。

      从三维窗口中保存视图时，该视图将成为默认的 Autodesk Navisworks 视图（包括窗口设置，如剖切平面）。

  6. 单击“确定”。


选项编辑器

使用“选项编辑器”可为 Autodesk Navisworks 文件导出器调整设置。

这些选项会显示在分层树结构中。单击 [image] 会展开这些节点，单击 [image] 会收拢这些节点。

本节内容

  • “文件导出器”节点


“文件导出器”节点

使用此节点中的设置可配置直接从 CAD 应用程序中导出原生 Autodesk Navisworks 文件所需的文件导出器。

提示如果要恢复默认值，请单击“默认值”按钮。

本节内容

  • “DWG”页面
  • “Revit”页面
  • “DGN”页面
  • “Max”页面


“DWG”页面

使用此页面可调整 DWG 文件导出器的选项。

转换实体句柄

选中此复选框可转换实体句柄，并将它们附加到 Autodesk Navisworks 中的对象特性。

如果清除此复选框，文件导出器会忽略实体句柄。

转换冻结图层

选中此复选框可转换在 DWG 文件和 DXF 文件中冻结的图层。在 Autodesk Navisworks 中会将它们自动标记为隐藏。

如果清除此复选框，文件导出器会忽略冻结的图层。

转换组

选中此复选框可在 DWG 文件和 DXF 文件内保留组；这样会将另一个选择级别添加到“选择树”中。

如果清除此复选框，文件导出器会忽略组。

转换隐藏的 ADT 空间

指示是否转换在 DWG 文件中缺少任何可见三维几何图形的空间对象（例如，缺少楼板厚度或天花板厚度的对象）。

选中此复选框后，会在 Autodesk Navisworks 中显示相应的隐藏对象。

注意此选项不会影响在 DWG 文件中有可见三维几何图形的空间对象的正常行为。
转换线

选中此复选框可转换 DWG 文件和 DXF 文件中的线和圆弧。

如果清除此复选框，文件导出器会忽略线。

关闭转换

选中此复选框可转换在 DWG 文件和 DXF 文件中关闭的图层。在 Autodesk Navisworks 中会将它们自动标记为隐藏。

如果清除此复选框，文件导出器会忽略关闭的图层。

转换点

选中此复选框可转换 DWG 文件和 DXF 文件中的点。

如果清除此复选框，文件导出器会忽略点。

转换捕捉点

选中此复选框可转换 DWG 文件和 DXF 文件中的捕捉点。

如果清除此复选框，文件导出器会忽略捕捉点。

转换文字

选中此复选框可转换 DWG 文件和 DXF 文件中的文字。

如果清除此复选框，文件导出器会忽略文字。

转换视图

选中此复选框可将已命名的视图转换为 Autodesk Navisworks 视点。

如果清除此复选框，文件导出器会忽略视图。

转换外部参照

选中此复选框可自动转换包含在 DWG 文件内的任何外部参照文件。

如果要稍后在 Autodesk Navisworks 中自行附加文件，请清除此复选框。

默认十进制单位

选择 Autodesk Navisworks 用于打开使用十进制绘图单位创建的 DWG 文件和 DXF 文件的单位类型。

注意DWG 文件和 DXF 文件不指定创建时所使用的单位。要调整 Autodesk Navisworks 中的单位，请使用“单位和变换”选项。
默认字体

指定用于在 Autodesk Navisworks 中显示转换文字的默认字体。

转换点云

选中此复选框可转换 AutoCAD 点云实体。这适用于 AutoCAD 和 Autodesk Navisworks 2011 或更高版本。早期版本将忽略点云或显示代理图形（通常作为一个线框）。

如果清除此复选框，文件读取器会忽略点云。

点云详图

指定要从点云提取多少详图。有效条目在 1 到 100 之间，其中 100 表示所有点，10 表示大约 10% 的点，1 表示大约 1% 的点。

使用点云颜色

控制点云颜色。选中此复选框可将颜色值用于点云中的点。

清除此复选框时，会忽略点云中的点的任何颜色值，并会使用实体的普通 AutoCAD 颜色。存储的特定颜色太暗或无意义时，此选项很有用。

镶嵌面系数

输入所需的值可控制发生的镶嵌面的级别。

镶嵌面系数必须大于或等于 0，值为 0 时，将导致禁用镶嵌面系数。默认值为 1。要获得两倍的镶嵌面数，请将此值加倍。要获得一半的镶嵌面数，请将此值减半。镶嵌面系数越大，模型的多边形数就越多，且 Autodesk Navisworks 文件也越大。

载入材质定义

选中此复选框可从 DWG 文件提取材质定义。

如果清除此复选框，文件导出器会忽略材质定义。

材质搜索路径

Autodesk Navisworks 会自动搜索默认的 Autodesk 材质路径。

使用此框可指定 Autodesk Architectural Desktop 材质中使用的纹理文件的其他路径。请使用分号分隔路径。

最大镶嵌面偏差

此设置控制镶嵌面的边与实际几何图形之间的最大距离。

如果此距离大于“最大镶嵌面偏差”值，Autodesk Navisworks 会添加更多的镶嵌面。

如果将“最大镶嵌面偏差”设置为 0，则会忽略此功能。

合并 3D 面

指示文件导出器是否将具有相同颜色、图层和父项目的相邻面解释为“选择树”中的单个项目。

清除此复选框可将实体保持为“选择树”中的单独项目。

线处理

指定文件读取器如何处理线和多段线。选择下列选项之一：

  • 按颜色合并线。此选项会合并同一图层上或按颜色匹配的同一代理实体上的所有线。需要更加有效的文件处理和导航时使用此选项。
  • 根据规定。此选项按原始 DWG 指定线和多段线的方式读取线和多段线。
  • 分割所有线。此选项会为线的每一段将线元素拆分为单独的节点。

    需要增强碰撞检查分析时使用此选项。默认情况下，“Clash Detective”会将多段实体视为单个对象，为每个对象对报告一个碰撞。对多段线对象进行解组意味着每个线段可以独立于该线的其他段进行碰撞。因此，会报告所有可能的碰撞，而不仅仅是找到的第一个碰撞。Clash Detective 功能仅适用于 Autodesk Navisworks Manage 用户。

    重要信息为使此功能正常工作，需要将“模型” [image] “性能” [image] “转换时合并”下拉菜单项设置为“无”，否则，多段线对象将被合并为一个几何图形节点。
合并外部参照图层

选中此复选框可将外部参照文件中的图层与“选择树”中主 DWG 文件中的图层合并。

清除此复选框可使外部参照文件与“选择树”中的主 DWG 文件分开。

渲染类型

指定载入 DWG 文件时用于对象的渲染样式。

选择“自动”意味着 Autodesk Navisworks 会使用在 DWG 文件中保存的渲染样式。

如果几何图形未正确显示，请使用下列选项之一调整渲染样式：“渲染”、“着色”或“线框”。

按颜色拆分

可以根据颜色将复合对象拆分为多个部分。如果要使用此功能，请选中此复选框。

例如，可以将一个来自 Architectural Desktop 的窗对象拆分为一个窗框和一个窗格。如果清除此复选框，则仅可以作为一个整体选择窗对象，反之，如果选中此复选框，则可以选择单独的窗格和窗框。

注意 Autodesk Navisworks 将按其颜色命名复合对象的各个部分。
使用 ADT 标准配置

选中此复选框可使用标准显示配置转换 DWG 文件中的几何图形和材质。

清除此复选框可根据几何图形和材质是否显示在当前保存的显示配置中来转换它们。

请参见

  • AutoCAD 文件导出器


“Revit”页面

通过此页面可以调整 Revit 文件导出器的 NWC 导出选项。

转换结构件

当使用 Revit 2019 建筑建模和部件功能时，可以使用一个选项将原始对象或结构件导出到 Autodesk Navisworks 中。如果要导出结构件，请选中此复选框；如果要导出原始对象，请清除此复选框。

转换元素 ID

选中此复选框可导出每个 Revit 元素的 ID 数。

如果清除此复选框，文件导出器会忽略 ID。

转换元素参数

指定读取 Revit 参数的方式。从以下选项中选择：

  • 无 - 文件导出器不转换参数。
  • 元素 - 文件导出器转换所有找到的元素的参数。
  • 所有 - 文件导出器转换所有找到的元素（包括参照元素）的参数。这样，会在 Autodesk Navisworks 中提供额外的特性选项卡。
转换链接 CAD 格式

Revit 项目可以将外部文件作为链接嵌入。如果选中此复选框，链接 CAD 文件（例如 DXF、DGN、SAT 和 SketchUp 格式）将包含在导出的 NWC 文件中。默认情况下会清除此复选框。

转换链接文件

Revit 项目可以将外部文件作为链接嵌入。如果选中此复选框，链接 RVT 文件将包含在导出的 NWC 文件中。默认情况下会清除此复选框。

注意只能导出链接 RVT 文件；链接 DWG 和任何其他文件格式均不受支持。
房间转换为属性

指示房间属性是否受支持。默认情况下，此复选框处于选中状态，并且每个房间的数据将转换为一个共享房间属性。

转换 URL

指示是否转换 URL 特性数据。默认情况下，此复选框处于选中状态，并且超链接在已转换的文件中受支持。

坐标

指定是使用共享坐标还是内部坐标进行文件聚合。默认情况下，将使用共享坐标。可以在 Revit 之外查看和修改共享坐标。

导出

指定导出几何图形的方式。从以下选项中选择：

  • 整个项目 - 导出项目中的所有几何图形。
  • 当前视图 - 导出当前可见的所有几何图形。
  • 选择 - 仅导出当前选定的几何图形。
导出房间几何图形

指示是否导出房间几何图形。

尝试查找丢失的材质

如果选中此复选框（默认选项），则文件导出器会为从导出丢失的材质查找匹配项。

注意如果结果将不适当的材质应用到模型几何图形，请清除此复选框以修复该问题。

请参见

  • Revit 文件导出器


“DGN”页面

使用此页面可调整三维 DGN 文件导出器的选项。

排列全局原点

指示 Autodesk Navisworks 是否将参照 DGN 文件中的全局原点与主 DGN 文件的原点对齐。

如果在附加 DGN 文件的同时选中此复选框，则会将其全局原点放置到同一位置。

转换隐藏项目

选中此复选框可转换 DGN 文件中隐藏的实体。Autodesk Navisworks 会将它们自动标记为隐藏。

如果清除此复选框，文件导出器会忽略隐藏的项目。

转换圆弧与线段

选中此复选框可转换 DGN 文件中的线、样条曲线、曲线、圆弧或椭圆。

转换 PDS 数据

选中此复选框可在转换 DGN 文件时从 Intergraph 的 Plant Design System™ 读取对象信息。

PDS 信息是从 Intergraph 的 DRV 文件读取的。文件导出器会查找与相同目录中的 DGN 文件具有相同基础名称的 DRV 文件。

如果清除此复选框，文件导出器会忽略 PDS 数据。

转换参照

选中此复选框可转换 DGN 文件中的参照文件。

如果清除此复选框，文件导出器会忽略参照文件。

转换文字

如果要将文本转换为 Autodesk Navisworks 中的快捷特性，请选中此复选框。

如果清除此复选框，则文件导出器会忽略 DGN 文件中的文字。

转换 TriCAD 数据

选中此复选框可在转换 DGN 文件时从 Triplan 的 TriCAD™ 读取对象信息。

如果清除此复选框，文件导出器会忽略 TriCAD 数据。

转换 TriForma 数据

选中此复选框可在转换 DGN 文件时从 Bentley 的 TriForma™ 读取对象信息。

如果清除此复选框，文件导出器会忽略 Tri-Forma 数据。

默认字体

指定用于在 Autodesk Navisworks 中显示转换文字的默认字体。

镶嵌面系数

输入所需的值可控制发生的镶嵌面的级别。

镶嵌面系数必须大于或等于 0，值为 0 时，将导致禁用镶嵌面系数。默认值为 1。要获得两倍的镶嵌面数，请将此值加倍。要获得一半的镶嵌面数，请将此值减半。镶嵌面系数越大，模型的多边形数就越多，且 Autodesk Navisworks 文件也越大。

忽略未解析参照

选中此复选框可忽略 DGN 文件中未解析的参照文件。

如果清除此复选框，文件导出器会尝试转换所有参照文件，并显示一个对话框以找到在运行时任何未解析的参照文件。

材质搜索路径

将一个用分号隔开的路径列表输入到 MicroStation 选项板文件 (.pal) 和材质文件 (.mat) 中。文件导出器会使用这些路径转换 MicroStation 材质。

最大镶嵌面偏差

此设置控制镶嵌面的边与实际几何图形之间的最大距离。

如果此距离大于“最大镶嵌面偏差”值，Autodesk Navisworks 会添加更多的镶嵌面。

如果将“最大镶嵌面偏差”设置为 0，则会忽略此功能。

合并圆弧与线段

如果要通过将具有相同颜色、级别和父项目的相邻线解释为单个项目来在“选择树”中降低模型的复杂性，请选中此复选框。

如果要在 Autodesk Navisworks 中将这些元素保留为单独的项目，请清除此复选框。

拆分线

此选项指导文件读取器对多段线对象进行解组。因此，会为线的每一段将线元素拆分为单独的节点。

需要增强碰撞检查分析时使用此选项。默认情况下，“Clash Detective”会将多段实体视为单个对象，为每个对象对报告一个碰撞。对多段线对象进行解组意味着每个线段可以独立于该线的其他段进行碰撞。因此，会报告所有可能的碰撞，而不仅仅是找到的第一个碰撞。Clash Detective 功能仅适用于 Autodesk Navisworks Manage 用户。

重要信息为了使此功能正常工作，必须清除“合并圆弧与线段”复选框，因为它比“拆分线”选项优先。此外，需要将“模型” [image] “性能” [image] “转换时合并”下拉菜单项设置为“无”，否则，多段线对象将被合并为一个几何图形节点。
外形合并阈值

指定 MicroStation 图形的顶点数。

如果顶点数小于或等于“模型体合并的临界值”，Autodesk Navisworks 会将处于相同级别上或在同一单元中且具有相同颜色的所有图形合并到一个“形状集”中。

显示隐藏项目

如果要在转换的 DGN 文件中显示所有实体，而不管实体是否隐藏，请选中此复选框。

注意要使用此选项，必须选中“转换隐藏项目”复选框。
TriForma 数据集搜索路径

输入一个用分号隔开的路径列表，文件读取器将使用此列表定位 Triforma 数据集文件。必须包含到用户定义数据集的路径。

使用级别标识

选中此复选框可从 MicroStation 启用级别符号。这使得 Autodesk Navisworks 中的项目从级别中获取其颜色而不是使用 MicroStation 中的默认元素颜色。

使用材质

指示是否导出 MicroStation 的材质并将其指定给元素。

选中此复选框可将与 MicroStation 场景中相同的纹理、漫反射、环境光和高光颜色指定给元素。

清除此复选框可将与 MicroStation 场景中相同的颜色指定给元素。

视图号

输入所需的值可选择要载入的特定视图。文件导出器在转换项目时使用此视图的级别可见性。

例如，输入 0 会使用第一个活动视图。

请参见

  • MicroStation 文件导出器


“Max”页面

使用此页面可调整 3DS 文件导出器的选项。

转换隐藏项目

选中此复选框可转换 3DS 文件中隐藏的实体。Autodesk Navisworks 会将它们自动标记为隐藏。

如果清除此复选框，文件导出器会忽略隐藏的项目。

转换用户特性

选中此复选框可将已在 Max 中定义的任何用户特性附加到已转换的 Autodesk Navisworks 项目。

如果清除此复选框，文件导出器会忽略用户特性。

预渲染场景

默认情况下会清除此复选框。

如果导出的文件缺少某些纹理贴图，请选中此复选框。这会强制 Max 进行内部渲染，并缓存所有纹理贴图。这样，所有纹理贴图都使用该模型导出。

请参见

  • Max 文件导出器


Autodesk Legal Notice

© 2018 Autodesk, Inc. All Rights Reserved. Except where otherwise noted, this work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License that can be viewed online at http://creativecommons.org/licenses/by-nc-sa/3.0/. This license content, applicable as of 16 December 2014 to this software product, is reproduced here for offline users:

CREATIVE COMMONS CORPORATION IS NOT A LAW FIRM AND DOES NOT PROVIDE LEGAL SERVICES. DISTRIBUTION OF THIS LICENSE DOES NOT CREATE AN ATTORNEY-CLIENT RELATIONSHIP. CREATIVE COMMONS PROVIDES THIS INFORMATION ON AN "AS-IS" BASIS. CREATIVE COMMONS MAKES NO WARRANTIES REGARDING THE INFORMATION PROVIDED, AND DISCLAIMS LIABILITY FOR DAMAGES RESULTING FROM ITS USE.

License

THE WORK (AS DEFINED BELOW) IS PROVIDED UNDER THE TERMS OF THIS CREATIVE COMMONS PUBLIC LICENSE ("CCPL" OR "LICENSE"). THE WORK IS PROTECTED BY COPYRIGHT AND/OR OTHER APPLICABLE LAW. ANY USE OF THE WORK OTHER THAN AS AUTHORIZED UNDER THIS LICENSE OR COPYRIGHT LAW IS PROHIBITED.

BY EXERCISING ANY RIGHTS TO THE WORK PROVIDED HERE, YOU ACCEPT AND AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE. TO THE EXTENT THIS LICENSE MAY BE CONSIDERED TO BE A CONTRACT, THE LICENSOR GRANTS YOU THE RIGHTS CONTAINED HERE IN CONSIDERATION OF YOUR ACCEPTANCE OF SUCH TERMS AND CONDITIONS.

1. Definitions

a. "Adaptation" means a work based upon the Work, or upon the Work and other pre-existing works, such as a translation, adaptation, derivative work, arrangement of music or other alterations of a literary or artistic work, or phonogram or performance and includes cinematographic adaptations or any other form in which the Work may be recast, transformed, or adapted including in any form recognizably derived from the original, except that a work that constitutes a Collection will not be considered an Adaptation for the purpose of this License. For the avoidance of doubt, where the Work is a musical work, performance or phonogram, the synchronization of the Work in timed-relation with a moving image ("synching") will be considered an Adaptation for the purpose of this License.

b. "Collection" means a collection of literary or artistic works, such as encyclopedias and anthologies, or performances, phonograms or broadcasts, or other works or subject matter other than works listed in Section 1(g) below, which, by reason of the selection and arrangement of their contents, constitute intellectual creations, in which the Work is included in its entirety in unmodified form along with one or more other contributions, each constituting separate and independent works in themselves, which together are assembled into a collective whole. A work that constitutes a Collection will not be considered an Adaptation (as defined above) for the purposes of this License.

c. "Distribute" means to make available to the public the original and copies of the Work or Adaptation, as appropriate, through sale or other transfer of ownership.

d. "License Elements" means the following high-level license attributes as selected by Licensor and indicated in the title of this License: Attribution, Noncommercial, ShareAlike.

e. "Licensor" means the individual, individuals, entity or entities that offer(s) the Work under the terms of this License.

f. "Original Author" means, in the case of a literary or artistic work, the individual, individuals, entity or entities who created the Work or if no individual or entity can be identified, the publisher; and in addition (i) in the case of a performance the actors, singers, musicians, dancers, and other persons who act, sing, deliver, declaim, play in, interpret or otherwise perform literary or artistic works or expressions of folklore; (ii) in the case of a phonogram the producer being the person or legal entity who first fixes the sounds of a performance or other sounds; and, (iii) in the case of broadcasts, the organization that transmits the broadcast.

g. "Work" means the literary and/or artistic work offered under the terms of this License including without limitation any production in the literary, scientific and artistic domain, whatever may be the mode or form of its expression including digital form, such as a book, pamphlet and other writing; a lecture, address, sermon or other work of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a musical composition with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography; a work of drawing, painting, architecture, sculpture, engraving or lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art; an illustration, map, plan, sketch or three-dimensional work relative to geography, topography, architecture or science; a performance; a broadcast; a phonogram; a compilation of data to the extent it is protected as a copyrightable work; or a work performed by a variety or circus performer to the extent it is not otherwise considered a literary or artistic work.

h. "You" means an individual or entity exercising rights under this License who has not previously violated the terms of this License with respect to the Work, or who has received express permission from the Licensor to exercise rights under this License despite a previous violation.

i. "Publicly Perform" means to perform public recitations of the Work and to communicate to the public those public recitations, by any means or process, including by wire or wireless means or public digital performances; to make available to the public Works in such a way that members of the public may access these Works from a place and at a place individually chosen by them; to perform the Work to the public by any means or process and the communication to the public of the performances of the Work, including by public digital performance; to broadcast and rebroadcast the Work by any means including signs, sounds or images.

j. "Reproduce" means to make copies of the Work by any means including without limitation by sound or visual recordings and the right of fixation and reproducing fixations of the Work, including storage of a protected performance or phonogram in digital form or other electronic medium.

2. Fair Dealing Rights. Nothing in this License is intended to reduce, limit, or restrict any uses free from copyright or rights arising from limitations or exceptions that are provided for in connection with the copyright protection under copyright law or other applicable laws.

3. License Grant. Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the rights in the Work as stated below:

  • a. to Reproduce the Work, to incorporate the Work into one or more Collections, and to Reproduce the Work as incorporated in the Collections;
  • b. to create and Reproduce Adaptations provided that any such Adaptation, including any translation in any medium, takes reasonable steps to clearly label, demarcate or otherwise identify that changes were made to the original Work. For example, a translation could be marked "The original work was translated from English to Spanish," or a modification could indicate "The original work has been modified.";
  • c. to Distribute and Publicly Perform the Work including as incorporated in Collections; and,
  • d. to Distribute and Publicly Perform Adaptations.
The above rights may be exercised in all media and formats whether now known or hereafter devised. The above rights include the right to make such modifications as are technically necessary to exercise the rights in other media and formats. Subject to Section 8(f), all rights not expressly granted by Licensor are hereby reserved, including but not limited to the rights described in Section 4(e).

4. Restrictions. The license granted in Section 3 above is expressly made subject to and limited by the following restrictions:

  • a. You may Distribute or Publicly Perform the Work only under the terms of this License. You must include a copy of, or the Uniform Resource Identifier (URI) for, this License with every copy of the Work You Distribute or Publicly Perform. You may not offer or impose any terms on the Work that restrict the terms of this License or the ability of the recipient of the Work to exercise the rights granted to that recipient under the terms of the License. You may not sublicense the Work. You must keep intact all notices that refer to this License and to the disclaimer of warranties with every copy of the Work You Distribute or Publicly Perform. When You Distribute or Publicly Perform the Work, You may not impose any effective technological measures on the Work that restrict the ability of a recipient of the Work from You to exercise the rights granted to that recipient under the terms of the License. This Section 4(a) applies to the Work as incorporated in a Collection, but this does not require the Collection apart from the Work itself to be made subject to the terms of this License. If You create a Collection, upon notice from any Licensor You must, to the extent practicable, remove from the Collection any credit as required by Section 4(d), as requested. If You create an Adaptation, upon notice from any Licensor You must, to the extent practicable, remove from the Adaptation any credit as required by Section 4(d), as requested.
  • b. You may Distribute or Publicly Perform an Adaptation only under: (i) the terms of this License; (ii) a later version of this License with the same License Elements as this License; (iii) a Creative Commons jurisdiction license (either this or a later license version) that contains the same License Elements as this License (e.g., Attribution-NonCommercial-ShareAlike 3.0 US) ("Applicable License"). You must include a copy of, or the URI, for Applicable License with every copy of each Adaptation You Distribute or Publicly Perform. You may not offer or impose any terms on the Adaptation that restrict the terms of the Applicable License or the ability of the recipient of the Adaptation to exercise the rights granted to that recipient under the terms of the Applicable License. You must keep intact all notices that refer to the Applicable License and to the disclaimer of warranties with every copy of the Work as included in the Adaptation You Distribute or Publicly Perform. When You Distribute or Publicly Perform the Adaptation, You may not impose any effective technological measures on the Adaptation that restrict the ability of a recipient of the Adaptation from You to exercise the rights granted to that recipient under the terms of the Applicable License. This Section 4(b) applies to the Adaptation as incorporated in a Collection, but this does not require the Collection apart from the Adaptation itself to be made subject to the terms of the Applicable License.
  • c. You may not exercise any of the rights granted to You in Section 3 above in any manner that is primarily intended for or directed toward commercial advantage or private monetary compensation. The exchange of the Work for other copyrighted works by means of digital file-sharing or otherwise shall not be considered to be intended for or directed toward commercial advantage or private monetary compensation, provided there is no payment of any monetary compensation in connection with the exchange of copyrighted works.
  • d. If You Distribute, or Publicly Perform the Work or any Adaptations or Collections, You must, unless a request has been made pursuant to Section 4(a), keep intact all copyright notices for the Work and provide, reasonable to the medium or means You are utilizing: (i) the name of the Original Author (or pseudonym, if applicable) if supplied, and/or if the Original Author and/or Licensor designate another party or parties (e.g., a sponsor institute, publishing entity, journal) for attribution ("Attribution Parties") in Licensor's copyright notice, terms of service or by other reasonable means, the name of such party or parties; (ii) the title of the Work if supplied; (iii) to the extent reasonably practicable, the URI, if any, that Licensor specifies to be associated with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and, (iv) consistent with Section 3(b), in the case of an Adaptation, a credit identifying the use of the Work in the Adaptation (e.g., "French translation of the Work by Original Author," or "Screenplay based on original Work by Original Author"). The credit required by this Section 4(d) may be implemented in any reasonable manner; provided, however, that in the case of a Adaptation or Collection, at a minimum such credit will appear, if a credit for all contributing authors of the Adaptation or Collection appears, then as part of these credits and in a manner at least as prominent as the credits for the other contributing authors. For the avoidance of doubt, You may only use the credit required by this Section for the purpose of attribution in the manner set out above and, by exercising Your rights under this License, You may not implicitly or explicitly assert or imply any connection with, sponsorship or endorsement by the Original Author, Licensor and/or Attribution Parties, as appropriate, of You or Your use of the Work, without the separate, express prior written permission of the Original Author, Licensor and/or Attribution Parties.
  • e. For the avoidance of doubt:
    • i. Non-waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme cannot be waived, the Licensor reserves the exclusive right to collect such royalties for any exercise by You of the rights granted under this License;
    • ii. Waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme can be waived, the Licensor reserves the exclusive right to collect such royalties for any exercise by You of the rights granted under this License if Your exercise of such rights is for a purpose or use which is otherwise than noncommercial as permitted under Section 4(c) and otherwise waives the right to collect royalties through any statutory or compulsory licensing scheme; and,
    • iii. Voluntary License Schemes. The Licensor reserves the right to collect royalties, whether individually or, in the event that the Licensor is a member of a collecting society that administers voluntary licensing schemes, via that society, from any exercise by You of the rights granted under this License that is for a purpose or use which is otherwise than noncommercial as permitted under Section 4(c).
  • f. Except as otherwise agreed in writing by the Licensor or as may be otherwise permitted by applicable law, if You Reproduce, Distribute or Publicly Perform the Work either by itself or as part of any Adaptations or Collections, You must not distort, mutilate, modify or take other derogatory action in relation to the Work which would be prejudicial to the Original Author's honor or reputation. Licensor agrees that in those jurisdictions (e.g. Japan), in which any exercise of the right granted in Section 3(b) of this License (the right to make Adaptations) would be deemed to be a distortion, mutilation, modification or other derogatory action prejudicial to the Original Author's honor and reputation, the Licensor will waive or not assert, as appropriate, this Section, to the fullest extent permitted by the applicable national law, to enable You to reasonably exercise Your right under Section 3(b) of this License (right to make Adaptations) but not otherwise.

5. Representations, Warranties and Disclaimer

UNLESS OTHERWISE MUTUALLY AGREED TO BY THE PARTIES IN WRITING AND TO THE FULLEST EXTENT PERMITTED BY APPLICABLE LAW, LICENSOR OFFERS THE WORK AS-IS AND MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND CONCERNING THE WORK, EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, WITHOUT LIMITATION, WARRANTIES OF TITLE, MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, NONINFRINGEMENT, OR THE ABSENCE OF LATENT OR OTHER DEFECTS, ACCURACY, OR THE PRESENCE OF ABSENCE OF ERRORS, WHETHER OR NOT DISCOVERABLE. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, SO THIS EXCLUSION MAY NOT APPLY TO YOU.

6. Limitation on Liability. EXCEPT TO THE EXTENT REQUIRED BY APPLICABLE LAW, IN NO EVENT WILL LICENSOR BE LIABLE TO YOU ON ANY LEGAL THEORY FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR EXEMPLARY DAMAGES ARISING OUT OF THIS LICENSE OR THE USE OF THE WORK, EVEN IF LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. Termination

  • a. This License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals or entities who have received Adaptations or Collections from You under this License, however, will not have their licenses terminated provided such individuals or entities remain in full compliance with those licenses. Sections 1, 2, 5, 6, 7, and 8 will survive any termination of this License.
  • b. Subject to the above terms and conditions, the license granted here is perpetual (for the duration of the applicable copyright in the Work). Notwithstanding the above, Licensor reserves the right to release the Work under different license terms or to stop distributing the Work at any time; provided, however that any such election will not serve to withdraw this License (or any other license that has been, or is required to be, granted under the terms of this License), and this License will continue in full force and effect unless terminated as stated above.

8. Miscellaneous

  • a. Each time You Distribute or Publicly Perform the Work or a Collection, the Licensor offers to the recipient a license to the Work on the same terms and conditions as the license granted to You under this License.
  • b. Each time You Distribute or Publicly Perform an Adaptation, Licensor offers to the recipient a license to the original Work on the same terms and conditions as the license granted to You under this License.
  • c. If any provision of this License is invalid or unenforceable under applicable law, it shall not affect the validity or enforceability of the remainder of the terms of this License, and without further action by the parties to this agreement, such provision shall be reformed to the minimum extent necessary to make such provision valid and enforceable.
  • d. No term or provision of this License shall be deemed waived and no breach consented to unless such waiver or consent shall be in writing and signed by the party to be charged with such waiver or consent.
  • e. This License constitutes the entire agreement between the parties with respect to the Work licensed here. There are no understandings, agreements or representations with respect to the Work not specified here. Licensor shall not be bound by any additional provisions that may appear in any communication from You. This License may not be modified without the mutual written agreement of the Licensor and You.
  • f. The rights granted under, and the subject matter referenced, in this License were drafted utilizing the terminology of the Berne Convention for the Protection of Literary and Artistic Works (as amended on September 28, 1979), the Rome Convention of 1961, the WIPO Copyright Treaty of 1996, the WIPO Performances and Phonograms Treaty of 1996 and the Universal Copyright Convention (as revised on July 24, 1971). These rights and subject matter take effect in the relevant jurisdiction in which the License terms are sought to be enforced according to the corresponding provisions of the implementation of those treaty provisions in the applicable national law. If the standard suite of rights granted under applicable copyright law includes additional rights not granted under this License, such additional rights are deemed to be included in the License; this License is not intended to restrict the license of any rights under applicable law.

Creative Commons Notice

Creative Commons is not a party to this License, and makes no warranty whatsoever in connection with the Work. Creative Commons will not be liable to You or any party on any legal theory for any damages whatsoever, including without limitation any general, special, incidental or consequential damages arising in connection to this license. Notwithstanding the foregoing two (2) sentences, if Creative Commons has expressly identified itself as the Licensor hereunder, it shall have all rights and obligations of Licensor.

Except for the limited purpose of indicating to the public that the Work is licensed under the CCPL, Creative Commons does not authorize the use by either party of the trademark "Creative Commons" or any related trademark or logo of Creative Commons without the prior written consent of Creative Commons. Any permitted use will be in compliance with Creative Commons' then-current trademark usage guidelines, as may be published on its website or otherwise made available upon request from time to time. For the avoidance of doubt, this trademark restriction does not form part of this License.

Creative Commons may be contacted at https://creativecommons.org/.

Certain materials included in this publication are reprinted with the permission of the copyright holder.

Creative Commons FAQ

Autodesk's Creative Commons FAQ can be viewed online at https://knowledge.autodesk.com/customer-service/share-the-knowledge, and is reproduced here for offline users.

Creative Commons is a simple, open licensing model which allows individuals to freely modify, remix, and share digital content created for learning and support.

Borrow from the Autodesk Learning, Support and Video libraries to build a new learning experience for anyone with any particular need or interest. It's out there. You can use it. It's yours.

In collaboration with Creative Commons, Autodesk invites you to share your knowledge with the rest of the world, inspiring others to learn, achieve goals, and ignite creativity.

What is Creative Commons?

Creative Commons (CC) is a nonprofit organization that offers a simple licensing model that frees digital content to enable anyone to modify, remix, and share creative works.

How do I know if Autodesk learning content and Autodesk University content is available under Creative Commons?

All Autodesk learning content and Autodesk University content released under Creative Commons is explicitly marked with a Creative Commons icon specifying what you can and cannot do. Always follow the terms of the stated license.

What Autodesk learning content is currently available under Creative Commons?

Over time, Autodesk will release more and more learning content under the Creative Commons licenses.

Currently available learning content:

  • Autodesk online help-Online help for many Autodesk products, including its embedded media such as images and help movies.
  • Autodesk Learning Videos-A range of video-based learning content, including the video tutorials on the Autodesk YouTube™ Learning Channels and their associated iTunes® podcasts.
  • Autodesk downloadable materials-Downloadable 3D assets, digital footage, and other files you can use to follow along on your own time.

Is Autodesk learning and support content copyrighted?

Yes. Creative Commons licensing does not replace copyright. Copyright remains with Autodesk or its suppliers, as applicable. But it makes the terms of use much more flexible.

What do the Autodesk Creative Commons licenses allow?

Autodesk makes some of its learning and support content available under two distinct Creative Commons licenses. The learning content is clearly marked with the applicable Creative Commons license. You must comply with the following conditions:

  • Attribution-NonCommercial-ShareAlike (CC BY-NC-SA) This license lets you copy, distribute, display, remix, tweak, and build upon our work noncommercially, as long as you credit Autodesk and license your new creations under the identical terms. Terms of this license can be viewed online at https://creativecommons.org/licenses/by-nc-sa/3.0/us/
  • Attribution-NonCommercial-No Derivative Works (CC BY-NC-ND) This license lets you copy, distribute, and display only verbatim copies of our work as long as you credit us, but you cannot alter the learning content in any way or use it commercially. Terms of this license can be viewed online at https://creativecommons.org/licenses/by-nc-nd/3.0/us/deed.en_US
  • Special permissions on content marked as No Derivative Works For video-based learning content marked as No Derivative Works (ND), Autodesk grants you special permission to make modifications but only for the purpose of translating the video content into another language.

These conditions can be modified only by explicit permission of Autodesk, Inc. Send requests for modifications outside of these license terms to creativecommons@autodesk.com.

Can I get special permission to do something different with the learning content?

Unless otherwise stated, our Creative Commons conditions can be modified only by explicit permission of Autodesk, Inc. If you have any questions or requests for modifications outside of these license terms, email us at creativecommons@autodesk.com.

How do I attribute Autodesk learning content?

You must explicitly credit Autodesk, Inc., as the original source of the materials. This is a standard requirement of the Attribution (BY) term in all Creative Commons licenses. In some cases, such as for the Autodesk video learning content, we specify exactly how we would like to be attributed.

This is usually described on the video's end-plate. For the most part providing the title of the work, the URL where the work is hosted, and a credit to Autodesk, Inc., is quite acceptable. Also, remember to keep intact any copyright notice associated with the work. This may sound like a lot of information, but there is flexibility in the way you present it.

Here are some examples:

"This document contains content adapted from the Autodesk® Maya® Help, available under a Creative Commons Attribution-NonCommercial-Share Alike license. Copyright © Autodesk, Inc."

"This is a Finnish translation of a video created by the Autodesk Maya Learning Channel @ www.youtube.com/mayahowtos. Copyright © Autodesk, Inc."

"Special thanks to the Autodesk® 3ds Max® Learning Channel @ www.youtube.com/3dsmaxhowtos. Copyright © Autodesk, Inc."

Do I follow YouTube's standard license or Autodesk's Creative Commons license?

The videos of the Autodesk Learning Channels on YouTube are uploaded under YouTube's standard license policy. Nonetheless, these videos are released by Autodesk as Creative Commons Attribution-NonCommercial-No Derivative Works (CC BY-NC-ND) and are marked as such.

You are free to use our video learning content according to the Creative Commons license under which they are released.

Where can I easily download Autodesk learning videos?

Most of the Autodesk Learning Channels have an associated iTunes podcast from where you can download the same videos and watch them offline. When translating Autodesk learning videos, we recommend downloading the videos from the iTunes podcasts.

Can I translate Autodesk learning videos?

Yes. Even though our learning videos are licensed as No Derivative Works (ND), we grant everyone permission to translate the audio and subtitles into other languages. In fact, if you want to recapture the video tutorial as-is but show the user interface in another language, you are free to do so. Be sure to give proper attribution as indicated on the video's Creative Commons end-plate. This special permission only applies to translation projects. Requests for modifications outside of these license terms can be directed to creativecommons@autodesk.com.

How do I let others know that I have translated Autodesk learning content into another language?

Autodesk is happy to see its learning content translated into as many different languages as possible. If you translate our videos or any of our learning content into other languages, let us know. We can help promote your contributions to our growing multilingual community. In fact, we encourage you to find creative ways to share our learning content with your friends, family, students, colleagues, and communities around the world. Contact us at creativecommons@autodesk.com.

I have translated Autodesk learning videos into other languages. Can I upload them to my own YouTube channel?

Yes, please do and let us know where to find them so that we can help promote your contributions to our growing multilingual Autodesk community. Contact us at creativecommons@autodesk.com.

Can I repost or republish Autodesk learning content on my site or blog?

Yes, you can make Autodesk learning material available on your site or blog as long as you follow the terms of the Creative Commons license under which the learning content is released. If you are simply referencing the learning content as-is, then we recommend that you link to it or embed it from where it is hosted by Autodesk. That way the content will always be fresh. If you have translated or remixed our learning content, then by all means you can host it yourself. Let us know about it, and we can help promote your contributions to our global learning community. Contact us at creativecommons@autodesk.com.

Can I show Autodesk learning content during my conference?

Yes, as long as it's within the scope of a noncommercial event, and as long as you comply with the terms of the Creative Commons license outlined above. In particular, the videos must be shown unedited with the exception of modifications for the purpose of translation. If you wish to use Autodesk learning content in a commercial context, contact us with a request for permission at creativecommons@autodesk.com.

Can I use Autodesk learning content in my classroom?

Yes, as long as you comply with the terms of the Creative Commons license under which the learning material is released. Many teachers use Autodesk learning content to stimulate discussions with students or to complement course materials, and we encourage you to do so as well.

Can I re-edit and remix Autodesk video learning content?

No, but for one exception. Our Creative Commons BY-NC-ND license clearly states that "derivative works" of any kind (edits, cuts, remixes, mashups, and so on) are not allowed without explicit permission from Autodesk. This is essential for preserving the integrity of our instructors' ideas. However, we do give you permission to modify our videos for the purpose of translating them into other languages.

Can I re-edit and remix Autodesk downloadable 3D assets and footage?

Yes. The Autodesk Learning Channels on YouTube provide downloadable 3D assets, footage, and other files for you to follow along with the video tutorials on your own time. This downloadable material is made available under a Creative Commons Attribution-NonCommercial-ShareAlike (CC BY-NC-SA) license. You can download these materials and experiment with them, but your remixes must give us credit as the original source of the content and be shared under the identical license terms.

Can I use content from Autodesk online help to create new materials for a specific audience?

Yes, if you want to help a specific audience learn how to optimize the use of their Autodesk software, there is no need to start from scratch. You can use, remix, or enrich the relevant help content and include it in your book, instructions, examples, or workflows you create, then Share-Alike with the community. Always be sure to comply with the terms of the Creative Commons license under which the learning content is released.

What are the best practices for marking content with Creative Commons Licenses?

When reusing a CC-licensed work (by sharing the original or a derivative based on the original), it is important to keep intact any copyright notice associated with the work, including the Creative Commons license being used. Make sure you abide by the license conditions provided by the licensor, in this case Autodesk, Inc.

Trademarks

The following are registered trademarks or trademarks of Autodesk, Inc., and/or its subsidiaries and/or affiliates in the USA and other countries: 123D, 3ds Max, ADSK, Alias, ArtCAM, ATC, AutoCAD LT, AutoCAD, Autodesk, the Autodesk logo, Autodesk 123D, Autodesk Alias, Autodesk Forge, Autodesk Fusion, Autodesk Inventor, AutoSnap, BIM 360, Buzzsaw, CADmep, CAMduct, Civil 3D, Configurator 360, Dancing Baby (image), DWF, DWG, DWG (design/logo), DWG Extreme, DWG TrueConvert, DWG TrueView, DWGX, DXF, Eagle, Ember, ESTmep, FBX, FeatureCAM, Flame, FormIt 360, Fusion 360, Fusion Lifecycle, The Future of Making Things, Glue, Green Building Studio, InfraWorks, Instructables, Instructables (stylized robot design/logo), Inventor, Inventor HSM, Inventor LT, Make Anything, Maya, Maya LT, Moldflow, MotionBuilder, Mudbox, Navisworks, Opticore, P9, Pier 9, PowerInspect, PowerMill, PowerShape, Publisher 360, RasterDWG, RealDWG, ReCap, ReCap 360, Remake, Revit LT, Revit, Scaleform, Shotgun, Showcase, Showcase 360, SketchBook, Softimage, Tinkercad, Tinkerplay, TrustedDWG, VRED.

All other brand names, product names or trademarks belong to their respective holders.

Disclaimer

THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE BY AUTODESK, INC. "AS IS." AUTODESK, INC. DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS.


评论？

请使用该表格将注释发送至负责该文档的 Autodesk 技术出版组。

主题标题和位置（请勿编辑）：
姓名（可选）：
         电子邮件（可选）：
评论：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢！