SOLIDWORKS 安装与管理

本指南介绍 SOLIDWORKS 产品单机安装和多个安装的安装、许可、升级和管理。

单机安装 | 调用多个安装
安装 在一台或几台计算机上安装。 | 安装 生成可调用到一系列客户端计算机的管理映像。
颁发许可 计算机激活或网络许可。 | 颁发许可 计算机激活或网络许可。
升级 将单台计算机升级到新发行版本。 | 升级 通过更新用于在多台计算机上进行安装的管理映像，将这些计算机升级到新版本。
管理 修改、修复、删除安装、升级到新版本。 | 管理 升级管理映像、客户端和网格许可管理员。

SOLIDWORKS 安装管理程序使您能够配置 SOLIDWORKS 产品组件的设置，包括 SOLIDWORKS、SOLIDWORKS Toolbox、SOLIDWORKS Electrical、SOLIDWORKS Manage、SOLIDWORKS PDM、SOLIDWORKS Visualize 和 SOLIDWORKS SolidNetWork License Manager。

SolidNetWork License Manager 可通过向网络中的客户端分发许可支持多个许可客户端。 这样就能够利用浮动许可，允许用户数量超过许可数量。

内容

  • 单机安装或管理映像

    您是否应在每台计算机上单独安装 SOLIDWORKSs 产品，或者应创建管理映像然后以一个命令将安装调用到所有客户端？

  • 检查系统及软件要求

    安装前，验证您的系统是否符合硬件、操作系统及 Microsoft 产品要求。SOLIDWORKS Electrical、SOLIDWORKS Visualize 和 eDrawings 等插件有其他要求。

  • 下载安装介质

    所有安装介质均可从 SOLIDWORKS 下载页面获得。

  • 安装 3DEXPERIENCE 应用程序

    如果您使用 3DEXPERIENCE Platform 管理数据，则可以购买 Collaborative Designer for SOLIDWORKS 角色，将您的 Desktop 环境连接到平台。


单机安装或管理映像

您是否应在每台计算机上单独安装 SOLIDWORKSs 产品，或者应创建管理映像然后以一个命令将安装调用到所有客户端？

如果您只在一台计算机上进行安装，或者如果您管理几十台或几百台计算机，则很容易做出选择。对于介于两者之间的情况，可考虑以下比较因素。

单机安装 | 管理映像
用户可进行自己的 SOLIDWORKS 管理。 | 系统管理员可使用选项编辑器自定义多个安装，可指定安装选项（如创建新的安装或更新现有安装）、以管理用户身份运行安装、在安装前或安装后运行外部命令、进行不同的产品分组等等。
进行安装的人员必须能够亲手操作计算机。 | 客户端计算机只要可从同一网络进行访问，则可位于远程位置。
您可以通过独立的设置，在不同计算机上安装不同版本、service pack 或产品。 | 通过使用选项编辑器，管理映像可在各个版本、service pack、产品及多个安装的设定之间保持一致。
计算机必须有网络或电子邮件可使用。 需要有网络或电子邮件连接才能激活 SOLIDWORKS 并下载文件。 从网络许可服务器获取许可时也需要网络访问。 | 要求有本地网络连接才可调用应用程序；客户端计算机上不要求有媒体驱动器。 客户端可自动进行更新。 所有从同一管理映像调用的客户端使用同样的 service pack。 若想保留多个版本，您可生成多个管理映像。 许可激活可自动化。 管理映像要求服务器上具有额外磁盘空间；客户端要求有与单机安装相同的空间。
父主题 SOLIDWORKS 安装与管理
检查系统及软件要求
下载安装介质
安装 3DEXPERIENCE 应用程序


检查系统及软件要求

安装前，验证您的系统是否符合硬件、操作系统及 Microsoft 产品要求。SOLIDWORKS Electrical、SOLIDWORKS Visualize 和 eDrawings 等插件有其他要求。

为确保成功安装及优化性能，请参阅系统要求。

父主题 SOLIDWORKS 安装与管理
单机安装或管理映像
下载安装介质
安装 3DEXPERIENCE 应用程序


下载安装介质

所有安装介质均可从 SOLIDWORKS 下载页面获得。

如果无法访问 SOLIDWORKS 下载页面，请联系您的增值经销商以获取 DVD。

要下载安装介质：

  1. 使用您的电子邮件地址和密码或您的 SOLIDWORKS 序列号，以订购服务客户身份登录到 SOLIDWORKS 下载页面。
  2. 在下载页面的选择版本中，选择年份。
  3. 选择 SOLIDWORKS 产品的 SOLIDWORKS 选项卡。
  4. 在“产品”区域中，选择 Service Pack。
    对于最新的主要发行版，请选择 SOLIDWORKS 产品版本 0.0。
  5. 单击接受协议并继续以接受许可协议的条款。
  6. 单击下载。
    您的 Web 浏览器将 SolidworksSetup.exe 下载到默认位置 C:\Users\Username\Downloads。
  7. 解压 SolidworksSetup.exe 到 Downloads 文件夹。
    您也可以解压 SolidworksSetup.exe 到您的首选位置。
  8. 使用管理权限运行 setup.exe。
  9. 在安装管理程序中，单击下载并共享所有文件。
    通过一次下载，在多台机器上创建单个安装或管理映像，然后按照提示完成此过程。

    安装管理程序将为您下载安装介质。

    此选项适用于：
    • 在少量机器上安装软件
    • 使用便携式驱动器或网络驱动器下载
    • 安装 service pack
    要有选择地下载安装文件，请按照提示选择手动下载方法。
父主题 SOLIDWORKS 安装与管理
单机安装或管理映像
检查系统及软件要求
安装 3DEXPERIENCE 应用程序


安装 3DEXPERIENCE 应用程序

如果您使用 3DEXPERIENCE Platform 管理数据，则可以购买 Collaborative Designer for SOLIDWORKS 角色，将您的 Desktop 环境连接到平台。

此角色提供对 3DEXPERIENCE 应用程序的访问，使 SOLIDWORKS Desktop 产品能够保存、搜索和管理平台上存储的数据。您还可以使用基于 Web 的 SOLIDWORKS Design Augmented 应用程序。有关安装详情，请参阅 安装。

您可以从 3DEXPERIENCE Platform（而非 SOLIDWORKS 安装管理程序）安装和许可这些应用程序。有关安装说明，请参阅 SOLIDWORKS 帮助中的使用 3DEXPERIENCE Platform 和 3DEXPERIENCE 应用程序 > 安装 3DEXPERIENCE 应用程序。

父主题 SOLIDWORKS 安装与管理
单机安装或管理映像
检查系统及软件要求
下载安装介质
https://help.solidworks.com


单机安装

内容

  • 在单台计算机上安装

    可通过多种安装方法在单台计算机上安装 SOLIDWORKS。

  • 单机安装的管理

    通常，单机安装的管理包括修改、修复、删除和升级安装。


在单台计算机上安装

可通过多种安装方法在单台计算机上安装 SOLIDWORKS。

SOLIDWORKS 安装管理程序会进行安装，并根据您所购买的产品定制安装过程。 在开始安装前：

  • 如果安装独立席位的 SOLIDWORKS，请准备好 SOLIDWORKS 序列号。
  • 核实您的因特网连接无故障。 要求有连接才能检查授权。
  • 创建 3DEXPERIENCE ID。有关创建 3DEXPERIENCE ID 的详细信息，请参见“https://www.3ds.com/support”。
  • 确认您是您帐户的指定管理员，或者您的管理员已将您列为联系人。

SOLIDWORKS 安装管理程序会安装各种 Microsoft 组件，其中包括 Microsoft Visual Studio Tools for Applications、Visual Basic 和 .NET Framework。如果计算机上未安装 Windows 必备组件的正确版本，SOLIDWORKS 安装管理程序会在安装 SOLIDWORKS 产品之前自动安装它们。

SOLIDWORKS Chromium Embedded Framework (CEF) 是 SOLIDWORKS 安装管理程序安装的另一个组件。其作用是显示 SOLIDWORKS 应用程序和 3DEXPERIENCE Platform 的内容。

SOLIDWORKS Login Manager 也由 SOLIDWORKS 安装管理程序安装。它允许登录到 3DEXPERIENCE Marketplace 和 3DEXPERIENCE 应用程序。

安装方法 流程摘要
从 SOLIDWORKS 下载页面下载

所有安装介质均可从 SOLIDWORKS 下载页面获得。

  1. 浏览到 SOLIDWORKS 下载页面。
  2. 使用 3DEXPERIENCE ID 登录。
  3. 在“下载”页面的选择版本中，选择年份。
  4. 单击 SOLIDWORKS 产品的 SOLIDWORKS 选项卡，然后在产品下选择 Service Pack。
  5. 单击接受协议并继续以接受许可协议的条款。
  6. 单击下载。
您必须具有正常工作的互联网连接，并且具有下载页面的登录访问权限。

如果无法访问下载页面，请联系您的增值经销商以获取安装介质。
使用服务器上的下载目录 在下载目录中双击 setup.exe。

必须能从安装 SOLIDWORKS 产品的计算机上访问下载目录，且下载目录必须包含所有的 SOLIDWORKS 安装文件，才能开始安装。如果您可接入因特网且拥有对下载目录的写入访问权，SOLIDWORKS 安装管理程序可帮助您查找缺少的文件。
使用 检查更新 更新现有的 SOLIDWORKS 安装 执行以下操作之一：
  • 在 SOLIDWORKS 中，单击 [image] > 检查更新。
  • 在 Windows 中，单击开始 > SOLIDWORKS 安装管理程序 > 检查更新。
您也可以单击开始 > SOLIDWORKS 安装管理程序 > SOLIDWORKS 后台下载程序。在 Windows 通知区域中，右键单击 SOLIDWORKS 后台下载程序，然后单击检查更新。
确保您的因特网连接无故障且您必须在计算机上具有管理员权限。

在 SOLIDWORKS 安装管理程序中，您还可以选择下载并共享所有文件选项，包括必备软件。 如果您要在几台计算机上安装软件，并要使用便携式驱动器或网络驱动器复制下载的文件，则此选项非常有用。 对安装 Service Pack 也很有帮助，因为一个安装文件中包含了完整的版本和 Service Pack。

当安装完成后，启动 SOLIDWORKS 应用程序并 激活许可。

要显示计算机上获许可产品的列表，请从 SOLIDWORKS 主菜单中 -
  • 单击 [image] > 我的产品
  • 在任务窗格中单击主页、SOLIDWORKS 资源 > 我的产品
  • 单击开始 > SOLIDWORKS 工具版本 > 我的产品。

对话框中的复选标记表示您或贵组织根据您的激活情况和网络许可证所拥有的产品。您也可以通过单击位于每个产品类别顶部的链接来了解有关 SOLIDWORKS 产品的更多信息。

如果您有 SOLIDWORKS 许可证，要在 Windows 中查看正在使用的许可证，请单击开始 > SOLIDWORKS 工具 <版本> > SolidNetWork License Manager 客户端 > 许可证使用情况选项卡。

父主题 单机安装
单机安装的管理


单机安装的管理

通常，单机安装的管理包括修改、修复、删除和升级安装。

内容

  • 修改安装

    假设已使用一组安装文件完成先前安装，您可以修改安装以安装未安装的产品或移除产品。 如果您通过 service pack 升级先前安装，则此选项不可用。

  • 修复安装

    如果您遇到所安装的 SOLIDWORKS 产品的问题，您可使用 SOLIDWORKS 安装管理程序来修复安装。

  • 将单机安装退回到先前的 Service Pack

  • 删除安装

    您可以在单台计算机或在服务器/客户端环境中删除安装。

  • 升级到新的发行版

    可使用多种方法将单机安装升级到新的 SOLIDWORKS 发行版。

  • 产品共存规则

    以下产品共存规则决定新产品如何安装及现有产品如何升级。

父主题 单机安装
在单台计算机上安装


修改安装

假设已使用一组安装文件完成先前安装，您可以修改安装以安装未安装的产品或移除产品。 如果您通过 service pack 升级先前安装，则此选项不可用。

如果安装了 SOLIDWORKS 并在之后购买了插件，则可以修改安装以包含新的插件。 您必须在每台单独机器上安装插件。

  1. 确认无激活的 SOLIDWORKS 进程。
  2. 在 Windows 中，依次选择设置 > 应用程序 > 安装的应用。
  3. 选择您要修改的 SOLIDWORKS 安装程序，然后单击 更改。
  4. 在 欢迎使用 SOLIDWORKS 安装管理程序 屏幕上，单击修复您的安装。
  5. 在序列号屏幕中，验证是否指定了适当的序列号。
  6. 在产品选择屏幕中，选择要安装或删除的产品。
    当修改安装时：
    • 默认情况下不会安装或删除任何产品，即使您指定了新的序列号。您必须更改每个产品或功能组件的安装操作。
    • 要查看对特定组件的预计操作，请单击该组件名称（而不是复选框）。预期的安装操作会出现在产品列表下方的信息字段中。
    • 您可以单击产品组件旁的复选框更改该组件的安装操作。（例如，如果您要安装或删除组件，可选中相应复选框指定要安装或删除的组件，或清除相应复选框指定不想安装或删除的组件。）
    • 当您从初始规格更改了组件安装操作时，列表中该组件旁会出现一个星号 (*)。
    • 如果零部件内含有可选安装子零部件，则该零部件旁会出现 [image] 图标。要查看零部件的可用子零部件，请单击 [image] 图标。
    • 如果零部件已展开，显示了可选子零部件，则该零部件旁会显示 [image] 图标。要折叠子零部件列表，请单击 [image] 图标。
  7. 在摘要屏幕中，单击现在修改。
  8. 在安装完成荧屏上单击完成。
父主题 单机安装的管理
修复安装
将单机安装退回到先前的 Service Pack
删除安装
升级到新的发行版
产品共存规则


修复安装

如果您遇到所安装的 SOLIDWORKS 产品的问题，您可使用 SOLIDWORKS 安装管理程序来修复安装。

要修复安装，您的计算机必须具有来自先前安装的所有源文件和所有应用的 Service Pack。这些必须位于最初安装它们的位置。

您可修复单机安装。您无法修复管理映像，您必须卸装然后重新安装管理映像。
  1. 打开 Windows 控制面板，然后单击程序 > 程序和功能。
  2. 右键单击您要修复的 SOLIDWORKS 版本，然后单击更改。
  3. 在欢迎使用 SOLIDWORKS 安装管理程序屏幕上，单击修复您的安装，然后单击下一步。
  4. 在要修复的产品 屏幕中，选择要修复的产品。
  5. 清除屏幕上的其它产品。
  6. 单击修复。
父主题 单机安装的管理
父主题 安装错误/安装已取消
修改安装
将单机安装退回到先前的 Service Pack
删除安装
升级到新的发行版
产品共存规则
恢复失败或取消的安装
请与 SOLIDWORKS 转售商联系


将单机安装退回到先前的 Service Pack

若要将单机安装退回到当前主要版本系列中先前的 Service Pack，请卸载计算机上当前安装的 service pack 版本，然后重新安装先前的版本。
父主题 单机安装的管理
修改安装
修复安装
删除安装
升级到新的发行版
产品共存规则


删除安装

您可以在单台计算机或在服务器/客户端环境中删除安装。

  1. 确认无激活的 SOLIDWORKS 进程。
  2. 如果您希望将 SOLIDWORKS 许可移到另一台计算机，请停用许可证，然后在此计算机上删除 SOLIDWORKS 安装。
    详细信息请参阅移动许可。
  3. 打开 Windows 控制面板，然后单击程序和功能。
  4. 选择要移除的产品组件，然后单击卸载。
    在某些情况下，您可能会发现给定的主要版本的多个 SOLIDWORKS Service Pack 组件。 要移除 SOLIDWORKS 主要发行版本，移除该主要版本的所有 Service Pack 单元。
  5. 在卸装荧屏上：
    1. 选定要移除的产品。
      默认会选中所有产品组件。
    2. 消除您不想移除的产品。
    3. 单击 高级选项 中的 更改。
      高级选项屏幕出现，“程序文件和文件夹”选项被选定。
    4. 选取一个或多个选项进行自定义卸载，或者选取所有选项进行完全卸载。
      默认情况下，SOLIDWORKS 安装管理程序执行完全卸载，并移除安装时添加的所有文件和文件夹。
    5. 单击返回到摘要。
    6. 在摘要屏幕上，展开高级选项显示卸装方法和条目。
    7. 单击移除项目。
父主题 单机安装的管理
父主题 多个安装的管理
修改安装
修复安装
将单机安装退回到先前的 Service Pack
升级到新的发行版
产品共存规则
将管理映像升级到新的发行版
Service Pack 产品更新管理
移动许可


升级到新的发行版

可使用多种方法将单机安装升级到新的 SOLIDWORKS 发行版。

您可在下列情况下升级到新版本：
  • 收到新的安装介质
  • 启动 SOLIDWORKS 时收到升级通知
  • 手动检查更新
  • 启动 SOLIDWORKS 安装管理程序的新实例

当安装新的主要版本时，可选择升级之前安装的主要版本或者同时安装新发行版。如果是为之前安装的主要版本安装 Service Pack 发行版，则会自动更新该发行版。

父主题 单机安装的管理
修改安装
修复安装
将单机安装退回到先前的 Service Pack
删除安装
产品共存规则

手动检查更新

如果您在计算机上具有管理员权限，则您可以使用下列方法之一检查安装的 SOLIDWORKS 版本是否有更新。

  • 在 SOLIDWORKS 中，单击 [image] > 检查更新。
  • 在 Windows 中，单击开始 > SOLIDWORKS 安装管理程序 > 检查更新。
您也可以单击开始 > Solidworks 安装管理程序 > SOLIDWORKS 后台下载程序。在 Windows 通知区域中，右键单击 SOLIDWORKS 后台下载程序，然后单击检查更新。

升级注意事项

可具有多个不同主要版本安装的产品并不始终支持主要升级，也不支持通过一次操作在主要版本之间进行升级的功能。

在此情况下，SOLIDWORKS 安装管理程序通过首先安装新版本，然后移除旧版本来模拟升级。 此时，核心 SOLIDWORKS 产品支持主要升级，而其他产品则不能。

此举的后果为：
  • 当在主要版本之间升级核心 SOLIDWORKS 产品时：
    • 您的现有安装位置不改变。
    • 如果在升级过程中发生错误或者您取消操作，则升级可退回。
  • 当在主要版本之间升级其它产品时：
    • 每个产品先作为新产品安装到新的位置，然后再删除原有安装。
    • 一旦开始，如果在升级过程中发生错误或者您取消操作，则升级不可退回。


产品共存规则

以下产品共存规则决定新产品如何安装及现有产品如何升级。

规则 | 示例
允许核心 SOLIDWORKS 产品的多个主要发行版本共存，但下述产品除外。 | SOLIDWORKS 2025 SP3.0 和 SOLIDWORKS Design 2026 SP0.0 可以在同一台计算机上共存。
不允许同一主要发行版本的多个 service pack 共存。 | SOLIDWORKS Design 2026 SP0.0 和 2026 SP1.0 不能在同一台计算机上共存。如果您在装有 SOLIDWORKS Design 2026 SP0.0 的计算机上安装 SOLIDWORKS Design 2026 SP1.0，SOLIDWORKS 安装管理程序会将 SP0.0 替换为 SP1.0。
以下产品在计算机上只允许有一个版本：
  • SolidNetWork License Manager
 如果安装了 SolidNetWork License Manager 2025 SP3.0，则 SolidNetWork License Manager 将升级到 2026 SP0.0，即使计算机上仍留有 SOLIDWORKS 的早期主要发行版本。
以下产品在计算机上只允许有一个版本：
  • SOLIDWORKS Electrical
 如果您创建 SOLIDWORKS Electrical 2026 SP1.0 的新安装，则 SOLIDWORKS 安装管理程序将自动从计算机中移除之前版本的 SOLIDWORKS Electrical。请在升级之前先备份您的 SOLIDWORKS Electrical 环境。
以下产品在计算机上只允许有一个版本：
  • SOLIDWORKS PDM 客户端
  • SOLIDWORKS PDM 服务器

如果您安装 SOLIDWORKS Design 2026 SP0.0 或 SP1.0，也应升级到 SOLIDWORKS 2026 PDM Server和 PDM Client。

如果您安装 SOLIDWORKS 2026 PDM Server，应使用 PDM Server 安装流程来安装 SOLIDWORKS PDM Client。不要使用客户端安装流程单独安装 SOLIDWORKS PDM Client。

SOLIDWORKS PDM 客户端必须与同一计算机上的 SOLIDWORKS PDM 服务器具有相同的发行版本和 service pack。

有关详细信息，请参见 SOLIDWORKS PDM 和 SOLIDWORKS Manage。

SOLIDWORKS 的任何主要发行版本只可安装所包括产品的一个版本。 但是，来自不同 SOLIDWORKS 主要发行版本的所包括产品的各个版本可以共存。 | 如果将 SOLIDWORKS Design 2026 SP0.0 升级到 2026 SP1.0，SOLIDWORKS Composer 20265 SP0.0 将自动升级到 2026 SP1.0，但 SOLIDWORKS Composer 2025 SP4.0 可与 SOLIDWORKS Composer 2025 SP0.0 或 SOLIDWORKS Composer 2026 SP1.0 共存。
父主题 单机安装的管理
修改安装
修复安装
将单机安装退回到先前的 Service Pack
删除安装
升级到新的发行版


多个安装

内容

  • 调用到多个客户端

    您可通过创建管理映像并将安装部署到客户端以在多个客户端上安装 SOLIDWORKS 产品。

  • 使用管理映像

    管理映像可用于从单一网络位置进行 SOLIDWORKS 产品的可配置安装。

  • 命令行调用

    您可使用命令提示符/批处理文件自动调用管理映像（无声安装）。

  • 多个安装的管理

    多个安装的管理任务包括将管理映像升级到新发行版、应用 service pack 更新以及删除安装。


调用到多个客户端

您可通过创建管理映像并将安装部署到客户端以在多个客户端上安装 SOLIDWORKS 产品。

调用到多个客户端的过程为：
  1. 创建管理映像。
    • 从 SOLIDWORKS 安装管理程序创建管理映像
  2. 将管理映像部署到客户端。
    • 通过（电子邮件）手动/提取方法将管理映像部署到客户端
    • 通过自动/推送方法将管理映像部署到客户端
    • 通过命令行从管理映像安装
  3. 实施许可。
    • 管理个人许可
    • 使用 SolidNetWork License Manager 管理许可
父主题 多个安装
使用管理映像
命令行调用
多个安装的管理


使用管理映像

管理映像可用于从单一网络位置进行 SOLIDWORKS 产品的可配置安装。

您可从网络上的任何计算机安装管理映像，包括客户端计算机。
  • 管理映像必须位于共享文件夹中。
  • 如果您包括所有产品，则管理映像磁盘空间可占用 17GB 或更多。
  • 如果在升级管理映像时更新共享名称，则在应用程序下次启动时客户端会自动升级。有关详细信息，请参阅 升级管理映像。
  • 部署管理映像时，映像路径必须少于 58 个字符。
  • 要求客户端在其计算机上具有管理员特权。如果客户端没有足够的权限，客户端可以作为不同用户运行安装。当个人用户在计算机上没有本地管理权限（安装 SOLIDWORKS 产品所需的权限）时，此选项非常有用。

    请参阅 从选项编辑器调用安装。其中介绍了客户端没有足够的权限时安装映像的备选方法。

  • 如果启用 Windows 记录或如果您使用“管理图像选项编辑器”中的状态功能，您必须具备此文件夹的读/写权限：{Administrative image directory}\x64\Logs。

生成管理映像后，管理映像选项编辑器可以为从该映像进行安装的用户和组管理安装选项设置。 有关详细信息，请参阅 管理映像选项编辑器。

内容

  • 管理映像的类型

    您可以使用管理映像选项编辑器为远程用户和您网络上的用户创建多种类型的映像。

  • 从 SOLIDWORKS 安装管理程序创建管理映像

    如果要在多台计算机上安装 SOLIDWORKS，您可以创建管理映像，然后将应用程序调用到其他计算机上。

  • 管理映像选项编辑器

    使用管理映像选项编辑器可以在管理映像中为机器组和单机自定义安装参数设定。

  • 设置管理员工具

父主题 多个安装
调用到多个客户端
命令行调用
多个安装的管理
从管理映像升级客户端


管理映像的类型

您可以使用管理映像选项编辑器为远程用户和您网络上的用户创建多种类型的映像。

管理映像类型 | 描述
标准 | 此映像是所有新管理映像的默认设置。 它是标准的 Windows 安装程序管理映像，非常适合对公司网络具有可靠访问权限的用户。 它将安装所选 SOLIDWORKS 产品所需的所有文件存储在共享映像文件夹中。 当用户升级到新的 Service Pack 时，他们可以下载和应用修补程序文件，而不需要下载整个映像。
远程客户端 | 此映像专为无法可靠访问公司网络的远程用户而设计。 安装此类映像时，远程用户将沿用您指定的所有安装选项，如序列号和要安装的产品。 用户可以通过互联网从 SOLIDWORKS 下载页面下载所需文件。从互联网访问和安装这些文件比从公司网络下载更可靠，并且可能会减少网络负载。 远程用户使用标准管理映像支持的相同技术安装此映像。 您仍然可以使用 sldim.exe 和 startwinstall.exe 文件编写安装脚本。 安装文件在安装之前下载到管理映像选项编辑器中指定的路径。 用户必须访问管理映像文件夹才能开始安装并运行在该文件夹中托管的任何批处理或设置文件。 远程用户必须有足够的可用磁盘空间来存储映像中的所有文件，但用户可以在安装完成后删除映像。
压缩 | 压缩管理映像适用于需要将管理映像下载到多个站点或客户端计算机并希望将对网络的影响降至最低的组织。 此映像比标准管理映像小 60%，但安装时间相同。 它支持所有安装操作，如修改和修复。 压缩管理映像也具有简短的文件路径。 这可避免映像存储在深文件夹结构中时出现问题。 当用户升级到新的 Service Pack 时，他们必须下载整个映像，而不仅仅是下载修补程序。
父主题 使用管理映像


从 SOLIDWORKS 安装管理程序创建管理映像

如果要在多台计算机上安装 SOLIDWORKS，您可以创建管理映像，然后将应用程序调用到其他计算机上。

  1. 启动 SOLIDWORKS 安装管理器。

    请参阅 下载安装介质。

  2. 在欢迎屏幕上，选择创建管理映像以部署到多台计算机，然后选择以下选项之一：
    选项 | 描述
    使用默认设定生成新映像。 | 使用默认配置设置创建映像（也就是说，不依据为您站点的现有管理映像建立的设置。)
    使用现有映像的设定和文件生成新映像。 | 使用为您站点的现有管理映像指定的配置设定生成映像。 单击 浏览，为现有管理映像指定安装目录。
  3. 输入 SOLIDWORKS 序列号。
  4. 单击更改以修改产品或默认选项，其中包括：
    • 管理映像位置
    • 管理映像类型
  5. 接受许可协议，然后单击现在生成。
  6. 单击自定义映像以在管理映像选项编辑器中打开和显示设置。
  7. 可选： 单击创建桌面快捷方式以访问桌面上的映像。
父主题 使用管理映像


管理映像选项编辑器

使用管理映像选项编辑器可以在管理映像中为机器组和单机自定义安装参数设定。

创建管理映像后，SOLIDWORKS 安装管理程序会要求您启动选项编辑器。 您也可通过在管理映像文件夹中双击 sldAdminOptionEditor.exe 开启选项编辑器。

要为成组机器或单台机器指定不同的安装配置，请在“选项编辑器”中选择机器。然后，为这些机器指定安装选项。

所有提示您输入文件或文件夹路径的对话框都包含一个将所选文件夹映射到环境变量的选项。例如，如果选择 C:\Program Files\SOLIDWORKS Corp，则文件路径将映射到 %ProgramFiles%\SOLIDWORKS Corp。最常见的变量是 %ProgramFiles% 和 %SystemDrive%。

不能将所有路径都映射到环境变量。例如，不能将 Z:\SOLIDWORKS Data 映射到环境变量。

内容

  • 添加和删除组和机器

    使用管理映像选项编辑器可以为机器组和单机指定不同的安装配置。

  • 查看和编辑选项设置

    SOLIDWORKS 管理映像选项编辑器可以查看和更改为映像指定的组和机器的选项设置。

  • 从选项编辑器调用安装

    您可以使用手动或推送方法，直接从“选项编辑器”中部署安装。

  • 退出选项编辑器

    您可单击“确定”或“关闭”以应用更改并退出选项编辑器。

  • 为选项编辑器生成桌面快捷方式

    您可以为选项编辑器创建 Windows 桌面快捷方式，用于来自应用程序内的特定管理映像。

  • 通过电子邮件将管理映像调用到客户端

    一旦创建好共享管理映像目录后，即可通过电子邮件通知客户端。

父主题 使用管理映像


添加和删除组和机器

使用管理映像选项编辑器可以为机器组和单机指定不同的安装配置。

例如，您可以将某几台机器配置为使用映像中可用产品零部件的一个子集，而将另一个组配置为使用零部件的另一个子集。 尽管使用的是同一个管理映像，选项编辑器组设定使您可为不同的机器组安装不同的产品子集。 您还可以在组之间移动设置和编辑机器组。

您还可以将机器组划分为子组。 子组从父组继承设置，但您可以更改每个子组的各项设置。

要添加组：
  1. 右键单击全局设置，然后单击添加组。
  2. 输入组名称。

要添加机器：
  1. 右键单击一个现有组或全局设置，然后单击添加机器。
    如果右键单击现有的组，则会将机器添加到该组中。 否则会将机器添加到顶层。
  2. 执行以下操作之一：
    • 选择按机器名称并输入机器名称。
      机器名称不能包含域限定符。例如 pluto.solidworks.com 是无效的。
    • 选择按 IP 地址，然后输入机器的 IP 地址。
    • 选择按 IP 地址范围，然后输入范围的起始 IP 地址和结束 IP 地址。
    • 单击添加多台机器以输入机器名称。您可以使用换行符、空格、制表符、逗号、句点、冒号或分号来分隔机器名称。您也可以从带分隔符的文件（如 *.xls 或 *.cvs 文件）中复制机器名称列表并粘贴到对话框中。

    如果按名称、IP 地址和 IP 地址范围添加机器，安装机器将按以下顺序查找匹配项：机器名称、IP 地址、IP 地址范围。安装选项将根据找到的第一个匹配项应用于安装机器。

要将现有机器移动到组或子组：

将机器拖动到组或子组上。

要将机器从组或子组中移出：

将机器拖动到全局设定上或者其他组或子组上。

要删除组、子组或机器：

右键单击组、子组或机器，然后单击删除组或删除机器。

如果删除组，则组中的所有机器将一并删除。

要删除所有组和机器：

右键单击全局设置，然后单击删除所有。

父主题 管理映像选项编辑器
查看和编辑选项设置
从选项编辑器调用安装
退出选项编辑器
为选项编辑器生成桌面快捷方式
通过电子邮件将管理映像调用到客户端


查看和编辑选项设置

SOLIDWORKS 管理映像选项编辑器可以查看和更改为映像指定的组和机器的选项设置。

  • 初次启动选项编辑器时，选项设置以只读模式显示。 “更改”图标 [image] 未上色。

    单击全局设置，组或机器将显示该项目的选项设置摘要：

    范围 | 显示的选项设置
    整体设定 | 为管理映像指定的所有选项设置
    组 | 与整体设定有关的组设置中的更改
    机床 | 与组有关的机器设置中的更改
  • 要更改选项设置，请单击更改 [image] 。 该图标将上色并且显示更详细的选项设置列表。

    单击全局设置，组或机器让您可以更改该项目的选项设置。 当您对选项设置的更改不同于继承的全局设置或组设置时，该选项设置将高亮显示。

    如果您再次单击更改 [image] ，则显示将恢复为只读模式。

    如果进行了更改，则选项编辑器会在退出时提示您保存或放弃更改。

内容

  • 指定组和机器的选项设置

    您可以为所有机器（整体设定）、机器组及单机指定选项设定。

  • 管理映像选项设置

    选项编辑器可让您为单独客户端或组指定选项设置，包括序列号、客户端安装选项、要安装哪些软件组件以及 Toolbox 的位置。

  • 继承整体和组选项设置

    整体设定或组的选项设置由其下的项目继承。

  • 每个机器的自定义设置

    您还可以通过右键单击机器名称来修改已应用到特定机器的设置。

父主题 管理映像选项编辑器
添加和删除组和机器
从选项编辑器调用安装
退出选项编辑器
为选项编辑器生成桌面快捷方式
通过电子邮件将管理映像调用到客户端


指定组和机器的选项设置

您可以为所有机器（整体设定）、机器组及单机指定选项设定。

  1. 在选项编辑器中，单击要修改的对象（全局设置、一个组或一台机器）。
  2. 在右侧单击更改 [image] 。
    该图标将上色并且显示更详细的选项设置列表。
  3. 在列表左侧选择条目，然后单击右侧的选项设定做出相应更改。
    选项设定中覆盖全局设置或组设置的更改将高亮显示。
  4. 单击确定或关闭以保存您的更改。
    选项 | 描述
    确定 | 选项编辑器保存您的更改并退出。
    关闭 | 选项编辑器将会询问您是否要保存所作的更改并退出。
父主题 查看和编辑选项设置
管理映像选项设置
继承整体和组选项设置
每个机器的自定义设置


管理映像选项设置

选项编辑器可让您为单独客户端或组指定选项设置，包括序列号、客户端安装选项、要安装哪些软件组件以及 Toolbox 的位置。

序列号

输入序列号以在客户端计算机上安装产品。
由于有多种办法购买 SOLIDWORKS 产品，有些序列号可覆盖两个或多个产品。例如，SOLIDWORKS 序列号可让您在安装 SOLIDWORKS Simulation 时不必输入单独的 SOLIDWORKS Simulation 序列号。此外，有些产品不需要序列号。如果您对序列号有任何疑问，请联系您的增值经销商 （VAR）。
如果您使用 SolidNetWork 许可管理许可：
  • 在第一个序列号字段中，输入 SolidNetWork 序列号。
  • 在 SNL Server port@server 字段中，输入 SolidNetWork License Manager 服务器名和端口，格式为 nnnnn@servername。 使用分号分隔多个条目。

有关 SolidNetWork 许可的详细信息，请参阅 安装 SolidNetWork 许可概述。

客户端安装选项

您想如何进行主要版本的客户端安装? 您可以指定客户端安装如何处理之前已有的主要版本安装：
  • 升级现有主要版本(如果有)。

    指定此选项可使用新版本安装替换之前的主要版本安装。

  • 创建新的主要版本。

    指定此选项可保留之前的主要版本，并为新的主要版本重新创建安装。 要指定新版本安装位置，请单击浏览。
您想在安装新主要版本之前卸装最新先前版本吗? 您可指定是否在安装主要版本之前卸装现有版本：
  • 请勿卸载。

    指定此选项以保留先前主要版本的安装。

  • 卸载最新版本。
  • 卸载所有版本。
您想如何应用 SOLIDWORKS 设置？ 您可以在启动软件时指定设置文件。客户端安装参考设置文件。在对所有安装可见的共享 UNC 路径上存储设置 (*.sldsettings) 文件。在安装 SOLIDWORKS 之前指定 *.sldsettings 路径。客户端安装在安装过程中检测 *.sldsettings 文件路径。
指定 Windows 文件权限以仅允许指定用户拥有写入访问权限，从而保护 *.sldsettings 文件。

要创建或编辑 *.sldsettings，请单击启动设置管理员。SOLIDWORKS Settings Administrator 工具可让您定义要应用哪些 SOLIDWORKS 系统选项，并可以选择为最终用户锁定。您也可以定义如何及何时将设置应用到各个安装，还可以随时运行“设置管理员”工具并覆盖现有 *.sldsettings 文件以对其进行修改。

您可以为不同的计算机或组使用不同的 *.sldsettings 文件。

*.sldsettings 的路径在安装时设置。部署后，不应重命名或移动 *.sldsettings 文件。

您必须具备现有 SOLIDWORKS [当前主要版本] 安装才能运行 Settings Administrator 工具。
您想如何激活客户端安装? 您可以指定是在运行安装后自动完成产品激活，还是要求用户在安装后手工进行产品激活。
  • 在每个客户端安装完成时自动激活。

    选择此选项设置可指定产品激活自动运行。输入在客户端计算机上运行激活时将提供的电子邮件地址。

  • 不自动激活。

    选择该选项设定指定无自动产品激活发生。客户端用户在安装后进行产品激活。

管理选项

在每次安装过程中生成诊断日志。 | 客户端安装可以创建诊断日志，用于安装问题故障排除。 创建此日志可能会使客户端安装的运行变慢。 日志文件存储在 Administrative image directory}\x64\Logs\<计算机名称> 中。
以不同用户运行安装。 | 您可以指定具有管理权限的其他用户，而不是登录用户，来运行安装。当个人用户在其计算机上没有本地管理权限（安装 SOLIDWORKS 产品所需的权限）时，此选项非常有用。 当客户端不具有管理权限时，则可使用另一部署和安装方法。 请参阅 从选项编辑器调用安装。
安装之前或之后运行程序。 | 您可以指定自定义程序在客户端安装之前或之后运行。
您想要客户端参与 SOLIDWORKS 客户经历计划吗？ | 您可以指定客户端计算机参与 SOLIDWORKS 客户体验计划。 性能信息将发送到 SOLIDWORKS Corporation 以帮助改进产品。 此过程是透明并且保密的。 有关详情，请参见客户体验改进计划网站。

在安装之前和之后运行程序的限制

这些选项可让您在部署 SOLIDWORKS 前后在客户端计算机上运行其他安装程序或脚本，例如 Microsoft Office 的安装脚本。

使用这些选项有限制。如果您使用任一选项部署显示用户界面的安装程序或脚本时出现故障，例如显示对话框的脚本。SOLIDWORKS 的自动部署运行时，无法在目标机器上安装 SOLIDWORKS。

要使用在安装之前运行程序和在安装之后运行程序选项，请仅选择能以静默模式安装的程序。

要安装的软件

您可以指定要安装的 SOLIDWORKS 产品组件。
  • 选中产品组件旁的复选框可以指定在客户端安装过程中安装该组件。
  • 清除复选框指定不安装该组件。
  • 如果组件内含有可选安装子组件，则该组件旁会出现 + 图标。 要查看组件的可用子组件，请单击 + 图标。
  • 如果组件已扩展以显示可选子组件，则该组件旁会显示 - 图标。 要折叠子组件列表，请单击 - 图标。
语言规格只限制为 SOLIDWORKS 产品所安装的语言。 其它产品安装不受该规范影响。 例如，eDrawings® 安装所有语言。

Toolbox 选项

您可以为客户端安装指定支持哪些标准及默认 Toolbox 位置。

多个用户访问 Toolbox 的情况很常见，这些访问通常是通过网络位置（例如，UNC 路径、共享文件夹或通用网络驱动器规范）进行的。

如果该位置包含较旧主要版本的 Toolbox，则客户端安装会将该 Toolbox 升级到新的主要版本。 这些文件将不再与之前主要版本的 SOLIDWORKS 兼容。
如果某些客户端继续使用较旧版本的 SOLIDWORKS，则您必须为要升级到较新版本的客户端指定不同的 Toolbox 网络位置。

有关 SOLIDWORKS Toolbox 管理的详细信息，请参阅 SOLIDWORKS 帮助中的 Toolbox 信息。

在不安装 Toolbox 数据的情况下安装 Toolbox 软件

如果您的环境具有 PDM 或共享的 Toolbox/异型孔向导位置，则可以将客户端安装指定为不在该位置安装或升级 Toolbox 数据。

执行此操作的条件是：
  • 您未在安装 SOLIDWORKS 之前指定 SOLIDWORKS PDM 本地视图。
  • 该位置中的文件正在使用中并且可能会阻止 SOLIDWORKS 安装完成。
  • 该位置不可用并且可能会阻止 SOLIDWORKS 安装完成。

将客户端安装指定为不安装 Toolbox 数据时，SOLIDWORKS 软件和设置将指向 Toolbox/异型孔向导位置，但之后必须将数据安装在中央位置。

要在不包括 Toolbox/异型孔向导数据的情况下安装 SOLIDWORKS 软件：
  • 当系统询问您是否希望此客户端安装/升级 Toolbox 文件时，请选择否，安装 Toolbox 软件而不包括数据文件。

至少有一个人，通常是 CAD 管理员，必须在中央位置安装或升级 Toolbox/异型孔向导数据，否则软件将无法正常运行。组织中的任何人都可以处理此任务，只需手动安装 SOLIDWORKS 软件即可。如果您在 SOLIDWORKS PDM 内部管理 Toolbox，请按照 SOLIDWORKS PDM 管理员指南的 Toolbox 部分中概述的步骤安装或升级 Toolbox 数据。

SOLIDWORKS PDM 客户端选项

您可选择以下选项来部署 SOLIDWORKS PDM 客户端和插件：

  • PDM 产品类型
  • PDM 客户端类型
  • 特征
  • 库视图

    要打开视图设置向导，您必须在安装了 SOLIDWORKS PDM 客户端的机器上运行管理映像选项编辑器。

    要在客户端机器上创建库视图，您需要 Conisio 视图设置 (.cvs) 文件，该文件定义用于在客户端机器上配置库视图的参数。您可以参考现有的 .cvs 文件或从管理映像选项编辑器创建此文件。

请参阅 SOLIDWORKS 帮助中关于 SOLIDWORKS PDM 的部分，了解有关这些客户端和插件的更多信息。

Electrical 选项

您可以为 SOLIDWORKS Electrical 的管理组件指定以下参数：
  • 数据路径
  • Collaborative Server 机器名称和端口号
  • SQL Server 机器名称和密码

有关这些组件的更多信息，请参阅 SOLIDWORKS Electrical 。

父主题 查看和编辑选项设置
指定组和机器的选项设置
继承整体和组选项设置
每个机器的自定义设置
安装 SolidNetWork 许可概述
从选项编辑器调用安装
SOLIDWORKS Electrical


继承整体和组选项设置

整体设定或组的选项设置由其下的项目继承。

例如：
  • 为整体设定定义的设置会被所有组和计算机继承。
  • 为组定义的设置会被该组中的所有子组和计算机继承。

您可以更改组、子组或计算机的选项设置以覆盖默认的或继承的设置。 当更改选项设置的默认值或继承值后，该选项将高亮显示。

要将选项设置恢复为原始继承值，请右键单击组、子组或机器，然后单击以下选项之一：
  • 恢复到全局设置（对于非组成员的组、子组或机器）
  • 恢复到组设置（对于是组成员的机器）
  • 将所有成员恢复为组设置（同时针对该组的所有成员）
父主题 查看和编辑选项设置
指定组和机器的选项设置
管理映像选项设置
每个机器的自定义设置


每个机器的自定义设置

您还可以通过右键单击机器名称来修改已应用到特定机器的设置。

从快捷键菜单中，您可以为每个机器执行以下任务：
  • 重命名
  • 删除机器
  • 恢复到全局设置
  • 编辑注释
  • 编辑选项

编辑选项允许您修改机器的所有选项，比如客户端安装选项和管理选项。

父主题 查看和编辑选项设置
指定组和机器的选项设置
管理映像选项设置
继承整体和组选项设置


从选项编辑器调用安装

您可以使用手动或推送方法，直接从“选项编辑器”中部署安装。

  • 使用“选项编辑器”的“手动部署”页面，向用户发送有关如何开始安装的指示电子邮件。 当用户拥有其客户端机器的管理权限时，请使用此种方法。
    在管理选项下面，您可以选择以其他用户身份运行安装以为用户分配管理权限。
  • 使用“选项编辑器”的“自动部署”页面自动推送安装至目标机器。 如果用户不具有在自己系统上安装软件的管理权限，则可使用此方法。 您也可以使用此方法来执行自定义安装。

要手动或自动部署，您必须将管理映像安装目录存储到 Windows 共享目录中，以便可通过网络位置（例如 \\machine\shared_directory）使用该目录。您也可以通过将映像复制到每台计算机上的本地目录（如 C:\SOLIDWORKS Admin\SOLIDWORKS 2026 SP0）来使用该映像。

内容

  • 使用 UNC 路径部署管理映像

    为管理映像安装目录指定网络位置时，请使用 UNC 路径 (\\machine_name\share_name)，而不是映射网络驱动器位置。

  • 使用 StartSWInstall.exe 调用管理映像

  • 手动部署

    如果用户具有在自己系统中安装所需的权限，您可以使用此方法。

  • 自动部署的先决条件

    自动部署对于没有管理权限的用户非常有效，因为它能确保软件安装可以无缝进行。

  • 自动部署

  • 测试推送部署的设置

    管理映像选项编辑器中的自动部署选项卡包含该测试功能。

父主题 管理映像选项编辑器
添加和删除组和机器
查看和编辑选项设置
退出选项编辑器
为选项编辑器生成桌面快捷方式
通过电子邮件将管理映像调用到客户端


使用 UNC 路径部署管理映像

为管理映像安装目录指定网络位置时，请使用 UNC 路径 (\\machine_name\share_name)，而不是映射网络驱动器位置。

映射的网络驱动器不兼容推送和自动安装方法，也不兼容提取和手动方法中的“以不同用户身份运行”。

父主题 从选项编辑器调用安装


使用 StartSWInstall.exe 调用管理映像

您可以通过运行命令 admin_image_install_dir\ StartSWInstall.exe，安装或卸装客户端上的管理映像。 此方法使用管理映像选项编辑器中定义的选项、机器和组安装 SOLIDWORKS。

您可以将以下开关附加至 StartSWInstall.exe 命令：
开关 | 描述
/安装 | 在客户端机器上安装管理映像。
/卸装 通过两个可选开关从客户端机器上卸装软件：

/removedata

只适用于卸装。 卸装期间删除 SOLIDWORKS 数据文件和文件夹。

/removeregistry

只适用于卸装。 卸装期间删除 SOLIDWORKS 注册表条目。
/showui | 显示 SOLIDWORKS 安装管理程序的进展窗口。 否则 SOLIDWORKS 安装管理窗口将对用户隐藏。
/现在 | 立即启动安装或卸装。 5 分钟警告对话框未出现。

如果您希望在安装过程中没有任何用户交互，但不想使用管理映像选项编辑器中的自动部署时，推荐使用 StartSWInstall.exe，而非 StartSWInstall.hta。

父主题 从选项编辑器调用安装


手动部署

如果用户具有在自己系统中安装所需的权限，您可以使用此方法。

要使用电子邮件手动部署安装：

  1. 在“选项编辑器”中，单击部署。
    此时将显示每个计算机的安装可用性和状态。
  2. 单击发送电子邮件。
  3. 指定管理映像安装目录的网络路径。
    通常，管理映像安装目录的目录路径最初显示为 Windows 文件路径（例如，C:\SOLIDWORKS Admin\SOLIDWORKS 2026 SP0）。对话框将指示该路径不是网络路径。
    1. 单击浏览指定此管理映像安装目录的网络位置。
    2. 导航至安装管理映像的计算机，然后选择指定用于管理映像安装目录的 Windows 共享目录。
      请不要在管理映像共享目录内部导航（例如，进入 64bit 子目录）。
    3. 单击确定。
      对话框将指示该路径是网络路径。
    此时将创建一封电子邮件，指导计算机所有者如何使用管理映像中 StartSWInstall.hta 文件的网络位置从管理映像进行安装。
  4. 该电子邮件将发送给负责安装 SOLIDWORKS 的用户。

用户可双击电子邮件中 StartSWInstall.hta 网络位置的链接，从管理映像安装 SOLIDWORKS。

在选项编辑器中，安装状态 显示：
待定 | 用户尚未在此计算机上运行安装。
成功 | 用户已在此计算机上成功完成安装。
已失败 | 用户在此计算机上运行了安装，但安装失败。
可能显示的其他状态信息为：安装成功、卸载成功、安装、卸载、需要重新启动、安装失败、卸载失败。
在状态列的顶部，单击绿色箭头以刷新并显示更新的信息。
父主题 从选项编辑器调用安装


自动部署的先决条件

自动部署对于没有管理权限的用户非常有效，因为它能确保软件安装可以无缝进行。

要使用自动部署，客户端和服务器都必须属于同一 Active Directory 域。此配置允许将安装任务推送到目标计算机，由 Microsoft Task Scheduler 执行这些任务，而无需任何用户操作。

推送安装时，Task Scheduler 使用管理员在选项编辑器中指定的凭据在客户端计算机上运行启动 SOLIDWORKS 安装管理程序的任务。 Task Scheduler 将在计算机的本地系统帐户下运行。 此帐户将在网络上显示为计算机安全基本账户。 计算机安全原则必须具有以下访问权限：
  • 对管理映像文件夹的读取访问权限。
  • 对管理映像文件夹\x64\logs 文件夹的读写访问权限。

在 Active Directory 中，当您将计算机添加到共享文件夹组时，选择对象类型和计算机。

此外，服务管理映像和目标客户端计算机的计算机必须是同一个 Active Directory 域的成员。

父主题 从选项编辑器调用安装


自动部署

要通过推送安装至用户系统的方法自动部署：

  1. 在“选项编辑器”中，单击自动部署选项卡。
    此时将显示每个计算机的安装可用性和状态。
  2. 在部署列下选择目标客户端计算机，然后选择部署列中的组。
    启动部署流程前，在部署列下选择一个或多个计算机或组。
  3. 在安装时间下选择现在来立即部署，或选择稍后以排定部署的特定日期和时间。
  4. 在客户端选项下，选择以下选项：
    • 安装或升级 SOLIDWORKS 2026
    • 卸载 SOLIDWORKS 2026
      如果选择卸载，您可指定卸载程序文件和文件夹时是否卸载注册表条目和数据文件以及文件夹。
  5. 如果要在部署期间或部署之后根据需要重新启动一台或多台目标计算机，请选择自动重新启动计算机。
  6. 输入一个或多个目标计算机的客户端凭据。
  7. 单击部署以启动部署流程。
在“选项编辑器”中，安装状态显示为：
待定 | 尚未在此计算机上运行安装。
成功 | 已在此计算机上成功完成安装。
已失败 | 此计算机上安装失败。

可能显示的其他状态信息为： 安装成功、卸载成功、正在计划、正在连接、正在安装、正在卸载、需要重新启动、按计划安装、按计划卸载、安装失败、卸载失败、连接失败、计划失败。

父主题 从选项编辑器调用安装


测试推送部署的设置

管理映像选项编辑器中的自动部署选项卡包含该测试功能。

您可以运行模拟安装来测试用于部署的系统，例如：
  • 正在连接到目标计算机。
  • 正在该计算机上创建安装任务。
  • 正在该计算机上完成安装任务。
  • 正在更新管理映像上的状态和日志。
  • 正在检测要在安装之前或之后运行的程序。

该测试将检查文件路径、验证权限，并报告安装已成功结束。它不会在目标系统上安装任何软件或修改注册表。如果系统在任何目标计算机上出现故障，该测试将指示哪个系统出现故障。

工具提示将提供有关故障的更多信息。您可以将结果导出到 .xml 电子表格（或 .csv）中，这对于复核多个故障或与其他支持人员共享结果非常有帮助。

要测试推送部署的设置：

  1. 使用安装管理程序创建管理映像。
  2. 启动管理映像选项编辑器。

    您可以在安装管理程序完成创建管理映像后启动该选项，也可以双击管理映像文件夹中的 sldAdminOptionEditor.exe。

  3. 在设置选项卡上，添加一台或多台计算机。
  4. 单击自动部署：
    1. 提供域管理员的用户名和密码。
    2. 选择要测试的一台或多台计算机。
    3. 单击测试。
  5. 当安装测试出现时，单击运行测试。
  6. 请等待几分钟以便测试完成，您也可随时单击取消测试。
  7. 查看并纠正任何安装问题。
父主题 从选项编辑器调用安装


退出选项编辑器

您可单击“确定”或“关闭”以应用更改并退出选项编辑器。

  • 单击确定应用选项设置更改并退出选项编辑器。
  • 单击 Windows 应用程序关闭按钮以退出选项编辑器。如果软件检测到有未保存的更改，它会提示您保存。
父主题 管理映像选项编辑器
添加和删除组和机器
查看和编辑选项设置
从选项编辑器调用安装
为选项编辑器生成桌面快捷方式
通过电子邮件将管理映像调用到客户端


为选项编辑器生成桌面快捷方式

您可以为选项编辑器创建 Windows 桌面快捷方式，用于来自应用程序内的特定管理映像。

  1. 启动选项编辑器。
    例如，在文件资源管理器中，导航至管理映像安装目录并双击 sldAdminOptionEditor.exe。
  2. 单击为该选项编辑器生成桌面快捷方式。
    Windows 桌面上将出现管理映像选项编辑器的快捷方式。
父主题 管理映像选项编辑器
添加和删除组和机器
查看和编辑选项设置
从选项编辑器调用安装
退出选项编辑器
通过电子邮件将管理映像调用到客户端


通过电子邮件将管理映像调用到客户端

一旦创建好共享管理映像目录后，即可通过电子邮件通知客户端。

在一台可供其它计算机访问（例如通过 UNC 路径）的机器上将管理映像目录配置为共享。

可向所有客户端发送包含指向 管理映像安装目录\StartSWInstall.hta 的链接的电子邮件。 客户端然后可单击该链接并接着单击现在安装 SOLIDWORKS 产品来开始从管理映像进行安装。

如果您正将管理映像升级到新的 SOLIDWORKS 版本，则可以配置您的管理映像位置和共享属性，这样所有使用该映像的先前安装的客户端将自动升级。详细信息请参阅从管理映像升级客户端。
父主题 管理映像选项编辑器
添加和删除组和机器
查看和编辑选项设置
从选项编辑器调用安装
退出选项编辑器
为选项编辑器生成桌面快捷方式


设置管理员工具

在部署或升级 SOLIDWORKS 软件时，为防止用户更改那些选项，您可以使用“设置管理员工具”来指定可应用的系统选项。尽管向导仍然可用于复制设置，此工具将替换“SOLIDWORKS 设置向导”来部署设置。

将“设置管理员工具”与“管理映像选项编辑器”配合使用分为三个步骤：
  1. 创建管理映像以访问该工具。
  2. 使用“设置管理员工具”生成 *.sldsettings 文件，其中包括您选定的 SOLIDWORKS 选项。
  3. 在 SOLIDWORKS 安装中包含 *.sldsettings 文件。
如果您使用的是 3DEXPERIENCE 插件，也可以在管理映像之外部署 *.sldsettings 文件。使用此方法的一个优点是设置会在登录时自动部署。
  1. 要访问“设置管理员工具”，请按照 访问设置管理员工具 中提供的步骤进行操作。
  2. 按照说明应用和锁定设置。
  3. 从 3DEXPERIENCE Compass 中，展开我的角色，然后单击 Platform Manager 应用程序。转至内容 > Collaboration Spaces Configuration Center > CAD 协作 > SOLIDWORKS > 设置 > 资源 > CAD 设置。
  4. 在 CAD 设置中，浏览、上传和下载 *.sldsettings 文件。

内容

  • 访问设置管理员工具

    要访问设置管理员工具，必须首先创建管理映像。

  • 使用设置管理员工具

  • 应用和锁定选项

  • 完成设置选项

  • 在 SOLIDWORKS 安装中包含 sldsettings 文件

父主题 使用管理映像


访问设置管理员工具

要访问设置管理员工具，必须首先创建管理映像。

您可以从管理映像中启动“设置管理员工具”。

要访问设置管理员工具：

  1. 运行管理映像文件夹中的 sldAdminOptionEditor.exe。
  2. 在“管理映像选项编辑器”中，单击更改 [image] 。
  3. 在客户端安装选项部分中，执行以下操作：
    1. 单击使用从 SOLIDWORKS 设置管理员中导出的设置文件。
    2. 单击启用设置管理员。
      要访问启动设置管理员，必须在运行 sldAdminOptionEditor.exe 的计算机上安装 SOLIDWORKS <version>。
父主题 设置管理员工具


使用设置管理员工具

要使用设置管理员工具：

  1. 在欢迎选项卡上，选择以下选项：
    • 默认选项集以启动 SOLIDWORKS 的该版本。
    • 从该计算机导入 SOLIDWORKS 2026 选项。
    • 浏览到现有 sldreg 文件。
    • 浏览到现有 sldsettings 文件。
    *.sldreg 文件由“SOLIDWORKS 设置向导”生成，而 *.sldsettings 文件由“设置管理员工具”生成。
  2. 单击下一步。
父主题 设置管理员工具


应用和锁定选项

在系统选项选项卡中，有两列复选框可让您选择要应用这些选项中的哪些选项和要锁定的所应用选项，这样用户将无法更改它们。

当用户在 SOLIDWORKS 软件中访问系统选项对话框时，带有锁定图标 [image] 的锁定选项将不可用。 但是，您可以创建允许用户解锁选项的密码。 当用户悬停在锁定选项上时，工具提示将显示您的姓名和电子邮件，以便于他们可以联系您并请求密码。

要应用和锁定选项：

  1. 在系统选项选项卡中，执行以下操作：
    1. 要应用系统选项，请选择选项，然后选中应用列中的相应框。
    2. 要锁定系统选项，请选择选项，然后选中两者应用和锁定列中相应的框。
      当用户访问系统选项选项卡时，这些选项以锁形 [image] 显示。
  2. 根据该选项，您可能必须为该选项指定其他参数。
  3. 您还可以阻止用户解除消息，方法是为消息/错误/警告应用控件。
    1. 单击消息/错误/警告。
    2. 为您要管理的消息选择应用，也可以选择锁定。
    3. 将消息设置为显示或不显示。

      如果您选择显示，将从用户的解除的消息列表中移除该消息并在相应的时间对该用户显示。 如果您选择不显示，该消息将被自动添加到用户的解除的消息列表中，并且在用户处理模型时不会对该用户显示。

      此表描述了软件中的行为：
      应用 | 锁定 | 显示 | 不显示 | 行为
      X | X | 强制显示消息。
      X | X | 解除消息并将消息添加到解除的消息列表中。
      X | X | X | 强制显示消息并禁用对话框中的不要再显示选项。
      X | X | X | 解除消息并禁止用户在工具 > 选项 > 消息/错误/警告中将其启用。
  4. 在系统选项选项卡中，单击下一步。
父主题 设置管理员工具


完成设置选项

要完成设置选项：

  1. 在完成选项卡上，选择何时应用系统选项：
    • 用户第一次启动软件。
    • 每次启动软件。
    • 是否同时应用自定义。
  2. 您可选择在用户下线时应用选项和允许 API 覆盖锁定的选项。
  3. 对于锁定的系统选项，您必须提供名称和电子邮件地址。 当用户将指针悬停在锁定的选项上时，SOLIDWORKS 软件将在工具提示中显示这一信息。
  4. 您还可以允许用户覆盖锁定的选项。 然后您必须指定提供给用户的密码。
  5. 单击保存，生成用于部署的 *.sldsettings 文件。
父主题 设置管理员工具


在 SOLIDWORKS 安装中包含 sldsettings 文件

要在安装中包含 *.sldsettings 文件：

  1. 双击管理映像文件夹中的 sldAdminOptionEditor.exe。
  2. 在“管理映像选项编辑器”中，单击更改。
  3. 在客户端安装选项部分中，执行以下操作：
    1. 单击使用从 SOLIDWORKS 设置管理员中导出的设置文件。
    2. 单击编辑路径，然后浏览到 *.sldsettings 文件。
    您以可为不同的组或机器创建和应用不同的 *.sldsettings 文件。
  4. 部署并安装 SOLIDWORKS 软件。

部署后，您可以随时重复步骤 2 来修改现有 *.sldsettings。 SOLIDWORKS 软件将在下次启动时读取修改后的 *.sldsettings。

父主题 设置管理员工具


命令行调用

您可使用命令提示符/批处理文件自动调用管理映像（无声安装）。

要使用命令行为 SOLIDWORKS PDM 客户端部署管理映像，请参阅 SOLIDWORKS PDM 安装指南。

内容

  • 准备客户端以便通过命令行从管理映像进行安装

    创建管理映像后，在通知客户端之前，您必须安装无法通过使用命令行或 Microsoft Active Directory 创建的管理映像来安装的 Microsoft Windows 组件。

  • 通过命令行从管理映像安装

    您可以通过命令行从管理映像调用安装。

  • 命令行属性

    此处所述的命令行属性包括特征属性、全局属性、产品特定的属性和 Windows 位置约定。

  • 使用 Microsoft Active Directory 调用管理映像

    Microsoft Active Directory Deployment 在为客户端调用核心 SOLIDWORKS 产品时受支持。

父主题 多个安装
调用到多个客户端
使用管理映像
多个安装的管理


准备客户端以便通过命令行从管理映像进行安装

创建管理映像后，在通知客户端之前，您必须安装无法通过使用命令行或 Microsoft Active Directory 创建的管理映像来安装的 Microsoft Windows 组件。

只有在从使用命令行或 Microsoft Active Directory 的管理映像安装时，才需要手动安装这些 Windows 组件。 如果您使用 SOLIDWORKS 安装管理程序创建和安装管理映像，则会自动安装这些 Windows 组件。
下面总结了 Windows 组件中 SOLIDWORKS 所需的文件：
Windows 性能工具包 | 在 SOLIDWORKS Rx 中启用扩展日志记录。
Visual C++ 2022 可重新分发软件包 | 包含 Microsoft Visual C++ 运行时组件。 必须安装 2022 版本。
Visual Basic for Applications 7.1 | 提供对 Visual Basic 宏的支持。
应用程序 2022 的 Visual Studio 工具 | 可选。包含支持 Visual Studio 2022 应用程序的工具集 (VSTA17)。
.NET Framework 4.8.1 | 包含有普通语言运行时间和运行 .NET Framework 4.8.1 应用程序所需的 .NET Framework 零部件。
SWCEF | Chromium Embedded Framework (CEF) 用于显示 3DEXPERIENCE platform 内容。
Microsoft Edge Web View2 | 用于显示 Web 内容。
SOLIDWORKS Login Manager | 允许登录到 3DEXPERIENCE Marketplace 和其他 3DEXPERIENCE 应用程序。
所有 SOLIDWORKS 产品（并非只是核心 SOLIDWORKS 产品）均要求有 Visual C++ 可重新分发软件包和 .NET Framework 4.8.1。

这些组件必须包括在管理映像目录的子目录中。

下表标示了每种受支持操作系统所需的特定文件。
操作系统：Windows Server 2022 64 位
Windows 性能工具包： | WPTx64-x86_en-us.msi
Visual C++ 2022 可重新分发软件包： | vc_redist.x86.exe vc_redist.x64.exe 必须安装两者。
Visual Basic 7.1: | vba71.msi 和 vba71_1033.msi 外加一个可选的语言包。
.NET Framework 4.8.1： | ndp481-x86-x64-allos-enu.exe
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe
操作系统：Windows 11 64 位
Windows 性能工具包： | WPTx64-x86_en-us.msi
Visual C++ 2022 可重新分发软件包： | vc_redist.x86.exe vc_redist.x64.exe 必须安装两者。
Visual Basic 7.1: | vba71.msi 和 vba71_1033.msi 外加一个可选的语言包。
.NET Framework 4.8.1： | .NET 4.8.1 是操作系统的一部分，可满足此要求。
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe

内容

  • 在 64 位操作系统上从命令行安装 Windows 必备组件

    您可以按照下列流程在 64 位 Windows 版本上使用命令行安装管理映像安装所需的 Windows 必备组件。

父主题 命令行调用
通过命令行从管理映像安装
命令行属性
使用 Microsoft Active Directory 调用管理映像


在 64 位操作系统上从命令行安装 Windows 必备组件

您可以按照下列流程在 64 位 Windows 版本上使用命令行安装管理映像安装所需的 Windows 必备组件。

若要一次安装多个组件，按照下面步骤中所提供的命令生成一个批处理文件，然后用它将组件推送到客户端计算机。

  1. 确定目标计算机至少具有 620 MB 可用磁盘空间及有效的 TEMP 目录。
  2. 安装 Visual C++ RELEASE 可重新分发软件包。您必须安装每个软件包的 32 位和 64 位版本。
    针对 RELEASE = 2022 安装软件包。

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vc_redist.x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vc_redist.x86.exe /Q

  3. 安装 Microsoft .NET Framework 4.8.1：
    administrative_image_directory\.Net_Framework_4.8.1\ndp481-x86-x64-allos-enu.exe
  4. 为应用程序 2022 安装 Visual Studio 工具：
    administrative_image_directory\Microsoft_VSTA17\vsta_setup.exe
  5. 安装 Visual Basic 7.1：
    administrative_image_directory\Microsoft_VBA\vba71.msi 所有语种都要求和 administrative_image_directory\Microsoft_VBA\vba71_1033.msi。
    只能安装此软件包的 64 位版本。

    此外，请为所需语言安装以下软件包：

    vba71_1028.msi | 中文
    vba71_1031.msi | 德文
    vba71_1036.msi | 法文
    vba71_1040.msi | 意大利文
    vba71_1041.msi | 日文
    vba71_1042.msi | 韩文
    vba71_1046.msi | 巴西葡萄牙文
    vba71_2052.msi | 简体中文
    vba71_3082.msi | 西班牙文
    英文、捷克文、波兰文、俄文和土耳其文无需其他语言软件包。
  6. 安装 SOLIDWORKS Chromium Embedded Framework (SWCEF)：
    administrative_image_directory\swcef\CEF for SOLIDWORKS Applications.msi.
  7. 安装 SOLIDWORKS Login Manager：
    administrative_image_directory\swloginmgr\SOLIDWORKS Login Manager.msi.
父主题 准备客户端以便通过命令行从管理映像进行安装


通过命令行从管理映像安装

您可以通过命令行从管理映像调用安装。

要进行无声安装：

  1. 打开命令提示符窗口（在 Windows 中，单击开始 > 运行）。
  2. 键入 msiexec.exe 命令，附上 /i 和 /qb 开关，并为任意非默认值的选项指定属性，如下所示。

    msiexec /i "administrative_image_directory\64bit\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

单机安装组件命令行属性包括:
  • 命令行特征属性
  • 命令行全局属性
  • eDrawings 命令行属性
  • SOLIDWORKS Flow Simulation 命令行属性

使用以下范例作为无声安装的模板。

SOLIDWORKS 客户端

  • SOLIDWORKS 核心产品（英文）
  • Toolbox 插件
  • 参与反馈项目
  • 法语

SOLIDWORKS：

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=4 ADDLOCAL=SolidWorks, SolidWorksToolbox TOOLBOXFOLDER="toolbox path for example C:\SolidWorks Data\" /qb

SOLIDWORKS 法语安装组件必须单独安装：

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS French\french.msi" /qb

指定 SOLIDWORKS 语言组件安装命令时，请勿指定命令行参数。

eDrawings 客户端

  • 所有特征

msiexec /i
            "administrative_image_directory\64bit\eDrawings\eDrawings.msi"
          INSTALLDIR="C:\Program Files\your_folder"
            SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst
          ADDLOCAL=All /qb

SOLIDWORKS Electrical

由于在 Microsoft SQL Server 中安装 SOLIDWORKS Electrical 的技术复杂性，SOLIDWORKS Electrical 的命令行示例将从文档中排除。

SOLIDWORKS Visualize 和 Visualize Boost

对于 SOLIDWORKS Visualize：

msiexec. /i “administrative_image_directory\64bit\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

对于 SOLIDWORKS Visualize Boost：

msiexec /i “administrative_image_directory\64bit\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

父主题 命令行调用
准备客户端以便通过命令行从管理映像进行安装
命令行属性
使用 Microsoft Active Directory 调用管理映像


命令行属性

此处所述的命令行属性包括特征属性、全局属性、产品特定的属性和 Windows 位置约定。

内容

  • 命令行特征属性

    SOLIDWORKS 安装支持适用于命令行部署的以下 ADDLOCAL 属性。

  • 命令行全局属性

    每个属性都为管理或单机安装定义，除非另有说明。可使用全局属性将序列号传递给管理安装及单机安装。

  • eDrawings 命令行属性

    这些命令行属性特定于 eDrawings ®。

  • SOLIDWORKS Composer/Composer Player 命令行属性

    这些命令行属性特定于 SOLIDWORKS Composer 和 SOLIDWORKS Composer Player。

  • SOLIDWORKS Flow Simulation 命令行属性

    这些命令行属性是特定于 SOLIDWORKS Flow Simulation 的。

  • SOLIDWORKS Inspection 命令行特性

    这些命令行特性是特定于 SOLIDWORKS Inspection 的。

  • SOLIDWORKS Visualize 命令行属性

    这些命令行属性特定于 SOLIDWORKS Visualize。

  • 管理映像的 MSI 文件位置

    要从命令行生成管理映像，产品组件 .msi 文件储存在 SOLIDWORKS 媒体的以下位置中。

父主题 命令行调用
准备客户端以便通过命令行从管理映像进行安装
通过命令行从管理映像安装
使用 Microsoft Active Directory 调用管理映像


命令行特征属性

SOLIDWORKS 安装支持适用于命令行部署的以下 ADDLOCAL 属性。

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • ScanTo3D
  • Simulation
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
指定命令行安装的属性时：
  • SOLIDWORKS 不支持使用 ADDSOURCE 选项进行产品安装。
  • 属性区分大小写，不能包含空格或破折号，并且必须由逗号隔开。
父主题 命令行属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
SOLIDWORKS Visualize 命令行属性
管理映像的 MSI 文件位置


命令行全局属性

每个属性都为管理或单机安装定义，除非另有说明。可使用全局属性将序列号传递给管理安装及单机安装。

属性 | 说明
ENABLEPERFORMANCE 应用程序是否自动将性能数据发送到 SOLIDWORKS Corporation。

1

发送性能数据。

0

不发送性能数据。
INSTALLDIR | SOLIDWORKS 的安装文件夹。
MBDSERIALNUMBER | 基于 SOLIDWORKS 模型的定义产品的序列号。
MOTIONSERIALNUMBER | SOLIDWORKS Motion 产品的序列号。
OFFICEOPTION 指定要安装的产品套件：
0 | SOLIDWORKS Standard
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
4 | SOLIDWORKS Ultimate
REINSTALL 指定 所有 以更新当前安装的所有功能。
仅在更新到现有主要版本的 Service Pack 发行版时，才指定此属性（例如，将现有 SOLIDWORKS 2026 SP01 更新到 SOLIDWORKS 2026 SP02 时）。
REINSTALLMODE Microsoft 安装程序重新安装选项。

例如，将安装程序从先前的 Service Pack 发行版升级到相同主要版本内的另一 Service Pack 发行版时，您应指定 REINSTALLMODE=vomus。

有关 REINSTALLMODE 设置的详细信息，请参阅 www.microsoft.com 上的 Windows Installer 文档。

仅在更新到现有主要版本的 Service Pack 发行版时，才指定此属性（例如，将现有 SOLIDWORKS 2026 SP01 更新到 SOLIDWORKS 2026 SP02 时）。首次安装 SOLIDWORKS 新的主要版本时请勿指定此属性。
SERVERLIST SolidNetWork 服务器清单。
SolidNetWork 服务器列表为分隔的字符串列表，每个字符串指明服务器上的一个端口号，格式为：
  • 三重轴（逗号分隔）=xxxxx@server_name1、yyyyy@server_name2、zzzzz@server_name3
  • 非三重轴（分号分隔的）= xxxxx@server_name1；yyyyy@server_name2；zzzzz@server_name3
X 和 Y 为单个数字。 列表中的最后一个服务器后不要放置分隔符。
SIMULATIONSERIALNUMBER | SOLIDWORKS Simulation 产品的序列号。
SOLIDWORKSSERIALNUMBER | SOLIDWORKS 产品的序列号，包括所有插件。
SWMIGRATE 按在 SOLIDWORKS 安装选择对话框列表中所显示内容指定要升级的 SOLIDWORKS 版本。例如：

SWMIGRATE="SOLIDWORKS 2026 x64 Edition SP01"

只有在当前已安装先前主要版本的情况下安装新的主要版本时，才需要指定此属性。将同一个主要版本中的 Service Pack 发行版升级为另一个版本时，请勿指定此属性。
TOOLBOXFOLDER SOLIDWORKS Toolbox 文件的安装文件夹。

例如： TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

如果您的环境具有 PDM 或共享 Toolbox/异型孔向导位置，则可以使用 NOTTOOLBOXSETUP 属性将客户端安装指定为不在该位置安装或升级 Toolbox 数据。指定：

0 | 安装 Toolbox 文件。
1 | 不安装 Toolbox 文件。
TRANSFORMS 包含语言特定的表单项：
TRANSFORMS 数字.mst
  • 中文 (1028)
  • 简体中文 (2052)
  • 捷克文 (1029)
  • 英文 (1033)
  • 法文 (1036)
  • 德文 (1031)
  • 意大利文 (1040)
  • 日文 (1041)
  • 韩文 (1042)
  • 波兰文 (1045)
  • 巴西葡萄牙文 (1046)
  • 俄文 (1049)
  • 西班牙文 (1034)
  • 土耳其文 (1055)
UPGRADESWINSTALL
指定是否将 SOLIDWORKS 现有版本升级到当前版本。
0 | 新安装，不更新。
1 | 更新
只有在当前已安装先前主要版本的情况下安装新的主要版本时，才需要指定此属性。 将同一个主要版本中的 Service Pack 发行版升级为另一个版本时，请勿指定此属性。
父主题 命令行属性
命令行特征属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
SOLIDWORKS Visualize 命令行属性
管理映像的 MSI 文件位置


eDrawings 命令行属性

这些命令行属性特定于 eDrawings ®。

属性 | 说明
ADDLOCAL 指定安装 eDrawings 应用程序的哪个部分。
All 为推荐选项。
命令行语法 | 特征
All | 安装所有功能。eDrawings 应用程序搜索已安装的 SOLIDWORKS 和 AutoCAD 出版程序应用程序以核准安装。
CALS | 在 eDrawings 浏览器中查看 CAL 文件
Inventor | 从 Autodesk Inventor 应用程序创建 eDrawings 文件。
eDrawingsViewer | 查看 eDrawings 及其它文件。
ProE | 使用 eDrawings 浏览器查看 ProE 文件
DXFDWGTranslator | 在 eDrawings Viewer 中观阅 DXF/DWG 文件。
Shortcuts | 安装桌面快捷方式。
XML3D | 在 eDrawings 浏览器中查看 3DXML 文件。
INSTALLDIR | 为 指定安装文件夹 eDrawings
SNLSERVER 请输入 SolidNetWork License 服务器的 端口@servername。使用分号分开多个 端口@服务器 组合。

只要求为 SOLIDWORKS SNL 服务器配置提供 SNLSERVER 的端口服务器名称以及 SERVERLIST。

SolidNetWork 服务器列表为分隔的字符串列表，每个字符串指明服务器上的一个端口号，格式为：
  • 三重轴（逗号分隔）

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

  • 非三重轴（分号分隔）

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

X 和 Y 为单个数字。在列表中的最后一个服务器后不要放置分号。
父主题 命令行属性
命令行特征属性
命令行全局属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
SOLIDWORKS Visualize 命令行属性
管理映像的 MSI 文件位置


SOLIDWORKS Composer/Composer Player 命令行属性

这些命令行属性特定于 SOLIDWORKS Composer 和 SOLIDWORKS Composer Player。

有关 SOLIDWORKS Composer：

属性 | 说明
ACTIVSERIALNUMBER | SOLIDWORKS Composer 序列号。
ACTIVSERIALNUMBERPLAYERPRO | 可选。 SOLIDWORKS Composer Player Pro 序列号。
ADDLOCAL 可选。如果您安装完整的应用程序，则不需要指定 ADDLOCAL 属性。
对于自定义安装，请将 ADDLOCAL 与以下所需项目配合使用：
  • 许可
  • CLOSA
  • InterOps
  • LicenseSupportFiles
  • 插件
  • SWComposerCommon
  • SWPlayer
您还可以使用可选功能 Sync3Dvia。
INSTALLDIR | 为 SOLIDWORKS Composer 指定安装文件夹。

有关 SOLIDWORKS Composer Player：

属性 | 说明
ACTIVSERIALNUMBERPLAYERPRO | 可选。 SOLIDWORKS Composer Player Pro 序列号。
INSTALLDIR | 为 SOLIDWORKS Composer Player 指定安装文件夹。
在未安装 SOLIDWORKS 的计算机上，您必须使用 SOLIDWORKS Translator 将 SOLIDWORKS 文件导入到 SOLIDWORKS Composer 中。要部署 SOLIDWORKS Translator，您必须使用 SOLIDWORKS 安装管理程序；您无法使用命令行。
父主题 命令行属性
命令行特征属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
SOLIDWORKS Visualize 命令行属性
管理映像的 MSI 文件位置


SOLIDWORKS Flow Simulation 命令行属性

这些命令行属性是特定于 SOLIDWORKS Flow Simulation 的。

属性 | 说明
ACTIVSERIALNUMBER SOLIDWORKS Flow Simulation 独立序列号。

（单机安装和从管理映像执行的客户端安装）
CWUPGRADEINSTALL 升级特定 SOLIDWORKS Flow Simulation 应用程序软件的现有版本。
1 | 更新
2 | 新的安装；在新目录中安装

（单机安装和从管理映像执行的客户端安装）
INSTALLDIR 为特定 SOLIDWORKS Flow Simulation 应用程序软件指定安装。

（仅适用于个人安装）
SERVERLIST | 以分号分隔的字符串列表，每个字符串指明服务器上的一个端口号，格式为： xxxxx@server_name1; yyyyy@server_name2;&，其中 x 和 y 为单个数字。 在列表中的最后一个服务器后不要放置分号。
SOLIDWORKSPATH 指定安装有 SOLIDWORKS 软件的文件夹。

（单机安装和从管理映像执行的客户端安装）
父主题 命令行属性
命令行特征属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Inspection 命令行特性
SOLIDWORKS Visualize 命令行属性
管理映像的 MSI 文件位置


SOLIDWORKS Inspection 命令行特性

这些命令行特性是特定于 SOLIDWORKS Inspection 的。

属性 | 说明
ACTIVSERIALNUMBER | SOLIDWORKS Inspection 序列号。 （单机安装和从管理映像执行的客户端安装）
INSTALLDIR | 为 SOLIDWORKS Inspection 应用程序软件指定安装位置。 （仅适用于个人安装）
SERVERLIST | 以分号分隔的字符串列表，每个字符串指明服务器上的一个端口号，格式为： xxxxx@server_name1; yyyyy@server_name2;&，其中 x 和 y 为单个数字。 在列表中的最后一个服务器后不要放置分号。
父主题 命令行属性
命令行特征属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Visualize 命令行属性
管理映像的 MSI 文件位置


SOLIDWORKS Visualize 命令行属性

这些命令行属性特定于 SOLIDWORKS Visualize。

属性 | 说明
ACTIVSERIALNUMBER | SOLIDWORKS Visualize 序列号。 （单机安装和从管理映像执行的客户端安装）
INSTALLDIR | 为 SOLIDWORKS Visualize 应用程序软件指定安装位置。 （仅适用于个人安装）
SERVERLIST | 以分号分隔的字符串列表，每个字符串指明服务器上的一个端口号，格式为： xxxxx@server_name1; yyyyy@server_name2;&，其中 x 和 y 为单个数字。 在列表中的最后一个服务器后不要放置分号。
父主题 命令行属性
命令行特征属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
管理映像的 MSI 文件位置


管理映像的 MSI 文件位置

要从命令行生成管理映像，产品组件 .msi 文件储存在 SOLIDWORKS 媒体的以下位置中。

SOLIDWORKS（核心产品，英文）

swwi\data\SOLIDWORKS.msi

SOLIDWORKS（非英文组件）

繁体中文 | swwi\lang\chinese\chinese.msi
简体中文 | swwi\lang\chinese-simplified\chinese-simplified.msi
捷克文 | swwi\lang\czech\czech.msi
法文 | swwi\lang\french\french.msi
德文 | swwi\lang\german\german.msi
意大利文 | swwi\lang\italian\italian.msi
日文 | swwi\lang\japanese\japanese.msi
韩文 | swwi\lang\korean\korean.msi
波兰文 | swwi\lang\polish\polish.msi
巴西葡萄牙文 | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
俄文 | swwi\lang\russian\russian.msi
西班牙文 | swwi\lang\spanish\spanish.msi
土耳其文 | swwi\lang\turkish\turkish.msi

DocManager API

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

3DExperience Marketplace for SOLIDWORKS

marketplace\3dexperience marketplace.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

swComposer\SOLIDWORKS Composer.msi

SOLIDWORKS Composer Player

swComposerPlayerSOLIDWORKS Composer Player.msi

SOLIDWORKS Electrical

swelectric\SOLIDWORKS Electrical.msi

SOLIDWORKS 文件实用程序

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS Manage Client

SWManageClient\SOLIDWORKS Manage Client.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional 提供了 API，但其仅可用于客户端且不可用于 .msi 文件中。 有关详细信息，请参阅 SOLIDWORKS PDM 客户端 install\API 目录中的 API 指南。

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Visualize

visualize\SOLIDWORKS Visualize.msi

SOLIDWORKS Visualize Boost

visualizeboost\SOLIDWORKS Visualize Boost.msi
父主题 命令行属性
命令行特征属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
SOLIDWORKS Visualize 命令行属性


使用 Microsoft Active Directory 调用管理映像

Microsoft Active Directory Deployment 在为客户端调用核心 SOLIDWORKS 产品时受支持。

Microsoft Active Directory 是在网络环境中管理客户端和服务器的目录服务。它可简化管理、迁移及调用。

有关通过 Microsoft Active Directory 安装 SOLIDWORKS 的信息，请联系您的经销商。

父主题 命令行调用
准备客户端以便通过命令行从管理映像进行安装
通过命令行从管理映像安装
命令行属性


多个安装的管理

多个安装的管理任务包括将管理映像升级到新发行版、应用 service pack 更新以及删除安装。

内容

  • 将管理映像升级到新的发行版

    若要更新从管理映像安装的客户端，请首先更新管理映像，然后将客户端配置为参考引用新版本的映像。

  • Service Pack 产品更新管理

    Service Pack 产品更新可包含系统可靠性、程序兼容性、安全性等的更新。

  • 删除安装

    您可以在单台计算机或在服务器/客户端环境中删除安装。

父主题 多个安装
调用到多个客户端
使用管理映像
命令行调用


将管理映像升级到新的发行版

若要更新从管理映像安装的客户端，请首先更新管理映像，然后将客户端配置为参考引用新版本的映像。

从 SOLIDWORKS 下载页面运行 SOLIDWORKS 安装管理程序，以便引用正确的文件。

更新管理映像（这将创建映像的新副本）后，可以通过让客户端引用管理映像的新副本来更新客户端。

如果客户端使用共享目录引用了以前的管理映像版本，则可以使用更新的管理映像的位置重新定义该共享目录。

内容

  • 为管理映像下载更新后的安装文件

    SOLIDWORKS 安装管理程序可在升级管理映像的过程中检测是否需要更新后的安装文件。

  • 升级管理映像

    若要升级管理映像，SOLIDWORKS 安装管理程序会创建一个新的映像目录。 随后，您可以指引客户端使用该新的管理映像目录以升级到该产品版本。

  • 从管理映像升级客户端

    SOLIDWORKS 安装管理程序可以自动从管理映像更新客户端计算机上安装的客户端。

父主题 多个安装的管理
Service Pack 产品更新管理
删除安装


为管理映像下载更新后的安装文件

SOLIDWORKS 安装管理程序可在升级管理映像的过程中检测是否需要更新后的安装文件。

  1. 启动 SOLIDWORKS 安装管理器。
  2. 在欢迎屏幕上，选择管理映像。
  3. 在 序列号 屏幕中，输入 SOLIDWORKS 序列号。
    SOLIDWORKS 安装管理程序检查 SOLIDWORKS 网站有关颁有许可的产品以及可用的 service pack。
  4. 如果出现有新版本可用屏幕，请选择是，下载并安装更新版本：版本。
    SOLIDWORKS 安装管理程序启动新会话以安装新版本。
  5. 如果下载文件夹有问题，则可能出现下载选项，在这种情况下，请接受新安装文件的默认目录或输入新的目录名称。
    如果您看到目录不存在的信息，请单击是以创建该目录。
  6. 在下载已完成屏幕上单击关闭，可关闭当前安装程序并启动新版本的安装程序。
父主题 将管理映像升级到新的发行版
升级管理映像
从管理映像升级客户端


升级管理映像

若要升级管理映像，SOLIDWORKS 安装管理程序会创建一个新的映像目录。 随后，您可以指引客户端使用该新的管理映像目录以升级到该产品版本。

此过程假定您已经下载了管理映像所需的所有已更新的安装文件。有关详细信息，请参阅为管理映像下载更新安装文件。

  1. 启动 SOLIDWORKS 安装管理器。
  2. 在欢迎屏幕上，选择管理映像。
    将显示管理映像生成选项。
    选项 | 描述
    使用默认设定生成新映像。 | 使用默认配置设置创建映像（也就是说，不依据为您站点的现有管理映像建立的设置。)
    使用现有映像的设定和文件生成新映像。 | 使用为您站点的现有管理映像指定的配置设定生成映像。 单击 浏览，为现有管理映像指定安装目录。
  3. 在序列号屏幕中，检查序列号。
  4. 在摘要（已准备好创建映像）屏幕中，检查确保管理映像选项正确。
    关于各个管理映像选项和安装选项的详细信息，请单击更改以转到选项页面，然后单击帮助。
  5. 若要创建新版本的管理映像，请单击立即创建。

现在可以将客户端升级到此新版本的管理映像了。详细信息请参阅从管理映像升级客户端。

父主题 将管理映像升级到新的发行版
为管理映像下载更新后的安装文件
从管理映像升级客户端


从管理映像升级客户端

SOLIDWORKS 安装管理程序可以自动从管理映像更新客户端计算机上安装的客户端。

一般而言，管理映像在服务器上的文件夹中进行组织。要想支持客户端自动升级，管理映像必须位于共享文件夹中。

在升级管理映像之后，原始安装将位于一个文件夹，而升级后的安装将位于另一个文件夹。要想使用升级后的安装，请首先从原始管理映像文件夹中移除共享选项，然后将共享选项添加到升级的管理映像文件夹中。

在从原始管理映像安装的客户端机器上启动 SOLIDWORKS 时，SOLIDWORKS 将查找新的版本并升级客户端。
另外，当 SOLIDWORKS 触发更新时，从管理映像安装的其他产品将自动更新。
父主题 将管理映像升级到新的发行版
为管理映像下载更新后的安装文件
升级管理映像

删除原始管理映像文件夹的共享选项

当升级在共享文件夹中供访问的管理映像时，必须删除原始文件夹的共享选项。

  1. 浏览到原始管理映像文件所处于的文件夹。
  2. 用右键单击文件夹并选择属性。
  3. 在共享选项卡上，选择不共享此文件夹，然后单击确定。

现在按照为升级的管理映像文件夹添加共享选项中的说明为升级的管理映像文件夹添加共享选项。

为升级后的管理映像文件夹添加共享选项

一旦您创建了更新后的管理映像文件夹并禁用了原始管理映像文件夹的共享之后，必须为新文件夹添加共享选项以重新启用管理映像。

  1. 浏览到已升级的管理映像文件所在的文件夹。
  2. 用右键单击文件夹并选择属性。
  3. 在共享选项卡上指定对您机构或组适合的共享属性，并将共享名称更改到用于原有管理映像文件夹的名称。
从原始管理映像共享位置安装的计算机会在启动 SOLIDWORKS 时自动升级到新版本。
限制：当您创建管理映像并通过共享自动部署时，如果替换映像，SOLIDWORKS 不会升级到新 Service Pack。只有当您最初使用安装管理程序手动安装原始映像时，SOLIDWORKS 才会自动升级。

例如，如果您创建了 SOLIDWORKS <版本> SP1 的管理映像并通过共享选项自动部署，客户端将按预期安装并运行。稍后，您将在同一文件夹中创建 SP5 的新映像，禁用 SP1 映像的共享功能，并使用相同共享名称启用 SP5 映像的共享。

当您在客户端上打开 SOLIDWORKS 时，它不会检测到新映像或触发升级。它将打开 SP1。即便将文件夹名称与原始镜像匹配，也无法解决此问题。


Service Pack 产品更新管理

Service Pack 产品更新可包含系统可靠性、程序兼容性、安全性等的更新。

您可使用两种方法获取产品更新：
  • 可使用 SOLIDWORKS 安装管理程序来检查、下载及安装更新。

    您可手动启动 SOLIDWORKS 安装管理程序，或者安排定期检查更新。

  • 可从 SOLIDWORKS 支持网站上手动下载 Service Pack。

    Service pack 作为对现有软件版本的修补而应用。例如，SOLIDWORKS 2026 SP1.0 是 SOLIDWORKS 2026 SP0.0 的 Service Pack。您可以使用 SOLIDWORKS 2026 安装管理程序来安装这些 Service Pack；您不能使用 SOLIDWORKS 2025 中的 SOLIDWORKS 安装管理程序安装它们。

    有关下载和安装 service pack 的帮助，请参阅您正在进行更新的 SOLIDWORKS 版本的安装文档。

内容

  • 在管理映像中退回 Service Pack

    您可将管理映像退回到早期安装的 service pack。 如果您以光盘安装了 SOLIDWORKS 软件，您需要原有光盘才可恢复某个 service pack。 您必须保存有早期管理映像的副本。

父主题 多个安装的管理
将管理映像升级到新的发行版
删除安装


在管理映像中退回 Service Pack

您可将管理映像退回到早期安装的 service pack。 如果您以光盘安装了 SOLIDWORKS 软件，您需要原有光盘才可恢复某个 service pack。 您必须保存有早期管理映像的副本。

已升级过的管理映像不能退回到先前的 service pack。 以 SOLIDWORKS 安装管理程序以外的其他方法所创建的管理映像无法退回到早期版本。 必须卸载从这些管理映像安装的客户端，然后使用由先前版本生成的管理映像重新安装。
  1. 删除包含当前管理映像的文件夹。若要进行此操作，打开命令提示符窗口并输入：
    rmdir /s/q 当前管理映像的路径
  2. 将管理映像的备份副本移到您删除了当前管理映像的位置。若要进行此操作，打开命令提示符窗口并输入：
    move 备份管理映像的路径 当前管理映像的路径
    在您退回管理映像后，客户端计算机在下次运行 SOLIDWORKS 软件时自动退回。
父主题 Service Pack 产品更新管理


SOLIDWORKS PDM 和 SOLIDWORKS Manage

SOLIDWORKS PDM 是与之前称为 SOLIDWORKS Enterprise PDM 的产品具有相同的客户端/服务器体系结构的文档管理产品。 SOLIDWORKS PDM 有两种类型：
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM 使用 Microsoft SQL Server 数据库来管理文件库。

此表列示各产品类型可用的数据库系统、服务器组件和客户端选项。
 | PDM Standard | PDM Professional
设计用途 | 小到中型办公网络，通常同时有不到 20 个用户。 | 大型办公网络，大量并发用户
限制 | 低于 1 插座或 4 核，内存 1 GB，数据库大小 10 GB | SQL Standard 限制：低于 4 插座或 16 核，内存 128 GB，数据库大小 524 PB
数据库管理系统 | Microsoft SQL Server Express 2019 或更高版本，直到 2022 版。 | Microsoft SQL Server 2019 或更高版本，直到 2022 版。
是否需要 SolidNetWork License Manager？ | 是 | 是
是否包括存档服务器和数据库服务器？ | 是 | 是
是否包括 SOLIDWORKS PDM Web2 服务器和 WebAPI 服务器？ | 否 | 是
客户端类型 | 本地 | 本地，基于浏览器
CAD Editor 的客户端插件 | SOLIDWORKS、DraftSight | SOLIDWORKS、DraftSight、Microsoft Office 集成
Contributor 的客户端插件 | DraftSight | DraftSight、Microsoft Office 集成
Viewer 的客户端插件 |  | Microsoft Office 集成

SOLIDWORKS Manage Professional 为 SOLIDWORKS PDM Professional 提供高级数据管理工具。 它提供高级版本的控制以及项目、流程和项目管理功能。 交互式仪表板和报告可以帮助您跟踪项目、活动以及项目完成进度。

SOLIDWORKS Manage Professional 与 SOLIDWORKS PDM Professional 具有相似的体系结构。它使用客户端-服务器体系结构，并使用 Microsoft SQL Server 数据库来管理项目和项目数据。提供有三个用于数据库、文件服务器和 web 服务器功能的服务，同时支持胖客户端和 web 浏览器客户端。这三个服务可以托管在同一服务器上或托管在单独的服务器上。具有 SOLIDWORKS Manage Professional Editor 许可证的用户可以使用 SOLIDWORKS Manage 插件直接从 SOLIDWORKS 内访问 Manage 数据。

您可以使用 SOLIDWORKS 安装管理程序来安装 SOLIDWORKS Manage Professional 服务器和客户端。

有关安装 SOLIDWORKS Manage Professional 的说明，请参阅 SOLIDWORKS PDM/SOLIDWORKS Manage 安装指南。

内容

  • PDM 服务器组件列表

  • 了解 PDM 客户端之间的区别

    在安装客户端软件之前，您必须根据 PDM 环境确定需要哪些客户端。

  • 安装 PDM 服务器之前

    安装 PDM 服务器组件之前请牢记这些要求：

  • 使用 SOLIDWORKS 安装管理程序安装 PDM 服务器

    当您为 PDM Standard 安装 PDM 服务器时，您可在同一台计算机上安装存档服务器、数据库服务器和 PDM CAD Editor 客户端。 您不需要单独运行客户端安装。

  • 使用 SOLIDWORKS 安装管理程序安装 PDM 客户端


PDM 服务器组件列表

此表概述了 SOLIDWORKS PDM 服务器的各服务器组件。

服务器 | Function | 安装
用于 PDM Standard 的 Microsoft SQL Server Express | 管理 SOLIDWORKS PDM 数据库中的数据。 | 可随 PDM Standard 安装，或者使用之前授权许可和安装的版本。
用于 PDM Professional 的 Microsoft SQL Server | 管理 SOLIDWORKS PDM 数据库中的数据。 | 要求有。 您还可使用之前授权许可和安装的版本。
SolidNetWork License Manager Client | 管理 SOLIDWORKS PDM 许可。 | 必须先进行安装才能创建新库。 在使用 SOLIDWORKS 安装管理程序时，可与 SOLIDWORKS PDM 服务器组件一起安装。
存档服务器 | 管理客户端之间的文件传输、文件库存档以及用户及其凭据。 | 要求有。 随 PDM Standard 或 Professional 安装。
数据库服务器 | 轮询 PDM 数据库以获取更新并管理数据导入和导出规则、管理邮件信息系统以及计划复制和冷存储。 | 要求有。 随 PDM Standard 或 Professional 安装。
Web2 服务器 | 允许通过 Internet 从基于浏览器的客户端访问文件库。 | 可选。 仅可随 PDM Professional 安装。
Web API 服务器 | EXALEAD OnePart 用户可以使用 Web API 服务器来索引和检索 SOLIDWORKS PDM 数据。 | 可选。 仅可随 PDM Professional 安装。

存档服务器在安装它们的计算机的系统帐户上作为服务运行。 一个存档服务器在同一计算机上可承载多个文件库。

在独立安装中，存档服务器、数据库服务器、许可证服务器、web API 服务器以及 SQL Express 或 SQL Server 数据库均可安装在同一台机器上。

在分布式环境中，服务器组件可位于不同机器上。 SOLIDWORKS PDM Professional 还支持复制文件库存档和 SQL Server 数据库，以提高在远程位置工作时的性能。 有关详细信息，请参阅 SOLIDWORKS PDM Professional 复制指南。

父主题 SOLIDWORKS PDM 和 SOLIDWORKS Manage


了解 PDM 客户端之间的区别

在安装客户端软件之前，您必须根据 PDM 环境确定需要哪些客户端。

此表概述了 SOLIDWORKS PDM Standard 的各客户端：
Standard 客户端类型 | 说明
CAD Editor | 支持处理 SOLIDWORKS、DWG/DXF 格式、Microsoft Word 和 Microsoft Excel 文件。Office 插件处理所有文件格式的方式与 SOLIDWORKS PDM Standard 相同（预览除外）。
贡献者 | 支持处理 SOLIDWORKS、DWG/DXF 格式、Microsoft Word 和 Microsoft Excel 文件。
查看者 | 允许以只读方式访问文件库。用户可以通过工作流程变换文件，但用户不能添加或修改（检出、检入、更新值）文件。
此表概述了 SOLIDWORKS PDM Professional 的各客户端：
Professional 客户端类型 | 说明
CAD Editor & Web | 支持处理所有文件类型（包括增强的管理）和预览 CAD 格式（例如 SOLIDWORKS）。CAD 插件允许用户从 CAD 应用程序内访问 SOLIDWORKS PDM Professional。远程用户可使用 Web2 客户端通过英特网搜索文件库并执行基本功能。
Contributor & Web | 支持处理所有的文件类型，包括 CAD 文件。但是，此客户端类型不支持 CAD 插件。远程用户可使用 Web2 客户端通过英特网搜索文件库并执行基本功能。
查看者 | 允许以只读方式访问文件库。 用户可以通过工作流程变换文件，但用户不能添加或修改（检出、检入、更新值）文件或使用 CAD 插件。
父主题 SOLIDWORKS PDM 和 SOLIDWORKS Manage


安装 PDM 服务器之前

安装 PDM 服务器组件之前请牢记这些要求：

  • 在要安装服务器和客户端的机器上获取完全管理权限。
  • 确保数据库服务器有权通过 TCP 端口 3030 访问存档服务器，以及通过 TCP 端口 1433 访问 SQL Server。
  • 如果您要使用现有的 SQL Server Express 或 SQL Server 数据库，请获取 SQL Server 数据库的名称以及具有数据库读写权限的 SQL Server 管理员或数据库所有者的帐户 ID 和密码。 您不能使用 tew 用户。
  • 如果系统上已安装 PDM 客户端，请将其卸载。 如果您希望 PDM Server 和 PDM Client 在同一个系统上，您可以从 SOLIDWORKS Installation Manager 的服务器产品页面中安装两者。
父主题 SOLIDWORKS PDM 和 SOLIDWORKS Manage


使用 SOLIDWORKS 安装管理程序安装 PDM 服务器

当您为 PDM Standard 安装 PDM 服务器时，您可在同一台计算机上安装存档服务器、数据库服务器和 PDM CAD Editor 客户端。 您不需要单独运行客户端安装。

当您为 PDM Professional 安装 PDM 服务器时，可以包含上述组件以及 Web2 服务器和 Web API 服务器。

要安装 PDM 服务器及其组件：

  1. 启动 SOLIDWORKS 安装管理程序。
  2. 在欢迎页面上，选择安装服务器组件，然后单击以下项：
    • 在此计算机上安装 SOLIDWORKS PDM 服务器组件。
    • 在此计算机上安装 SolidNetWork License Manager。

      如果 SolidNetWork License Manager 安装在此计算机或另一台计算机上，则此选项不会显示。

  3. 如果显示 SolidNetWork License Manager 选项页面，输入序列号并指定目录位置，然后单击下一步。
  4. 请遵循系统警告的说明进行操作，然后单击下一步。
  5. 在摘要页面上，对于 SOLIDWORKS PDM 服务器，单击更改。
  6. 在 SOLIDWORKS PDM 服务器选项页面上：
    1. 对于选择服务器产品，单击 SOLIDWORKS PDM Standard 或 Professional。
    2. 对于安装位置，单击浏览以指定文件路径。
    3. 在选择功能中：
      1. 单击存档服务器、数据库服务器和客户端以在同一台计算机上安装这些组件。如果您在分布式环境中，则您也可通过在另一台计算机上运行安装管理程序来安装存档服务器和数据库服务器。
        • 如果已在计算机上安装 PDM 客户端，则您必须取消安装并卸载客户端。您接着可以运行 SOLIDWORKS 安装管理程序来一起安装 PDM 服务器和客户端。
        • SOLIDWORKS PDM Server 安装随附的 SOLIDWORKS PDM Client 组件包括无法排除的项目浏览器。
      2. 如果您安装的是 PDM Professional，则您也可单击 Web2 服务器和 Web API 服务器。
        如果您安装的是 Web API 服务器，则您可以为 HTTP 端口号指定介于 0 和 65535 之间的值。默认值为 65453。
    4. 在 SQL Server 中，您可以安装 PDM 服务器随附的数据库工具的新实例（对于 PDM Standard，即为 SQL Server Express），或者您也可指定现有实例的数据库名称、用户名和密码。
      必须为 SOLIDWORKS PDM Professional 安装完整版本的 SQL Server。
    5. 单击返回到摘要。
  7. 在摘要页面上，接受 SOLIDWORKS 许可协议条款，然后单击立即安装。

    当 SOLIDWORKS 安装管理程序完成安装后，将启动存档服务器配置工具。 按照向导中的提示配置存档服务器。

要设置和配置存档服务器、数据库服务器、Web2 服务器以及 SQL Server 数据库并对其进行故障排除，请参阅 SOLIDWORKS PDM 安装指南中的相关主题。

内容

  • 修改 SOLIDWORKS PDM Server 安装

父主题 SOLIDWORKS PDM 和 SOLIDWORKS Manage


修改 SOLIDWORKS PDM Server 安装

要修改 SOLIDWORKS PDM Server 及其组件的安装，请使用 Windows 控制面板中的程序和功能。 您不能使用 SOLIDWORKS Installation Manager (SLDIM) 修改安装，即使您过去使用它安装 SOLIDWORKS PDM Server 也是如此。

父主题 使用 SOLIDWORKS 安装管理程序安装 PDM 服务器


使用 SOLIDWORKS 安装管理程序安装 PDM 客户端

SOLIDWORKS PDM 客户端的主要版本必须与 SOLIDWORKS PDM 服务器的主要版本匹配。 当您安装或升级 SOLIDWORKS PDM 客户端时，确保版本匹配。

要安装 PDM 客户端：

  1. 启动 SOLIDWORKS 安装管理程序。
  2. 在欢迎页面上，选择在此计算机上安装。
  3. 在序列号页面上，单击下一步。
    SOLIDWORKS PDM 客户端不需要单独的序列号。
  4. 请遵循系统警告的说明进行操作，然后单击下一步。
  5. 在摘要页面上，在产品下，单击更改。
  6. 在产品选择页面上，单击选择不同软件包或产品。
  7. 在选择您想显示的软件包对话框中，选择 SOLIDWORKS 版本。然后单击确定。
  8. 在产品选择页面上，选择 SOLIDWORKS PDM 客户端。 然后选择 eDrawings 以启用 PDM 预览功能。 如果您使用的是 SOLIDWORKS PDM Professional，则您还可选择条目探索器。
  9. 在摘要页面上，展开 SOLIDWORKS PDM 选项，然后单击更改。
  10. 在 SOLIDWORKS PDM 客户端选项页面上，选择以下选项，然后单击返回到摘要：
    • PDM 产品类型
    • PDM 客户端类型
    • 插件
  11. 在摘要页面上，接受 SOLIDWORKS 许可协议条款，然后单击立即安装。
您也可使用管理映像选项编辑器来创建和部署 PDM 客户端的映像。有关详细信息，请参阅 使用管理映像。
父主题 SOLIDWORKS PDM 和 SOLIDWORKS Manage


SOLIDWORKS Electrical

SOLIDWORKS 安装管理程序允许您以独立或客户端/服务器模式安装 SOLIDWORKS Electrical 的所有组件。

SOLIDWORKS Electrical 使用多个组件。在安装过程中，必须根据所需的安装类型选择这些组件。
  • SOLIDWORKS Electrical Schematic - 2D 应用程序，用于创建和管理电气原理图。
  • SOLIDWORKS Electrical 3D - SOLIDWORKS 插件，用于将 2D 原理图与 3D 模型集成。SOLIDWORKS Electrical 3D 使您可以管理电气设备的布局并布置电线、电缆和线束。
  • Data - Data 对软件所需的所有数据进行分组。此数据为图形（如代表符号和标题块的文件）或技术（如制造商目录和与符号相关的数据）。您可以共享所有用户都可以访问的数据。
  • Collaborative Server - 管理电力工程图打开和更新的实用程序。
  • SQL Server - SOLIDWORKS Electrical 需要使用 Microsoft SQL Server 数据库。您可以选择在安装过程中创建新数据库或使用现有数据库。

安装类型

您可以在同一台机器上安装所有 SOLIDWORKS Electrical 组件。这是独立安装。所有程序数据，如项目工程图和报表，都存储在工作站上。

您也可以安装 SOLIDWORKS Electrical 组件作为客户端/服务器应用程序。如果要将数据存储在网络服务器上，请使用此类型的安装。客户端/服务器安装允许多个用户处理同一项目。客户端系统必须具有对服务器的网络访问权限和创建项目、库和符号的读取/写入权限。

信息

无论安装类型是什么（独立或客户端/服务器），您都必须以完全权限模式启动 Windows 会话以安装 SOLIDWORKS Electrical。

您只能在一台计算机上安装一个版本的 SOLIDWORKS Electrical。如果要安装 SOLIDWORKS 并选择 SOLIDWORKS Electrical 作为要安装的产品之一，则安装程序将移除旧版本的 SOLIDWORKS Electrical。

启动 SOLIDWORKS 安装管理程序时，会自动检测工作站上或服务器上安装的 SOLIDWORKS Electrical 的现有版本。

始终在安装新版本之前先备份现有 SOLIDWORKS Electrical 环境。从 SOLIDWORKS Electrical Schematic 内，选择文件 > 存档环境，或者从 SOLIDWORKS Electrical 3D 内，选择 SOLIDWORKS Electrical > 工具 > 存档环境。

内容

  • 安装 SOLIDWORKS Electrical 的要求

  • 独立或客户端/服务器安装

    您可以在两种模式下安装 SOLIDWORKS Electrical。在独立模式下，您可以在工作站上安装软件。在客户端/服务器模式下，用户将共享数据。

  • 配置 Collaborative Sever

  • 配置 Microsoft SQL Server

  • 指定数据位置


安装 SOLIDWORKS Electrical 的要求

要访问当前系统要求，请参阅系统要求。

父主题 SOLIDWORKS Electrical
独立或客户端/服务器安装
配置 Collaborative Sever
配置 Microsoft SQL Server
指定数据位置


独立或客户端/服务器安装

您可以在两种模式下安装 SOLIDWORKS Electrical。在独立模式下，您可以在工作站上安装软件。在客户端/服务器模式下，用户将共享数据。

SOLIDWORKS Electrical 必须始终连接到 SQL Server 实例。

父主题 SOLIDWORKS Electrical
安装 SOLIDWORKS Electrical 的要求
配置 Collaborative Sever
配置 Microsoft SQL Server
指定数据位置

Stand-Alone 安装

首次安装时，您必须在工作站上安装所有组件。

  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • 应用程序数据
  1. 在摘要选项卡中，单击产品选择部分的更改，并选择所有 SOLIDWORKS Electrical 组件。
  2. 如果要修改安装选项，请在摘要选项卡中，单击 Electrical 选项部分的更改。 可以创建 SQL Server 的新实例或使用现有实例。 有关更多详细信息，请参阅本文档中有关数据和 Microsoft SQL Server 的特定章节。 否则，请保留默认选项。
  3. 单击立即安装往下继续。
如果工作站上已安装了 SOLIDWORKS Electric，则 SOLIDWORKS 安装管理程序将自动查找并提示您进行更新。安装所有组件，而不更改 Electrical 选项。

客户端/服务器安装

客户端/服务器安装允许您在多个用户之间共享数据。

在服务器上，您必须安装以下组件：
  • Collaborative Server
  • 应用程序数据
  • SQL Server
在客户端上，您必须安装以下组件：
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  1. 在服务器上，安装服务器组件。
  2. 在欢迎使用 SOLIDWORKS 安装管理程序选项卡中，单击安装服务器组件。
  3. 选择 SOLIDWORKS Electrical 选项。
  4. 在摘要选项卡中，您可以修改安装选项。 有关更多详细信息，请参阅本文档中有关数据和 Microsoft SQL Server 的特定章节。 否则，请保留默认选项。
  5. 单击立即安装往下继续。
  6. 在客户端上，安装应用程序。
  7. 在欢迎使用 SOLIDWORKS 安装管理程序选项卡中，单击在此计算机上安装。
  8. 在摘要选项卡中，单击产品选择部分的更改，然后清除 Electrical Server 选项。
  9. 在摘要选项卡中，单击 Electrical 选项部分的更改，然后修改设置以连接到服务器。
  10. 单击立即安装往下继续。
如果工作站上或服务器上已安装 SOLIDWORKS Electrical，则 SOLIDWORKS 安装管理程序将自动查找并提示您更新。使用与第一次安装相同的流程更新软件。


配置 Collaborative Sever

Collaborative Server 是必须始终运行的 Windows 服务，且通过防火墙和病毒扫描工具与客户端进行固定、不间断的双向通信。

要在单机或服务器模式下配置 Collaborative Server，请指定以下参数：
  • 机器名称（例如 LOCALHOST 或 MyMachine)，或其 IP 地址（例如 127.0.0.1 或 192.168.255.255）。
  • 端口号（默认为 26666).

您可以在安装期间或以后在工具 > 应用程序设置命令中配置 Collaborative Server。

对于客户端/服务器安装，为了提供不间断的双向通信，请确保安装了 Collaborative Server 的机器上的端口号 26666 可用且打开。否则，请让系统管理员为 SOLIDWORKS Electrical 查找其他端口。您需要确保在服务器机器上允许 SOLIDWORKS Electrical 端口 (26666) 的传入连接。

父主题 SOLIDWORKS Electrical
安装 SOLIDWORKS Electrical 的要求
独立或客户端/服务器安装
配置 Microsoft SQL Server
指定数据位置


配置 Microsoft SQL Server

确保 SQL Server 数据库的一个实例可用于任何类型的 SOLIDWORKS Electrical 安装。如果现有的 SQL Server 数据库已安装到系统，或安装新的实例作为 SOLIDWORKS Electrical 安装的一部分，则您可以使用现有的 SQL Server 数据库。

当您安装新的 SQL Server 实例时，SOLIDWORKS 安装提供了 Microsoft SQL Express 2022 的免费版本。此版本限制为 1 个 CPU、1 GB 内存和 10 GB 数据。内存和 CPU 限制足够同时支持 10 个用户。

如果您安装 SQL Express 2022，请确保服务器软件和硬件满足系统要求中列出的要求。

最佳做法是，如果同一服务器上有 10 个以上的并发用户，则应购买并安装完整版本的 SQL Server。按照介绍的工作流程，通过 SQL Server 的现有实例安装 SOLIDWORKS Electrical。

关于 SQL Express 2022 的信息，请参阅 Microsoft SQL Server 文档资料。

父主题 SOLIDWORKS Electrical
安装 SOLIDWORKS Electrical 的要求
独立或客户端/服务器安装
配置 Collaborative Sever
指定数据位置

管理 SOLIDWORKS Electrical 中的数据

很多程序使用包含所有程序数据的的单一数据库。这与 SOLIDWORKS Electrical 的情况不同。SOLIDWORKS Electrical 的每个项目分配有唯一 ID 号码，且每个项目都有可以基于唯一 ID 号码识别的相关数据库。例如，在 SOLIDWORKS Electrical Project Manager 中，如果您找到的项目为 ID#112，则关联的数据库名称为 “tew_project_data_112”。

为每个项目分配唯一数据库的原因是，这样可以显著缩短处理时间。 而且，在关键数据库故障时，仅有一个项目会受到影响，大部分程序信息的完整性会得以保留。

但是，一些公司有限制创建新数据库的策略。要运行 SOLIDWORKS Electrical，不应限制用户创建新数据库。请向系统管理员或数据库管理员核实，以确保不会有配置阻止用户创建新数据库。

SQL Server 的新实例

如果您安装 SQL Server 的新实例，则需要服务器和任意客户端系统的完全管理权限。 您还必须确保客户端具有数据库的读/写权限，以便客户端可以创建并修改项目、库、符号和其他项目数据。

安装 SQL Server 的新实例时，请选择一个名称，而非选择默认。

SQL Server 的现有实例

您需要有一个对 SQL Server 数据库有完全管理权限的用户账户，以在现有 SQL Server 实例上安装新的 SOLIDWORKS Electrical 数据库或连接到 SOLIDWORKS Electrical 安装。

要使 SOLIDWORKS Electrical 妥当运行，您必须启用 SQL Server 的混合模式身份验证。混合模式身份验证允许使用 Windows 或 SQL Server 证书。

要连接现有 SQL Server 数据库，您可以使用 Windows 或 SQL Server 身份验证。 输入具有完全管理权限的 Windows 或 SQL Server 登录的用户名和密码。

您不能使用 ‘tew’ 用户连接 SQL Server 进行安装。 请联系您的 SQL Server 管理员或系统管理员获得帮助，以获取 SQL Server 适当证书的登录名。

SOLIDWORKS Electrical 数据库

安装 SOLIDWORKS Electrical 后，安装程序将在 SQL Server 实例中创建以下数据库。

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


指定数据位置

关于数据位置，选择一个目录来存储程序数据，例如零件、模板和 2D 及 3D 符号。 该位置必须为专用目录。 它不能是根目录或用于存储 SOLIDWORKS 数据的同一目录。

默认目录为 C:\ProgramData\SOLIDWORKS Electrical。

在安装客户端/服务器的情况下，您必须共享数据目录。

安装程序将在默认目录中创建名为更新的新文件夹，以存储所有新数据。

首次启动 SOLIDWORKS Electrical 时，程序会自动将 Update 文件夹中存储的数据与现有数据合并。在更新数据向导中，您可以选择要添加到应用程序和 SQL Server 数据库中的数据。

父主题 SOLIDWORKS Electrical
安装 SOLIDWORKS Electrical 的要求
独立或客户端/服务器安装
配置 Collaborative Sever
配置 Microsoft SQL Server


SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize 提供单机版工具套件，该套件结合了先进的渲染功能和可视化面向设计的功能和工作流程，因此您可以创建 3D CAD 模型的高度逼真图像。

SOLIDWORKS Visualize 产品在两个软件包中可用：
  • Standard
  • Professional

SOLIDWORKS Visualize Standard 的免费套件包括活动订阅上的每个 SOLIDWORKS Professional 和 Premium 许可证。对于激活 SOLIDWORKS 单机的客户，您需要额外的序列号。如果您不知道 SOLIDWORKS Visualize 序列号，请咨询您的 SOLIDWORKS 管理员或经销商。

SOLIDWORKS Visualize 还支持 SolidNetWork 许可 (SNL) 许可类型（如浮动）以及脱机激活。

使用 SOLIDWORKS 安装管理程序 (SLDIM)，您可以将 SOLIDWORKS Visualize 作为单机安装（在此计算机上安装）的一部分进行安装。您可以将其作为独立的应用程序安装，这是要使用单独的计算机进行建模和渲染时的一大优势。它不会使用 SOLIDWORKS 许可。

SOLIDWORKS Visualize Boost 服务可让您将渲染从运行 SOLIDWORKS Visualize Professional 的计算机分发到网络上的一台或多台计算机。您可以在生成渲染的图像时在计算机上执行其他任务，并且可以更快地获得最终渲染的图像。您还可以在 SOLIDWORKS 安装管理程序中将 Visualize Boost 作为单机安装（在此计算机上安装）的一部分进行安装。

SOLIDWORKS Visualize Boost 的免费套件包括活动订阅上的每个 SOLIDWORKS Visualize Professional 套件。
Visualize Boost 仅为 Visualize Professional 的产品加载项。Visualize Boost 不可用于 Visualize Standard。

内容

  • SOLIDWORKS Visualize 的系统要求

  • 使用 SOLIDWORKS 安装管理程序安装 SOLIDWORKS Visualize

  • 使用 SOLIDWORKS 安装管理程序安装 Visualize Boost


SOLIDWORKS Visualize 的系统要求

为获得 SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost 的最佳性能和设置，请在安装前遵循以下准则：
  • 在安装 SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost 之前，请确保每个产品都有单独的序列号。
  • 核实运行 SOLIDWORKS Visualize 或 SOLIDWORKS Visualize Boost 的每台计算机都满足系统要求中列出的要求。
  • 在同一网络中的专用渲染计算机上安装 SOLIDWORKS Visualize Boost 应用程序。这些计算机应不同于运行 SOLIDWORKS Visualize Professional 的计算机，以便卸载渲染任务。
  • 如果未找到适用的 GPU，则 SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost 会默认使用中央处理器 (CPU) 代替。有关特定图形卡和驱动程序的详细信息，请参阅 SOLIDWORKS 硬件认证。

对于使用 3DS Stellar Physically Correct 时的 GPU 支持

Stellar 精确渲染模式：
  • 至少基于 Maxwell™ 微架构的 NVIDIA® 显卡
  • 建议使用支持 CUDA® 12.2 的 538.78 驱动程序版本
  • 最低 4 GB 的视频内存
在 Stellar 快速渲染模式下，您需要选择以下选项之一：
  • 至少基于 Turing® 微架构的 NVIDIA 显卡（具有 RT 核心）
  • 或基于 RDNA® 2 或更新版本微架构的 AMD® 显卡

对于使用 AMD ProRender 时的 GPU 支持

AMD ProRender™ 精确渲染模式：
  • 支持 Vulkan® 标准的 GPU 和驱动程序
  • 最低 4 GB 的视频内存
父主题 SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost


使用 SOLIDWORKS 安装管理程序安装 SOLIDWORKS Visualize

要安装 SOLIDWORKS Visualize：

  1. 启动 SOLIDWORKS 安装管理程序。
  2. 在欢迎页面上，选择在此计算机上安装。
  3. 执行以下操作：
    1. 在序列号页面上，展开可视化。
    2. 选择 SOLIDWORKS Visualize，然后输入序列号。
    3. 单击下一步。
  4. 请遵循系统警告的说明进行操作，然后单击下一步。
  5. 在摘要页面上，接受 SOLIDWORKS 许可协议条款，然后单击立即安装。
按照产品激活向导中的说明激活您的产品。

激活后，在桌面上双击 SOLIDWORKS Visualize 快捷方式图标以启动应用程序，或从 Windows 开始菜单，单击 SOLIDWORKS 版本 > SOLIDWORKS Visualize 版本。

内容

  • 发布安装任务

父主题 SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost


发布安装任务

安装后，您需要执行几项任务以配置 SOLIDWORKS Visualize。

有关更多信息，请参阅 SOLIDWORKS Visualize 帮助中的 SOLIDWORKS Visualize 入门。

内容

  • 创建内容文件夹

  • 访问帮助、教程、系统信息和许可

父主题 使用 SOLIDWORKS 安装管理程序安装 SOLIDWORKS Visualize


创建内容文件夹

当您首次运行软件时，SOLIDWORKS Visualize 会向您提示获取位置以创建内容文件夹。

内容文件夹包含如下子文件夹，您可在其中存储项目资产：
子文件夹 | 存储
相机 | 默认相机和您已保存的相机
环境 | 高动态范围 (HDR) 图像
调色板 | 背板图像
图像 | 渲染和快照
外观 | 您外观库中的材料 当您添加外观到库时更新内容。
模型 | 模型文件 默认情况下，SOLIDWORKS Visualize 在您使用文件 > 导入模型时首次搜索该文件夹。
板 | 背板中可用的标准 2D 图像
项目 | .SVPJ 格式的本地项目文件。
纹理 | 外观中可用的 2D 纹理
父主题 发布安装任务


访问帮助、教程、系统信息和许可

“帮助”菜单提供文档和选项以更新软件和解疑您的系统问题。

Visualize 帮助 | 打开 SOLIDWORKS Visualize 在线帮助。
Visualize 教程 | 打开 MySolidWorks，使您可以访问 SOLIDWORKS Visualize 教程。
新版本说明 | 显示当前版本的在线新版本说明。
新增功能 | 显示 SOLIDWORKS 产品的新功能。
系统信息 | 执行 SOLIDWORKS Visualize 软件和您计算机硬件的系统检查，根据需要建议升级。
检查更新 | 检查服务器是否有最新的 SOLIDWORKS Visualize 更新。
激活许可 | （按节锁定许可）使用 SOLIDWORKS 产品激活向导激活您的产品。
停用许可 | （按节锁定许可）使用 SOLIDWORKS 产品激活向导停用您的产品。
SolidNetWork License Manager | 使用 SOLIDWORKS 产品激活向导停用您的产品。
关于 Visualize | 显示您 SOLIDWORKS Visualize副本的版本编号和许可信息。
父主题 发布安装任务


使用 SOLIDWORKS 安装管理程序安装 Visualize Boost

您可使用 SOLIDWORKS 安装管理程序安装 Visualize Boost。 它需要独立的序列号。

您应在不同于运行 SOLIDWORKS Visualize Professional 的机器上安装 Visualize Boost。您可通过在计算机上安装 Visualize Boost，同时配备多个图形处理单元 (GPU) 来实现渲染性能最大化。

要安装 SOLIDWORKS Visualize Boost：

  1. 启动 SOLIDWORKS 安装管理程序。
  2. 在欢迎页面上，选择在此计算机上安装。
  3. 执行以下操作：
    1. 在序列号页面上，展开可视化。
    2. 选择 SOLIDWORKS Visualize Boost，然后输入序列号。
    3. 单击下一步。
  4. 请遵循系统警告的说明进行操作，然后单击下一步。
  5. 在摘要页面上，接受 SOLIDWORKS 许可协议条款，然后单击立即安装。
按照产品激活向导中的说明激活您的产品。

激活后，双击 SOLIDWORKS Visualize Boost 桌面快捷方式 [image] 打开应用程序。

内容

  • 配置 Visualize Boost

    您可以将主要 Visualize Boost 机器配置为协调程序，并将渲染集群中的其他机器配置为节点。

父主题 SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost


配置 Visualize Boost

您可以将主要 Visualize Boost 机器配置为协调程序，并将渲染集群中的其他机器配置为节点。

使用 Visualize Boost，您可以在单个机器上或跨机器集群渲染图像。设置简单直观。主要计算机，即协调程序，管理集群并从 SOLIDWORKS Visualize 分发渲染作业。其他机器，称为节点，连接到协调程序以帮助在网络上执行这些任务。在渲染农场中，集群中的每台机器都持续运行 Visualize Boost 实例。

要配置 Visualize Boost：

  1. 打开 Visualize Boost：
    • 双击 Visualize Boost 桌面快捷方式 [image] 。
    • 从 Windows 开始菜单，单击 SOLIDWORKS <版本> > SOLIDWORKS Visualize Boost <版本>。
    激活后，Visualize Boost 窗口将识别并显示许可机器的名称和 IP 地址。
  2. 在 Visualize Boost 中，单击文件 > 设置。
  3. 在设置对话框中：
    1. 选择一台机器作为协调程序。在配置所有其他节点时，取消勾选协调程序。
    2. 接受 Boost 端口的默认值 8001 和 DStellar 端口的默认值 8002。
      您可以更新这些端口以满足网络要求。确保为节点通信添加防火墙异常。如有疑问，请咨询您的网络管理员。
  4. 可选： 其他参数包括：
    选项 | 描述
    语言 | 机器会自动使用操作系统的语言。
    主题 | 为主题选择浅色或深色背景。如果 SOLIDWORKS Visualize 安装在与 Visualize Boost 相同的机器上，则此设置会影响 SOLIDWORKS Visualize。
    通知已启用 | 在 Windows 通知区域中显示来自 DStellar.Boost 的消息。
    导出 | 将 Visualize Boost 配置设置保存到 .json 文件。
    输入 | 将现有设置加载到 .json 文件中的 Visualize Boost 实例。
  5. 单击应用。
要完成设置，请参阅使用 Visualize Boost 的说明。
父主题 使用 SOLIDWORKS 安装管理程序安装 Visualize Boost


许可管理

安装后，您可以通过两种方式激活 SOLIDWORKS 许可证：激活个人计算机（计算机激活），或在服务器上安装并激活浮动网络许可证 (SolidNetWork Licensing)。

一般而言，在个人计算机上进行的安装需要使用许可激活；但是，您也可以单独安装软件，然后通过 SolidNetWork License Manager 控制许可。 与之相反的是，尽管大型场所通常使用浮动网络许可，但是您可以从管理映像调用安装，然后从个人计算机激活序列号。

内容

  • 管理个人许可

    您可以指定单个许可证以使用机器激活。

  • 使用 SolidNetWork License Manager 管理许可

    SolidNetWork License Manager 可通过向网络中的客户端分发许可支持多个许可客户端。 这样就能够利用浮动许可，允许用户数量超过许可数量。


管理个人许可

您可以指定单个许可证以使用机器激活。

通常，管理个人许可包括直接从 SOLIDWORKS 软件激活和停用许可。

激活是 SOLIDWORKS 单机（非 SolidNetWork 许可）许可的产品许可颁发和注册过程。 通常，如果产品许可尚未激活，在您启动产品时 SOLIDWORKS 会尝试激活该许可。

从 SOLIDWORKS 2022 和更高版本开始，如果您购买了 SOLIDWORKS 的永久许可，您还必须每年重新激活许可一次。永久许可永不过期，但需要重新激活。SOLIDWORKS 会在所需的重新激活日期之前提示您重新激活永久许可。

您也可以在 SOLIDWORKS 中单击 [image] > 许可 > 停用来停用个人许可。

父主题 许可管理
使用 SolidNetWork License Manager 管理许可

激活许可

您必须首先激活单台计算机的许可，才能在该计算机上运行 SOLIDWORKS 产品。

激活要求您具有因特网或电子邮件访问权限。 激活后，您不必上网即可使用该产品。 如果您使用该产品的计算机上无法访问电子邮件，您可以保存激活文件并从另一计算机上发送。

该过程将：
  • 激活 SOLIDWORKS 产品系列的所有软件许可。
  • 允许您将许可权从一台计算机移动到另一台计算机。
  • 可立即执行（推荐）或在安装 30 天内执行。
  • 消除硬件锁 (dongle) 的必要。 但是，如果您运行不使用激活的先前 SOLIDWORKS 产品版本，则必须保留硬件锁。

对于需要管理多个序列号的系统管理员，可以使用管理映像选项编辑器。有关详细信息，请参阅 管理映像选项编辑器。

要激活许可：

  1. 启动 SOLIDWORKS。
  2. 使用以下方法之一启动 SOLIDWORKS 产品激活：
    • 如果您尚未激活该计算机的许可证，SOLIDWORKS 产品激活窗口将在您启动 SOLIDWORKS 软件时自动出现。
    • 如果 SOLIDWORKS 产品激活窗口未自动出现，请单击 [image] > 许可 > 激活来启动激活。
  3. 选择产品列表，指定您想要为其激活许可的产品。
  4. 指定通过因特网自动激活或使用电子邮件手动激活。
  5. 提供电子邮件联系信息。
  6. 单击下一步。
    • 因特网：自动激活。
    • 电子邮件：单击保存创建请求文件，然后将该文件发送到 activation@solidworks.com。在收到包含响应文件的电子邮件后，从电子邮件中提取文件，然后单击打开以加载该文件。
      如有必要，可以退出并返回激活程序以打开响应文件。
  7. 单击完成。
管理映像选项编辑器

重新激活许可

如果您拥有 SOLIDWORKS 2022 和更高版本产品的永久商业或教育许可，您必须每年重新激活这些许可一次。SOLIDWORKS 产品激活会在所需的重新激活日期之前提示您执行此操作。

要重新激活许可：

  1. 启动 SOLIDWORKS。
    SOLIDWORKS 产品激活提示您重新激活。对于每个 SOLIDWORKS 产品许可，它显示以下内容：
    • 当前激活失效的日期
    • 为了继续使用产品而需要的操作，例如重新激活永久许可，或续订和重新激活许可期限或评估许可。
  2. 单击立即重新激活以启动产品激活向导。

    如果不想立即重新激活许可，请单击以后提醒我。 例如，在 SOLIDWORKS 中，单击 [image] > 许可 > 激活以启动产品激活向导。 请参阅 激活许可。

移动许可

要将 SolidNetWork 许可移至新计算机或升级的计算机，请首先从 Dassault Systèmes SOLIDWORKS Corporation 的许可密钥服务器停用它。然后在另一台计算机上重新激活它。

如果您无法停用 Dassault Systèmes SOLIDWORKS Corporation 许可（例如由于硬盘驱动器故障），在大部分情况下仍然能够成功地重新激活。如果失败，请联系您的增值经销商寻求帮助。

要转移许可：

  1. 在 SOLIDWORKS 中，单击 [image] > 许可 > 停用，然后按照指示操作。
  2. 若要重新激活，请转到新计算机或升级的计算机，并按照初始激活程序激活许可。 有关详细信息，请参阅激活许可。


使用 SolidNetWork License Manager 管理许可

SolidNetWork License Manager 可通过向网络中的客户端分发许可支持多个许可客户端。 这样就能够利用浮动许可，允许用户数量超过许可数量。

下图显示了典型的 SolidNetWork 许可安装：

此图说明：
  • SolidNetWork 许可管理器软件仅可在许可管理器计算机上安装和激活。
  • 许可客户端计算机没有安装额外的特定 SolidNetWork 软件。

    如果您在安装时指定了 SolidNetWork 许可序列号，SOLIDWORKS 安装管理程序将把该计算机识别为 SolidNetWork 许可客户端。SOLIDWORKS 安装管理程序将向您提示客户端连接到许可管理程序时使用的 SolidNetWork License Manager 计算机名和端口号。

  • 许可管理器和所有许可客户端都必须使用 TCP/IP（传输控制协议/因特网协议）连接。

内容

  • 安装 SolidNetWork 许可概述

    在任何计算机上安装 SOLIDWORKS 客户端软件之前，您可以使用 SOLIDWORKS 安装管理程序在至少一台计算机上安装 SolidNetWork License Manager Server。然后，您可以使用产品激活向导为永久和有期限许可添加和激活序列号。

  • 启动 SolidNetWork License Manager

    您可以从 Windows 开始菜单启动 SolidNetWork License Manager。

  • 升级 SolidNetWork License Manager

    对于 SOLIDWORKS 的主要版本，升级许可管理器包括卸载旧版许可管理器、安装新版本，以及重新激活 SolidNetWork 许可。

  • 移动 SolidNetWork 许可

    要将 SolidNetWork 许可移动到新计算机或升级的计算机上，请首先在 Dassault Systèmes SOLIDWORKS Corporation 的许可密钥服务器上将其停用，然后再在其他计算机上重新激活该密钥。

  • 删除 SolidNetWork 许可文件

    在升级到新许可之前，可以删除过期的 SolidNetWork 许可文件。

  • 借用和归还 SolidNetWork 许可

    您可以借用 SolidNetWork 许可以从远程位置使用软件。由于许可已从可用许可库中移除，因此借用的许可必须要在归还后才能继续可用。

  • 管理 SOLIDWORKS 各版本的访问权限

    您可在 SolidNetWork 环境中限制用户使用特定版本的 SOLIDWORKS。此功能让您能够管理不同个人、项目和业务单位所使用的 SOLIDWORKS 版本。

  • 监控许可闲置时间

    SOLIDWORKS 可在 SolidNetWork License Manager 上登记闲置时间，以便将在一段时间内未使用的许可归还到可用许可库中。

  • 使用临时许可

    当 SolidNetWork 许可不可用时，您可以使用临时“任意”许可。

  • 在插件产品中使用 SolidNetWork 许可

    您可以使用 SolidNetWork License Manager 来为 SOLIDWORKS 核心插件产品分发许可。

  • 使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可

    SolidNetWork 许可用户可控制在其许可池中添加 SOLIDWORKS Simulation 许可时要使用的 SOLIDWORKS® Simulation 许可。 他们还可以在需要更高级的许可类型来执行更高级的算例时升级 SOLIDWORKS Simulation 许可，而无需卸载插件。

  • 加载 Flow Simulation 模块

    作为 SolidNetWork 许可证客户，您可以使用两种方法控制如何为 Flow Simulation 加载 HVAC 和 Electronics Cooling 插件模块。

  • SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时

    当您运行 SOLIDWORKS Simulation、Plastics 或 Flow Simulation 算例时，网络许可证保持活动状态，不会超时。SOLIDWORKS 在计算过程中持有许可证，因为此过程被视为一项活动。

  • 在同一台计算机上安装许可管理器和管理映像

    您可以配置网络上的一台计算机，作为发布 SolidNetWork 许可的许可管理器，同时作为可供用户安装 SOLIDWORKS 软件的管理映像位置。

  • 卸载 SolidNetWork License Manager

    在升级 SolidNetWork License Manager 时，您必须先卸载旧许可管理器才能安装新版本。

  • FlexNet Publisher 许可管理

    SolidNetWork 的许可管理方式建立在 FlexNet Publisher® 许可管理的基础之上。

父主题 许可管理
管理个人许可


安装 SolidNetWork 许可概述

在任何计算机上安装 SOLIDWORKS 客户端软件之前，您可以使用 SOLIDWORKS 安装管理程序在至少一台计算机上安装 SolidNetWork License Manager Server。然后，您可以使用产品激活向导为永久和有期限许可添加和激活序列号。

当您在计算机上安装 SOLIDWORKS 客户端软件时，请指定 SolidNetWork 许可序列号。SOLIDWORKS 安装管理程序将该计算机识别为 SolidNetWork 许可客户端，并提示您输入 SolidNetWork License Manager Server 的计算机名称和端口号。如果未安装 SolidNetWork License Manager Server 或者名称或端口号不正确，则会显示错误。

激活流程

您必须首先在 SolidNetWork License Manager Server 计算机上激活 SolidNetWork 许可，才能在单台计算机上运行 SOLIDWORKS 产品。

激活要求您具有有效的互联网连接或电子邮件访问权限。激活后，您不必上网即可使用该产品。如果您使用该产品的计算机上无法访问电子邮件，您可以保存激活文件并从另一计算机上发送。

该过程将：
  • 激活所有 SOLIDWORKS 产品拥有 SolidNetWork 许可的 SOLIDWORKS SolidNetWork 许可管理器。
  • 允许您将 SolidNetWork 许可权限从一台 SolidNetWork License Manager 计算机移动到另一计算机。
  • 使您能够在一台 SolidNetWork 许可管理器计算机上安装并激活 SolidNetWork 许可权限。
  • 必须执行，您才能使用 SolidNetWork 许可。
  • 消除硬件锁 (dongle) 的必要。如果您为此版本的 SOLIDWORKS 激活 SolidNetWork 许可，旧版 SOLIDWORKS 的 SolidNetWork 许可也激活。您无需再保留硬件锁。

内容

  • 安装 SolidNetWork License Manager Server

    SolidNetWork License Manager Server 支持多个许可客户端。它在网络上为客户端分发许可。

  • 激活 SolidNetWork 许可

    您必须首先在 SolidNetWork License Manager 计算机上激活 SolidNetWork 许可，才能在单台计算机上运行 SOLIDWORKS 产品。

  • 使用 SolidNetWork License Manager Server 手动激活

    当您安装或升级 SolidNetWork License Manager Server 时，需要激活或重新激活许可。您可以通过互联网激活或重新激活许可，或选择手动执行。

  • 安装 SolidNetWork License Client

  • 在防火墙中使用 SolidNetWork 许可

    如果您的计算机使用防火墙，您必须配置相应的端口来支持 SolidNetWork 许可。

  • 重新激活 SolidNetWork 许可

    在组织将 SolidNetWork License Manager Server 升级到 2022 版本或更高版本后，重新激活适用于 SolidNetWork 许可产品。即使安装的产品来自较早版本，服务器上从 2022 版本开始的许可也需要每年重新激活一次。

  • 三合一许可管理器安装

    三合一许可管理器使用三台计算机以确保万无一失。如果管理许可文件的计算机不可使用，另外两台计算机之一将接管。

父主题 使用 SolidNetWork License Manager 管理许可
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


安装 SolidNetWork License Manager Server

SolidNetWork License Manager Server 支持多个许可客户端。它在网络上为客户端分发许可。

如果您在从为许可激活使用硬件锁的 SolidNetWork License Manager Server 先前版本进行升级，在安装 SolidNetWork License Manager Server 的新版本之前移除硬件锁。

  1. 按照下载安装介质中的说明启动 SOLIDWORKS 安装管理程序。
  2. 对于安装类型，请选择安装服务器组件，然后单击在该计算机上安装 SolidNetWork License Manager（分布式许可）。
  3. 在摘要页面上，查看安装位置和后台下载程序，同意许可条款，然后单击立即安装。
  4. 在 SolidNetWork License Manager Server 的 SOLIDWORKS 产品激活向导中，添加序列号并激活至少一个许可。请参阅添加序列号和激活 SolidNetWork License。
父主题 安装 SolidNetWork 许可概述
激活 SolidNetWork 许可
使用 SolidNetWork License Manager Server 手动激活
安装 SolidNetWork License Client
在防火墙中使用 SolidNetWork 许可
重新激活 SolidNetWork 许可
三合一许可管理器安装


激活 SolidNetWork 许可

您必须首先在 SolidNetWork License Manager 计算机上激活 SolidNetWork 许可，才能在单台计算机上运行 SOLIDWORKS 产品。

要激活 SolidNetWork 许可：

  1. 单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Server版本，以启动 SolidNetWork License Manager。
  2. 可选： 如果您尚未激活 SolidNetWork 许可，则软件会要求您激活它。单击是。
    这将启动 SOLIDWORKS 产品激活向导。
  3. 可选： 如果有防火墙，请选择此服务器上使用了防火墙。
  4. 在 SolidNetWork License 服务器信息页面中输入端口号，然后单击下一步。
  5. 在序列号：中选择特定序列号，或者单击全选以突出显示并激活您的所有 SOLIDWORKS 序列号。
    1. 选择该选项以激活通过英特网自动进行（推荐）。
    2. 在联系信息下，输入电子邮件地址。
    激活/重新激活成功对话框会显示所有已激活的产品。
  6. 单击完成。
父主题 安装 SolidNetWork 许可概述
安装 SolidNetWork License Manager Server
使用 SolidNetWork License Manager Server 手动激活
安装 SolidNetWork License Client
在防火墙中使用 SolidNetWork 许可
重新激活 SolidNetWork 许可
三合一许可管理器安装


使用 SolidNetWork License Manager Server 手动激活

当您安装或升级 SolidNetWork License Manager Server 时，需要激活或重新激活许可。您可以通过互联网激活或重新激活许可，或选择手动执行。

手动激活时：
  • 对于新的 SolidNetWork License Manager Server，您需要激活两次才能正确配置服务器。您在首次激活时将初始化服务器上的许可系统。第二次重复此过程时，您将激活许可。
  • 对于升级的 SolidNetWork License Manager Server，您需要重新激活现有许可。如果服务器没有激活的许可，则可以使用“服务器管理”选项卡上的修改运行激活。
父主题 安装 SolidNetWork 许可概述
安装 SolidNetWork License Manager Server
激活 SolidNetWork 许可
安装 SolidNetWork License Client
在防火墙中使用 SolidNetWork 许可
重新激活 SolidNetWork 许可
三合一许可管理器安装


安装 SolidNetWork License Client

当您在计算机上安装 SOLIDWORKS CAD 软件时，您指定 SolidNetWork 许可序列号。SOLIDWORKS 安装管理程序将该计算机识别为 SolidNetWork License Client，并提示您输入 SolidNetWork License Manager 的计算机名称和编号。如果未安装 SolidNetWork License Manager Server，或者名称或端口号不正确，则会显示错误。

要使用 SolidNetWork 许可安装 SOLIDWORKS：

  1. 按照下载安装介质中的说明启动 SOLIDWORKS 安装管理程序。
  2. 如果是首次在这台计算机上安装此 SOLIDWORKS 主要版本，请在欢迎页面单击在此计算机上安装。
    如果是从现有的版本升级，并从单一许可更改为 SolidNetWork 许可，单击修改单机安装（此计算机上）。 有关详细信息，请参阅 从个人许可升级为 SolidNetWork 许可 ：
  3. 在添加服务器对话框中，输入 SolidNetWork License Manager 的地址，格式为：

    端口@计算机名

    端口号必须与许可管理器计算机使用的相同。默认为 25734。

    SOLIDWORKS 安装管理程序将尝试验证此 SolidNetWork License Manager 是否可访问。如果您尚未安装许可管理器，此验证将失败；但是，您仍然可以继续进行许可客户端安装。
  4. 按照 SOLIDWORKS 安装管理器的说明完成 SOLIDWORKS 安装程序。
父主题 安装 SolidNetWork 许可概述
安装 SolidNetWork License Manager Server
激活 SolidNetWork 许可
使用 SolidNetWork License Manager Server 手动激活
在防火墙中使用 SolidNetWork 许可
重新激活 SolidNetWork 许可
三合一许可管理器安装


在防火墙中使用 SolidNetWork 许可

如果您的计算机使用防火墙，您必须配置相应的端口来支持 SolidNetWork 许可。

在防火墙软件中，您必须添加两个 SolidNetWork License 端口（例如，SNL-in-port 和 SNL-out-port）至防火墙例外列表中。有关配置这些端口的详细信息，请咨询您的系统管理员。

如果您使用 Windows 操作系统上的 Windows 防火墙，则您必须在 SolidNetWork License Manager 计算机上修改端口，并修改 SolidNetWork 许可文件，以向许可客户端计算机分发许可。

修改用于 Windows 防火墙的许可管理器计算机端口

  1. 单击开始并打开 Windows 安全中心。
  2. 选择防火墙和网络保护 > 高级设置，然后单击是确认更改。
  3. 在高级安全 Windows Defender 防火墙对话框，选择入站规则 > 新建规则。
  4. 在新建入站规则向导中，选择规则类型端口，然后单击下一步。
  5. 在特定本地端口：中输入端口号（例如 80、25734、443），然后单击下一步。
  6. 选择名称。输入名称（例如 SNL-in-port）。
  7. 单击完成。

修改用于 Windows 防火墙的 SolidNetWork License Manager 设置

  1. 单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Server版本，以启动 SolidNetWork License Manager。
  2. 在许可服务器下的服务器管理标签上，单击停止。单击是确认，单击确定停止许可服务器。
  3. 在许可信息下，单击修改。
  4. 在服务器类型下，选择您的网络的服务器配置（单一或三合一），然后单击下一步。
  5. 在服务器信息下：
    1. 选择此服务器上使用了防火墙。
    2. 端口号和卖方端口监控程序端口号应包含为 Windows 防火墙指定的端口号（详细信息，请参阅上述程序）。
    3. 选择选项文件并单击浏览以查找文件。单击编辑以更改它的任何参数。
    选项文件允许许可管理员控制 FlexNet 许可的各种操作参数。

    建议：您可在 SolidNetWork License Manager 安装目录中找到选项文件 (SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt)。该文件必须与 sw_d.lic 文件位于同一目录中。

    有关选项文件的详细信息，请参阅 SolidNetWork License Manager 安装目录下的 FlexNet Publisher 许可管理指南：

    C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

父主题 安装 SolidNetWork 许可概述
安装 SolidNetWork License Manager Server
激活 SolidNetWork 许可
使用 SolidNetWork License Manager Server 手动激活
安装 SolidNetWork License Client
重新激活 SolidNetWork 许可
三合一许可管理器安装


重新激活 SolidNetWork 许可

在组织将 SolidNetWork License Manager Server 升级到 2022 版本或更高版本后，重新激活适用于 SolidNetWork 许可产品。即使安装的产品来自较早版本，服务器上从 2022 版本开始的许可也需要每年重新激活一次。

在重新激活日期后的 30 天内，网络上的 SOLIDWORKS 产品会通知用户许可将过期。 管理员必须知道过期，才能及时重新激活许可。

要重新激活 SolidNetWork 许可：

  1. 单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Server 版本 以启动 SolidNetWork License Manager Server。
  2. 在服务器管理选项卡的许可信息下，单击重新激活。

  3. 在序列中，为所有许可选择全部，或输入许可号以搜索特定许可。

    重新激活许可对话框以红色突出显示 30 天内的所有许可到期和重新激活日期。星号标记需要续订的许可证。

  4. 单击重新激活。
父主题 安装 SolidNetWork 许可概述
安装 SolidNetWork License Manager Server
激活 SolidNetWork 许可
使用 SolidNetWork License Manager Server 手动激活
安装 SolidNetWork License Client
在防火墙中使用 SolidNetWork 许可
三合一许可管理器安装


三合一许可管理器安装

三合一许可管理器使用三台计算机以确保万无一失。如果管理许可文件的计算机不可使用，另外两台计算机之一将接管。

使用三合一许可管理器的要求：
  • 三合一许可管理器只能安装在不常关机的计算机上。
  • 三台许可管理器应在同一子网络上。不要使用通信速度较低的链接或拨号链接配置三合一许可管理器。
  • 系统管理员应及时探测到许可管理器何时死机并且尽快重新开机。
    如果只有两台许可管理器计算机在运行，这种状况比单一许可管理器更糟，因为有两个故障点。

内容

  • 安装初始三合一许可管理器

    此过程显示如何在三元组中的第一台计算机上安装 SolidNetWork License Manager。

  • 在随后的计算机上安装三合一许可管理器

    要在三合一组合的第二和第三台计算机上安装 SolidNetWork License Manager 软件，请按以下指示操作。 除步骤 2(f) 和 2(i)，该过程与首台计算机的软件安装基本相同。

父主题 安装 SolidNetWork 许可概述
安装 SolidNetWork License Manager Server
激活 SolidNetWork 许可
使用 SolidNetWork License Manager Server 手动激活
安装 SolidNetWork License Client
在防火墙中使用 SolidNetWork 许可
重新激活 SolidNetWork 许可


安装初始三合一许可管理器

此过程显示如何在三元组中的第一台计算机上安装 SolidNetWork License Manager。

  1. 在三合一许可管理器的第一台计算机上，使用 SOLIDWORKS 安装管理程序安装 SolidNetWork License Manager：
    1. 按照下载安装介质中的说明启动 SOLIDWORKS 安装管理程序。
    2. 对于安装类型，选择安装服务器组件，然后单击在该计算机上安装 SolidNetWork License Manager（分布式许可）。
    3. 在摘要页面，检查 SolidNetWork License Manager 的安装位置和下载选项，再单击立即安装以完成 SOLIDWORKS 安装管理程序流程。
  2. 使用 SolidNetWork License Manager 配置三合一许可管理器的初始计算机：
    1. 启动 SolidNetWork License Manager。单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Server 版本。

      由于这是在这台计算机上首次运行 SolidNetWork License Manager，系统将会询问您是否要现在激活。

    2. 单击否。

      此时将出现 SOLIDWORKS SolidNetWork License Manager 的“服务器管理”选项卡。

    3. 在“服务器管理”选项卡的高级选项下，单击选项。
    4. 在 SolidNetWork 服务器许可模式下，单击使用许可文件，然后单击确定。
    5. 在许可信息下，单击修改。
      SolidNetWork 许可文件向导出现。
    6. 在服务器类型下，选择三合一，然后单击下一步。
    7. 在“服务器信息”窗格中，验证三合一许可管理器的首台计算机的计算机名和端口号是否正确无误，然后单击下一步。

      检查网络接口卡 (NIC) 地址是否与从 SOLIDWORKS 接收到的许可文件中的信息相匹配，以及三合一许可管理器计算机的端口号是否正确。 NIC 地址也被称为 MAC（媒体访问控制地址）地址。 然后单击下一步。

      要查找 NIC 地址，打开命令提示符窗口，然后键入：

      ipconfig /all

      此外，如果您的计算机使用防火墙，您可能还需要在此屏幕上添加规范。有关更多信息，请参阅使用具有防火墙的 SolidNetWork 许可。

    8. 在三元组伙伴服务器信息屏幕上，输入三元组许可管理器的其他两台计算机的名称和主机 ID 值，然后单击下一步。
      这样可确保如果一个三元组许可管理器不可用，客户端计算机可从其他两台服务器获得许可。
    9. 在许可屏幕上，单击读取浏览并打开 SolidNetWork 许可文件。
      许可将出现在 SolidNetWork License 文件向导中。对于此计算机，您可以使用从增值经销商或 Dassault Systèmes SOLIDWORKS 客户支持人员收到的许可文件。
    10. 单击完成。
    11. 单击确定退出，单击完成关闭 SolidNetWork License Manager。
父主题 三合一许可管理器安装
在随后的计算机上安装三合一许可管理器
在防火墙中使用 SolidNetWork 许可


在随后的计算机上安装三合一许可管理器

要在三合一组合的第二和第三台计算机上安装 SolidNetWork License Manager 软件，请按以下指示操作。 除步骤 2(f) 和 2(i)，该过程与首台计算机的软件安装基本相同。

假定您已在另一台计算机上安装了至少一个三合一许可管理器。

  1. 在三合一许可管理器的计算机上，使用 SOLIDWORKS 安装管理程序安装 SolidNetWork License Manager：
    1. 按照下载安装介质中的说明启动 SOLIDWORKS 安装管理程序。
    2. 对于安装类型，请选择安装服务器组件，然后单击在该计算机上安装 SolidNetWork License Manager（分布式许可）。
    3. 在摘要页面验证 SolidNetWork License Manager 的安装位置和下载选项，然后单击立即安装以完成 SOLIDWORKS 安装管理程序流程。
  2. 使用 SolidNetWork License Manager 配置三合一许可管理器计算机：
    1. 启动 SolidNetWork License Manager。单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Server 版本。
      由于这是在这台计算机上首次运行 SolidNetWork License Manager，系统将会询问您是否要现在激活。
    2. 单击否。
      此时将出现 SOLIDWORKS SolidNetWork License Manager 的“服务器管理”选项卡。
    3. 在高级选项下，单击选项。
      将出现高级选项对话框。
    4. 在 SolidNetWork 服务器许可模式下，单击使用许可文件，然后单击确定。
      高级选项对话框关闭。
    5. 在许可信息下，单击修改。
      SolidNetWork 许可文件向导出现。
    6. 在服务器类型下，选择三合一和同步服务器/许可信息，然后单击下一步。
    7. 在三元组服务器信息屏幕上，输入计算机名称和主机 ID 值。然后单击下一步。
      这样可以确保如果一个许可管理器不可用，客户端计算机可以从其他两台服务器获得许可。
    8. 在许可屏幕上，单击读取浏览并打开 SolidNetWork 许可文件。
      许可出现在 SolidNetWork 许可文件向导中。
    该许可文件由您配置的三元组许可管理器的首台计算机生成。通常，该许可文件位于 \licenses\sw_d.lic。例如：C:\Program Files\SOLIDWORKS SolidNetWork License Manager\licenses\sw_d.lic
    1. 单击完成。
      SolidNetWork 许可文件向导警告出现。
    2. 单击确定退出 SolidNetWork 许可文件向导，然后单击完成退出 SolidNetWork License Manager。

为三合一许可管理器的第三台计算机重复此流程。

父主题 三合一许可管理器安装
安装初始三合一许可管理器


启动 SolidNetWork License Manager

您可以从 Windows 开始菜单启动 SolidNetWork License Manager。

在 Windows 中，单击开始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Server版本。

您可以使用 Windows 开始菜单中的相同路径打开 SolidNetWork License Manager Client 版本。

父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


升级 SolidNetWork License Manager

对于 SOLIDWORKS 的主要版本，升级许可管理器包括卸载旧版许可管理器、安装新版本，以及重新激活 SolidNetWork 许可。

新版本的许可管理器也可为仍然使用先前版本的客户端计算机分发许可。

  1. 单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Server版本，以启动 SolidNetWork License Manager。
  2. 在许可使用选项卡上，验证网络上没有客户端计算机正在运行 SOLIDWORKS。
  3. 卸载旧版许可管理器。有关详细信息，请参阅 卸载 SolidNetWork License Manager。
  4. 在许可管理器计算机上安装新的许可管理器并重新激活 SolidNetWork 许可。有关详细信息，请参阅 安装 SolidNetWork License Manager Server。

如果您要在同样运行 SOLIDWORKS 应用程序的计算机上升级 SolidNetWork License Manager，请先升级 SolidNetWork License Manager 和客户端，然后再在该计算机上安装任何新的 SOLIDWORKS 应用程序 Service Pack。

如果您正在作为管理映像主机的计算机上升级许可管理器，先升级许可管理器再升级管理映像。 有关详细信息，请参阅 在同一台计算机上安装许可管理器和管理映像。

父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


移动 SolidNetWork 许可

要将 SolidNetWork 许可移动到新计算机或升级的计算机上，请首先在 Dassault Systèmes SOLIDWORKS Corporation 的许可密钥服务器上将其停用，然后再在其他计算机上重新激活该密钥。

如果您无法停用 Dassault Systèmes SOLIDWORKS Corporation 许可（例如由于硬盘驱动器故障），大部分情况下仍然能够成功地重新激活。如果失败，请联系您的增值经销商寻求帮助。

要迁移 SolidNetWork 许可：

  1. 单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Server 版本 以启动 SolidNetWork License Manager Server。
  2. 在服务器管理选项卡的许可信息下，单击修改。SOLIDWORKS 产品激活向导启动。
  3. 在您想做什么？下，选择转移产品许可到新的/已升级的计算机，然后单击下一步。
  4. 在序列号：列表下选择序列号，或者单击全选以激活您的所有 SOLIDWORKS 序列号。
    1. 选择通过英特网自动进行（推荐）选项。
    2. 在联系信息（必填）：下，指定电子邮件地址。
  5. 此时将出现停用成功消息框。
    完成产品许可的停用。
  6. 单击完成。
父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


删除 SolidNetWork 许可文件

在升级到新许可之前，可以删除过期的 SolidNetWork 许可文件。

  1. 启动 SolidNetWork License Manager，方法是单击开始 > SOLIDWORKS 工具 版本 > SolidNetWork License Manager Server。
  2. 在服务器管理选项卡的许可信息下，单击修改，然后单击下一步。
  3. 在激活/停用您的 SOLIDWORKS 产品页面上，选择过期的 SolidNetWork 许可文件，然后单击移除。
  4. 单击完成和确定退出。
父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


借用和归还 SolidNetWork 许可

您可以借用 SolidNetWork 许可以从远程位置使用软件。由于许可已从可用许可库中移除，因此借用的许可必须要在归还后才能继续可用。

借用的许可只对当前用户和所借用的机器有效；它们不能移动。

许可可以在指定的借用期限内使用，最多 30 天（或由您的系统管理员定义），过期后许可将从许可资源库中移除。

如果 SOLIDWORKS 许可证正在被使用，则无法借用和归还许可证。

系统管理员可自定义借用以便：
  • 定义允许借用许可的用户或组
  • 设定不能借用的许可数

有关详情，请参阅 SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf。

内容

  • 借用 SolidNetWork 许可

  • 归还借用的 SolidNetWork 许可

    由于借用的 SolidNetWork 许可已从许可库中移除，因此借用的许可必须要在归还后才能继续保持可用。

父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


借用 SolidNetWork 许可

始终从开始菜单启动 SolidNetWork License Manager。您必须连接到 SolidNetWork License Manager 才能借用许可。

这些步骤可能因系统配置而异。 参阅 Microsoft Windows 文档了解其他说明和选项。
  1. 在客户端计算机上，单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Client版本，以启动 SolidNetWork License Manager。
  2. 在许可借用标签上：
    1. 在借用到中选取一日期。
    2. 在可用的产品许可下，选择要借用的产品，然后单击借用。
    3. 在该对话框的提示中，单击选定产品，从列表中选择产品，然后单击确定进行确认。
    4. 在该对话框底部，单击刷新。
      借用截止日期一列指示许可的到期时间。
  3. 单击确定。

在“许可证使用”选项卡中，您还可以查看许可证总数、空闲许可证、许可证用户以及借用截止日期。

如果您正在远程工作且 SOLIDWORKS 应用程序打开速度较慢，请选择仅使用借用的许可证（启动速度更快）。

此选项可阻止对许可证服务器的查询，在某些环境中可能会较慢。应用程序可以通过忽略查询来加快启动速度，但仅使用您借用的许可。

重新启动应用程序，使此选项生效。

父主题 借用和归还 SolidNetWork 许可
归还借用的 SolidNetWork 许可


归还借用的 SolidNetWork 许可

由于借用的 SolidNetWork 许可已从许可库中移除，因此借用的许可必须要在归还后才能继续保持可用。

  1. 在客户端计算机上，单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Client版本，以启动 SolidNetWork License Manager。
  2. 在许可借用标签上：
    1. 在“借用的产品许可”下，选择要返回的产品，然后单击归还。
    2. 单击刷新。借用截止日期一列将变为空白，指示许可已归还。
  3. 单击确定。

在“许可证使用”选项卡中，您还可以查看许可证总数。

无需归还已过期的许可。在失效日期午夜，许可将归还到 SolidNetWork License Manager 上的许可库中，远程系统上的应用程序不再运行。
父主题 借用和归还 SolidNetWork 许可
借用 SolidNetWork 许可


管理 SOLIDWORKS 各版本的访问权限

您可在 SolidNetWork 环境中限制用户使用特定版本的 SOLIDWORKS。此功能让您能够管理不同个人、项目和业务单位所使用的 SOLIDWORKS 版本。

要使用 FlexNet 选项文件管理访问权限：

  1. 在 SolidNetWork License Manager 安装目录中创建文本文件：
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. 在许可文件中，在 SOLIDWORKS 旁边使用以下语法添加 SOLIDWORKS 版本控制：
    :SWVERSION=xx 其中 xx 是您要管理的 SOLIDWORKS 的发行版本
  3. 要管理多个版本的 SOLIDWORKS，为您要管理的每个版本均添加一行。

    并非所有 FlexNet 选项均受到支持。 受支持的版本过滤器选项包括：

    INCLUDE | 仅允许指定的用户/组启动特定版本。
    INCLUDE_BORROW | 仅允许指定的用户/组启动特定版本。
    EXCLUDE | 阻止指定的用户/组启动特定版本（覆盖 INCLUDE）。
    EXCLUDE_BORROW | 阻止指定的用户/组借用特定版本（覆盖 INCLUDE_BORROW）。
    示例：
    1 | INCLUDE solidworks:SWVERSION=xx USER jane
    INCLUDE_BORROW solidworks:SWVERSION=xx USER jane
    只有用户 jane 可以运行或借用 SOLIDWORKS 的指定版本。其他用户可按权限访问其他版本。
    2 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=xx GROUP chicago
    EXCLUDE solidworks USER don
    该组 chicago 被限制使用特定版本。用户 don 被限制使用 SOLIDWORKS 的所有版本。
    3 | EXCLUDE swinspection_std:SWVERSION=xx HOST machine1
    阻止 machine1 上的用户启动 SOLIDWORKS Inspection 的指定版本。

    有关 FlexNet 的信息，请参阅 SolidNetWork License Manager 安装目录下的 FlexNet Publisher 许可管理指南：\Docs\flexuser\fnp_LicAdmin.pdf。

父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


监控许可闲置时间

SOLIDWORKS 可在 SolidNetWork License Manager 上登记闲置时间，以便将在一段时间内未使用的许可归还到可用许可库中。

  1. 在 SolidNetWork License Manager 安装目录中，创建一个文本文件：
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. 将下行添加到文件：
    TIMEOUTALL 秒

    其中秒是大于或等于 900（15 分钟）的数字，是允许的最小时间。

父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


使用临时许可

当 SolidNetWork 许可不可用时，您可以使用临时“任意”许可。

默认情况下，SolidNetWork License Manager 一次只能激活一台服务器。要在测试环境中工作，您可以通过技术支持获取临时许可文件，并将“任意”许可加载到另一台服务器上的 SolidNetWork License Manager 中。如果使用脱机服务器，您可以使用相同的说明加载激活豁免许可。

使用“任意”许可文件，即表示您同意在从 Dassault Systèmes SOLIDWORKS Corporation 收到 SolidNetWork 许可时，实施许可。仍要求遵循许可限制。

要使用“任意”许可：

  1. 单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Server版本，以启动 SolidNetWork License Manager。
  2. 如果软件提示您激活，请单击否。
  3. 在“服务器管理”选项卡中，单击高级选项 > 选项。
  4. 在“SolidNetWork 服务器许可模式”下，单击使用许可文件，然后单击确定。
  5. 在“服务器管理”选项卡的许可信息下，单击修改。
    SolidNetWork 许可文件向导出现。
  6. 在服务器类型下，选择单一，然后单击下一步。
  7. 选择硬件锁 ID，并输入任何或 NIC 地址以获取服务器信息。然后单击下一步。

    当您看到以下消息时，单击取消：无法读取硬件锁 ID 号码。

    如果您的计算机使用防火墙，您可能需要在此屏幕上指定其他规格。详细信息请参阅在防火墙中使用 SolidNetWork 许可。
  8. 在“许可”下，单击读取以读取许可文件。
  9. 在读取对话框中，浏览到技术支持提供的 SNL_ANY.txt 或 SNL_(NIC Card Number).txt 文件，然后单击打开。然后单击确定。
    SolidNetWork 文件许可向导列出了文本文件中的许可。
    单击移除以删除列表中已过期的临时许可条目。
  10. 单击完成以关闭 SolidNetWork 许可文件向导。
  11. 激活“任意”许可：
    1. 在“服务器管理”选项卡中，单击高级选项 > 选项。
    2. 在 SolidNetWork 服务器许可模式下，选择使用许可文件，然后单击确定。
    3. 在“服务器管理”选项卡中，单击修改 > 激活/停用您的产品许可。
    4. 选择序列号，输入联系信息，然后选择激活方法。如果您选择手动激活，请按照说明执行操作。
    5. 单击完成确认激活。
父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


在插件产品中使用 SolidNetWork 许可

您可以使用 SolidNetWork License Manager 来为 SOLIDWORKS 核心插件产品分发许可。

  • SOLIDWORKS 软件许可和 SOLIDWORKS 插件许可的数量不一定要相等。
  • 若要为某一插件产品检出许可，您必须首先检出 SOLIDWORKS 的许可。
  • 要借用插件产品许可，您必须同时借用 SOLIDWORKS 软件许可和包括插件的 SOLIDWORKS 产品许可。默认情况下会借用 SOLIDWORKS Standard 许可，但是要启用插件，必须借用 SOLIDWORKS Professional、SOLIDWORKS Premium 或 SOLIDWORKS Ultimate 产品许可。
  • 要释放插件产品许可：
    • 在 SOLIDWORKS 中，单击工具 > 插件，然后清除插件。
    • 退出 SOLIDWORKS。
父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可

SolidNetWork 许可用户可控制在其许可池中添加 SOLIDWORKS Simulation 许可时要使用的 SOLIDWORKS® Simulation 许可。 他们还可以在需要更高级的许可类型来执行更高级的算例时升级 SOLIDWORKS Simulation 许可，而无需卸载插件。

  1. 要使用特定 SOLIDWORKS Simulation 许可：
    1. 在 SOLIDWORKS 中，单击工具 > 插件，然后在插件对话框中，选择 SOLIDWORKS Simulation。
    2. 在 SOLIDWORKS Simulation (CommandManager) 上，单击向下箭头 [image] 以显示服务器上可支持 Simulation 的许可列表。

    3. 选择相应的 SOLIDWORKS Simulation 许可。
  2. 要检查或更改当前的 SOLIDWORKS Simulation 许可，单击 SOLIDWORKS Simulation (CommandManager) 上的向下箭头 [image] 。

    正在使用的许可将显示有一个复选标记。 如果有更高级的许可类型可用，则您可以升级。
    您不能降级 SOLIDWORKS Simulation 许可。 禁用 SOLIDWORKS Simulation 插件并在较低级别添加回许可。
  3. 可选： 要禁用插件，单击 SOLIDWORKS Simulation (CommandManager) 或从工具 > 插件中清除它。
以下情况仍使用许可顺序：
  • 当 SOLIDWORKS Simulation 开始运行时。
  • 已在工具 > 插件中添加了 SOLIDWORKS Simulation 时。
  • 当您单击 SOLIDWORKS Simulation 但未从下拉列表中指定许可时。
父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


加载 Flow Simulation 模块

作为 SolidNetWork 许可证客户，您可以使用两种方法控制如何为 Flow Simulation 加载 HVAC 和 Electronics Cooling 插件模块。

第一种方法允许您在加载 Flow Simulation 时为插件指定默认行为。选项可用时自动加载 Flow Simulation 插件模块 位于 SolidNetWork License Manager Client > 许可顺序选项卡中。如果您不需要 Flow Simulation 插件，请清除此选项。使用现有方法添加 Flow Simulation 时，HVAC 和 Electronics Cooling 插件模块不会加载。

第二种方法允许您覆盖默认行为，并在加载 Flow Simulation 时包括 HVAC 和 Electronics Cooling 插件模块。单击 SOLIDWORKS Flow Simulation（SOLIDWORKS®“插件”工具栏）或 SOLIDWORKS Flow Simulation 上的向下箭头 [image] ，以便加载一个或两个插件模块。

未使用这两种方法时，则无论您是否需要，都将耗用插件模块的许可证，并且系统可能拒绝网络上的其他用户使用。

父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时

当您运行 SOLIDWORKS Simulation、Plastics 或 Flow Simulation 算例时，网络许可证保持活动状态，不会超时。SOLIDWORKS 在计算过程中持有许可证，因为此过程被视为一项活动。

由 TIMEOUT 选项定义的闲置期仅在算例完成计算后生效。

父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


在同一台计算机上安装许可管理器和管理映像

您可以配置网络上的一台计算机，作为发布 SolidNetWork 许可的许可管理器，同时作为可供用户安装 SOLIDWORKS 软件的管理映像位置。

客户端计算机可以从许可管理器获得许可，然后从同一台计算机安装 SOLIDWORKS。

此配置要求许可管理器和管理映像安装在同一台计算机上。首先安装许可管理器，然后再创建和调用管理映像。
详情请参阅：
  • 安装 SolidNetWork License Manager Server
  • 调用到多个客户端
父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
卸载 SolidNetWork License Manager
FlexNet Publisher 许可管理


卸载 SolidNetWork License Manager

在升级 SolidNetWork License Manager 时，您必须先卸载旧许可管理器才能安装新版本。

  1. 单击启动 > SOLIDWORKS 工具版本 > SolidNetWork License Manager Server 版本，以启动 SolidNetwork License Manager。
  2. 验证网络上没有客户端计算机在运行 SOLIDWORKS。
    许可使用标签会显示在运行 SOLIDWORKS 的客户端。
  3. 如果您想将 SolidNetWork 许可移动到其他计算机上，则先在该计算机上将许可停用，然后再移除 SolidNetWork License Manager。
    有关移动 SolidNetWork 许可的信息，请参阅移动 SolidNetWork 许可。
  4. 在许可服务器下的服务器管理标签上，单击停止。
  5. 单击确定退出许可管理器。
  6. 在 Windows 中，打开控制面板 > 程序和功能。
  7. 选择 SOLIDWORKS SolidNetWork License Manager，单击卸载，然后确认卸载。
  8. 在文件资源管理器中，删除 SOLIDWORKS SolidNetWork 许可管理器文件夹。
    （通常，此文件夹位于 SOLIDWORKS 安装目录的 Program Files (x86) 下。）

现在，您已经准备好安装新版本的许可管理器了。有关详细信息，请参阅安装 SolidNetWork License Manager Server。

如果 SolidNetWork License Manager 计算机附加有硬件锁，在安装 SolidNetWork License Manager 的新版本之前移除硬件锁。
父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
FlexNet Publisher 许可管理
安装 SolidNetWork License Manager Server


FlexNet Publisher 许可管理

SolidNetWork 的许可管理方式建立在 FlexNet Publisher® 许可管理的基础之上。

有关 FlexNet Publisher 许可管理的信息，请参阅 SolidNetWork License Manager 安装目录下的 FlexNet Publisher 许可管理指南：C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

如需 FlexNet Publisher 许可管理的最新信息，请联系 Flexera® Software。

您可以通过查看许可证服务器上的日志来检查 FlexNet 版本。打开 SolidNetwork License Manager，然后单击服务器管理 > 查看日志。日志会将 FlexNet 许可版本列在开头的括号中。

父主题 使用 SolidNetWork License Manager 管理许可
安装 SolidNetWork 许可概述
启动 SolidNetWork License Manager
升级 SolidNetWork License Manager
移动 SolidNetWork 许可
删除 SolidNetWork 许可文件
借用和归还 SolidNetWork 许可
管理 SOLIDWORKS 各版本的访问权限
监控许可闲置时间
使用临时许可
在插件产品中使用 SolidNetWork 许可
使用 SolidNetWork License 选择 SOLIDWORKS Simulation 许可
加载 Flow Simulation 模块
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 非活动超时
在同一台计算机上安装许可管理器和管理映像
卸载 SolidNetWork License Manager


疑难解答

遇到安装问题时请参阅这些主题以排除故障。

内容

  • 网络许可证使用

  • SOLIDWORKS 安装管理程序日志文件

    SOLIDWORKS 安装管理程序日志文件可帮助您在遇到安装问题时排除故障。

  • SOLIDWORKS 安装管理程序下载文件夹

    SOLIDWORKS 安装管理程序可将所需的安装文件下载到您指定的文件夹中。 该主题提供对下载文件夹常见问题的回答。

  • SolidNetWork 许可故障排除

    如果 SolidNetWork License Manager 安装失败，请检查这些可能的解释。

  • 升级故障排除

    如果在升级到新的 SOLIDWORKS 发行版时遇到问题，请查看这些可能的解释。

  • 安装或升级时验证显卡

    当您在计算机上完成 SOLIDWORKS 安装或升级后，运行 SOLIDWORKS Rx 来确保您的计算机运行的是受支持的显卡和显卡驱动程序。


网络许可证使用

此对话框在服务器缺少某种产品许可证时出现。

单击 产品 框中的箭头来显示所有产品选择。 选择包括 SOLIDWORKS 及其所有可购买的插件。

许可证总数是您所购买的许可证总数量。

闲置许可证是未在使用的许可证总数量。

许可证用户方框为您提供使用许可的每个人的信息。

父主题 疑难解答
SOLIDWORKS 安装管理程序日志文件
SOLIDWORKS 安装管理程序下载文件夹
SolidNetWork 许可故障排除
升级故障排除
安装或升级时验证显卡


SOLIDWORKS 安装管理程序日志文件

SOLIDWORKS 安装管理程序日志文件可帮助您在遇到安装问题时排除故障。

这些日志文件与其他 SOLIDWORKS 应用程序的日志文件放在相同的位置。

  • C:\Users\username\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

如果您从系统帐户运行“安装管理器”，则日志位于以下文件夹中：
  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version
若要查看日志文件目录，必须将 Windows 文件夹选项配置为显示隐藏的文件和文件夹。

如果该应用程序数据不在 C: 盘上，请相应调整目录路径。

此目录包含 SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt 文件，该文件是 SOLIDWORKS 安装管理程序进度的常规日志。

Other Logs 子目录包含更详细的安装日志信息。

父主题 疑难解答
网络许可证使用
SOLIDWORKS 安装管理程序下载文件夹
SolidNetWork 许可故障排除
升级故障排除
安装或升级时验证显卡


SOLIDWORKS 安装管理程序下载文件夹

SOLIDWORKS 安装管理程序可将所需的安装文件下载到您指定的文件夹中。 该主题提供对下载文件夹常见问题的回答。

问题 答案
我如何安装此文件夹中的文件？

运行 setup.exe。如果您选择安装以前没有下载的项目，您可能仍需要下载某些文件。

不要使用 msiexec 进行安装（参阅下文）。
我可以使用 msiexec 或一些其它应用程序手工从此文件夹安装 MSI 文件吗？

否。 安装管理程序不下载在运行 msiexec 时所需的某些文件。
我可为每个安装的版本选取同一下载文件夹吗？

下载文件夹是版本特定的。 SOLIDWORKS 安装管理程序自动在指定文件夹内创建版本特定的子文件夹。

我从 Dassault Systèmes SOLIDWORKS Corporation 网站手动下载了一些产品。 安装管理程序可安装这些内容吗？
SOLIDWORKS 安装管理程序可以使用手动下载的文件。 但最好是运行 SOLIDWORKS 安装管理程序，然后选择文件下载选项。 SOLIDWORKS 安装管理程序会根据您的安装内容来显示所需的文件，并提供下载每个文件的链接。 当下载页面无法正常运行时（很可能是因为代理服务器施加了下载限制），可以使用此选项。
如果在下载或安装过程中有一个对话框问您是保存还是运行文件，请始终指定保存。
我下载的文件可被其他用户共享吗？

是。 若要共享，下载到网络共享中。 然后，每个客户端即可从共享处运行 SOLIDWORKS 安装管理程序进行安装。

无需另外下载，除非用户选择下载在初始下载时未选择的某些项目，或者使用此下载内容进行安装的计算机上的必备组件集与初始下载文件的计算机上的必备组件集不同。

如果您在代表他人进行下载但不进行安装，请在安装时选择只下载选项。 无论您的系统上可能安装了什么项目，此选项都让您可选择产品。 但是，您不能使用此选项下载修补程序或创建管理映像。
我如何知道有新版本 SOLIDWORKS 产品可用？
在以下情况下，当有新版本可用时将会通知您：
  • 如果您运行“检查更新”（开始 > SOLIDWORKS 安装管理程序 > 检查更新）
  • 如果您已启用 SOLIDWORKS 后台下载程序
  • 如果您在 Windows 的添加/删除程序中选择了一个已安装的 SOLIDWORKS 版本并单击更改
  • 如果您从下载文件夹运行安装管理程序 (sldIM.exe) 的旧版本
在这些情况下，您可选择下载新版本。 SOLIDWORKS 安装管理程序将下载并运行自身的新版本，而不是任何安装文件。 在 SOLIDWORKS 安装管理程序的新版本运行后，您可选取一组安装操作。 SOLIDWORKS 安装管理程序确定需要哪些安装文件（以前未下载），并主动下载这些文件。
SOLIDWORKS 安装管理程序为什么不让我选择安装产品的另一个 service pack？

每个 SOLIDWORKS 安装管理程序仅用于安装 SOLIDWORKS 产品的特定版本。 如果您想安装另一 service pack，您需要运行该版本的 SOLIDWORKS 安装管理程序。 要找到最新的可用版本，请参见之前的条目。
SOLIDWORKS 安装管理程序为什么被禁止下载文件？

如果代理服务器的限制阻止应用程序下载文件，则 SOLIDWORKS 安装管理程序无法自动下载文件。

您可以手动下载文件，然后使用 SOLIDWORKS 安装管理程序安装这些文件。在 SOLIDWORKS 安装管理程序中，选择用于下载单独文件的选项（例如下载选项页面中的手动下载方法）。根据您的产品选择和系统要求，将在单独的窗口中显示网页，其中包含所有手动下载文件的链接。
并不是我的所有 SOLIDWORKS 产品都会更新到最新的 service pack。 为什么“检查更新”告诉我所使用的已是最新版本？

检查更新仅告诉您是否您已安装有（或在运行）SOLIDWORKS 安装管理程序的最新版本。

如果您想将所有产品都更新到最新安装版本，请在控制面板 > 程序 > 程序和功能中选择 SOLIDWORKS 的最新安装版本，然后单击更改。
我可将 DVD 复制到下载文件夹中吗？

是，但安装可能失败，除非您为该平台复制每张 DVD 提供的全部内容。 SOLIDWORKS 安装管理程序通过查找文件 swdata*.id 来确定版本。 如果这些文件不存在，它将无法识别您所复制的任何安装文件，并要求将之下载。
父主题 疑难解答
网络许可证使用
SOLIDWORKS 安装管理程序日志文件
SolidNetWork 许可故障排除
升级故障排除
安装或升级时验证显卡


SolidNetWork 许可故障排除

如果 SolidNetWork License Manager 安装失败，请检查这些可能的解释。

父主题 疑难解答
网络许可证使用
SOLIDWORKS 安装管理程序日志文件
SOLIDWORKS 安装管理程序下载文件夹
升级故障排除
安装或升级时验证显卡

访问 SolidNetWork 许可日志文件

出现许可错误时，答案常常出现在 SNL_管理器安装目录\lmgrd.log 文件中。

无法获得 SOLIDWORKS 许可。 不能连接到许可服务器。

通常，此问题是由端口设定导致的。

  • SolidNetWork 许可管理器和许可客户端之间的端口设定不匹配。
  • 可能未指定 SolidNetWork License Manager 多个版本的其他端口设定。
  • 根据提供的服务器名称检查客户端机器是否可以准确还原并步路到该服务器。
关于 SolidNetWork 许可管理器和客户端的端口设置详细信息，请参阅 在防火墙中使用 SolidNetWork 许可。
在防火墙中使用 SolidNetWork 许可


升级故障排除

如果在升级到新的 SOLIDWORKS 发行版时遇到问题，请查看这些可能的解释。

父主题 疑难解答
网络许可证使用
SOLIDWORKS 安装管理程序日志文件
SOLIDWORKS 安装管理程序下载文件夹
SolidNetWork 许可故障排除
安装或升级时验证显卡

修改或修复已移动的安装源

安装 SOLIDWORKS 时，SOLIDWORKS 安装管理程序会记住安装源的位置（光盘媒介、网络上的光盘映像等）。在修改或修复时，它期望这些位置的安装源仍然可用。

如果安装源已移动或删除，或者如果源媒介已更改，则 SOLIDWORKS 安装管理程序会产生一错误信息。但是，您可以浏览到另一位置修改或修复安装源，只要该位置包含完全相同的文件和文件夹结构。


安装或升级时验证显卡

当您在计算机上完成 SOLIDWORKS 安装或升级后，运行 SOLIDWORKS Rx 来确保您的计算机运行的是受支持的显卡和显卡驱动程序。

要在安装或升级时验证显卡：

  1. 当安装管理程序完成安装并显示完成页面时，在检查您的系统下，单击运行系统诊断。

    SOLIDWORKS Rx 将启动并运行诊断。

  2. SOLIDWORKS Rx 将确认图形卡和图形卡驱动程序是否受支持。
    如果显卡受支持但驱动程序不受支持，将出现一条状态消息，指示您更新驱动程序。

您每启动 SOLIDWORKS 十次会出现一次请检查您的系统消息，并建议您再次运行系统诊断。要抑制这些通知，请右键单击 Windows 通知区域中的 SOLIDWORKS Resource Monitor [image] 并单击退订图形通知。

您可通过右键单击 Windows 通知区域中的 SOLIDWORKS Resource Monitor 随时验证显卡和驱动程序。该菜单还让您能够：
  • 访问 SOLIDWORKS Resource Monitor 的帮助部分
  • 运行系统诊断程序
  • 退订图形通知
  • 退订订阅通知
  • 查看经认证的显卡驱动程序
父主题 疑难解答
网络许可证使用
SOLIDWORKS 安装管理程序日志文件
SOLIDWORKS 安装管理程序下载文件夹
SolidNetWork 许可故障排除
升级故障排除


SOLIDWORKS 安装管理程序应用程序帮助

SOLIDWORKS 安装管理程序是用于安装和更新 SOLIDWORKS 产品的单独应用程序。

SOLIDWORKS 安装管理程序是下载、安装、修改、更新、修复和移除 SOLIDWORKS 软件的主要工具。

您可以下列方式运行 SOLIDWORKS 安装管理程序：
  • 从 SOLIDWORKS DVD 或共享源或下载文件夹（安装新版本时）
  • 从控制面板添加或删除程序页面（当修改或删除现有版本时）
  • 通过计划或手动的更新检查（当检测、下载并安装新发行版时）

每个 SOLIDWORKS 版本都有特定于该版本的 SOLIDWORKS 安装管理程序。

内容

  • SOLIDWORKS 后台下载程序

    SOLIDWORKS 后台下载程序使用后台程序进行文件自动下载（例如，发现新的 Service Pack 发行版时），使您可在下载时继续进行其他工作。 当下载完成时，您可以决定是想马上安装、推迟下载还是移除下载。

  • 为安装管理程序指定选项

    这些选项包括日志记录设置、Internet 访问设置和安装管理程序中所用语言的设置。

  • 检查更新结果

    检查更新会查找更高版本的 SOLIDWORKS。

  • 管理映像位置

    指定管理映像的安装位置。

  • 下载选项

    指定完成下载操作的详细信息，例如下载的文件的位置、文件下载方式以及是否安装下载的文件。

  • SOLIDWORKS 安装管理程序文件的下载选项

    您选择了下载 SOLIDWORKS 安装管理程序的新版本。 使用此荧屏指定在何处以及如何下载。

  • 下载产品安装文件

    指定在何处及如何为所指定的产品下载遗失的文件。

  • 下载进度

    SOLIDWORKS 安装管理程序在此过程中同时下载、验证并提取所有文件。

  • 下载结果

    表示下载是成功完成、操作过程失败还是被取消。

  • 安装错误/安装已取消

    安装遇到问题或被取消。

  • 安装完成

    SOLIDWORKS 安装管理程序已完成安装过程。

  • 安装位置

  • 升级选项

    此计算机上安装有一个或多个旧的 SOLIDWORKS 主要版本。 您可以创建与旧版本共存的新安装，或者进行升级以移除旧版本。

  • 安装进度

    该荧屏显示安装的进度。

  • 安装类型

    您可以指定要运行的安装操作。 例如，创建新安装、修改或修复现有安装、创建管理映像、安装管理服务器产品或下载文件，以便您可以在其他计算机上进行共享和安装。

  • 安装并管理多台计算机

    SOLIDWORKS 安装管理程序提供以下工具用于安装并管理多台 SOLIDWORKS 计算机。

  • 手动下载

    您已选择手动下载文件（或者可能在上次运行 SOLIDWORKS 安装管理程序时选择了手动下载）。

  • 有新版本可用

    安装管理程序检测到 SOLIDWORKS 产品的新版本。 您可选择安装包含在原有安装 DVD 或下载中的版本，或者您可选择下载并安装更新的版本。

  • 没有新版本可用

    没有可下载的更新版本。开始安装指定的版本。

  • 检测到进程

    SOLIDWORKS 安装管理程序在此计算机上检测到可能影响安装成功完成的进程。

  • 产品选择

    您可以指定要安装、修改、下载或移除的产品组件。

  • 要下载的产品

    选取要下载到指定位置的 SOLIDWORKS 产品。

  • 要修复的产品

    当您指定修复此安装时，该屏幕显示出可由此版本 SOLIDWORKS 安装管理程序修复的 SOLIDWORKS 产品（带有版本号）。

  • 序列号

    序列号将您的计算机与您购买的 SOLIDWORKS 产品相关联。

  • 服务器安装

    会列出您正在尝试安装的服务器产品，并显示安装结果。

  • 摘要

    SOLIDWORKS 安装管理程序具有完成安装操作所需的所有信息。

  • 系统检查警告

    系统检查报告了可能影响您继续安装的问题。 大多数情况下，您应该能够继续运行 SOLIDWORKS 安装管理程序。

  • 异型孔向导/Toolbox 选项

    如果您安装 SOLIDWORKS Toolbox，SOLIDWORKS 将包含一个标准的孔类型与五金器具库。

  • 卸载产品

    当您从 控制面板 中选取删除或卸装程序时，该屏幕显示可由此版本 SOLIDWORKS 安装管理程序卸载的 SOLIDWORKS 产品（带有版本号）。 您可选择进行标准、自定义或完整卸装。


SOLIDWORKS 后台下载程序

SOLIDWORKS 后台下载程序使用后台程序进行文件自动下载（例如，发现新的 Service Pack 发行版时），使您可在下载时继续进行其他工作。 当下载完成时，您可以决定是想马上安装、推迟下载还是移除下载。

安装 SOLIDWORKS 时，会默认启用后台下载程序。

运行安装管理程序时，无论是在进行安装还是下载操作，后台下载程序都将暂停运行。 例如，暂停所有运行中的下载、不允许开始新的下载并且不允许更改下载文件夹规格等。

您可以在安装期间禁用后台下载程序。 在“摘要”页面的“下载选项”下，清除为将来的 Service Pack 使用后台下载程序选项。

启用后，工具栏的 Windows 通知区域将显示以下图标：

单击此图标，可启用下列操作：
  • 帮助后台下载程序
  • 暂停下载
  • 恢复下载
  • 取消下载
  • 安装选项
  • 更改下载设定
  • 检查更新
  • 自动检查更新
  • 自动下载更新
  • 禁用后台下载程序

帮助后台下载程序

打开 SOLIDWORKS 安装指南中的此后台下载程序帮助主题。

暂停/恢复下载

如果后台正在运行下载，单击暂停下载可暂停下载，稍后也可通过单击恢复下载来恢复下载。

取消下载

如果正在运行下载，此操作将会停止下载，并删除后台下载程序已经下载的所有文件。
下载一旦取消，将无法恢复。

安装选项

下载完成后，您可以从以下选项选择：
  • 现在安装： 安装下载的文件。
  • 以后再提醒我： 暂不安装下载的文件，以后再发送消息提醒我。
  • 删除该下载： 请勿安装下载的文件并将其删除。 （如果您确定不再需要安装下载的文件，这非常有用。）

更改下载设定

更改后台下载程序所下载文件的保存文件夹位置。

下载正在运行或暂停时，此选项不可用。
您还可以指定两次更新检查之间的天数。

检查更新

运行 SOLIDWORKS 安装管理器的检查更新功能。

自动检查更新

定期运行检查更新，它会在有更新可供下载时通知您。

自动下载更新

定时运行检查更新，它会在有更新可供下载时自动下载更新。

禁用和再次启用 SOLIDWORKS 后台下载程序

要禁用后台下载程序，请单击 Windows 系统托盘中的图标，然后选择禁用后台下载程序。

要重新启用后台下载程序，请单击开始 > SOLIDWORKS 安装管理程序 > SOLIDWORKS 后台下载程序。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


为安装管理程序指定选项

这些选项包括日志记录设置、Internet 访问设置和安装管理程序中所用语言的设置。

要在安装软件之前指定安装管理程序选项：

  1. 在安装管理程序中，右键单击标题栏上的 SOLIDWORKS 图标，然后选择：
    选项 | 描述
    安装日志层 将日志记录级别指定为高、中或低。层越高，收集到的故障排除数据越多，但会降低安装速度。默认值为低（最快），提供最佳性能和稳定性。

    创建 Windows 安装程序日志（较慢）会将日志与其他安装日志存储在相同的文件夹中。
    管理映像选项 | 选择使用短文件名（8.3 格式）或使用完整文件夹和文件名。
    收集安装日志 | 指定安装日志的存储位置。 安装管理程序将这些文件存储在 IM_Logs.zip 中。
    禁用英特网访问
    语言 | 指定安装管理程序中使用的语言。 默认语言为英语。
  2. 单击关闭。
父主题 SOLIDWORKS 安装管理程序应用程序帮助


检查更新结果

检查更新会查找更高版本的 SOLIDWORKS。

如果您在计算机上具有管理员权限，则可以手动运行 检查更新：
  • 在 Windows 中，单击开始 > SOLIDWORKS 安装管理程序 > 检查更新
  • 在 SOLIDWORKS 中，单击 [image] > 检查更新。
在通过管理映像安装的客户端上，检查更新不可用。

有新版本可用

SOLIDWORKS 安装管理程序检测到 SOLIDWORKS 产品的新版本。 您可选择该版本的 SOLIDWORKS 安装管理程序来更新到新版本。

此新版本可以根据您在安装中指定的产品来下载安装文件。 您可与其他使用 SOLIDWORKS 安装管理程序进行安装的用户共享下载的文件。

这些下载只可为 SOLIDWORKS 安装管理程序所用。
有这些选项可供使用：
  • 如果有多个版本可供使用，您可从列表中选取一个版本。
  • 有关该版本的细节，单击检查以查看此升级包括什么内容。
单击下一步会获得并运行所选版本的 SOLIDWORKS 安装管理程序。

无新下载可用/不能检查新版本

SOLIDWORKS 安装管理程序未发现更高版本的 SOLIDWORKS 产品，原因要么是您安装的就是最新版本，要么是它无法连接到 SOLIDWORKS 网站以进行检查。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


管理映像位置

指定管理映像的安装位置。

当创建管理映像时，这些选项可适用：
新映像位置 | 这是 SOLIDWORKS 安装管理程序将创建新映像的目标目录位置。 | 此位置不能包含现有的管理映像。 管理映像必须位于共享文件夹中以供客户端调用。
创建映像所需的估计空间 | 这是管理映像所需的额外空间。 | 验证您的安装磁盘有足够的可用空间支持映像要求。
从此处创建映像 | 这是您安装 SOLIDWORKS 产品的源目录位置。 仅当指定了仅安装选项时，此选项才出现。 有关详细信息，请参阅 下载选项：
父主题 SOLIDWORKS 安装管理程序应用程序帮助


下载选项

指定完成下载操作的详细信息，例如下载的文件的位置、文件下载方式以及是否安装下载的文件。

SOLIDWORKS 安装管理程序支持电子软件发布 (ESD)。 如果您不是从 SOLIDWORKS DVD 进行安装，系统将提示您为正在安装的 SOLIDWORKS 产品指定来源。

若有关于下载文件夹的疑问，请参阅SOLIDWORKS 安装管理程序下载文件夹。

您想做什么？

选择以下选项之一：

下载并安装/下载并创建映像

下载完成之后，SOLIDWORKS 安装管理程序会使用下载的文件运行安装。

只下载。 您可下载一次，然后在多台计算机之间共享下载的文件。

SOLIDWORKS 安装管理程序不会在下载完成后运行安装。

通常，如果您要下载文件以配置安装文件集并在多台计算机之间共享，则请指定此选项。

若您指定此选项，则程序会要求您在要下载的两个文件集中作出选择：
  • 此计算机的文件： 下载将只包含此计算机上当前的安装文件集中缺少的那些文件。
    这样下载的内容应该较少，因为它只包含：
    • 适用于在“产品选择”页面上选择的产品的文件
    • 您的计算机上尚未安装的必要文件

    然而，如果您尝试使用此下载文件集在其它计算机上进行安装，则可能会缺少某些文件（因为其它计算机上的安装文件集可能有所差异）。 您可使用这些下载文件在其它计算机上进行安装，但在安装过程中，可能必须下载其它文件才能备齐该计算机上的安装文件集。

  • 与任何计算机共享的文件： 下载将包含可用于在任何计算机上安装此版本的完整安装文件集。

    这样下载的内容应该较多，因为它将包含可用于在任何计算机上安装此版本的任何产品的完整安装文件集。

    如果您指定了要下载有限产品集，此选项会忽略该指定并下载该产品发行版中的所有产品。

    下载将包含创建管理映像所需的所有文件，而不仅仅是进行单机安装所需的那些文件。

仅安装/仅创建映像。 我已拥有所需的所有安装文件。

SOLIDWORKS 安装管理程序不会下载任何文件，而是使用所选文件夹中的文件。

单击浏览以导航到其它位置。 例如，您可浏览到包含所需文件的安装 DVD 或下载文件夹。

如果您收到错误信息说文件夹不完整，而您认为所有安装文件都应出现在该位置，可能的解释包括：
  • 您选取了先前未下载的组件进行安装或者是默认选取。
  • 文件下载到另一台具有不同系统要求的计算机上。
  • 您先前进行了客户端安装，而现在正在生成管理映像，这将要求更大的文件集。

您既可浏览到包含所有文件的文件夹（例如 DVD），也可选择下载选项之一。

您想在什么地方下载所需文件？

这是下载文件夹位置。

在某些情况下，此选项虽然可见，但被禁用。 例如，如果指定了仅安装，则 SOLIDWORKS 安装管理程序会从为该选项指定的目录中安装下载的任何文件，而非使用单独的下载文件夹。

无论您是否在下载这些文件或从您自己的位置访问这些文件，所有文件都必须下载到同一个下载文件夹。

估计的下载大小

所估计的下载磁盘空间要求基于选定的完整组件清单，无论此为新下载或从先前进程恢复的下载。

例如，如果您在恢复先前下载，SOLIDWORKS 安装管理程序将只处理那些还未下载的文件。 下载时间可能比估计的要少。

如果某文件已经在之前下载时完成了下载，则其大小不会包含在估计值中。因此，估计的下载大小可能大于实际大小。

您想如何下载？

进行手动下载

某些情况下，代理服务器可能禁止 SOLIDWORKS 安装管理程序自动下载。

通过选择此选项，您可从网页手动下载文件，然后在 SOLIDWORKS 安装管理程序中继续进行安装操作。此网页由 SOLIDWORKS 安装管理程序自定义，仅用于下载完成安装所需的文件。

使用 SOLIDWORKS 后台下载程序

您可使用 SOLIDWORKS 后台下载程序完成该下载操作或者在以后发布 SOLIDWORKS Service Pack 新版本时进行下载。

SOLIDWORKS 后台下载程序可在后台自动检测并下载新的 Service Pack 更新，并在下载完成及文件可用于安装时通知您。 有关详细信息，请参阅 SOLIDWORKS 后台下载程序。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


SOLIDWORKS 安装管理程序文件的下载选项

您选择了下载 SOLIDWORKS 安装管理程序的新版本。 使用此荧屏指定在何处以及如何下载。

若有关于下载文件夹的疑问，请参阅SOLIDWORKS 安装管理程序下载文件夹。

仅当默认下载文件夹有问题（例如写入访问权限或网络访问权限不可用）时，本屏幕才会出现。通常，您只需指定一个替代下载目录即可继续。

下载目录

浏览到 SOLIDWORKS 安装管理程序文件的目标位置。

下载大小和所需的空间量会显示出来。所需空间量包括解压某些下载内容所需的额外空间，大于实际下载大小。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


下载产品安装文件

指定在何处及如何为所指定的产品下载遗失的文件。

SOLIDWORKS 安装管理程序在下载过程中同时下载、验证并提取所有文件。

取消此屏幕也将取消其余安装序列。

有关取消的后果及完成中断的安装的说明，请参阅 安装错误/安装已取消。

下载目录

浏览到下载文件的目的地。

下载大小和所需的空间会显示出来。所需空间包括解压某些下载内容所需的额外空间，大于实际下载大小。

若有关于下载文件夹的疑问，请参阅 SOLIDWORKS 安装管理程序下载文件夹。

父主题 SOLIDWORKS 安装管理程序应用程序帮助
安装错误/安装已取消
SOLIDWORKS 安装管理程序下载文件夹


下载进度

SOLIDWORKS 安装管理程序在此过程中同时下载、验证并提取所有文件。

若要在开始后取消下载，单击取消。

如果您取消下载或下载失败，已取消下载或下载问题屏幕会指出哪些下载未完成，并允许您恢复下载或者关闭该应用程序。

若有关于下载文件夹的疑问，请参阅SOLIDWORKS 安装管理程序下载文件夹。
父主题 SOLIDWORKS 安装管理程序应用程序帮助


下载结果

表示下载是成功完成、操作过程失败还是被取消。

下载问题/下载被取消

如果您看到 下载问题，则说明 SOLIDWORKS 安装管理程序遇到了问题，使下载无法完成。

如果您看到下载被取消，则说明您在下载完成前将其取消。

若要继续：

重试/恢复自动下载 | 若要从您取消的位置恢复自动下载，请选择此选项并单击重试下载或恢复下载。
在 Web 浏览器中单独下载文件 | 某些情况下，代理服务器可能禁止 SOLIDWORKS 安装管理程序自动下载。 | 通过选择此选项，您可从网页手动下载文件，然后在 SOLIDWORKS 安装管理程序中继续进行安装操作。 此网页由 SOLIDWORKS 安装管理程序自定义，仅用于下载完成安装所需的文件。

下载已完成

如果您指定了仅下载选项，则当下载完成时，会出现“下载完成”屏幕。

单击完成以退出 SOLIDWORKS 安装管理程序。

切勿尝试手动安装这些产品中的任一项。 始终使用 SOLIDWORKS 安装管理程序来安装下载的文件。
父主题 SOLIDWORKS 安装管理程序应用程序帮助


安装错误/安装已取消

安装遇到问题或被取消。

如果发生错误或取消安装：
  • 在发生错误或取消之前安装的产品在计算机上保留。
  • 如有可能，在取消时刻安装的产品将被退回，这样不会存在部分安装。
  • 剩余的产品将不会安装或卸载。将在还未尝试下提供一个列表。

    若要恢复安装或卸载这些产品，请单击提供的链接。

SOLIDWORKS 安装管理程序将首先安装计算机上还未安装的必备组件，如 .NET framework。

内容

  • 恢复失败或取消的安装

    如果在安装过程中出错或取消，可通过重新运行安装来从该位置恢复安装。

  • 修复安装

    如果您遇到所安装的 SOLIDWORKS 产品的问题，您可使用 SOLIDWORKS 安装管理程序来修复安装。

  • 请与 SOLIDWORKS 转售商联系

    如果修改或修复安装失败，请与您的本地 SOLIDWORKS 转售商联系并提供从该屏幕所收集的信息。 您可能还需要提供 SOLIDWORKS 安装管理程序日志文件的 zip 文件。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


恢复失败或取消的安装

如果在安装过程中出错或取消，可通过重新运行安装来从该位置恢复安装。

  1. 记录已失败的安装的错误信息和产品代码，如安装错误或安装已取消屏幕上所示。
    如果软件提示输入源文件，并且您不修改现有的 SOLIDWORKS 安装，则安装或计算机可能已损坏。 请与您的 SOLIDWORKS 转售商联系。
  2. 重新启动计算机。
  3. 为确保当前 Windows 中未运行 SOLIDWORKS 产品，按 Ctr+Alt+Del 打开任务管理器。
  4. 在进程选项卡上，如果下列任何进程出现在映像名称下，请选择该进程并单击结束进程。
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. 如果应用程序已安装，而您试图修改或删除该应用程序，请尝试修复安装。有关详细信息，请参阅修复安装。
  6. 在 Windows 中，单击开始 > 控制面板 > 程序和功能。
  7. 选取已失败的 SOLIDWORKS 版本。
    如果没有您在尝试进行安装的 SOLIDWORKS 版本条目，请重复安装过程。
  8. 执行以下操作之一：
    • 若要重试，单击更改然后选取安装失败或在安装过程中跳过的所有产品。

    • 要跳过已失败的安装，单击更改然后选取所有在安装过程中跳过的产品。 清除安装失败的产品。

    • 若要放弃安装，单击删除然后选取任何已安装的产品。
    这将恢复您在升级的任何产品的先前版本。
父主题 安装错误/安装已取消
修复安装
请与 SOLIDWORKS 转售商联系


请与 SOLIDWORKS 转售商联系

如果修改或修复安装失败，请与您的本地 SOLIDWORKS 转售商联系并提供从该屏幕所收集的信息。 您可能还需要提供 SOLIDWORKS 安装管理程序日志文件的 zip 文件。

  1. 找出日志文件。 对于 Windows：
    C:\Users\用户名\AppData\Roaming\SOLIDWORKS\Installation Logs\安装的版本\。
    如果您找不到文件夹，可能文件夹已隐藏。在文件资源管理器中，单击工具 > 文件夹选项。在视图选项卡上的高级设置下，为隐藏的文件和文件夹选择显示隐藏的文件、文件夹和驱动程序。
  2. 压缩此文件夹的全部内容，包括子文件夹。
父主题 安装错误/安装已取消
恢复失败或取消的安装
修复安装


安装完成

SOLIDWORKS 安装管理程序已完成安装过程。

可能显示下列选项中的一项或多项。

新增功能

对于单机安装，在您完成安装过程时，将出现一个描述 SOLIDWORKS 及其插件产品中新增功能的文档。

对于管理映像安装，该文档会在客户端计算机完成其安装时出现在这些计算机上。

参加 SOLIDWORKS 客户经历改进计划

性能信息将发送到 SOLIDWORKS Corporation 以帮助改进产品。此过程是透明并且保密的。选择以下项之一：
  • 是，我想参加
  • 不，谢谢
  • 以后再提醒我
有关详细信息，请参阅客户经历改进计划网站。

管理映像创建已完成

当您完成生成管理映像时，您可单击自定义映像运行管理映像选项编辑器来自定义映像。

单击为我示范如何在客户端上安装此映像显示使用选项编辑器的指南。

关于使用选项编辑器配置管理映像的详细信息，请参阅 管理映像选项编辑器。

单击自定义映像以打开管理映像选项编辑器，从中自定义您的管理映像选项设置。
您可以稍后通过双击 SOLIDWORKS Admin 文件夹中的 sldAdminOptionEditor.exe 来启动选项编辑器。

内容

  • 检查 SOLIDWORKS 的更新

    如果您在计算机上具有管理员权限，则您可以使用 SOLIDWORKS 安装管理程序来手动检查更新或配置自动定期检查更新。

  • SOLIDWORKS 客户经历改进计划

    安装 SOLIDWORKS 时，您可以指定将性能信息发送到 SOLIDWORKS Corporation 以帮助改进产品。

父主题 SOLIDWORKS 安装管理程序应用程序帮助
管理映像选项编辑器


检查 SOLIDWORKS 的更新

如果您在计算机上具有管理员权限，则您可以使用 SOLIDWORKS 安装管理程序来手动检查更新或配置自动定期检查更新。

  1. 通过以下操作之一开启 SOLIDWORKS 安装管理程序：

    • 在 SOLIDWORKS 应用程序中依次单击帮助 > 检查更新。

    • 在 Windows 中，单击开始 > 程序 > SOLIDWORKS 安装管理程序 > 检查更新。

    您也可以单击开始 > SOLIDWORKS 安装管理程序 > SOLIDWORKS 后台下载程序。在 Windows 通知区域中，右键单击 SOLIDWORKS 后台下载程序，然后单击检查更新。
    SOLIDWORKS 安装管理程序会告诉您是否有任何更新可用。
  2. 如果有更新可用，选择是否下载更新并安装。
  3. 若要启用自动定期检查更新，当 SOLIDWORKS 安装管理程序完成处理后，选择每 __ 天一次检查更新并指定检查频率。
父主题 安装完成
SOLIDWORKS 客户经历改进计划


SOLIDWORKS 客户经历改进计划

安装 SOLIDWORKS 时，您可以指定将性能信息发送到 SOLIDWORKS Corporation 以帮助改进产品。

SOLIDWORKS 使用该信息来决定有关产品使用和质量的趋向。 我们的目标是提供最佳质量的产品，性能日志是该过程中的有用工具。

此过程是透明的。日志文件中包含的所有信息都视为机密。该信息不用于任何其它目的，没人会接洽您。

有关详细信息，请参阅客户体验改善计划网站。

父主题 安装完成
检查 SOLIDWORKS 的更新


安装位置

对于除管理映像创建之外的安装，这些选项可适用：
将选定产品安装到 | 这是您要将 SOLIDWORKS 安装到的目录位置。 当升级或修改安装时，所有文件必须安装到该安装的现有位置。在此情况下，您无法更改现有 SOLIDWORKS 安装的位置。
估计的安装所需空间 | 这是选定要安装或修改的产品所需的额外空间。 | 验证您的安装磁盘有足够的可用空间支持安装要求。
从此处安装 | 这是您安装 SOLIDWORKS 的源目录位置。 仅当指定了仅安装选项时，此选项才出现。有关详细信息，请参阅下载选项。
在更改任何 SOLIDWORKS 安装位置之前请咨询系统管理员。

管理映像位置

当创建管理映像时，这些选项可适用：
新映像位置 | 这是 SOLIDWORKS 安装管理程序将创建新映像的目标目录位置。 | 此位置不能包含现有的管理映像。
创建映像所需的估计空间 | 这是管理映像所需的额外空间。 | 验证您的安装磁盘有足够的可用空间支持映像要求。
从此处创建映像 | 这是您安装 SOLIDWORKS 产品的源目录位置。 仅当指定了仅安装选项时，此选项才出现。有关详细信息，请参阅下载选项。
现有映像位置 | 当升级现有的管理映像时，SOLIDWORKS 安装管理程序会基于该现有映像的设置创建新的映像。不会修改现有映像。这显示了您在欢迎屏幕中指定的原始映像的位置。

避免使用版本特定的目录路径

如果您在安装目录位置（例如 C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2025\）指定了版本号，然后将该安装升级到 SOLIDWORKS 2026，则您的 SOLIDWORKS 2026 安装目录会标记为 SOLIDWORKS 2025。

父主题 SOLIDWORKS 安装管理程序应用程序帮助
下载选项


升级选项

此计算机上安装有一个或多个旧的 SOLIDWORKS 主要版本。 您可以创建与旧版本共存的新安装，或者进行升级以移除旧版本。

创建 SOLIDWORKS 版本的新安装。

如果您选择创建新安装，则您可以选择要安装的 SOLIDWORKS 产品。

对于每个选定产品，将创建此主要版本的新安装。旧的主要版本将保留在计算机上，但 SOLIDWORKS Electrical 和 SOLIDWORKS PDM Client 除外。

如果清除产品，则不会安装新版本。

如果在您安装了新的 SOLIDWORKS 版本后仍希望访问旧版本，则创建新安装将很有用。 例如，如果您要与仍使用旧版本的用户共享文件，则可避免采用新版本保存的文件出现版本不兼容的情况。

SOLIDWORKS previous_major_version 升级为 SOLIDWORKS current_major_version

如果您选择升级，则您可以选择要升级的 SOLIDWORKS 产品。 对于每个选定产品，将创建新安装并移除旧版本。

如果您清除某个产品，则不会安装该产品的新版本并且其旧版本将保留在计算机上。

SOLIDWORKS Electrical 和 SOLIDWORKS PDM Client 的注意事项

您只能在一台计算机上安装一个版本的 SOLIDWORKS Electrical。如果您正在创建 SOLIDWORKS 的新安装并将 SOLIDWORKS Electrical 选作要安装的产品之一，则将移除旧版本的 SOLIDWORKS Electrical。

在安装新版本之前先备份现有 SOLIDWORKS Electrical 环境。从 SOLIDWORKS Electrical Schematic 内，选择文件 存档环境，或者从 SOLIDWORKS Electrical 3D 内，选择SOLIDWORKS Electrical > 工具 > 存档环境。

SOLIDWORKS PDM 客户端的主要版本必须与 SOLIDWORKS PDM 服务器的主要版本匹配。 如果您不打算升级 SOLIDWORKS PDM 服务器，则请勿选择 SOLIDWORKS PDM 客户端进行升级。

要移除 Windows 中的某个产品，请使用添加/删除程序。有关详细信息，请参阅 删除安装。
父主题 SOLIDWORKS 安装管理程序应用程序帮助
删除安装


安装进度

该荧屏显示安装的进度。

若要在开始后取消安装，请单击取消。

有关取消的后果及完成中断的安装的说明，请参阅 安装错误。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


安装类型

您可以指定要运行的安装操作。 例如，创建新安装、修改或修复现有安装、创建管理映像、安装管理服务器产品或下载文件，以便您可以在其他计算机上进行共享和安装。

如果您的计算机上已安装了最新版本的 SOLIDWORKS 软件，则您可以选择对其进行修改或修复。

单机型

在该计算机上安装 SOLIDWORKS 产品。

仅当此计算机上未安装此版本时，才会出现此选项。

修改单机安装

修改此计算机上现有的 SOLIDWORKS 安装。

仅当此计算机上安装了此版本时，才会出现此选项。
修改包括：
  • 添加或删除 SOLIDWORKS 产品组件
  • 更改为其他 SOLIDWORKS 软件包（例如 SOLIDWORKS Professional、SOLIDWORKS Premium、SOLIDWORKS Ultimate 等等）
  • 更改 SOLIDWORKS 序列号设定
    如果您已经在以前的安装中指定了 SOLIDWORKS 序列号，则 SOLIDWORKS 安装管理程序可能不会再显示该提示。要更改序列号，您必须选择此选项。

修复单机安装

修复此计算机上现有的 SOLIDWORKS 安装。

仅当此计算机上安装了此版本时，才会出现此选项。
修复操作将核实是否所有文件都存在并已妥当注册，并且修复发现的任何问题。 您所生成的数据不受影响。
  • 若要修复产品，请将其选定。
  • 清除您不想修复的产品的复选框。
您可修复单机安装。您无法修复管理映像安装；您必须使用管理映像重新安装。

管理映像

创建或更新管理映像以部署到多台计算机。

有关使用管理映像在多台客户端上安装 SOLIDWORKS 的详细信息，请参阅使用管理映像。

当创建或更新管理映像时：
  • 您可使用现有映像的安装设定来配置新的或更新后的映像，也可使用默认的 SOLIDWORKS 安装设定。
  • 如果是从现有映像更新：
    • 虽然是在更新，SOLIDWORKS 安装管理程序也会将该映像复制一份。 原始映像并未修改。
    • 您可使用正在更新的映像中的文件创建更新后的映像。这样可使下载内容较少。
    如果您不指定可供 Service Pack 发行版更新的先前版本的映像，则无法利用下载内容较少的便利。

服务器产品

SOLIDWORKS 服务器产品包括 SOLIDWORKS Electrical、SOLIDWORKS PDM 和 SolidNetWork License Manager。

对于 SOLIDWORKS Electrical 和 SOLIDWORKS PDM，您可以选择在同一台计算机或不同计算机上安装客户端和服务器工具。

有关安装这些服务器的详细信息，请参阅帮助中的相应主题。

下载并共享所有文件

为选定的 SOLIDWORKS 产品下载安装文件而不安装产品。

如果从 DVD 安装，则不会出现该选项。
下载的文件的内容与 SOLIDWORKS 安装 DVD 上的文件内容相同。 选择此选项会下载整套安装文件，无论您的计算机上已安装有什么文件。 然后，您可以将文件复制到便携式设备或网络目录，并用其在其他计算机上安装 SOLIDWORKS 软件。 您也可以使用此方法设置服务器，您的用户可以从该服务器进行安装。
此方法与创建管理映像不同。
父主题 SOLIDWORKS 安装管理程序应用程序帮助
使用管理映像
使用 SolidNetWork License Manager 管理许可
SOLIDWORKS Electrical


安装并管理多台计算机

SOLIDWORKS 安装管理程序提供以下工具用于安装并管理多台 SOLIDWORKS 计算机。

SOLIDWORKS 管理映像

如果要在多台计算机上安装 SOLIDWORKS，您可以创建管理映像，然后将应用程序调用到其他计算机上。

SOLIDWORKS PDM

SOLIDWORKS PDM 是基于与 SOLIDWORKS Enterprise PDM 相同的客户端/服务器体系结构的文档管理产品。 它有两个版本： Standard 和 Professional。 SOLIDWORKS PDM 使用 Microsoft SQL Server 数据库来管理文件库。

SolidNetWork License Manager

SolidNetWork License Manager 可通过浮动许可使用而允许用户数量超过许可数量。 客户端许可在没有使用时可供另一 SOLIDWORKS 用户使用。

还可使用 SolidNetWork License Manager 来为 SOLIDWORKS 核心插件产品（例如 FeatureWorks）分发许可。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


手动下载

您已选择手动下载文件（或者可能在上次运行 SOLIDWORKS 安装管理程序时选择了手动下载）。

单机该链接以打开一个包含完成下载所需的文件的完整列表的自动生成的网页。

您必须下载到“摘要”页面中指定的文件夹。将所有文件下载到该文件夹后安装才能开始。

完成手动下载后，请单击下一步继续。

如果您要自动下载，可返回到“摘要”页面并更改下载选项。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


有新版本可用

安装管理程序检测到 SOLIDWORKS 产品的新版本。 您可选择安装包含在原有安装 DVD 或下载中的版本，或者您可选择下载并安装更新的版本。

如果您是从下载的文件进行安装

选择以下选项之一：
  • 继续安装版本。

    选取该选项继续安装包含在原有下载中的版本。

  • 下载并安装新版本： 版本。

    选择此选项以下载和安装新版本。 如果有多个新版本可供使用，您可选取要下载并安装的版本。

如果您是从 DVD 进行安装

在您想使用更新版本吗？下，选项下列选项之一：
  • 不，继续从该 DVD 安装版本。 您可以之后更新。

    选取该选项可继续使用当前的安装管理程序进行安装。

    在安装完成后，您可使用安装管理程序检查并安装更新。 若要检查更新，请运行开始 > SOLIDWORKS 安装管理程序 > 检查更新。
    仅当您在计算机上具有管理权限时，检查更新才可用。

    好处在于下载更小。 缺点在于此为两步骤过程，而且您下载的文件为版本特定（不能被使用其他版本的其他用户所共享）。

  • 是，使用该 DVD 进行安装，然后下载并更新到版本。

    选取该选项以下载并运行安装管理程序的以后版本，从而为该版本安装 SOLIDWORKS 产品。

    如果提供了可用于更新 DVD 版本的较小 Service Pack 发行版，则安装管理程序会从 DVD 安装原始版本，然后应用 Service Pack 更新。 这样可使下载内容较少。

    若选择继续从 DVD 安装的选项，日后再应用更新，也可获得相同的结果。

    此选项的好处在于一步到位。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


没有新版本可用

没有可下载的更新版本。开始安装指定的版本。

要开始安装，请单击下一步。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


检测到进程

SOLIDWORKS 安装管理程序在此计算机上检测到可能影响安装成功完成的进程。

  • 若要继续安装，请进行以下操作之一：
    • 关闭这些进程（例如使用 Microsoft Windows 任务管理器），然后按重试。
    • 单击忽略继续安装而不关闭该进程。
  • 若要停止安装，请按取消。
父主题 SOLIDWORKS 安装管理程序应用程序帮助


产品选择

您可以指定要安装、修改、下载或移除的产品组件。

在产品列表中：
  • 产品列表是在其上方指定的套包中的所有可用产品的完整列表。
  • 要查看对特定组件的预计操作，请单击该组件名称（而不是复选框）。 预期的安装操作会出现在产品列表下方的信息字段中。
  • 您可以单击产品组件旁的复选框更改该组件的安装操作。 （例如，如果您要安装或删除组件，可选中相应复选框指定要安装或删除的组件，或清除相应复选框指定不想安装或删除的组件。）
  • 如果要进行修改安装，则当您在产品选择中进行任何更改时，相应的组件左边会出现一个星号 (*)。
  • 如果组件内含有可选安装子组件，则该组件旁会出现 + 图标。 要查看组件的可用子组件，请单击 + 图标。
  • 如果组件已扩展以显示可选子组件，则该组件旁会显示 - 图标。 要折叠子组件列表，请单击 - 图标。

如果您正在应用 Service Pack，则无法选择 SOLIDWORKS 下出现的功能（如 FeatureWorks）。 这是因为在进行此类升级时您不能添加或移除功能。

SOLIDWORKS 安装管理程序所进行的操作受一系列产品共存规则控制。有关详细信息，请参阅 产品共存规则。

SOLIDWORKS 安装管理程序默认选择这些产品组件：
  • 如果您正在执行升级或 Service Pack 更新，则 SOLIDWORKS 安装管理程序会选择当前已安装的产品。
  • 否则，SOLIDWORKS 安装管理程序会选择您有资格安装的所有产品。
要减少您的安装或下载时间和磁盘空间要求，展开产品组件，然后清除您不需要的那些组件的复选框。

如果 SOLIDWORKS 安装管理程序无法核实您有权使用的产品，则您可单击选择不同软件包或产品以更改要安装或修改的产品软件包（例如 SOLIDWORKS Professional、SOLIDWORKS Premium 或 SOLIDWORKS Ultimate）清单。SOLIDWORKS 安装管理程序将列出安装媒体上与您所选软件包兼容的所有 SOLIDWORKS 产品。您可选择任何自己购买或有权评估的产品。

SOLIDWORKS 搜索

SOLIDWORKS 搜索对 SOLIDWORKS 文档具有强大完整的文本搜索功能。搜索显示预览及文件位置和名称。

在安装完成后，SOLIDWORKS 搜索对 SOLIDWORKS 文档编制索引以便进行更快速搜索。 只有 SOLIDWORKS 文件才默认进行索引编制。

语言支持

展开 SOLIDWORKS 产品以及 语言 组件可看到能够安装的语种。

语言规格只限制为 SOLIDWORKS 产品所安装的语言。其它产品安装不受该规范影响。例如，eDrawings® 和 SOLIDWORKS PDM 将安装所有语言。

需要的空间

SOLIDWORKS 安装管理程序在页底报告出总安装大小或总下载大小。

  • 如果选择了仅下载选项，则下载大小会出现。下载大小为所有下载文件所需的磁盘空间总量（不包括下载完成后解压文件所需的额外空间）。该数字为估计值。
    安装所需的所有文件都包括在总下载大小中。如果有些文件已下载到当前下载文件夹中，它们将不会再下载。因此，您的实际下载大小可能比所示总下载大小要小，或者您可能不必下载任何文件。
  • 否则，安装大小会出现。 安装大小为在您完成此安装时会发生的磁盘空间使用变化。 由于压缩关系，这些数字为估计值。

    如果您在升级或移除现有安装，安装大小可能为零。

    所示数字不包括下载或提取安装所需要文件而要用的任何空间。

    如果要求下载且您在下载到同一个驱动器，实际磁盘空间要求可能比所出现的安装大小要大得多。

    要为将来修改减少下载或安装时间，不要在安装后删除下载的文件。 以后更新和修补通常要求访问上次完整安装文件集。

父主题 SOLIDWORKS 安装管理程序应用程序帮助
产品共存规则


要下载的产品

选取要下载到指定位置的 SOLIDWORKS 产品。

可下载的产品由您所提供的序列号决定：

  • 为每个组件所进行的操作出现在每项的右侧。
  • 如果一个组件内含有可选安装子组件，则该组件旁会出现一个 + 图标。 要查看一个组件的可用子组件，请单击 + 图标。
  • 如果扩展一个组件以显示可选子组件，则该组件旁会显示一个 - 图标。 要折叠子组件列表，请单击 - 图标。
  • 单击每个组件左边的复选框以选择它们如何被 SOLIDWORKS 安装管理程序处理。
SOLIDWORKS 安装管理程序将下载您有权使用的所有产品组件，除非您另有指定。要减少您的下载时间和磁盘空间要求，请展开产品组件，并选择您不需要的那些组件。

如果 SOLIDWORKS 安装管理程序无法验证您有权使用的产品，则您可选择一个 SOLIDWORKS 软件包进行下载。 SOLIDWORKS 安装管理程序将列举与您所选软件包兼容的所有 SOLIDWORKS 产品。

如果 SOLIDWORKS 安装管理程序无法核实您有权使用的产品，则您可单击选择不同软件包或产品以更改要安装或修改的产品软件包（例如 SOLIDWORKS Professional、SOLIDWORKS Premium 或 SOLIDWORKS Ultimate）清单。SOLIDWORKS 安装管理程序将列出安装媒体上与您所选软件包兼容的所有 SOLIDWORKS 产品。您可选择任何自己购买或有权评估的产品。

语言支持

语言规格只限制为 SOLIDWORKS 产品所安装的语种。 其它产品安装不受该规范影响。 例如，eDrawings® 将安装所有语言。

需要的空间

根据您所选取的产品，将显示出下载所需的空间。下载大小为所有下载文件所需的磁盘空间总量（不包括下载完成后解压文件所需的额外空间）。该数字为估计值。

要为将来更新和修补减少下载或安装时间，不要在安装后删除下载的文件。以后更新和修补通常要求访问上次完整安装文件集。
父主题 SOLIDWORKS 安装管理程序应用程序帮助


要修复的产品

当您指定修复此安装时，该屏幕显示出可由此版本 SOLIDWORKS 安装管理程序修复的 SOLIDWORKS 产品（带有版本号）。

修复操作将核实是否所有文件都存在并已妥当注册，并且修复发现的任何问题。您所生成的数据不受影响。
  • 若要修复产品，请将其选定。
  • 清除您不想修复的产品的复选框。

单击修复以开始修复所选的产品。

您可修复单机安装。您无法修复管理映像安装；您必须使用管理映像重新安装。
父主题 SOLIDWORKS 安装管理程序应用程序帮助


序列号

序列号将您的计算机与您购买的 SOLIDWORKS 产品相关联。

如果您的计算机上已安装有 SOLIDWORKS 产品，其序列号将默认显示：
  • 如果您的 SOLIDWORKS 序列号未显示，请输入该序列号。
  • 如果您具有未包括在 SOLIDWORKS 许可证中的产品的序列号，则在相应的字段中输入这些序列号。

如果您拥有互联网连接，则继续安装过程时，您提供的序列号将确定您有权使用的产品。

由于有多种办法购买 SOLIDWORKS 产品，有些序列号可覆盖两个或多个产品。 例如，SOLIDWORKS 序列号可让您在安装 SOLIDWORKS Simulation 时不必输入单独的 SOLIDWORKS Simulation 序列号。 此外，有些产品不需要序列号。 如果您对序列号有疑问，请与您的经销商联系。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


服务器安装

会列出您正在尝试安装的服务器产品，并显示安装结果。

服务器安装状态

服务器产品安装由外部安装应用程序进行。如果您不在该应用程序中，请切换到该应用程序以完成安装。

单击取消以停止服务器产品安装。

服务器安装已完成

外部安装应用程序已成功完成。

单击 完成 或 下一步。
  • 如果您安装的是其他管理产品（例如 SOLIDWORKS 管理映像），该安装会继续。
  • 如果该服务器产品安装是唯一的安装操作，则 SOLIDWORKS 安装管理程序会关闭。

服务器安装被取消或失败

如果服务器产品安装在开始后失败或被取消，则会列出未安装的服务器。

单击 关闭 或 下一步。
  • 如果您指定了其他管理产品安装，则 SOLIDWORKS 安装管理程序会恢复。
  • 如果该服务器产品安装是唯一的安装操作，则 SOLIDWORKS 安装管理程序会关闭。

详情

有关安装、配置和使用 SolidNetWork License Manager 的详细信息，请参阅 使用 SolidNetWork License Manager 管理许可。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


摘要

SOLIDWORKS 安装管理程序具有完成安装操作所需的所有信息。

若要继续： | 单击现在操作启动安装操作（例如现在安装、现在生成、现在下载或现在修改）。
要更改安装设置： | 单击更改 [image] 以更改您要更改的部分（例如产品、安装位置和 Toolbox 选项）。
若要取消： | 单击 取消 以退出 SOLIDWORKS 安装管理程序而不更改安装组件。
若要返回先前的页面： | 单击 返回 以返回到 SOLIDWORKS 安装管理程序中的前一页。
关于特定安装选项集（例如 产品、安装位置、Toolbox 选项 等）的信息：
  1. 单击您要获取信息的部分旁边的更改 [image] 。
  2. 在出现的详细信息页面中，单击 帮助 以获取关于这些安装选项设置的信息。
父主题 SOLIDWORKS 安装管理程序应用程序帮助


系统检查警告

系统检查报告了可能影响您继续安装的问题。 大多数情况下，您应该能够继续运行 SOLIDWORKS 安装管理程序。

下面列举了系统检查阶段您可能遇到的警告，并提供了如何继续操作的建议。

序列号验证性问题

安装管理程序因为无法验证您的序列号而不能检查新版本。 如果您已连网并且输入了有效序列号，此警告可能表示我们的服务器出现临时性问题。 请稍后再试。

序列号验证：安装管理程序无法验证您的序列号以决定您有权安装哪些产品。您仍将可以选择要安装的产品，但无法下载任何安装文件。您需要提供可从之进行安装的整套下载源文件或 DVD。

分辨率(R):
  • 检查英特网连接。序列号检查需要连接有效的英特网连接。
  • 检查您输入的序列号是否是要安装产品的有效序列号。
  • 有些安装要求您在版本发行时就进行了有效的订阅。 有关详细信息，请咨询您的 SOLIDWORKS 转售商。
  • 大多数情况下，只要您是从 DVD 或先前下载的组文件进行安装，就可以继续操作。

有新版本可用

有新版本可用

有新版本可用

该产品有新版本可供下载。

分辨率(R): 执行检查更新操作时，安装程序可能会提示您从 SOLIDWORKS 下载较新版本进行安装。 您可以使用最初指定的版本继续操作，或者下载此较新版本并使用该版本继续操作。

可用的最新版本

此为可供使用的最新版本。单击“下一步”以继续。

无新下载可用

解决方案：在安装或修改过程中检查更新时，可能会出现此信息。它表示您当前安装的（或已安装的）是最新的可用版本。

英特网连接问题

Internet 连接： 安装管理程序无法连接到 SOLIDWORKS 服务器以决定您有权安装哪些产品。 您仍将可以选择要安装的产品，但无法下载任何安装文件。 您需要提供 DVD 上的源文件或先前下载的组文件。

不能检查新版本

安装管理程序因为无法连接到服务器而不能够检查新版本。

解决方案:
  • 检查英特网连接。
  • 只要您是从 DVD 或先前下载的组文件进行安装，就可以继续操作。

父主题 SOLIDWORKS 安装管理程序应用程序帮助


异型孔向导/Toolbox 选项

如果您安装 SOLIDWORKS Toolbox，SOLIDWORKS 将包含一个标准的孔类型与五金器具库。

有关配置、扩展和使用 SOLIDWORKS Toolbox 的详细信息，请单击 SOLIDWORKS 中的帮助，参阅 Toolbox 章节。

在使用 SOLIDWORKS Toolbox 之前，确保已根据贵公司或集团的政策妥当配置它。在许多情况下，组会配置并维护一个中央 Toolbox。请咨询 SOLIDWORKS 管理员，获取关于如何在 SOLIDWORKS 安装过程中指定 Toolbox 的指导。

您可在安装之后更改选定的 SOLIDWORKS Toolbox。 在 SOLIDWORKS 中，单击工具 > 选项。在系统选项选项卡上，单击异型孔向导/Toolbox。

下面的章节介绍您在此屏幕上可能遇到的所有配置的所有选项。您实际看到的 Toolbox 选项取决于此计算机上早先存在的 SOLIDWORKS 和 Toolbox 配置以及目前您已指定的 SOLIDWORKS 安装管理程序选项。

创建新的新版 Toolbox

在此计算机上创建新版 SOLIDWORKS Toolbox。

创建新版本后，在“产品选择”屏幕中，展开 SOLIDWORKS > SOLIDWORKS Toolbox，然后选择支持 Toolbox 的标准。 默认会选取所有标准。

不会修改此计算机上现有的任何 Toolbox。

参考引用或升级现有 Toolbox

使用现有 Toolbox。 单击浏览以指定您要在此安装中使用的 Toolbox 的位置。

  • 如果已经为先前的 SOLIDWORKS 主要版本配置了该 Toolbox，则会将其升级为此版本。 对该 Toolbox 进行的任何自定义均会保留在升级后的 Toolbox 中。
    将 Toolbox 升级到新的 SOLIDWORKS 主要版本会使该 Toolbox 与运行 SOLIDWORKS 先前主要版本的计算机不兼容。
  • 如果 Toolbox 已针对此版本 SOLIDWORKS 进行了配置（例如您指定了一个已升级的共享网络 Toolbox），则不会对该 Toolbox 进行升级。
  • 如果您在 SOLIDWORKS PDM 环境中升级 Toolbox，则需要执行其它程序。有关详细信息，请参阅 关于配置 SOLIDWORKS Toolbox 的说明。

此选项出现在除创建管理映像外的所有安装场景中。

升级先前版本 Toolbox

将配置为用于先前主要版本的 Toolbox 复制到新位置，并将该拷贝升级为此版本。

如果此计算机上安装有先前的 SOLIDWORKS 主要版本且您选择不将该安装升级为此发行版，则会出现此选项。
此选项的用途在于在升级先前的 SOLIDWORKS 主要版本的 Toolbox 的同时，不影响使用该旧版 Toolbox 的用户。

如果您在 SOLIDWORKS PDM 环境中升级 Toolbox，则需要执行其它程序。有关详细信息，请参阅 关于配置 SOLIDWORKS Toolbox 的说明。

升级此安装的先前版本 Toolbox

将此 Toolbox 升级到新版本。
将 Toolbox 升级到新的 SOLIDWORKS 主要版本会使该 Toolbox 与运行 SOLIDWORKS 先前主要版本的计算机不兼容。

如果您正在将先前的 SOLIDWORKS 主要版本升级到此版本且在此计算机上发现了为该发行版配置的 Toolbox，则会出现此选项。

如果您在 SOLIDWORKS PDM 环境中升级 Toolbox，则需要执行其它程序。有关详细信息，请参阅 关于配置 SOLIDWORKS Toolbox 的说明。

使用此安装的当前版本 Toolbox

SOLIDWORKS 安装管理程序在此计算机上检测到了为此 SOLIDWORKS 主要版本配置的 Toolbox。

如果您选择此选项，SOLIDWORKS 将使用此 Toolbox。 不会进行升级。

如果此计算机上安装了先前的 SOLIDWORKS 主要版本，但为此版本配置了 Toolbox，则会出现此选项。 如果在仍然运行较旧 SOLIDWORKS 版本的计算机上创建共享 Toolbox，则可能出现这种情况。

为客户端计算机指定 Toolbox 位置

将一个网络或目录位置指定为当客户端从管理映像安装时的默认 Toolbox 位置。
如果在开始客户端安装时，该位置包含为先前的 SOLIDWORKS 主要版本配置的 Toolbox，则 SOLIDWORKS 安装管理程序会升级该 Toolbox。

当您创建新的管理映像时，此选项会出现。

为客户端计算机升级或使用在现有映像中参考引用的 Toolbox

使用您正在更新的现有管理映像中所指定的 Toolbox 位置。
如果在开始客户端安装时，该位置包含为先前的 SOLIDWORKS 主要版本配置的 Toolbox，则 SOLIDWORKS 安装管理程序会升级该 Toolbox。

为客户端计算机选择另一个 Toolbox 位置

指定一个不同于您正在更新的现有管理映像中所指定的 Toolbox 位置的其他 Toolbox 位置。
如果在开始客户端安装时，该位置包含为先前的 SOLIDWORKS 主要版本配置的 Toolbox，则 SOLIDWORKS 安装管理程序会升级该 Toolbox。

内容

  • 关于配置 SOLIDWORKS Toolbox 的说明

    SOLIDWORKS Toolbox 是一项强大而复杂的功能。本主题概述了在使用 SOLIDWORKS 安装管理程序配置 Toolbox 之前需要考虑的一些概念。

  • UNC（通用命名代码）格式

    通用命名代码格式指定了描述共享文件位置的文件名称语法格式。

父主题 SOLIDWORKS 安装管理程序应用程序帮助
关于配置 SOLIDWORKS Toolbox 的说明


关于配置 SOLIDWORKS Toolbox 的说明

SOLIDWORKS Toolbox 是一项强大而复杂的功能。本主题概述了在使用 SOLIDWORKS 安装管理程序配置 Toolbox 之前需要考虑的一些概念。

查找关于 SOLIDWORKS Toolbox 的更多信息

有关配置、扩展和使用 SOLIDWORKS Toolbox 的详细信息，请在 SOLIDWORKS 中单击 [image] 帮助，参阅 Toolbox 部分。

使用共享的 Toolbox

在安装 Toolbox 时，可在本地计算机或共享的网络位置存放 Toolbox 数据。 建议将 Toolbox 数据存储在网络位置。 通过使用公用位置，所有的 SOLIDWORKS 用户可以共享一致的扣件信息。

如果是首次安装 Toolbox，请浏览到要安装 Toolbox 的新共享位置。

升级现有 Toolbox

将 Toolbox 升级到新的 SOLIDWORKS 主要版本会使该 Toolbox 与运行 SOLIDWORKS 先前主要版本的计算机不兼容。

如果其它计算机保持在先前的主要版本，且仍然需要为该发行版配置 Toolbox，则将该 Toolbox 复制一份后再对副本升级。新安装的 SOLIDWORKS 将升级 Toolbox 的副本，而先前安装的 SOLIDWORKS 则会继续使用旧的 Toolbox。

配置 Toolbox 访问设置

安装完毕后，访问 Toolbox 零部件时，SOLIDWORKS 会检查您的 Toolbox 配置，并提供一些建议来改善访问和性能。

若要访问共享网络 Toolbox（推荐的），请使用指向该共享 Toolbox 所在服务器的 UNC 路径。有关详细信息，请参阅 UNC（通用命名代码）格式。

管理员可以为 Toolbox 生成密码并为工作组设置权限和设定。限制对配置的访问和设置公用首选项，可以确保 Toolbox 数据的一致性。

在 SOLIDWORKS PDM 环境中升级 Toolbox

在您升级 SOLIDWORKS 软件时，如果已添加了零件，则会升级 Toolbox。 如果 Toolbox 根文件夹位于 SOLIDWORKS PDM 库中，则在开始升级 SOLIDWORKS 前，必须准备 Toolbox 文件夹。

在执行升级的第一个系统上，您必须使用获取最新版本下载 Toolbox 文件到本地缓存，然后检出 Toolbox 数据库文件。 在要升级的其它系统上，只需下载 Toolbox 文件即可。

在您升级之前：
  • 确保拥有数据库和存档的最新完整备份。
  • 确保 Toolbox 零件未检出或未用于任何已检出的装配体中。

升级工具箱：

  1. 在文件资源管理器中，使用拥有所有权限（检出、检入、添加和删除）的用户登录库。
  2. 右键单击 Toolbox 文件夹，然后单击获取最新版本将 Toolbox 文件和数据库复制到本地缓存中。
    如果您的存档服务器在远处，这需要几分钟的时间。
  3. 从 \Toolbox_folder_name\lang\your_lang 中检出 Toolbox 数据库文件 (SWBrowser.mdb) 或 (swbrowser.sldedb)。
  4. 运行 SOLIDWORKS 安装管理程序以进行升级。
  5. 在摘要荧屏上确保 Toolbox 选项安装位置是库中的位置。

    如果不是，单击更改，选择参考引用或升级现有 Toolbox，然后浏览到库中的 Toolbox 位置。

  6. 当升级完成时，在文件资源管理器中，检入 Toolbox 文件夹以将任何新的或已更新的文件添加到库中，这样其他用户即可使用 Toolbox。
  7. 如果是升级，则导航至资源库中的 Toolbox 文件夹，确保包括下列文件：
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      否则，联系您的增值经销商。

  8. 升级其余使用 SOLIDWORKS PDM 与 Toolbox 集成的计算机：
    1. 在文件资源管理器中，使用至少拥有 Toolbox 文件夹读权限的用户登录到库。
    2. 右键单击 Toolbox 文件夹，然后单击获取最新版本将 Toolbox 零件复制到本地缓存中。
    3. 运行 SOLIDWORKS 安装管理程序以进行升级。

      安装程序检测到 Toolbox 已经完成升级。

有关 SOLIDWORKS PDM 中的 Toolbox 配置的详细信息，请参阅SOLIDWORKS PDM管理工具帮助中的配置 Toolbox。

父主题 异型孔向导/Toolbox 选项
UNC（通用命名代码）格式


UNC（通用命名代码）格式

通用命名代码格式指定了描述共享文件位置的文件名称语法格式。

\\服务器\卷\路径

例如：

\\Disk_Server\SOLIDWORKS\AdminImage

父主题 异型孔向导/Toolbox 选项
关于配置 SOLIDWORKS Toolbox 的说明


卸载产品

当您从 控制面板 中选取删除或卸装程序时，该屏幕显示可由此版本 SOLIDWORKS 安装管理程序卸载的 SOLIDWORKS 产品（带有版本号）。 您可选择进行标准、自定义或完整卸装。

标准卸装移除 SOLIDWORKS 产品的程序文件和文件夹。 在默认情况下，所选发行版本的所有 SOLIDWORKS 产品都将被指定为标准卸载。

自定义卸载可移除一个或多个以下项： 程序文件和文件夹、注册表项和数据文件夹，如 SOLIDWORKS Toolbox 和原始下载位置的文件和文件夹。

完整卸装移除安装目录、注册表项和数据文件夹。

要卸装产品：
  1. 在卸装荧屏上确定产品已选定。

    如果您卸载所有产品，Solidworks 安装管理程序也会被卸载。

  2. 消除您不想移除的产品。

    如果您保留任何产品，SOLIDWORKS 安装管理程序不会移除。

  3. 选择是否进行自定义或完整卸装。
    1. 在高级选项中单击更改。

      高级选项屏幕出现。程序文件和文件夹选项被复选。

    2. 选取一个或多个选项进行自定义卸载，或者选取所有选项进行完整卸载。
    3. 单击返回到摘要。
    4. 在摘要荧屏上扩展高级选项显示卸装方法和条目。
  4. 单击移除项目。
当您单击移除项目后，SOLIDWORKS 安装管理程序会立即开始移除产品。
父主题 SOLIDWORKS 安装管理程序应用程序帮助


安装

SOLIDWORKS Design Augmented 可根据您的角色来授权您访问所有 3DEXPERIENCE 服务和应用程序。

许可

3DEXPERIENCE Platform 使用指定用户许可。 当管理员向您授予角色时，将分配许可证。 角色决定您有权使用的 3DEXPERIENCE 服务和应用程序。 您可以在任何设备上使用许可证。 许可证未绑定到特定机器。

有关详细信息，请参阅 DS 许可要素。

3DEXPERIENCE Launcher

当您首次安装 SOLIDWORKS Design Augmented 时，3DEXPERIENCE platform 会提示您下载并安装 3DEXPERIENCE Launcher。Launcher 是一种后台服务，可帮助本地应用程序（如 SOLIDWORKS Design Augmented）访问该平台。Launcher 图标 [image] 在安装后显示在 Windows 系统托盘中。

有关详细信息，请参阅 3DEXPERIENCE 启动程序。 访问 Dassault Systèmes 用户帮助需要提供 3DEXPERIENCE 凭据。


SOLIDWORKS Visualize Boost

SOLIDWORKS Visualize Boost 是一款应用程序，可让您将渲染从运行 SOLIDWORKS Visualize Professional 的计算机分发到网络上的一台或多台计算机。

当渲染在后台执行时，您可以在机器上执行其他任务，而最终渲染图像将很快准备就绪。您可在单台机器上渲染图像，或在运行 Visualize Boost 的多台机器组成的集群上进行渲染。

SOLIDWORKS Visualize Professional 的每个活动订阅都包含 SOLIDWORKS Visualize Boost 的一个免费许可证。

性能增益（如更快的渲染时间）取决于 Visualize Boost 计算机的功能。搭载更好 GPU 的机器将提供更好的改进。


从个人许可升级为 SolidNetWork 许可

您可以在 SOLIDWORKS 安装管理程序中指定 SolidNetWork 许可序列号，将计算机从个人 SOLIDWORKS 许可升级为 SolidNetWork 许可。

如果计算机上未安装 SOLIDWORKS，您可以在使用 SOLIDWORKS 安装管理程序进行安装时输入 SolidNetWork 序列号，以指定 SolidNetWork 许可。

如果计算机已经安装 SOLIDWORKS，并且您已将个人许可转换为 SolidNetWork 许可，您可以为该计算机修改安装，并在运行 SOLIDWORKS 安装管理程序时指定 SolidNetWork 许可序列号代替个人许可序列号。有关详细信息，请参阅修改安装。
如果您从管理映像安装了 SOLIDWORKS，则修改选项不可用。使用管理选项编辑器更改管理映像、卸载客户端并重新运行安装程序。


使用 Visualize Boost

要启用分布式渲染，您必须在配置 SOLIDWORKS Visualize 后将其连接到 Visualize Boost。

Boost 连接需要 SOLIDWORKS Visualize 中的协调程序 IP 地址和 Boost 端口值。

在以下步骤中保持 Visualize Boost 和 SOLIDWORKS Visualize 打开。

要将 SOLIDWORKS Visualize 连接到 Visualize Boost：

  1. 通过双击桌面快捷方式 [image] 打开 Visualize Boost。
  2. 在 Visualize Boost 中双击协调程序 IP 地址，将其复制到剪贴板。
  3. 在 SOLIDWORKS Visualize 中，单击工具 > 选项 > Boost，然后按 CTRL+V 粘贴协调程序 IP 地址。
  4. 重复步骤 2 和 3，将 Boost 端口 从 Visualize Boost 复制到 SOLIDWORKS Visualize。
    在 Visualize Boost 和 SOLIDWORKS Visualize Boost 中指定的 Boost 端口必须相同。
    Boost 状态控件出现在 SOLIDWORKS Visualize 中。
  5. 单击确定关闭选项对话框。
  6. 要连接到 Boost，请在这些界面中单击 Boost 状态控件 [image] 或断开连接 [image] ：
    • 前导显示
    • 渲染向导质量页面
    • 工具 选项 Boost 选项卡

有关 Boost 配置的详细信息，请参阅 SOLIDWORKS Visualize Boost。


初始化新 SolidNetWork 许可服务器

要初始化新 SolidNetWork 许可服务器：

  1. 安装并打开 SolidNetWork License Manager 服务器后，在系统提示激活时单击是。
  2. 在 SolidNetWork 许可服务器信息对话框中，验证防火墙和端口，然后单击下一步。
  3. 在产品激活向导中，选择要激活的序列号，选择通过电子邮件手工进行作为激活方法，然后输入电子邮件联系信息。

    手动方法要求您创建请求文件并将其通过电子邮件发送到 activation@solidworks.com。当您收到包含许可证响应文件的电子邮件时，解压该文件，然后单击打开将其加载到服务器。

    您可以关闭并重新运行产品激活向导，以打开和加载响应文件。

  4. 当消息框通知您初始化成功时，单击确定，然后在产品激活向导中单击完成。


手动激活新的 SolidNetWork License Manager Server

初始化 SolidNetWork License Manager Server 后，打开 SolidNetWork License Manager Server 并创建第二个请求以完成激活。

要手动激活新的 SolidNetWork License Manager Server：

  1. 执行以下操作之一：
    • 如果出现提示要求您激活，请单击是。
    • 如果未出现提示，请单击服务器管理选项卡中的修改。
    默认情况下，高级选项设置为使用激活模式。
  2. 在“SolidNetWork 许可服务器信息”对话框中验证防火墙和端口，然后单击下一步。
  3. 在产品激活向导中，选择要激活的序列号，输入电子邮件联系信息，然后选择通过电子邮件手工进行作为激活方法。
  4. 按照步骤创建请求文件并将其发送到 activation@solidworks.com。当您收到许可响应文件时，单击打开以加载该文件。
  5. 激活完成后单击完成。


手动激活升级后的 SolidNetWork License Manager Server

使用 SOLIDWORKS 安装管理程序升级 SolidNetWork License Manager Server 后，打开 SolidNetWork License Manager Server。

要手动激活升级后的 SolidNetWork License Manager Server：

  1. 在服务器管理选项卡的许可信息下，单击重新激活。
    如果您在卸载和升级 SolidNetWork License Manager Server 之前停用了许可，请在服务器管理选项卡中单击修改。仅当服务器上有激活的许可时，重新激活才可用。

    继续执行步骤 3。

  2. 在重新激活对话框中，选择已安装的序列号以查看其关联的许可，然后单击重新激活。
  3. 在 SolidNetWork 许可服务器信息对话框中验证防火墙和端口，然后单击下一步。
  4. 在产品激活向导中，选择要激活的序列号，输入电子邮件联系信息，然后选择通过电子邮件手工进行作为激活方法。
    手动激活是一个简单的流程。产品激活向导中的说明将指导您完成此过程。
  5. 激活完成后单击完成。