Установка и администрирование SOLIDWORKS

В данном руководстве описываются установка, лицензирование, обновление и администрирование продуктов SOLIDWORKS для установки на отдельных компьютерах и массовой установки.

Индивидуальные установки | Внедрение установок в многопользовательской среде
Установка Установка на одном или нескольких компьютерах. | Установка Создание администрирующего образа, который внедряется на многих клиентских компьютерах.
Лицензии Активация на компьютере или сетевые лицензии. | Лицензии Активация на компьютере или сетевые лицензии.
Обновление Обновление индивидуальных компьютеров до новой версии. | Обновление Обновление нескольких компьютеров до нового выпуска посредством обновления администрирующего образа, используемого для установки на данных компьютерах.
Администрирование Изменение, восстановление и удаление установок, обновление до новых выпусков. | Администрирование Обновление администрирующих образов и клиентов и администрирование сетевых лицензий.

Менеджер установки SOLIDWORKS позволяет задать настройки для компонентов продуктов SOLIDWORKS, включая SOLIDWORKS, SOLIDWORKS Toolbox, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS Visualize и SOLIDWORKS SolidNetWork License Manager.

SolidNetWork License Manager поддерживает несколько лицензионных клиентов, распределяя лицензии для клиентов в сети. При этом благодаря использованию плавающих лицензий, число пользователей может превышать число лицензий.

Содержание

  • Индивидуальная установка или Администрирующий образ

    Необходимо установить продукты SOLIDWORKS отдельно на каждый компьютер или следует создать администрирующий образ и внедрить установку на другие клиентские компьютеры, с помощью одной команды?

  • Проверка системы и требований к программному обеспечению

    Перед началом установки убедитесь, что система соответствует требованиям оборудования, операционной системы и продуктов Microsoft. Дополнения, например SOLIDWORKS Electrical, SOLIDWORKS Visualize и eDrawings, имеют дополнительные требования.

  • Скачивание установочного носителя

    Все установочные материалы доступны на странице загрузок SOLIDWORKS.

  • Установка приложений 3DEXPERIENCE

    При управлении данными с помощью 3DEXPERIENCE Platform можно приобрести роль Collaborative Designer for SOLIDWORKS для подключения среды рабочего стола к платформе.


Индивидуальная установка или Администрирующий образ

Необходимо установить продукты SOLIDWORKS отдельно на каждый компьютер или следует создать администрирующий образ и внедрить установку на другие клиентские компьютеры, с помощью одной команды?

Если Вы проводите установку на одном компьютере или администрируете десятки или сотни компьютеров, Ваш выбор очевиден. Для менее явных ситуаций рассмотрите приведенные сравнения.

Индивидуальная установка | Администрирующий образ
Пользователи могут администрировать свои установки SOLIDWORKS самостоятельно. | Системный администратор может настроить несколько установок с помощью Редактора параметров, указав параметры установки, такие как создание новой установки или обновление существующей, запуск установки в качестве административного пользователя, запуск внешних команд до или после установки, различные группы продуктов и т.д.
Компьютеры должны быть физически доступны для человека, проводящего установку. | Клиентские компьютеры могут быть удалены, если они доступны через сеть.
Пользователь может устанавливать разные версии, пакеты обновления и продукты на разных компьютерах, используя разные настройки. | С помощью Редактора параметров администрирующие образы могут сохранить последовательность в версиях, пакетах обновления, продуктах и настройках для нескольких установок.
На компьютере должен быть установлен доступ к сети или электронной почте. Требуется установить сетевое подключение или подключение электронной почты для активации SOLIDWORKS и загрузки файлов. Сетевой доступ также требуется при сборе лицензий с сервера сетевых лицензий.

Подключение к локальной сети необходимо для распространения программы; наличие носителей на клиентских компьютерах не требуется.

Клиенты можно обновить автоматически. Установка на всех клиентских компьютерах, проведенная с помощью одного администрирующего образа, распространяет единый пакет обновления на все компьютеры. Для поддержки нескольких версий пакетов обновления можно создать несколько администрирующих образов.

Лицензия может активироваться автоматически.

Администрирующий образ занимает дополнительное место на сервере; клиенты должны обладать таким же количеством свободного места, что и индивидуальные установки.

На уровень выше Установка и администрирование SOLIDWORKS
Проверка системы и требований к программному обеспечению
Скачивание установочного носителя
Установка приложений 3DEXPERIENCE


Проверка системы и требований к программному обеспечению

Перед началом установки убедитесь, что система соответствует требованиям оборудования, операционной системы и продуктов Microsoft. Дополнения, например SOLIDWORKS Electrical, SOLIDWORKS Visualize и eDrawings, имеют дополнительные требования.

Для проверки успеха установки и оптимальной производительности убедитесь, что система отвечает следующим Требованиям к системе.

На уровень выше Установка и администрирование SOLIDWORKS
Индивидуальная установка или Администрирующий образ
Скачивание установочного носителя
Установка приложений 3DEXPERIENCE


Скачивание установочного носителя

Все установочные материалы доступны на странице загрузок SOLIDWORKS.

Если вы не можете получить доступ к странице загрузок SOLIDWORKS, обратитесь к своему реселлеру для получения DVD-дисков.

Чтобы скачать установочный носитель:

  1. Выполните вход на Страницу загрузок SOLIDWORKS в качестве клиента с подпиской на услугу, используя свой адрес электронной почты и пароль или свой серийный номер SOLIDWORKS.
  2. На странице загрузок в разделе Выбор версии выберите год.
  3. Выберите вкладку SOLIDWORKS для продуктов SOLIDWORKS.
  4. В области "Продукт" выберите пакет обновления.
    Для последнего основного выпуска выберите Продукты SOLIDWORKS версии 0.0.
  5. Нажмите Принять соглашение и продолжить, чтобы принять условия лицензионного соглашения.
  6. Нажмите Скачать.
    Ваш веб-браузер скачивает SolidworksSetup.exe в папку по умолчанию C:\Users\Username\Downloads.
  7. Распакуйте файл SolidworksSetup.exe в папку Downloads.
    Вы также можете распаковать SolidworksSetup.exe в любую другую папку.
  8. Откройте файл setup.exe, используя права администратора.
  9. В Менеджере установки нажмите Скачать и предоставить общий доступ ко всем файлам.
    Создайте отдельные установки или администрирующие образы на нескольких компьютерах с помощью одной операции скачивания и следуйте инструкциям для завершения процесса.

    Менеджер установки скачивает установочный пакет.

    Этот параметр полезно использовать в следующих случаях:
    • установка программного обеспечения на небольшом количестве компьютеров;
    • скачивание с портативного или сетевого диска;
    • установка пакетов обновления;
    выборочное скачивание установочных файлов (следуйте подсказкам, чтобы выбрать метод ручного скачивания).
На уровень выше Установка и администрирование SOLIDWORKS
Индивидуальная установка или Администрирующий образ
Проверка системы и требований к программному обеспечению
Установка приложений 3DEXPERIENCE


Установка приложений 3DEXPERIENCE

При управлении данными с помощью 3DEXPERIENCE Platform можно приобрести роль Collaborative Designer for SOLIDWORKS для подключения среды рабочего стола к платформе.

Эта роль предоставляет доступ к приложениям 3DEXPERIENCE, которые позволяют продуктам SOLIDWORKS Desktop сохранять, искать и управлять данными, хранящимися на платформе. Также можно использовать веб-приложение SOLIDWORKS Design Augmented. Дополнительные сведения об установке см. в разделе Установка.

Установка и лицензирование этих дополнений осуществляется в 3DEXPERIENCE Platform, а не с помощью Менеджера установки SOLIDWORKS. Инструкции по установке см. в справке SOLIDWORKS в разделе Работа с 3DEXPERIENCE Platform и приложениями 3DEXPERIENCE > Установка приложений 3DEXPERIENCE.

На уровень выше Установка и администрирование SOLIDWORKS
Индивидуальная установка или Администрирующий образ
Проверка системы и требований к программному обеспечению
Скачивание установочного носителя
https://help.solidworks.com


Индивидуальные установки

Содержание

  • Установка на отдельных компьютерах

    Программу SOLIDWORKS можно установить на отдельном компьютере следующими способами.

  • Администрация индивидуальных установок

    Как правило, администрирование индивидуальных установок включает изменение, исправление, удаление и обновление установленных версий.


Установка на отдельных компьютерах

Программу SOLIDWORKS можно установить на отдельном компьютере следующими способами.

Менеджер установки SOLIDWORKS выполняет установку, адаптируя ее для приобретенных продуктов. Перед началом установки необходимо:

  • Если вы устанавливаете автономное рабочее место SOLIDWORKS, необходимо иметь собственный серийный номер для SOLIDWORKS.
  • Убедитесь, что у Вас есть работающее подключение к Интернету. Для проверки объема обслуживания требуется установить подключение.
  • Создайте 3DEXPERIENCE ID. Подробнее о создании 3DEXPERIENCE ID см. в разделе https://www.3ds.com/support.
  • Проверьте, что вы являетесь назначенным администратором вашей учетной записи или что ваш администратор включил вас в список контактов.

Диспетчер установки SOLIDWORKS Installation Manager устанавливает различные компоненты Microsoft, в том числе Microsoft Visual Studio Tools для приложений, Visual Basic и .NET Framework. Если на компьютере не установлены все необходимые компоненты Windows, Менеджер установки SOLIDWORKS автоматически выполнит их установку перед установкой продуктов SOLIDWORKS.

SOLIDWORKS Chromium Embedded Framework (CEF) — это другой компонент, устанавливаемый Менеджером установки SOLIDWORKS. Он предназначен для отображения содержимого приложений SOLIDWORKS и 3DEXPERIENCE Platform.

SOLIDWORKS Login Manager также устанавливается SOLIDWORKS Installation Manager. Он позволяет войти в 3DEXPERIENCE Marketplace и 3DEXPERIENCE Apps.

Метод установки Сводка по процессу
Скачивание со страницы загрузок SOLIDWORKS

Все установочные материалы доступны на странице загрузок SOLIDWORKS.

  1. Перейдите на страницу загрузок SOLIDWORKS.
  2. Выполните вход с помощью 3DEXPERIENCE ID.
  3. На странице скачивания в разделе Select Version (Выбор версии) выберите год.
  4. Перейдите на вкладку SOLIDWORKS в разделе продуктов SOLIDWORKS, затем выберите пакет обновления в разделе Продукт.
  5. Нажмите Принять соглашение и продолжить, чтобы принять условия лицензионного соглашения.
  6. Нажмите Скачать.
У вас должно быть активно подключение к Интернету с доступом к странице загрузок.

Если вы не можете получить доступ к странице загрузок, обратитесь к своему реселлеру для получения установочных носителей.
Установка с помощью каталога загрузки на сервере В каталоге скачивания дважды нажмите setup.exe.

Каталог скачивания должен быть доступен с компьютера, на котором выполняется установка продуктов SOLIDWORKS, и должен содержать все установочные файлы SOLIDWORKS до начала процесса установки. Менеджер установки SOLIDWORKS позволяет искать недостающие файлы при наличии доступа в Интернет и права записи в каталог скачивания.
Обновление текущей установки SOLIDWORKS с помощью параметра Проверить наличие обновлений. Выполните одну из следующих операций.
  • В SOLIDWORKS выберите [image] > Проверить наличие обновлений.
  • В Windows выберите Пуск > Менеджер установки SOLIDWORKS > Проверить наличие обновлений.
Можно также нажать Пуск > Менеджер установки SOLIDWORKS > Фоновый загрузчик SOLIDWORKS. В области уведомлений Windows нажмите правой кнопкой мыши на пункт Фоновый загрузчик SOLIDWORKS и выберите Проверить наличие обновлений.
Необходимо наличие рабочего подключения к Интернету и полномочия администратора на компьютере.

В Менеджере установки SOLIDWORKS можно также выбрать параметр Скачать и предоставить общий доступ ко всем файлам, включая необходимое программное обеспечение. Эта функция полезна, если вы устанавливаете программное обеспечение на нескольких компьютерах и хотите скопировать его с помощью портативного или сетевого диска. Также полезно установить пакеты обновления, т.к. полная версия и пакет обновления содержатся в одной установке.

После завершения установки запустите программу SOLIDWORKS и активируйте лицензию.

Чтобы отобразить список продуктов, для которых используется лицензия на вашем компьютере, в главном меню SOLIDWORKS выполните следующие действия.
  • Нажмите [image] > Мои продукты.
  • Выберите Главная на панели задач и перейдите в раздел Ресурсы SOLIDWORKS > Мои продукты.
  • Нажмите Пуск > Инструменты SOLIDWORKS версия > Мои продукты.

В диалоговом окне флажками отмечены продукты, которыми владеют вы или ваша организация на основе активации или сетевых лицензий. Также можно узнать больше о продуктах SOLIDWORKS, нажав на ссылку в верхней части каждой категории продукта.

Если у вас есть лицензия SOLIDWORKS, в ОС Windows можно посмотреть, какие лицензии используются. Перейдите на вкладку Пуск > Инструменты SOLIDWORKS <версия> > Клиент SolidNetWork License Manager > Использование лицензии.

На уровень выше Индивидуальные установки
Администрация индивидуальных установок


Администрация индивидуальных установок

Как правило, администрирование индивидуальных установок включает изменение, исправление, удаление и обновление установленных версий.

Содержание

  • Изменение установки

    Вы можете изменить установку, чтобы установить еще не установленные продукты, или удалить продукты, если установлен полный набор установочных файлов во время предыдущей установки. Этот вариант не может использоваться, если обновление предыдущей установки выполнено с использованием пакета обновления.

  • Исправление установки

    При возникновении неполадок в установленном продукте SOLIDWORKS можно воспользоваться Менеджером установки SOLIDWORKS для исправления установки.

  • Откат индивидуальной установки к предыдущей версии пакета обновления

  • Удаление установки

    Можно удалить установку на отдельном компьютере или в среде клиент/сервер.

  • Обновление до новой версии

    Выполнить обновление индивидуальной установки SOLIDWORKS до новой версии можно несколькими способами.

  • Правила сосуществования продуктов

    Правилами совместимости продуктов определяются способы установки новых продуктов и обновления существующих.

На уровень выше Индивидуальные установки
Установка на отдельных компьютерах


Изменение установки

Вы можете изменить установку, чтобы установить еще не установленные продукты, или удалить продукты, если установлен полный набор установочных файлов во время предыдущей установки. Этот вариант не может использоваться, если обновление предыдущей установки выполнено с использованием пакета обновления.

Если вы установили SOLIDWORKS и позднее приобрели дополнение, можно изменить установку, чтобы включить в нее новое дополнение. Дополнение следует установить на каждом отдельном компьютере.

  1. Убедитесь, что нет активных сеансов SOLIDWORKS.
  2. В Windows, выберите Параметры > Приложения > Установленные приложения.
  3. Выберите версию SOLIDWORKS, которую требуется изменить, и нажмите кнопку Изменить.
  4. На экране Вас приветствует Менеджер установки SOLIDWORKS нажмите Изменить установку.
  5. На экране Серийный номер проверьте, указаны ли соответствующие серийные номера.
  6. На странице выбора продуктов выберите продукты для установки или удаления.
    При изменении установки:
    • продукты не устанавливаются и не удаляются по умолчанию, даже если указан новый серийный номер. Необходимо изменить установку каждого продукта или компонента.
    • Для просмотра спроецированного действия определенного компонента щелкните его имя (не флажок). Планируемое действие по установке появится в поле сведений под списком продуктов.
    • Можно установить флажок рядом с компонентом продукта, чтобы изменить действие по установке для данного компонента. (Например, установка флажка при установке или удалении компонента означает, что отмеченный компонент необходимо установить или удалить, а снятие флажка означает, что компонент не следует устанавливать или удалять.)
    • При изменении действия по установке компонента, заданного в исходной спецификации, в списке рядом с этим компонентом отобразится звездочка (*).
    • Если компонент содержит необязательные для установки подкомпоненты, рядом с ним отображается значок [image] . Для просмотра доступных подкомпонентов компонента нажмите на значок [image].
    • Если компонент уже был развернут для просмотра необязательных подкомпонентов, рядом с ним отобразится значок [image]. Чтобы свернуть список подкомпонентов, нажмите на значок [image] .
  7. На экране Сводная информация нажмите кнопку Изменить сейчас.
  8. На экране Установка завершена нажмите на кнопку Готово.
На уровень выше Администрация индивидуальных установок
Исправление установки
Откат индивидуальной установки к предыдущей версии пакета обновления
Удаление установки
Обновление до новой версии
Правила сосуществования продуктов


Исправление установки

При возникновении неполадок в установленном продукте SOLIDWORKS можно воспользоваться Менеджером установки SOLIDWORKS для исправления установки.

Для исправления установки на вашем компьютере должны быть все исходные файлы предыдущей установки, а также все примененные пакеты обновлений. Они должны находиться в том месте, где они были изначально установлены.

Можно исправить индивидуальную установку. Администрирующий образ исправить нельзя; необходимо отменить установку и затем повторно установить администрирующий образ.
  1. Откройте Панель управления Windows и выберите Программы > Программы и компоненты.
  2. Выберите правой кнопкой мыши версию SOLIDWORKS, которую требуется исправить, и нажмите Изменить.
  3. На странице Добро пожаловать в Менеджер установки SOLIDWORKS нажмите Исправить эту установку, затем Далее.
  4. На экране Продукты для исправления выберите продукт, который требуется исправить.
  5. Отмените выбор всех остальных продуктов.
  6. Выберите Исправить.
На уровень выше Администрация индивидуальных установок
На уровень выше Ошибки установки/Отмена установки
Изменение установки
Откат индивидуальной установки к предыдущей версии пакета обновления
Удаление установки
Обновление до новой версии
Правила сосуществования продуктов
Восстановление после неудачной или отмененной установки
Обращение к реселлеру SOLIDWORKS


Откат индивидуальной установки к предыдущей версии пакета обновления

Чтобы выполнить откат индивидуальной установки к предыдущей версии пакета обновления в текущем семействе версий, удалите установленную на компьютере версию пакета обновления и переустановите более раннюю версию.
На уровень выше Администрация индивидуальных установок
Изменение установки
Исправление установки
Удаление установки
Обновление до новой версии
Правила сосуществования продуктов


Удаление установки

Можно удалить установку на отдельном компьютере или в среде клиент/сервер.

  1. Убедитесь, что нет активных сеансов SOLIDWORKS.
  2. Чтобы перенести лицензию SOLIDWORKS на другой компьютер, деактивируйте лицензию до удаления установки SOLIDWORKS с этого компьютера.
    Для получения дополнительной информации см. Перенос лицензии.
  3. Откройте панель управления Windows и выберите Программы и компоненты.
  4. Выберите компонент продукта для удаления и нажмите Удалить.
    В некоторых случаях можно обнаружить несколько компонентов пакета обновления SOLIDWORKS для существующей основной версии. Чтобы удалить основной выпуск SOLIDWORKS, удалите все элементы пакета обновления для данного основного выпуска.
  5. На экране Удалить:
    1. Выберите продукты для удаления.
      По умолчанию установлено значение "Все компоненты продуктов".
    2. Отмените выбор продуктов, которые вы не хотите удалять.
    3. Выберите Изменить в Дополнительные параметры.
      Откроется экран Дополнительные параметры с выбранным параметром "Файлы и папки программ".
    4. Выберите один или несколько параметров, чтобы выполнить отмену установки по выбору, или все параметры, чтобы выполнить полную отмену установки.
      По умолчанию Менеджер установки SOLIDWORKS выполняет полное удаление программы и всех ее файлов и папок, добавленных при установке.
    5. Нажмите Назад в Сводку.
    6. На экране Сводка разверните Дополнительные параметры, чтобы отобразить удаляемые объекты и метод отмен установки.
    7. Выберите Удалить объект.
На уровень выше Администрация индивидуальных установок
На уровень выше Администрация множественных установок
Изменение установки
Исправление установки
Откат индивидуальной установки к предыдущей версии пакета обновления
Обновление до новой версии
Правила сосуществования продуктов
Обновление администрирующих образов до новой версии
Администрирование обновлений продуктов с помощью пакетов обновления
Перенос лицензии


Обновление до новой версии

Выполнить обновление индивидуальной установки SOLIDWORKS до новой версии можно несколькими способами.

Выполнять обновление до новой версии можно в следующих случаях.
  • При получении нового установочного носителя;
  • при получении уведомления о наличии обновлений во время запуска SOLIDWORKS.
  • Проверка наличия обновлений вручную
  • Запуск новой версии Менеджера установки SOLIDWORKS

При установке новой основной версии можно обновить установленную ранее версию или установить новую параллельно с существующей версией. При установке версии пакета обновления для установленной ранее основной версии эта версия обновляется автоматически.

На уровень выше Администрация индивидуальных установок
Изменение установки
Исправление установки
Откат индивидуальной установки к предыдущей версии пакета обновления
Удаление установки
Правила сосуществования продуктов

Проверка наличия обновлений вручную

Если у вас есть полномочия администратора компьютера, можно выполнить проверку обновлений для установленной версии SOLIDWORKS одним из перечисленных ниже способов.

  • В SOLIDWORKS выберите [image] > Проверить наличие обновлений.
  • В Windows выберите Пуск > Менеджер установки SOLIDWORKS > Проверить наличие обновлений.
Можно также нажать Пуск > Менеджер установки SOLIDWORKS > Фоновый загрузчик SOLIDWORKS. В области уведомлений Windows нажмите правой кнопкой мыши на пункт Фоновый загрузчик SOLIDWORKS и выберите Проверить наличие обновлений.

Предупреждения относительно обновления

Продукты, допускающие множественные установки, принадлежащие разным основным выпускам, не всегда поддерживают основные обновления или возможность обновления до следующего основного выпуска посредством одного действия.

В этом случае Менеджер установки SOLIDWORKS имитирует обновление: сначала устанавливается новая версия, а затем удаляется более ранняя. В настоящее время только основной продукт SOLIDWORKS поддерживают основные обновления.

Последствия таковы:
  • При обновлении основного продукта SOLIDWORKS до следующей основной версии происходит следующее.
    • Текущее месторасположение установки не изменяется.
    • Можно выполнить откат обновления при возникновении ошибки или при отмене процесса обновления во время его выполнения.
  • При обновлении других продуктов до следующего основного выпуска:
    • Каждый из продуктов сначала устанавливается в качестве нового продукта в новом месторасположении, а затем его исходная установка удаляется.
    • После запуска процесса обновления его нельзя откатить назад при возникновении ошибки или при отмене процесса обновления во время его выполнения.


Правила сосуществования продуктов

Правилами совместимости продуктов определяются способы установки новых продуктов и обновления существующих.

Правило | Примеры
Разрешается устанавливать несколько основных версий базовых продуктов SOLIDWORKS, исключение составляют три перечисленных ниже продукта. | На одном компьютере можно установить SOLIDWORKS 2025 SP3.0 и SOLIDWORKS Design 2026 SP0.0.
Несколько пакетов обновления из одной основной версии базовых продуктов запрещены. | Версии SOLIDWORKS Design 2026 SP0.0 и 2026 SP1.0 не могут работать на одном компьютере. При установке SOLIDWORKS Design 2026 SP1.0 на компьютер с уже установленной версией SOLIDWORKS Design 2026 SP0.0 программа SOLIDWORKS Installation Manager заменяет версию SP0.0 версией SP1.0.
Перечисленные ниже продукты можно устанавливать на компьютере только в одной версии:
  • SolidNetWork License Manager
 Если установлена версия SolidNetWork License Manager 2025 SP3.0, то SolidNetWork License Manager обновляется до версии 2026 SP0.0, даже если на данном компьютере остается более ранний основной выпуск SOLIDWORKS.
Перечисленные ниже продукты можно устанавливать на компьютере только в одной версии:
  • SOLIDWORKS Electrical
 Если создается новая установка SOLIDWORKS Electrical 2026 SP1.0, Менеджер установки SOLIDWORKS автоматически удалит более ранние версии SOLIDWORKS Electrical с компьютера. Создайте резервную копию среды SOLIDWORKS Electrical перед обновлением.
Перечисленные ниже продукты можно устанавливать на компьютере только в одной версии:
  • Клиент SOLIDWORKS PDM
  • Сервер SOLIDWORKS PDM

При установке SOLIDWORKS Design 2026 SP0.0 или SP1.0 необходимо также обновить сервер и клиент до версии SOLIDWORKS 2026 PDM.

При установке сервера SOLIDWORKS 2026 PDM необходимо использовать процесс установки сервера PDM для установки SOLIDWORKS PDM Client. Не устанавливайте SOLIDWORKS PDM Client отдельно в процессе установки клиента.

На одной машине клиент SOLIDWORKS PDM должен иметь ту же рабочую версию и пакет обновления, что сервер SOLIDWORKS PDM.

Подробнее см. в разделе SOLIDWORKS PDM и SOLIDWORKS Manage.

Для каждой основной версии SOLIDWORKS встроенного продукта можно установить только одну версию. Однако версии встроенных продуктов с других основных выпусков SOLIDWORKS могут работать на одном компьютере. | При обновлении SOLIDWORKS Design 2026 SP0.0 до 2026 SP1.0 программа SOLIDWORKS Composer 20265 SP0.0 автоматически обновится до 2026 SP1.0. Однако SOLIDWORKS Composer 2025 SP4.0 может работать одновременно с SOLIDWORKS Composer 2025 SP0.0 или SOLIDWORKS Composer 2026 SP1.0.
На уровень выше Администрация индивидуальных установок
Изменение установки
Исправление установки
Откат индивидуальной установки к предыдущей версии пакета обновления
Удаление установки
Обновление до новой версии


Множественные установки

Содержание

  • Внедрение на нескольких клиентах

    Продукты SOLIDWORKS можно установить на нескольких клиентских компьютерах, создав для этого соответствующий администрирующий образ и внедрив его на клиентах.

  • Использование администрирующих образов

    Администрирующий образ позволяет настраивать установку продуктов SOLIDWORKS из одной сетевой папки.

  • Внедрение с использованием командной строки

    Можно автоматически внедрить администрирующий образ с использованием командной строки или пакетного файла (автоматическая установка).

  • Администрация множественных установок

    К административным задачам по созданию нескольких установок относятся обновление администрирующих образов до новых версий, применение пакетов обновления и удаление установок.


Внедрение на нескольких клиентах

Продукты SOLIDWORKS можно установить на нескольких клиентских компьютерах, создав для этого соответствующий администрирующий образ и внедрив его на клиентах.

Ниже дается описание процесса внедрения на нескольких клиентских компьютерах.
  1. Создайте администрирующий образ.
    • Создание администрирующего образа с помощью Менеджера установки SOLIDWORKS
  2. Разверните администрирующий образ на клиентских компьютерах.
    • Развертывание администрирующего образа на клиентских компьютерах вручную/принудительно (эл. почта)
    • Развертывание администрирующего образа на клиентских компьютерах автоматически/принудительно
    • Установка администрирующего образа с использованием командной строки
  3. Выполните лицензирование.
    • Администрирование индивидуальных лицензий
    • Администрирование лицензий с помощью SolidNetWork License Manager
На уровень выше Множественные установки
Использование администрирующих образов
Внедрение с использованием командной строки
Администрация множественных установок


Использование администрирующих образов

Администрирующий образ позволяет настраивать установку продуктов SOLIDWORKS из одной сетевой папки.

Администрирующий образ можно установить с любого компьютера в сети, включая клиент.
  • Администрирующий образ должен находиться в общей папке.
  • При включении всех продуктов необходимый объем дискового пространства для создания администрирующего образа может составить 17 ГБ и больше.
  • Если обновить общее имя при обновлении администрирующего образа, клиент будет обновлен автоматически при следующем запуске приложения. Для получения дополнительной информации см. Обновление администрирующего образа.
  • При развертывании администрирующего образа путь к файлу образа должен содержать менее 58 символов.
  • Клиенты должны иметь полномочия администраторов на своих компьютерах. Если у клиента недостаточно прав, он может выполнить установку от имени другого пользователя. Этот возможность полезна, когда отдельные пользователи не имеют на компьютере прав административного доступа, что необходимо для установки продуктов SOLIDWORKS.

    См. Внедрение установок из Редактора параметров. Здесь также описан альтернативный метод установки образов, когда клиент не обладает достаточными правами.

  • Если ведение журнала Windows включено или используется функциональность статуса в редакторе параметров администрирующего образа, необходимо иметь права на чтение/запись данных в этой папке: {Administrative image directory}\x64\Logs.

Параметрами установки созданного администрирующего образа можно управлять при помощи Редактора параметров администрирующего образа, настраивая их для пользователей и групп, использующих данный образ для установки. Для получения дополнительной информации см. Редактор параметров администрирующего образа.

Содержание

  • Типы администрирующих образов

    Редактор параметров администрирующего образа можно использовать для создания нескольких типов образов для удаленных пользователей и для пользователей в сети.

  • Создание администрирующего образа с помощью Менеджера установки SOLIDWORKS

    Если Вы устанавливаете программу SOLIDWORKS на нескольких компьютерах, можно создать администрирующий образ и затем распространить программу на другие компьютеры.

  • Редактор параметров администрирующего образа

    С помощью Редактора параметров администрирующего образа можно настроить параметры установки администрирующего образа для отдельных компьютеров или для группы компьютеров.

  • Инструмент "Администратор параметров"

На уровень выше Множественные установки
Внедрение на нескольких клиентах
Внедрение с использованием командной строки
Администрация множественных установок
Обновление клиентов с помощью администрирующих образов


Типы администрирующих образов

Редактор параметров администрирующего образа можно использовать для создания нескольких типов образов для удаленных пользователей и для пользователей в сети.

Тип администрирующего образа Описание
Стандарт

Этот образ используется по умолчанию для всех новых администрирующих образов.

Этот стандартный администрирующий образ установщика Windows идеально подходит для пользователей, которые имеют надежный доступ к корпоративной сети. В нем хранятся все файлы, необходимые для установки выбранных продуктов SOLIDWORKS в папке с общим доступом к образу.

При обновлении до нового пакета обновления пользователи могут скачивать и применять файлы исправлений, а не скачивать весь образ.
Удаленный клиент

Этот образ предназначен для удаленных пользователей, которые не имеют надежного доступа к корпоративной сети.

При установке этого типа образа удаленные пользователи наследуют все указанные параметры установки, такие как серийный номер и устанавливаемые продукты.

Пользователи скачивают необходимые файлы через Интернет со страницы загрузок SOLIDWORKS. Доступ к этим файлам и их установка из Интернета более надежны, чем скачивание из корпоративной сети, и позволяют снизить нагрузку на сети.

Удаленные пользователи устанавливают этот образ с помощью тех же методов, которые поддерживаются стандартным администрирующим образом. Вы по-прежнему можете создавать сценарии установки с помощью файлов sldim.exe и startinstall.exe.

Файлы установки скачиваются в папку, указанную в редакторе параметров администрирующего образа перед установкой. Пользователи должны получить доступ к папке администрирующего образа, чтобы начать установку и запустить файлы пакета или настроек, размещенные в этой папке.

Удаленные пользователи должны иметь достаточно свободного места на диске для хранения всех файлов в образе, хотя пользователи могут удалить образ после завершения установки.
Сжатый

Сжатый администрирующий образ предназначен для организаций, которым необходимо скопировать администрирующие образы на несколько площадок или клиентских компьютеров и минимизировать влияние на сеть.

Этот образ на 60% меньше стандартного администрирующего образа, но устанавливается за то же время. Он поддерживает все операции установки, такие как изменение и восстановление.

Сжатые административные образы также имеют короткие пути к файлам. Это позволяет избежать проблем при хранении образов в длинных структурах папок.

При обновлении до нового пакета обновления пользователи должны скачать весь образ, а не только исправления.
На уровень выше Использование администрирующих образов


Создание администрирующего образа с помощью Менеджера установки SOLIDWORKS

Если Вы устанавливаете программу SOLIDWORKS на нескольких компьютерах, можно создать администрирующий образ и затем распространить программу на другие компьютеры.

  1. Запустите Менеджер установки SOLIDWORKS.

    См. Скачивание установочного носителя.

  2. На экране Приветствия выберите Создать администрирующий образ для развертывания на нескольких компьютерах и выберите один из следующих параметров:
    Опция | Описание
    Создать новый образ с использованием параметров по умолчанию. | Создать образ при помощи параметров конфигурации, настроенных по умолчанию (иными словами, не используя параметры, заданные для имеющегося администрирующего образа).
    Создать новый образ с использованием параметров и файлов существующего образа. | Создать образ, используя параметры конфигурации, настроенные для существующего администрирующего образа. Нажмите Обзор, чтобы указать каталог установки существующего администрирующего образа.
  3. Введите свой серийный номер SOLIDWORKS.
  4. Нажмите Изменить, чтобы изменить продукты или параметры по умолчанию, включая следующее.
    • Расположение администрирующего образа
    • Тип администрирующего образа
  5. Примите условия лицензионного соглашения и нажмитеСоздать сейчас.
  6. Нажмите Настройка образа, чтобы открыть и отобразить настройки в редакторе параметров администрирующего образа.
  7. Необязательно: Нажмите Создать ярлык на рабочем столе, чтобы получить доступ к образу на рабочем столе.
На уровень выше Использование администрирующих образов


Редактор параметров администрирующего образа

С помощью Редактора параметров администрирующего образа можно настроить параметры установки администрирующего образа для отдельных компьютеров или для группы компьютеров.

После создания администрирующего образа Менеджер установки SOLIDWORKS выдает запрос на запуск Редактора параметров. Можно также запустить Редактор параметров, дважды нажав sldAdminOptionEditor.exe в папке администрирующего образа.

Чтобы указать разные конфигурации установки для групп компьютеров или отдельных компьютеров, в редакторе параметров выберите компьютеры. Затем укажите параметры установки для этих компьютеров.

Все диалоговые окна, запрашивающие путь к файлу или папке, содержат возможность сопоставить выбранную папку переменной среды. Например, при выборе C:\Program Files\SOLIDWORKS Corp путь к файлу сопоставляется с %ProgramFiles%\SOLIDWORKS Corp. Наиболее распространенными переменными являются %ProgramFiles% и %SystemDrive%.

Не все пути можно сопоставить с переменными среды. Например, невозможно сопоставить Z:\SOLIDWORKS Data с переменной среды.

Содержание

  • Добавление и удаление групп и компьютеров

    В Редакторе параметров администрирующего образа можно указать различные конфигурации установки для групп компьютеров или отдельных компьютеров.

  • Просмотр и изменение значений параметров

    Редактор параметров администрирующего образа SOLIDWORKS позволяет просматривать и изменять настройки параметров для групп и компьютеров, указанных для образа.

  • Внедрение установок из Редактора параметров

    Развертывание можно выполнять непосредственно из редактора параметров двумя способами — вручную или автоматически.

  • Выход из Редактора параметров

    Для закрытия редактора параметров можно нажать кнопку "OK" или "Закрыть".

  • Создание ярлыка Редактора параметров на рабочем столе

    Можно создать ярлык Редактора параметров на рабочем столе Windows для определенного администрирующего образа внутри приложения.

  • Внедрение администрирующего образа на клиентах через электронную почту

    Когда будет создан общий каталог администрирующего образа, можно по электронной почте оповестить об этом клиентов.

На уровень выше Использование администрирующих образов


Добавление и удаление групп и компьютеров

В Редакторе параметров администрирующего образа можно указать различные конфигурации установки для групп компьютеров или отдельных компьютеров.

Например, можно настроить нескольких компьютеров, на которых планируется использовать набор компонентов продукта, доступных в образе. А на другой группе компьютеров планируется использовать другой набор компонентов. Даже в случае использования одного администрирующего образа групповые настройки Редактора параметров позволяют устанавливать на разных группах машин разные наборы компонентов продукта. Можно также перемещать настройки между группами и редактировать группы компьютеров.

Можно также разделить группы компьютеров на подгруппы. Подгруппы наследуют параметры из родительской группы, но можно изменить отдельные настройки для каждой подгруппы.

Чтобы добавить группу, выполните следующие действия.
  1. Нажмите правой кнопкой мыши Глобальные настройки, а затем выберите Добавить группу.
  2. Введите имя группы.

Чтобы добавить компьютеры, выполните следующие действия.
  1. Нажмите правой кнопкой мыши существующую группу или пункт Глобальные настройки, а затем выберите Добавить компьютер.
    Если нажать существующую группу правой кнопкой мыши, компьютеры будут добавлены в эту группу. В противном случае они будут добавлены на верхний уровень.
  2. Выполните одну из следующих операций.
    • Выберите По имени компьютера и ведите имя компьютера.
      Имена компьютеров не могут включать квалификаторы домена. Например, имя pluto.solidworks.com неверное.
    • Выберите По IP-адресу и введите IP-адрес компьютера.
    • Выберите По диапазону IP-адресов и введите начальный и конечный IP-адреса диапазона.
    • Нажмите Добавить несколько компьютеров, чтобы ввести имена компьютеров. Можно разделить имена нескольких компьютеров с помощью разрыва строки, пробела, символа табуляции, запятой, точки, двоеточия или точки с запятой. Можно также скопировать и вставить в диалоговое окно список имен компьютеров из файла с разделителями, например из файла *.xls или *.cvs.

    При добавлении компьютеров по имени, IP-адресу и диапазону IP-адресов компьютером, производящим установку, выполняется поиск совпадения в следующем порядке: Имя компьютера, IP-адрес, а затем Диапазон IP-адресов. Параметры установки будут применены к установке компьютера на основе первого найденного совпадения.

Чтобы переместить существующий компьютер в группу или подгруппу, выполните следующее действие.

Перетащите компьютер в группу или подгруппу.

Чтобы переместить компьютер из группы или подгруппы, выполните следующее действие.

Перетащите компьютер в раздел Глобальные настройки или в другую группу или подгруппу.

Чтобы удалить группу, подгруппу или компьютер, выполните следующие действия.

Нажмите правой кнопкой мыши на группу или компьютер и выберите Удалить группу или Удалить компьютер.

При удалении группы удаляются все компьютеры, входящие в ее состав.

Чтобы удалить все группы и компьютеры, выполните следующие действия.

Нажмите правой кнопкой мыши Глобальные настройки, а затем выберите Удалить все.

На уровень выше Редактор параметров администрирующего образа
Просмотр и изменение значений параметров
Внедрение установок из Редактора параметров
Выход из Редактора параметров
Создание ярлыка Редактора параметров на рабочем столе
Внедрение администрирующего образа на клиентах через электронную почту


Просмотр и изменение значений параметров

Редактор параметров администрирующего образа SOLIDWORKS позволяет просматривать и изменять настройки параметров для групп и компьютеров, указанных для образа.

  • При первом запуске Редактора параметров настройки параметров отображаются в режиме только для чтения. Значок "Изменить" [image] не затенен.

    При выборе параметра Глобальные настройки, группы или компьютера отобразится краткий перечень настроек параметра для данного элемента:

    Область | Отображаемые настройки параметров
    Глобальные настройки | Все настройки параметров, указанные для администрирующего образа
    Группа | Изменения настроек групп относительно глобальных настроек
    Машина | Изменения настроек компьютеров относительно группы
  • Для изменения настроек параметров нажмите Изменить [image]. Значок становится затемненным, а на экране появится более подробный список настроек параметров.

    При выборе параметра Глобальные настройки, группы или компьютера пользователь может изменять настройки параметра для данного элемента. При изменении настройки параметра, отличной от унаследованной глобальной настройки или настроек группы, эта настройка параметра будет выделена.

    Повторное нажатие Изменить [image] приводит к тому, что содержимое на экране снова отображается в режиме только для чтения.

    Если в «Редакторе параметров» были внесены изменения, перед выходом отобразится запрос об их сохранении или отмене.

Содержание

  • Установка значений параметров для отдельных компьютеров и групп

    Задать параметры можно для всех компьютеров (Глобальные параметры), группы компьютеров или отдельного компьютера.

  • Настройка параметров администрирующего образа

    Редактор параметров позволяет указать настройки для отдельных клиентов или групп, включая серийные номера, параметры установки клиента, компонентов для установки и расположение Toolbox.

  • Наследование настроек глобальных и групповых параметров

    Настройки параметров для элемента Глобальные настройки или групп наследуются по элементам нижнего уровня.

  • Настройка параметров для каждого компьютера

    Можно также изменить настройки, которые применены к определенным компьютерам, нажав правой кнопкой мыши на имя соответствующего компьютера.

На уровень выше Редактор параметров администрирующего образа
Добавление и удаление групп и компьютеров
Внедрение установок из Редактора параметров
Выход из Редактора параметров
Создание ярлыка Редактора параметров на рабочем столе
Внедрение администрирующего образа на клиентах через электронную почту


Установка значений параметров для отдельных компьютеров и групп

Задать параметры можно для всех компьютеров (Глобальные параметры), группы компьютеров или отдельного компьютера.

  1. В Редакторе параметров нажмите объект, который необходимо изменить (например, Глобальные настройки, группа, компьютер).
  2. Справа нажмите Изменить [image].
    Значок становится затемненным, а на экране появится более подробный список настроек параметров.
  3. Измените настройки для параметров в левой части окна, выбирая необходимые значения справа.
    Изменения параметров, влияющие на Глобальные настройки или параметры группы, будут выделены.
  4. Нажмите OK или Закрыть, чтобы сохранить изменения.
    Опция | Описание
    OK | Изменения будут сохранены, а Редактор параметров будет закрыт.
    Закрыть | На экран будет выдан запрос на сохранение изменений, после чего Редактор параметров будет закрыт.
На уровень выше Просмотр и изменение значений параметров
Настройка параметров администрирующего образа
Наследование настроек глобальных и групповых параметров
Настройка параметров для каждого компьютера


Настройка параметров администрирующего образа

Редактор параметров позволяет указать настройки для отдельных клиентов или групп, включая серийные номера, параметры установки клиента, компонентов для установки и расположение Toolbox.

Серийные номера

Введите серийные номера для установки продуктов на клиентских компьютерах.
Поскольку существует множество способов приобретения продуктов SOLIDWORKS, некоторые серийные номера могут принадлежать двум или нескольким продуктам. Например, серийный номер SOLIDWORKS дает возможность установить SOLIDWORKS Simulation без ввода отдельного серийного номера SOLIDWORKS Simulation. Кроме того, для некоторых продуктов серийный номер не требуется. В случае возникновения вопросов, касающихся серийных номеров, обратитесь к своему реселлеру.
При управлении лицензиями с помощью лицензий SolidNetWork:
  • В первом поле для серийного номера введите серийный номер SolidNetWork.
  • В поле Порт сервера SNL@сервер введите имя сервера SolidNetWork License Manager и порт следующим образом: nnnnn@имя_сервера. В качестве разделителей между различными записями используйте точку с запятой.

Для получения более подробной информации о лицензиях SolidNetWork см. раздел Установка обзора лицензий SolidNetWork.

Параметры установки на клиентском компьютере

Как вы хотите выполнить установку основных версий на клиентских компьютерах? Можно указать, каким образом клиентские установки будут взаимодействовать с уже существующей установкой основной версии:
  • Обновить существующий основной выпуск (если есть).

    Выберите этот параметр для замены предыдущего основного выпуска версии новым.

  • Создать новый основной выпуск.

    Выберите этот параметр, чтобы сохранить предыдущий основной выпуск и создать новую установку для нового основного выпуска. Чтобы указать местоположение установки новой версии, нажмите кнопку Обзор.
Удалить установку последней предыдущей версии перед установкой новой основной версии? Можно указать, отменять ли установку существующей прежней основной версии:
  • Не отменять установку.

    Выберите этот вариант, чтобы сохранить прежнюю установку основной версии.

  • Удалить последнюю версию.
  • Удалить все версии.
Применение настроек SOLIDWORKS При запуске программы можно указать файл настроек. Клиентские установки ссылаются на файл настроек. Файл настроек (*.sldsettings) должен быть сохранен в общем пути UNC, который виден для всех установок. Перед установкой SOLIDWORKS укажите путь к файлу *.sldsettings. Клиентские установки обнаруживают путь к файлу *.sldsettings во время установки.
Обеспечьте защиту файла *.sldsettings, указав разрешения Windows на доступ к записи только для определенных пользователей.

Чтобы создать или изменить файл *.sldsettings, нажмите Запустить администратор настроек. Инструмент Администратор параметров SOLIDWORKS позволяет определить, какие параметры системы SOLIDWORKS необходимо применить и при необходимости заблокировать для конечных пользователей. Также можно определить способ и время применения настроек к индивидуальным установкам. Файл *.sldsettings можно изменить в любое время с помощью запуска инструмента администратора настроек и перезаписи существующего файла.

Можно использовать другие файлы *.sldsettings для разных компьютеров или групп.

Путь к *.sldsettings задается во время установки. После развертывания не следует переименовывать или перемещать файл *.sldsettings.

Для запуска инструмента администратора настроек необходимо иметь существующую установку SOLIDWORKS [текущая основная версия].
Как вы хотите активировать установки клиента? Можно указать, следует ли после запуска установки продукта автоматически выполнять активацию продукта или пользователь должен вручную выполнять активацию продукта после установки.
  • Активировать автоматически после завершения каждой установки клиента.

    Выбор этого параметра указывает, что активация продукта выполняется автоматически. Введите адрес электронной почты, который будет указан при запуске активации на клиентском компьютере.

  • Не активировать автоматически.

    Выбор этого параметра указывает на отсутствие автоматической активации продуктов. Клиент производит активации продукта после установки.

Административные настройки

Во время каждой установки следует создать журнал диагностики. | Установка клиента может создать журнал диагностики для устранения проблем с установкой. Создание такого журнала может замедлить установку клиента. Файл журнала хранится в каталоге Administrative image directory}\x64\Logs\<имя_компьютера>.
Выполнить установку как другой пользователь.

Можно указать другого пользователя с правами администратора для запуска установки вместо вошедшего в систему пользователя. Этот параметр полезен, если отдельные пользователи не имеют прав административного доступа на локальный компьютер, что необходимо для установки продуктов SOLIDWORKS.

Альтернативный метод развертывания и установки доступен только тогда, когда клиенты не имеют административных прав. См. раздел Внедрение установок из Редактора параметров.
Программы для запуска до или после установки. | Можно указать, чтобы до установки клиента или после нее запускалась программа, указанная пользователем.
Вы хотите, чтобы клиенты участвовали в Программе отзывов клиентов SOLIDWORKS? | Можно указать, что компьютеры клиентов могут принимать участие в Программе отзывов клиентов SOLIDWORKS. Информация по быстродействию программы посылается корпорации SOLIDWORKS с целью улучшения продукта. Процесс является прозрачным и конфиденциальным. Дополнительные сведения см. на веб-сайте программы улучшения качества программного обеспечения.

Ограничения на параметры выполнения программ до и после установки

Эти параметры позволяют выполнять другие программы и сценарии установки на клиентских компьютерах до или после развертывания SOLIDWORKS, например, сценарий установки Microsoft Office.

Есть ограничение на использование этих параметров. Сбой возникает в случае использования любого из этих вариантов для развертывания программы или сценария установки, которые отображают пользовательский интерфейс, например сценарий, который открывает диалоговые окна. При автоматическом развертывании выполняющихся экземпляров SOLIDWORKS программу SOLIDWORKS не удастся установить на целевых компьютерах.

Чтобы использовать параметры Запустить программу до установки и Запустить программу после установки, выберите только те программы, которые могут быть установлены в автоматическом режиме.

Программное обеспечение для установки

Можно указать, какие компоненты продукта SOLIDWORKS следует установить.
  • Установленный флажок рядом с компонентом продукта означает, что компонент устанавливается во время установки клиента.
  • Отсутствие флажка означает, что компонент не будет установлен.
  • Если компонент содержит необязательные для установки подкомпоненты, рядом с ним отображается значок +. Для просмотра доступных подкомпонентов компонента нажмите на значок +.
  • Если компонент уже был развернут для просмотра подкомпонентов, рядом с ним отобразится значок -. Чтобы свернуть список подкомпонентов, нажмите на значок -.
Параметр Языки ограничивает иностранные языки, устанавливаемые для продуктов SOLIDWORKS. Это не повлияет на установки других продуктов. Например, eDrawings® устанавливает все языки.

Параметры Toolbox

Можно указать поддерживаемые стандарты и местоположение Toolbox по умолчанию для установок клиентов.

Обычно к общей установке Toolbox , как правило в сети, имеют доступ несколько пользователей (например, указывается путь UNC, общая папка или общий сетевой диск).

Если в указанном месте расположен более ранний основной выпуск Toolbox, во время установки клиента версия Toolbox будет обновлена до нового основного выпуска. После этого файлы не будут распознаваться в предыдущих основных выпусках SOLIDWORKS.
Если некоторые клиенты продолжают использовать более раннюю версию SOLIDWORKS, необходимо указать другое сетевое расположение Toolbox для клиентов, обновляющихся до более новой версии.

Для получения более подробной информации об администрировании SOLIDWORKS Toolbox см. раздел Toolbox в Справке SolidWorks.

Установка программного обеспечения Toolbox без установки данных Toolbox

Если в вашей среде используется PDM или общая папка для "Toolbox/Отверстие под крепеж", можно настроить установленные клиенты так, чтобы они не устанавливали и не обновляли данные Toolbox в этом расположении.

Это необходимо сделать в следующих случаях:
  • Если перед установкой SOLIDWORKS не был указан локальный вид SOLIDWORKS PDM.
  • Если файлы в этом расположении используются и могут блокировать завершение установки SOLIDWORKS.
  • Если это расположение недоступно и может блокировать завершение установки SOLIDWORKS.

Если указанные клиенты настроены так, чтобы данные Toolbox не устанавливались, программа SOLIDWORKS и настройки ссылаются на расположение "Toolbox/Отверстие под крепеж", но в дальнейшем необходимо установить данные в центральном расположении.

Чтобы установить программное обеспечение SOLIDWORKS без включения данных Toolbox/Отверстие под крепеж, выполните следующие действия.
  • При появлении запроса на установку/обновление файлов Toolbox для этого клиента выберите Нет, установить программное обеспечение Toolbox без включения файлов данных.

Как минимум один пользователь, как правило, администратор CAD, должен установить или обновить данные Toolbox или мастера "Отверстие под крепеж" в центральном расположении, иначе программа будет работать неправильно. Все пользователи в организации могут однократно установить программное обеспечение SOLIDWORKS вручную. Если Toolbox находится под управлением SOLIDWORKS PDM, выполните действия, описанные в разделе "Toolbox" в Руководстве администратора SOLIDWORKS PDM, чтобы установить или обновить данные Toolbox.

Параметры клиента SOLIDWORKS PDM

Можно выбрать следующие параметры для развертывания добавлений и клиентов SOLIDWORKS PDM:

  • Тип продукта PDM
  • Тип клиента PDM
  • Элементы
  • Вид хранилища

    Чтобы открыть Мастер настройки вида, необходимо запустить редактор параметров администрирующего образа на компьютере с установленным клиентом SOLIDWORKS PDM.

    Для создания вида хранилища на клиентском компьютере требуется файл Conisio View Setup (.cvs), который определяет параметры настройки вида хранилища на клиентском компьютере. Можно ссылаться на существующий файл .cvs или создать его в редакторе параметров администрирующего образа.

Дополнительные сведения о клиентах и добавлениях см. в разделе SOLIDWORKS PDM в Справке SOLIDWORKS.

Параметры электрики

Можно указать следующие параметры для компонентов администрирования SOLIDWORKS Electrical:
  • Путь к данным
  • Имя компьютера Collaborative Server и номер порта
  • Имя компьютера SQL Server и пароль

Для получения сведений о данных компонентах см. SOLIDWORKS Electrical .

На уровень выше Просмотр и изменение значений параметров
Установка значений параметров для отдельных компьютеров и групп
Наследование настроек глобальных и групповых параметров
Настройка параметров для каждого компьютера
Установка обзора лицензий SolidNetWork
Внедрение установок из Редактора параметров
SOLIDWORKS Electrical


Наследование настроек глобальных и групповых параметров

Настройки параметров для элемента Глобальные настройки или групп наследуются по элементам нижнего уровня.

Например:
  • Параметры, заданные в разделе Глобальные настройки, применяются ко всем группам и отдельным компьютерам.
  • Параметры, заданные для группы, применяются ко всем подгруппам и компьютерам, входящим в нее.

Можно изменить настройки параметров для группы, подгруппы или компьютера, чтобы переопределить настройки по умолчанию или унаследованные настройки. Если изменить наследуемый параметр или параметр по умолчанию, соответствующее значение выделяется.

Чтобы вернуть исходные унаследованные настройки параметра, нажмите правой кнопкой мыши на группу, подгруппу или компьютер, а затем выберите один из следующих параметров.
  • Вернуть глобальные настройки (для группы, подгруппы или компьютера, не состоящего в группе)
  • Вернуться к настройкам группы (для компьютера, который состоит в группе)
  • Вернуть настройки группы для участников (для всех участников группы одновременно)
На уровень выше Просмотр и изменение значений параметров
Установка значений параметров для отдельных компьютеров и групп
Настройка параметров администрирующего образа
Настройка параметров для каждого компьютера


Настройка параметров для каждого компьютера

Можно также изменить настройки, которые применены к определенным компьютерам, нажав правой кнопкой мыши на имя соответствующего компьютера.

В контекстном меню можно выполнять следующие задачи для каждого из компьютеров:
  • Переименовать
  • Удалить компьютер
  • Вернуть глобальные настройки
  • Редактировать заметки
  • Редактировать параметры

Благодаря параметрам редактирования можно изменять все параметры для соответствующего компьютера, например параметры установки на клиентском компьютере и административные параметры.

На уровень выше Просмотр и изменение значений параметров
Установка значений параметров для отдельных компьютеров и групп
Настройка параметров администрирующего образа
Наследование настроек глобальных и групповых параметров


Внедрение установок из Редактора параметров

Развертывание можно выполнять непосредственно из редактора параметров двумя способами — вручную или автоматически.

  • На странице развертывания вручную в редакторе параметров можно передать пользователям сообщения электронной почты с инструкциями по установке. Этот метод используется, когда у пользователей имеются права локальных администраторов на их клиентских машинах.
    В разделе Административные настройки можно назначить пользователям права администратора, выбрав параметр Запустить установку как другой пользователь.
  • На странице автоматического развертывания в редакторе параметров можно настроить автоматическую передачу задач установки на соответствующие компьютеры. Этот способ применяется в том случае, если пользователям систем не предоставлены полномочия на администрирование, необходимые для установки программного обеспечения. С помощью этого метода можно также выполнять пользовательскую установку.

Чтобы выполнить развертывание вручную или автоматически, необходимо сохранить каталог установки администрирующего образа в общий каталог Windows для обеспечения доступа по сети, например \\machine\shared_directory. Обеспечить доступность образа также можно, скопировав его в локальный каталог на каждом компьютере, например в каталог C:\SOLIDWORKS Admin\SOLIDWORKS 2026 SP0.

Содержание

  • Использование пути UNC для развертывания администрирующего образа

    Вместо сопоставления расположений сетевых дисков используйте путь UNC (\\machine_name\share_name) при указании сетевого расположения каталога установки администрирующего образа.

  • Использование процесса StartSWInstall.exe для развертывания администрирующего образа

  • Развертывание вручную

    Используйте этот метод, если у пользователей есть права, необходимые для установки на их системах.

  • Требования к автоматическому развертыванию

    Автоматическое развертывание особенно полезно для пользователей без административных привилегий, поскольку оно позволяет без помех устанавливать программное обеспечение.

  • Автоматическое развертывание

  • Тестирование конфигурации для автоматического развертывания

    На вкладке Автоматическое развертывание в редакторе параметров администрирующего образа доступна функция тестирования.

На уровень выше Редактор параметров администрирующего образа
Добавление и удаление групп и компьютеров
Просмотр и изменение значений параметров
Выход из Редактора параметров
Создание ярлыка Редактора параметров на рабочем столе
Внедрение администрирующего образа на клиентах через электронную почту


Использование пути UNC для развертывания администрирующего образа

Вместо сопоставления расположений сетевых дисков используйте путь UNC (\\machine_name\share_name) при указании сетевого расположения каталога установки администрирующего образа.

Сопоставленные сетевые диски не совместимы с методом принудительной и автоматической установки, а также с методом "Запуск от имени другого пользователя".

На уровень выше Внедрение установок из Редактора параметров


Использование процесса StartSWInstall.exe для развертывания администрирующего образа

Можно установить или удалить администрирующий образ на клиентах, выполнив команду admin_image_install_dir\ StartSWInstall.exe. Это метод установки SOLIDWORKS использует параметры, компьютеры и группы, определенные в Редакторе параметров администрирующего образа.

К команде StartSWInstall.exe можно добавить следующие параметры:
Переключатель | Описание
/установить | Служит для установки администрирующего образа на компьютеры клиента.
/удалить Служит для удаления программного обеспечения с компьютеров клиента, с двумя дополнительными переключателями:

/removedata

Доступно только для удаления. Служит для удаления файлов данных и папок SOLIDWORKS.

/removeregistry

Доступно только для удаления. Служит для удаления записей реестра SOLIDWORKS.
/showui | Служит для отображения окна хода выполнения для Менеджер установки SOLIDWORKS. В противном случае Менеджер установки SOLIDWORKS скрыт от пользователя.
/сейчас | Служит для незамедлительного запуска установки или удаления. 5-минутное диалоговое окно предупреждения не отображается.

Рекомендуется использовать процесс StartSWInstall.exe вместо StartSWInstall.hta в тех случаях, когда необходимо продолжить установку без взаимодействия с пользователем, не используя при этом автоматическое развертывание в Редакторе параметров администрирующего образа.

На уровень выше Внедрение установок из Редактора параметров


Развертывание вручную

Используйте этот метод, если у пользователей есть права, необходимые для установки на их системах.

Развертывание установок вручную с помощью электронной почты:

  1. Выберите элемент Развертывание в Редакторе параметров.
    На экране отобразятся сведения о возможности и состоянии установки для каждого компьютера.
  2. Нажмите Отправить сообщение.
  3. Укажите сетевой путь к каталогу установки администрирующего образа.
    Как правило, путь к каталогу установки администрирующего образа изначально отображается как путь к файлу Windows (например, C:\SOLIDWORKS Admin\SOLIDWORKS 2026 SP0). В диалоговом окне отобразится сообщение Данный путь не является сетевым.
    1. Для указания местоположения в сети для каталога установки администрирующего образа нажмите кнопку Обзор.
    2. Укажите путь к компьютеру, на котором установлен администрирующий образ, а затем укажите совместно используемый каталог Windows, указанный в качестве каталога установки администрирующего образа.
      Не переходите в другие папки в общедоступном каталоге администрирующего образа (например, в подкаталоги 64bit).
    3. Нажмите кнопку ОК.
      В диалоговом окне отобразится сообщение Данный путь является сетевым.
    Для владельцев компьютеров будет создано сообщение электронной почты с указаниями по выполнению установки из администрирующего образа с указанием сетевого местоположения файла StartSWInstall.hta в администрирующем образе.
  4. Отправьте это электронное сообщение пользователям, ответственным за установку SOLIDWORKS.

Для установки SOLIDWORKS из администрирующего образа пользователь может дважды щелкнуть ссылку на сетевое расположение файла StartSWInstall.hta, которая содержится в сообщении электронной почты.

В Редакторе параметров Статус установки показывает:
Ожидается | Пользователь еще не начал установку на данном компьютере.
Успешно | Пользователь успешно завершил установку на данном компьютере.
Сбой | Пользователь запустил установку на данном компьютере, однако установку не удалось выполнить.
Прочие возможные статусные сообщения: "установка успешно завершена", "удаление успешно завершено", "выполняется установка", "выполняется удаление", "требуется перезагрузка", "сбой установки", "сбой удаления".
В верхней части столбца Статус нажмите на зеленую стрелку, чтобы обновить и отобразить обновленную информацию.
На уровень выше Внедрение установок из Редактора параметров


Требования к автоматическому развертыванию

Автоматическое развертывание особенно полезно для пользователей без административных привилегий, поскольку оно позволяет без помех устанавливать программное обеспечение.

Для автоматического развертывания клиент и сервер должны принадлежать одному домену Active Directory. Такая конфигурация позволяет передавать задачи установки на целевые компьютеры, где они выполняются планировщиком задач Microsoft Task Scheduler, не требуя вмешательства пользователя.

При принудительной установке планировщик задач запускает задачу, которая запускает Менеджер установки SOLIDWORKS на клиентском компьютере с помощью указанных администратором учетных данных в Редакторе параметров. Планировщик задач работает под учетной записью LocalSystem компьютера. Эта учетная запись представлена в сети в виде принципа обеспечения безопасности компьютера. Принцип обеспечения безопасности компьютера должен иметь следующий доступ:
  • Доступ для чтения к папке администрирующего образа.
  • Доступ для чтения и записи в папку администрирующий образ\x64\logs.

В Active Directory при добавлении компьютера в группу Общей папки выберите Типы объектов и Компьютеры.

Кроме того, компьютер, обслуживающий администрирующий образ, и целевые клиентские компьютеры должны принадлежать одному домену Microsoft Active Directory.

На уровень выше Внедрение установок из Редактора параметров


Автоматическое развертывание

Для автоматического развертывания путем передачи задач установки в системы пользователей выполните следующие действия.

  1. В редакторе параметров перейдите на вкладку Автоматическое развертывание.
    На экране отобразятся сведения о возможности и состоянии установки для каждого компьютера.
  2. В столбце Развертывание выберите целевые клиентские компьютеры и группы.
    Перед запуском процесса развертывания необходимо выбрать в столбце Развертывание один или несколько компьютеров или групп.
  3. В разделе Время установки выберите Сейчас для безотлагательного развертывания или Позднее для планирования развертывания на конкретную дату и время.
  4. В окне Параметры клиента, выберите следующее.
    • Установка или обновление SOLIDWORKS 2026
    • Удаление SOLIDWORKS 2026
      При выборе удаления можно указать, следует ли удалять записи из реестра, а также файлы и папки данных наряду с файлами и данным программы.
  5. Выберите Перезагрузить компьютер автоматически, если вы хотите, чтобы один или несколько целевых компьютеров перезагружались (при необходимости) во время или после развертывания.
  6. Введите Учетные данные клиента одного или нескольких целевых компьютеров.
  7. Нажмите Развертывание для запуска процесса развертывания.
В Редакторе параметров в разделе Статус установки отображаются состояния:
Ожидается | На данном компьютере установка еще не завершена.
Успешно | На данном компьютере установка успешно не завершена.
Сбой | На данном компьютере произошел сбой установки.

Прочие возможные статусные сообщения: "установка успешно завершена", "удаление успешно завершено", "планирование", "подключение", "выполняется установка", "выполняется удаление", "требуется перезагрузка", "установка запланирована", "удаление запланировано", "сбой установки", "сбой удаления", "сбой подключения", "сбой планирования".

На уровень выше Внедрение установок из Редактора параметров


Тестирование конфигурации для автоматического развертывания

На вкладке Автоматическое развертывание в редакторе параметров администрирующего образа доступна функция тестирования.

Можно запустить пробный процесс установки, в котором будут участвовать системы, используемые для развертывания, например:
  • Подключение к целевому компьютеру.
  • Создание задачи установки на этом компьютере.
  • Выполнение задачи установки на этом компьютере.
  • Обновление состояния и журналов в администрирующем образе.
  • Обнаружение программ, которые должны быть запущены до или после установки.

В ходе тестирования проверяются пути к файлам и разрешения. После успешного завершения установки отображается соответствующее сообщение. Функция тестирования не устанавливает программное обеспечение и не вносит изменения в реестр на целевом компьютере. Если происходит сбой системы на одном из целевых компьютеров, функция тестирования показывает, в какой системе возникли проблемы.

Всплывающие подсказки содержат дополнительную информацию о сбоях. Результаты можно экспортировать в электронную таблицу .xml или .csv. Эта таблица позволяет просматривать информацию о различных сбоях, и ее можно отправить другим специалистам службы поддержки.

Чтобы протестировать конфигурацию для автоматического развертывания, выполните следующие действия.

  1. С помощью Менеджера установки создайте Администрирующий образ.
  2. Откройте Редактор параметров администрирующего образа.

    Для этого выберите соответствующую функцию в менеджере установки, когда он завершить создание администрирующего образа, или дважды нажмите на файл sldAdminOptionEditor.exe в папке администрирующего образа.

  3. На вкладке Настройка добавьте один или несколько компьютеров.
  4. Нажмите Автоматическое развертывание:
    1. Введите Имя пользователя и Пароль администратора домена.
    2. Выберите один или несколько компьютеров для тестирования.
    3. Нажмите Проверить.
  5. В открывшемся окне "Проверка установки" нажмите Запуск проверки.
  6. Подождите несколько минут до завершения теста или нажмите Отменить проверку в любое время.
  7. Проверьте информацию и устраните проблемы конфигурации.
На уровень выше Внедрение установок из Редактора параметров


Выход из Редактора параметров

Для закрытия редактора параметров можно нажать кнопку "OK" или "Закрыть".

  • Чтобы применить изменения настроек параметров и закрыть редактор параметров, нажмите кнопку OK.
  • Нажмите кнопку Закрыть в приложении Windows, чтобы закрыть редактор параметров. Если программное обеспечение обнаружит несохраненные изменения, появится запрос на сохранение.
На уровень выше Редактор параметров администрирующего образа
Добавление и удаление групп и компьютеров
Просмотр и изменение значений параметров
Внедрение установок из Редактора параметров
Создание ярлыка Редактора параметров на рабочем столе
Внедрение администрирующего образа на клиентах через электронную почту


Создание ярлыка Редактора параметров на рабочем столе

Можно создать ярлык Редактора параметров на рабочем столе Windows для определенного администрирующего образа внутри приложения.

  1. Запустите Редактор параметров.
    Например, в Проводнике файлов перейдите к каталогу для установки администрирующего образа и дважды щелкните файл sldAdminOptionEditor.exe.
  2. Выберите Создать ярлык на Рабочем столе для данного Редактора параметров.
    На рабочем столе Windows отобразится ярлык Редактора параметров для администрирующего образа.
На уровень выше Редактор параметров администрирующего образа
Добавление и удаление групп и компьютеров
Просмотр и изменение значений параметров
Внедрение установок из Редактора параметров
Выход из Редактора параметров
Внедрение администрирующего образа на клиентах через электронную почту


Внедрение администрирующего образа на клиентах через электронную почту

Когда будет создан общий каталог администрирующего образа, можно по электронной почте оповестить об этом клиентов.

Настройте каталог администрирующего образа так, чтобы к компьютеру, на котором хранится этот каталог, имели доступ все другие компьютеры (например, по пути UNC).

Всем клиентам можно отправить электронные сообщения со ссылкой на каталог каталог_установки_администрирующего_образа\StartSWInstall.hta. Клиенты могут перейти по этой ссылке и выбрать параметр Установить продукты SOLIDWORKS сейчас, чтобы начать установку с использованием администрирующего образа.

При обновлении администрирующего образа до новой версии SOLIDWORKS можно настроить его местоположение и общие свойства так, чтобы все клиенты, установленные ранее с помощью этого образа, были обновлены автоматически. Для получения дополнительной информации см. раздел Обновление клиентов с помощью администрирующих образов.
На уровень выше Редактор параметров администрирующего образа
Добавление и удаление групп и компьютеров
Просмотр и изменение значений параметров
Внедрение установок из Редактора параметров
Выход из Редактора параметров
Создание ярлыка Редактора параметров на рабочем столе


Инструмент "Администратор параметров"

Инструмент "Администратор параметров" можно использовать для указания параметров системы, которые применяются при развертывании и обновлении программы SOLIDWORKS, а также для предотвращения изменения этих параметров пользователями. При развертывании параметров этот инструмент заменяет Мастер настроек SOLIDWORKS, даже если мастер все еще доступен для копирования настроек.

Существует три действия для использования инструмента "Администратор параметров" с редактором параметров администрирующего образа:
  1. Создайте администрирующий образ, чтобы получить доступ к данному инструменту.
  2. Используйте инструмент "Администратор параметров" для создания файла *.sldsettings, который содержит выбранные параметры SOLIDWORKS.
  3. Включите файл *.sldsettings в установки SOLIDWORKS.
Если используется дополнение 3DEXPERIENCE, можно также развернуть файл *.sldsettings за пределами администрирующего образа. Преимущество использования этого метода заключается в том, что настройки автоматически развертываются при входе в систему.
  1. Для доступа к инструменту "Администратор параметров" выполните действия, описанные в разделе Доступ к инструменту "Администратор параметров".
  2. Следуйте инструкциям, чтобы применить и заблокировать настройки.
  3. В 3DEXPERIENCE Compass разверните раздел Мои роли и нажмите на приложение Platform Manager. Перейдите в раздел Содержимое > Центр конфигурации пространств совместной работы > Совместная работа CAD > SOLIDWORKS > Настройки > Ресурсы > Настройки CAD.
  4. В разделе Настройки CAD можно просматривать, загружать и скачивать файл *.sldsettings.

Содержание

  • Доступ к инструменту "Администратор параметров"

    Для доступа к инструменту "Администратор параметров" необходимо сначала создать администрирующий образ.

  • Использование инструмента "Администратор параметров"

  • Применение и блокировка параметров

  • Завершение настройки параметров

  • Добавление файла .sldsettings в установки SOLIDWORKS

На уровень выше Использование администрирующих образов


Доступ к инструменту "Администратор параметров"

Для доступа к инструменту "Администратор параметров" необходимо сначала создать администрирующий образ.

Инструмент администратора параметров можно запустить из администрирующего образа.

Чтобы получить доступ к инструменту "Администратор параметров", выполните следующие действия.

  1. Запустите файл sldAdminOptionEditor.exe в папке администрирующего образа.
  2. В редакторе параметров администрирующего образа нажмите Изменить [image].
  3. В разделе Параметры установки клиента выполните следующие действия:
    1. Нажмите Использовать экспорт файла параметров из администратора параметров SOLIDWORKS.
    2. Нажмите Запустить администратор параметров.
      Для доступа к параметру Запустить администратор настроек на компьютере, на котором запускается файл sldAdminOptionEditor.exe, должна быть установлена программа SOLIDWORKS <версия>.
На уровень выше Инструмент "Администратор параметров"


Использование инструмента "Администратор параметров"

Чтобы использовать инструмент Администратор параметров, выполните указанные ниже действия.

  1. На вкладке приветствия выберите следующие параметры:
    • Набор параметров по умолчанию — запуск этой версии SOLIDWORKS.
    • Импорт параметров SOLIDWORKS 2026 с этого компьютера.
    • Перейти к существующему файлу sldreg.
    • Перейти к существующему файлу .sldsettings.
    Файл *.sldreg создается с помощью Мастера настроек SOLIDWORKS, а файл *.sldsettings — с помощью инструмента "Администратор параметров".
  2. Щелкните Далее.
На уровень выше Инструмент "Администратор параметров"


Применение и блокировка параметров

На вкладке Параметры системы два столбца флажков позволяют выбрать параметры для применения, а также заблокировать примененные параметры, чтобы пользователи не могли их изменить.

При получении пользователем доступа к диалоговому окну Параметры системы в ПО SOLIDWORKS заблокированные параметры отображаются недоступными со значком блокировки [image]. Тем не менее, можно создать пароль, который позволяет пользователям разблокировать параметры. Когда пользователь наводит курсор на заблокированный параметр, отображается подсказка с именем и адресом эл. почты, чтобы пользователи могли обратиться к вам и запросить пароль.

Порядок применения и блокировки параметров

  1. На вкладке Параметры системы выполните указанные ниже действия.
    1. Для применения параметра выберите его и установите соответствующий флажок в столбце Применить.
    2. Для блокировки параметра выберите его и установите соответствующие флажки в обоих столбцах Применить и Заблокировать.
      При получении пользователями доступа к вкладке Параметры системы параметры отображаются со значком замка [image].
  2. В зависимости от параметра может потребоваться указать дополнительные параметры.
  3. Кроме того, для пользователей можно заблокировать закрытые сообщения, применив элементы управления для элемента Сообщения/Ошибки/Предупреждения.
    1. Нажмите Сообщения/Ошибки/Предупреждения.
    2. Установите флажок Применить и дополнительно установите флажок Заблокировать для сообщений, которыми хотите управлять.
    3. Установите для сообщения значение Показывать или Не показывать.

      При выборе значения Показывать сообщение удаляется из списка закрытых сообщений пользователя и показывается пользователю в соответствующее время. При выборе значения Не показывать сообщение автоматически добавляется в список закрытых сообщений пользователя и не отображается при работе пользователя с моделью.

      В данной таблице описано поведение в программе.
      Применить | Заблокировать | Показать | Не показывать | Поведение
      X | X | Принудительное отображение сообщения.
      X | X | Отключает сообщение и добавляет сообщение в список закрытых сообщений.
      X | X | X | Принудительное отображение сообщения и отключение параметра Не показывать в окне сообщения.
      X | X | X | Отключает сообщение и запрещает пользователю включать его в меню Инструменты > Параметры > Сообщения/ошибки/предупреждения.
  4. На вкладке Параметры системы нажмите Далее.
На уровень выше Инструмент "Администратор параметров"


Завершение настройки параметров

Чтобы завершить настройку параметров, выполните указанные ниже действия.

  1. На вкладке Готово выберите вариант применения параметров системы:
    • при первом запуске программы пользователем;
    • каждый раз при запуске программы;
    • а также необходимость одновременного применения настроек.
  2. Можно выбрать Применение параметров блокировки, когда пользователи вне сети и Разрешение API перезаписывать заблокированные параметры.
  3. Для заблокированных системных параметров необходимо указать имя и адрес электронной почты. SOLIDWORKS отображает эту информацию в виде подсказки при наведении курсора на заблокированный параметр.
  4. Также можно разрешить пользователям перезаписывать заблокированные параметры. В данном случае необходимо указать Пароль, который можно предоставить пользователям.
  5. Нажмите Сохранить, чтобы создать файл *.sldsettings для развертывания.
На уровень выше Инструмент "Администратор параметров"


Добавление файла .sldsettings в установки SOLIDWORKS

Чтобы добавить файл *.sldsettings в установку, выполните следующие действия.

  1. Дважды нажмите sldAdminOptionEditor.exe в папке администрирующего образа.
  2. В редакторе параметров администрирующего образа нажмите Изменить.
  3. В разделе Параметры установки клиента выполните следующие действия:
    1. Нажмите Использовать экспорт файла параметров из администратора параметров SOLIDWORKS.
    2. Нажмите Изменить путь и перейдите к файлу *.sldsettings.
    Можно создать и применить разные файлы *.sldsettings к разным группам или компьютерам.
  4. Выполните развертывание и установку ПО SOLIDWORKS.

После развертывания можно повторить шаг 2, чтобы изменить существующий файл *.sldsettings в любое время. Программа SOLIDWORKS считывает измененный файл *.sldsettings при следующем запуске.

На уровень выше Инструмент "Администратор параметров"


Внедрение с использованием командной строки

Можно автоматически внедрить администрирующий образ с использованием командной строки или пакетного файла (автоматическая установка).

Развертывание административного образа с помощью командной строки для клиентов SOLIDWORKS PDM см. в руководстве по установке SOLIDWORKS PDM.

Содержание

  • Подготовка клиентов для установки командной строки из администрирующего образа

    После создания администрирующего образа и до оповещения клиентов необходимо установить компоненты Microsoft Windows, которые не могут быть установлены с помощью администрирующих образов, созданных с использованием командной строки или Microsoft Active Directory.

  • Установка администрирующего образа с использованием командной строки

    С помощью командной строки можно выполнить внедрение установок с использованием администрирующего образа.

  • Свойства командной строки

    К свойствам командной строки, описанным в данном разделе, относятся свойства элемента, глобальные свойства, свойства продукта и условные обозначения расположения, используемые в Windows.

  • Развертывание администрирующего образа с помощью Microsoft Active Directory

    Развертывание с помощью Microsoft Active Directory поддерживается при внедрении основных продуктов SOLIDWORKS на клиентах.

На уровень выше Множественные установки
Внедрение на нескольких клиентах
Использование администрирующих образов
Администрация множественных установок


Подготовка клиентов для установки командной строки из администрирующего образа

После создания администрирующего образа и до оповещения клиентов необходимо установить компоненты Microsoft Windows, которые не могут быть установлены с помощью администрирующих образов, созданных с использованием командной строки или Microsoft Active Directory.

Установка данных компонентов Windows вручную требуется только в том случае, если установка выполняется из администрирующего образа с помощью командной строки или через Microsoft Active Directory. Если для создания и установки администрирующего образа использовался Менеджер установки SOLIDWORKS, это значит, что данные компоненты Windows установлены автоматически.
Здесь представлен перечень файлов, которые требуется использовать в SOLIDWORKS при работе с компонентами Windows:
Набор средств для оценки производительности Windows | Включает расширенные журналы в SOLIDWORKS Rx.
Распространяемый пакет Visual C++ 2022 | Содержит компоненты времени выполнения для Microsoft Visual C++. Необходимо установить версию 2022.
Visual Basic для приложений 7.1 | Поддерживает макросы Visual Basic.
Visual Studio Tools for Application 2022 | Дополнительно. Содержит набор инструментов, поддерживающих приложения Visual Studio 2022 (VSTA17).
.NET Framework 4.8.1 | Содержит общие для языка программирования компоненты времени выполнения и компоненты .NET Framework, необходимые для работы приложений в .NET Framework 4.8.1.
SWCEF | Chromium Embedded Framework (CEF) используется для отображения контента 3DEXPERIENCE platform.
Microsoft Edge Web View2 | Требуется для отображения веб-содержимого.
SOLIDWORKS Login Manager | Позволяет выполнять вход в 3DEXPERIENCE Marketplace и другие приложения 3DEXPERIENCE.
Распространяемый пакет Visual С++ и .NET Framework 4.8.1 требуются для всех продуктов SOLIDWORKS, не только для базового продукта SOLIDWORKS.

Эти компоненты должны быть включены в подкаталоги каталога администрирующего образа.

Следующие таблицы определяют требуемые для каждой из поддерживаемых операционных систем файлы.
Операционная система: Windows Server 2022, 64-разрядная версия
Набор средств для оценки производительности Windows: | WPTx64-x86_en-us.msi
Распространяемый пакет Visual C++ 2022: | vc_redist.x86.exe vc_redist.x64.exe Необходимо установить оба.
Visual Basic 7.1 | vba71.msi and vba71_1033.msi Плюс дополнительный языковой пакет.
.NET Framework 4.8.1: | ndp481-x86-x64-allos-enu.exe
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe
Операционная система: Windows 11, 64-разрядная версия
Набор средств для оценки производительности Windows: | WPTx64-x86_en-us.msi
Распространяемый пакет Visual C++ 2022: | vc_redist.x86.exe vc_redist.x64.exe Необходимо установить оба.
Visual Basic 7.1 | vba71.msi and vba71_1033.msi Плюс дополнительный языковой пакет.
.NET Framework 4.8.1: | .NET 4.8.1 — часть операционной системы, которая соответствует данным требованиям.
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe

Содержание

  • Установка необходимых компонентов Windows с использованием командной строки в 64-разрядных операционных системах

    Чтобы установить администрирующий образ с помощью командной строки в 64-разрядных версиях операционных систем Windows, можно выполнить следующие действия для установки необходимых компонентов Windows.

На уровень выше Внедрение с использованием командной строки
Установка администрирующего образа с использованием командной строки
Свойства командной строки
Развертывание администрирующего образа с помощью Microsoft Active Directory


Установка необходимых компонентов Windows с использованием командной строки в 64-разрядных операционных системах

Чтобы установить администрирующий образ с помощью командной строки в 64-разрядных версиях операционных систем Windows, можно выполнить следующие действия для установки необходимых компонентов Windows.

Чтобы установить несколько компонентов за одну операцию, создайте пакетный файл с командами, описанными в следующих процедурах, и используйте его для установки компонентов на клиентские компьютеры.

  1. Убедитесь, что на целевом компьютере объем свободного дискового пространства составляет минимум 620 МБ и имеется верный каталог TEMP.
  2. Установите распространяемые пакеты Visual C++ RELEASE. Необходимо установить обе версии каждого пакета: 32-разрядную и 64-разрядную.
    Установите пакет для RELEASE = 2022.

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vc_redist.x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vc_redist.x86.exe /Q

  3. Установите Microsoft .NET Framework 4.8.1:
    administrative_image_directory\.Net_Framework_4.8.1\ndp481-x86-x64-allos-enu.exe
  4. Установите Visual Studio Tools for Applications 2022:
    administrative_image_directory\Microsoft_VSTA17\vsta_setup.exe
  5. Установите Visual Basic 7.1
    administrative_image_directory\Microsoft_VBA\vba71.msi и administrative_image_directory\Microsoft_VBA\vba71_1033.msi требуются для всех языков.
    Только 64-разрядная версия этого пакета должна быть установлена.

    Кроме этого, установите следующий пакет для необходимого языка:

    vba71_1028.msi | Китайский
    vba71_1031.msi | Немецкий
    vba71_1036.msi | Французский
    vba71_1040.msi | Итальянский
    vba71_1041.msi | Японский
    vba71_1042.msi | Корейский
    vba71_1046.msi | Португальский (Бразилия)
    vba71_2052.msi | Китайский (упрощенный)
    vba71_3082.msi | Испанский
    Для английского, чешского, польского, русского и турецкого языков дополнительные языковые пакеты не требуются.
  6. Установите SOLIDWORKS Chromium Embedded Framework (SWCEF):
    administrative_image_directory\swcef\CEF for SOLIDWORKS Applications.msi.
  7. Установите Диспетчер входа SOLIDWORKS Login Manager:
    administrative_image_directory\swloginmgr\SOLIDWORKS Login Manager.msi.
На уровень выше Подготовка клиентов для установки командной строки из администрирующего образа


Установка администрирующего образа с использованием командной строки

С помощью командной строки можно выполнить внедрение установок с использованием администрирующего образа.

Чтобы провести автоматическую установку:

  1. Откройте окно командной строки (в Windows нажмите Пуск > Выполнить).
  2. Введите команду msiexec.exe с автоматическими ключами /i и /qb и укажите свойства для параметров, не являющихся значениями по умолчанию.

    msiexec /i "administrative_image_directory\64bit\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

Свойства командной строки для установки отдельных компонентов включают в себя:
  • Свойства элементов командной строки
  • Глобальные свойства командной строки
  • eDrawings Свойства командной строки
  • Свойства командной строки SOLIDWORKS Flow Simulation

Используйте следующие примеры в качестве шаблона для автоматической установки.

Клиент SOLIDWORKS

  • SOLIDWORKS основной продукт (на английском языке)
  • Дополнительное приложение Toolbox
  • Участие в Программе отзывов клиентов
  • Поддержка французского языка

SOLIDWORKS:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=4 ADDLOCAL=SolidWorks, SolidWorksToolbox TOOLBOXFOLDER="toolbox path for example C:\SolidWorks Data\" /qb

Установка компонента поддержки французского языка SOLIDWORKS должна быть проведена отдельно:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS French\french.msi" /qb

Не следует указывать аргументы командной строки вместе с командами установки компонента языковой поддержки SOLIDWORKS.

Клиент eDrawings

  • Все элементы

msiexec /i
            "administrative_image_directory\64bit\eDrawings\eDrawings.msi"
          INSTALLDIR="C:\Program Files\your_folder"
            SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst
          ADDLOCAL=All /qb

SOLIDWORKS Electrical

Из-за технической сложности установки SOLIDWORKS Electrical с Microsoft SQL Server примеры командной строки для SOLIDWORKS Electrical были исключены из документации.

SOLIDWORKS Visualize и Visualize Boost

Для SOLIDWORKS Visualize:

msiexec. /i “administrative_image_directory\64bit\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

Для SOLIDWORKS Visualize Boost:

msiexec /i “administrative_image_directory\64bit\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

На уровень выше Внедрение с использованием командной строки
Подготовка клиентов для установки командной строки из администрирующего образа
Свойства командной строки
Развертывание администрирующего образа с помощью Microsoft Active Directory


Свойства командной строки

К свойствам командной строки, описанным в данном разделе, относятся свойства элемента, глобальные свойства, свойства продукта и условные обозначения расположения, используемые в Windows.

Содержание

  • Свойства элементов командной строки

    Установка SOLIDWORKS поддерживает следующие свойства ADDLOCAL для развертывания с использованием командной строки.

  • Глобальные свойства командной строки

    Если не указано иное, каждое свойство определено либо для административной, либо для индивидуальной установки. Серийные номера можно передавать как в административную, так и в индивидуальную установку с помощью глобальных свойств.

  • eDrawings Свойства командной строки

    Данные свойства командной строки присущи только программе eDrawings ®.

  • Свойства командной строки SOLIDWORKS Composer/Composer Player

    Перечисленные здесь свойства командной строки относятся только к SOLIDWORKS Composer и SOLIDWORKS Composer Player.

  • Свойства командной строки SOLIDWORKS Flow Simulation

    Перечисленные здесь свойства командной строки присущи только SOLIDWORKS Flow Simulation.

  • Свойства командной строки SOLIDWORKS Inspection

    Эти свойства командной строки относятся только к только программе SOLIDWORKS Inspection.

  • Свойства командной строки SOLIDWORKS Visualize

    Эти свойства командной строки относятся только к программе SOLIDWORKS Visualize.

  • Месторасположение файла MSI для администрирующих образов

    Файлы .msi компонентов продуктов, позволяющие создавать администрирующие образы при помощи командной строки, хранятся в указанных каталогах на носителях SOLIDWORKS.

На уровень выше Внедрение с использованием командной строки
Подготовка клиентов для установки командной строки из администрирующего образа
Установка администрирующего образа с использованием командной строки
Развертывание администрирующего образа с помощью Microsoft Active Directory


Свойства элементов командной строки

Установка SOLIDWORKS поддерживает следующие свойства ADDLOCAL для развертывания с использованием командной строки.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • ScanTo3D
  • Simulation
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
При указании свойств для установки с использованием командной строки следует иметь в виду, что:
  • SOLIDWORKS не поддерживает установку продукта с использованием параметра ADDSOURCE.
  • Свойства зависят от регистра, не должны содержать пробелы или дефисы и должны быть разделены запятыми.
На уровень выше Свойства командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


Глобальные свойства командной строки

Если не указано иное, каждое свойство определено либо для административной, либо для индивидуальной установки. Серийные номера можно передавать как в административную, так и в индивидуальную установку с помощью глобальных свойств.

Свойство | Описание
ENABLEPERFORMANCE Указывает, должно ли приложение автоматически посылать данные по быстродействию корпорации SOLIDWORKS.

1

Отправлять данные об эффективности программы.

0

Не отправлять.
INSTALLDIR | Папка установки SOLIDWORKS.
MBDSERIALNUMBER | Серийный номер для продукта с определением на основе модели SOLIDWORKS.
MOTIONSERIALNUMBER | Серийный номер для продукта SOLIDWORKS Motion
OFFICEOPTION Указывает пакет для установки:
0 | SOLIDWORKS Standard
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
4 | SOLIDWORKS Ultimate
REINSTALL Укажите Укажите , чтобы обновить все установленные компоненты.
Данное свойство требуется указывать только при обновлении выпуска Service Pack в рамках одного и того же основного выпуска (например, при обновлении установленного пакета SOLIDWORKS 2026 SP01 до SOLIDWORKS 2026 SP02).
REINSTALLMODE Параметры переустановки пакета установки Microsoft Installer.

Например, при обновлении установки, в случае замены одного выпуска Service Pack на другой в рамках одного и того же основного выпуска, требуется указать REINSTALLMODE=vomus.

Подробнее о параметрах REINSTALLMODE см. в документации по установщику Windows на сайте www.microsoft.com.

Данное свойство требуется указывать только при обновлении выпуска Service Pack в рамках одного и того же основного выпуска (например, при обновлении установленного пакета SOLIDWORKS 2026 SP01 до SOLIDWORKS 2026 SP02). Не следует указывать данное свойство при первой установке нового основного выпуска SOLIDWORKS.
SERVERLIST Список серверов SolidNetWork.
Список серверов SolidNetWork представляет собой разделенный список строк, каждая из которых ссылается на номер порта сервера и имеет следующий формат:
  • Система координат (разделенная запятыми) =xxxxx@имя_сервера1,yyyyy@имя_сервера2,zzzzz@имя_сервера3.
  • Не система координат (разделенная точками с запятой) =xxxxx@имя_сервера1;yyyyy@имя_сервера2;zzzzz@имя_сервера3.
X и Y являются однозначными числами. После последнего названия сервера в списке разделение не ставится.
SIMULATIONSERIALNUMBER | Серийный номер для продукта SOLIDWORKS Simulation
SOLIDWORKSSERIALNUMBER | Серийный номер продукта SOLIDWORKS, который включает все дополнения.
SWMIGRATE Указывает версию SOLIDWORKS для обновления так, как она будет отображаться в списке диалогового окна Выбор установки SOLIDWORKS. Например:

SWMIGRATE="SOLIDWORKS 2026 x64 Edition SP01"

Данное свойство указывается только при установке нового основного выпуска в систему, где уже установлен предыдущий основной выпуск SOLIDWORKS. Не следует указывать это свойство при замене одного выпуска Service Pack на другой в рамках одного и того же основного выпуска.
TOOLBOXFOLDER Папка установки файлов SOLIDWORKS Toolbox.

Например: TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

Если в вашей среде используется PDM или общая папка "Toolbox/Отверстие под крепеж", можно настроить установленные клиенты так, чтобы они не устанавливали и не обновляли данные Toolbox в этом расположении с помощью свойства NOTTOOLBOXSETUP. Указать:

0 | Установка файлов Toolbox.
1 | Без установки файлов Toolbox.
TRANSFORMS Содержит зависящие от языка элементы в следующем формате:
TRANSFORMS номер.mst
  • Китайский (1028)
  • Китайский (упрощенный) (2052)
  • Чешский (1029)
  • Английский (1033)
  • Французский (1036)
  • Немецкий (1031)
  • Итальянский (1040)
  • Японский (1041)
  • Корейский (1042)
  • Польский (1045)
  • Португальский (Бразилия) (1046)
  • Русский (1049)
  • Испанский (1034)
  • Турецкий (1055)
UPGRADESWINSTALL
Укажите, следует ли обновлять существующую версию SOLIDWORKS до новейшей версии.
0 | Новая установка, не обновлять.
1 | Обновить
Данное свойство указывается только при установке нового основного выпуска в систему, где уже установлен предыдущий основной выпуск SOLIDWORKS. Не следует указывать это свойство при замене одной версии пакета обновления на другую в рамках одного и того же основного выпуска SOLIDWORKS.
На уровень выше Свойства командной строки
Свойства элементов командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


eDrawings Свойства командной строки

Данные свойства командной строки присущи только программе eDrawings ®.

Свойство | Описание
ADDLOCAL Указывает, какую часть приложения eDrawings требуется установить.
All является рекомендуемым параметром.
Синтаксис командной строки | Элемент
All | Установка всех элементов. Приложение eDrawings осуществляет поиск установленных приложений опубликования SOLIDWORKS и AutoCAD, чтобы проверить установку.
CALS | Просмотр файлов CAL в eDrawings Viewer.
Inventor | Создайте файлы eDrawings из приложения Autodesk Inventor.
eDrawingsViewer | Просмотр файлов eDrawings и других файлов.
ProE | Просмотр файлов ProE в eDrawings Viewer.
DXFDWGTranslator | Просмотр файлов DXF/DWG в программе eDrawings Viewer.
Shortcuts | Установка ярлыка на Рабочем столе.
XML3D | Просмотр файлов 3DXML в eDrawings Viewer.
INSTALLDIR | Указывает папку установки для eDrawings
SNLSERVER Введите порт@имясервера для сервера SolidNetWork License. Используйте точку с запятой для разделения нескольких комбинаций порт@имясервера .

Имя сервера порта для SNLSERVER и SERVERLIST требуется только для настройки сервера SOLIDWORKS SNL.

Список серверов SolidNetWork представляет собой разделенный список строк, каждая из которых ссылается на номер порта сервера и имеет следующий формат:
  • Система координат (с разделителями-запятыми)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

  • Не система координат (разделенная точками с запятой)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

X и Y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


Свойства командной строки SOLIDWORKS Composer/Composer Player

Перечисленные здесь свойства командной строки относятся только к SOLIDWORKS Composer и SOLIDWORKS Composer Player.

Для SOLIDWORKS Composer:

Свойство | Описание
ACTIVSERIALNUMBER | Серийный номер SOLIDWORKS Composer.
ACTIVSERIALNUMBERPLAYERPRO | Дополнительно. Серийный номер SOLIDWORKS Composer Player Pro.
ADDLOCAL Дополнительно. При установке полноценного приложения не требуется указывать свойство ADDLOCAL.
Для выборочной установки используйте ADDLOCAL со следующими необходимыми компонентами:
  • Лицензирование
  • CLOSA
  • InterOps
  • LicenseSupportFiles
  • Подключаемые модули
  • SWComposerCommon
  • SWPlayer
Можно также использовать дополнительную функцию Sync3Dvia.
INSTALLDIR | Указывает папку для установки SOLIDWORKS Composer.

Для SOLIDWORKS Composer Player:

Свойство | Описание
ACTIVSERIALNUMBERPLAYERPRO | Дополнительно. Серийный номер SOLIDWORKS Composer Player Pro.
INSTALLDIR | Указывает папку для установки SOLIDWORKS Composer Player.
На компьютерах, на которых не установлена программа SOLIDWORKS, необходимо использовать SOLIDWORKS Translator для импорта файлов SOLIDWORKS в SOLIDWORKS Composer. Чтобы развернуть SOLIDWORKS Translator, необходимо использовать Менеджер установки SOLIDWORKS. Командную строку использовать нельзя.
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


Свойства командной строки SOLIDWORKS Flow Simulation

Перечисленные здесь свойства командной строки присущи только SOLIDWORKS Flow Simulation.

Свойство | Описание
ACTIVSERIALNUMBER Отдельный серийный номер SOLIDWORKS Flow Simulation.

(индивидуальные установки и установки клиента с помощью администрирующего образа)
CWUPGRADEINSTALL Обновление существующей версии определенного программного обеспечения SOLIDWORKS Flow Simulation.
1 | Обновление
2 | Новая установка; установка в новый каталог

(индивидуальные установки и установки клиента с помощью администрирующего образа)
INSTALLDIR Задание установки определенного программного обеспечения SOLIDWORKS Flow Simulation.

(только индивидуальные установки)
SERVERLIST | Список строк, разделенных точкой с запятой, каждая из которых указывает на номер порта формата: xxxxx@имя_сервера1; yyyyy@имя_сервера2;& где x и y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.
SOLIDWORKSPATH Указывает папку, в которой установлена программа SOLIDWORKS.

(индивидуальные установки и установки клиента с помощью администрирующего образа)
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


Свойства командной строки SOLIDWORKS Inspection

Эти свойства командной строки относятся только к только программе SOLIDWORKS Inspection.

Свойство | Описание
ACTIVSERIALNUMBER | Серийный номер SOLIDWORKS Inspection. (индивидуальные установки и установки клиента с помощью администрирующего образа)
INSTALLDIR | Указывает папку для установки программного обеспечения SOLIDWORKS Inspection. (только индивидуальные установки)
SERVERLIST | Список строк, разделенных точкой с запятой, каждая из которых указывает на номер порта формата: xxxxx@имя_сервера1; yyyyy@имя_сервера2;& где x и y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


Свойства командной строки SOLIDWORKS Visualize

Эти свойства командной строки относятся только к программе SOLIDWORKS Visualize.

Свойство | Описание
ACTIVSERIALNUMBER | Наличие серийного номера SOLIDWORKS Visualize. (индивидуальные установки и установки клиента с помощью администрирующего образа)
INSTALLDIR | Указывает папку для установки программного обеспечения SOLIDWORKS Visualize. (только индивидуальные установки)
SERVERLIST | Список строк, разделенных точкой с запятой, каждая из которых указывает на номер порта формата: xxxxx@имя_сервера1; yyyyy@имя_сервера2;& где x и y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Месторасположение файла MSI для администрирующих образов


Месторасположение файла MSI для администрирующих образов

Файлы .msi компонентов продуктов, позволяющие создавать администрирующие образы при помощи командной строки, хранятся в указанных каталогах на носителях SOLIDWORKS.

SOLIDWORKS (основной продукт, англоязычная версия)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (версии компонентов для языков, отличных от английского)

Традиционный китайский | swwi\lang\chinese\chinese.msi
Китайский (упрощенный) | swwi\lang\chinese-simplified\chinese-simplified.msi
Чешский | swwi\lang\czech\czech.msi
французский | swwi\lang\french\french.msi
немецкий | swwi\lang\german\german.msi
итальянский | swwi\lang\italian\italian.msi
японский | swwi\lang\japanese\japanese.msi
корейский | swwi\lang\korean\korean.msi
Польский | swwi\lang\polish\polish.msi
Португальский (Бразилия) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
русский | swwi\lang\russian\russian.msi
испанский | swwi\lang\spanish\spanish.msi
Turkish | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

3DExperience Marketplace для SOLIDWORKS

marketplace\3dexperience marketplace.msi

Менеджер лицензии SolidNetWork

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

Комплект программ для разработчиков программных интерфейсов приложений SOLIDWORKS

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

swComposer\SOLIDWORKS Composer.msi

SOLIDWORKS Composer Player

swComposerPlayerSOLIDWORKS Composer Player.msi

SOLIDWORKS Electrical

swelectric\SOLIDWORKS Electrical.msi

SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS Manage Client

SWManageClient\SOLIDWORKS Manage Client.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional предоставляет API, который доступен только для клиента, но не в файле .msi. Дополнительные сведения см. в Руководстве по API в каталоге клиента SOLIDWORKS PDM Client install\API.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Visualize

visualize\SOLIDWORKS Visualize.msi

SOLIDWORKS Visualize Boost

visualizeboost\SOLIDWORKS Visualize Boost.msi
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize


Развертывание администрирующего образа с помощью Microsoft Active Directory

Развертывание с помощью Microsoft Active Directory поддерживается при внедрении основных продуктов SOLIDWORKS на клиентах.

Microsoft Active Directory – это служба каталогов для управления клиентами и серверами в сетевой среде. Упрощает управление, миграцию и развертывание.

Для получения сведений об установке SOLIDWORKS через Microsoft Active Directory обратитесь к реселлеру.

На уровень выше Внедрение с использованием командной строки
Подготовка клиентов для установки командной строки из администрирующего образа
Установка администрирующего образа с использованием командной строки
Свойства командной строки


Администрация множественных установок

К административным задачам по созданию нескольких установок относятся обновление администрирующих образов до новых версий, применение пакетов обновления и удаление установок.

Содержание

  • Обновление администрирующих образов до новой версии

    Для обновления клиентов, установки на которых были выполнены из администрирующего образа, сначала требуется обновить сам администрирующий образ, а затем настроить клиентов на обращение к новой копии этого образа.

  • Администрирование обновлений продуктов с помощью пакетов обновления

    Пакеты обновления могут включать обновления, касающиеся надежности системы, совместимости программ, безопасности и т.д.

  • Удаление установки

    Можно удалить установку на отдельном компьютере или в среде клиент/сервер.

На уровень выше Множественные установки
Внедрение на нескольких клиентах
Использование администрирующих образов
Внедрение с использованием командной строки


Обновление администрирующих образов до новой версии

Для обновления клиентов, установки на которых были выполнены из администрирующего образа, сначала требуется обновить сам администрирующий образ, а затем настроить клиентов на обращение к новой копии этого образа.

Запустите Менеджер установки SOLIDWORKS со страницы загрузок SOLIDWORKS, чтобы установились ссылки на верные файлы.

После обновления администрирующего образа (которое создает новую копию образа), можно обновить клиентов путем создания ссылки на новую копию администрирующего образа.

Если клиенты были связаны с предыдущей версией администрирующего образа через общий каталог, то общий каталог можно переопределить в соответствии с расположением обновленного образа.

Содержание

  • Загрузка обновленных файлов установки для администрирующих образов

    С помощью Менеджера установки SOLIDWORKS можно определить, когда при обновлении администрирующего образа требуются обновленные файлы установки.

  • Обновление администрирующего образа

    Для обновления администрирующего образа Менеджер установки SOLIDWORKS создает новый каталог образа. Затем клиентам дается указание использовать новый каталог администрирующего образа, чтобы с его помощью выполнить обновление до этой версии продукта.

  • Обновление клиентов с помощью администрирующих образов

    Менеджер установки SOLIDWORKS позволяет автоматически обновлять клиентские компьютеры, установленные с помощью администрирующего образа.

На уровень выше Администрация множественных установок
Администрирование обновлений продуктов с помощью пакетов обновления
Удаление установки


Загрузка обновленных файлов установки для администрирующих образов

С помощью Менеджера установки SOLIDWORKS можно определить, когда при обновлении администрирующего образа требуются обновленные файлы установки.

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На экране Добро пожаловать выберите Администрирующий образ.
  3. На экране Серийный номер введите серийный номер SOLIDWORKS.
    Менеджер установки SOLIDWORKS проверяет веб-сайт SOLIDWORKS на наличие лицензированных Вам продуктов и доступных пакетов обновлений.
  4. Если появляется окно Доступные более новые версии, выберите Да, скачать и установить новую версию: Версия.
    Менеджер установки SOLIDWORKS запустит новый сеанс для установки более новой версии.
  5. При наличии проблемы с папкой загрузки может отобразиться сообщение Параметры загрузки. В этом случае для новых файлов установки выберите каталог по умолчанию или введите имя нового каталога.
    Если отобразится сообщение о том, что каталог не существует, выберите Да, чтобы его создать.
  6. На экране Загрузка завершена выберите Закрыть, чтобы закрыть текущую программу установки и запустить программу установки для новой версии.
На уровень выше Обновление администрирующих образов до новой версии
Обновление администрирующего образа
Обновление клиентов с помощью администрирующих образов


Обновление администрирующего образа

Для обновления администрирующего образа Менеджер установки SOLIDWORKS создает новый каталог образа. Затем клиентам дается указание использовать новый каталог администрирующего образа, чтобы с его помощью выполнить обновление до этой версии продукта.

Данный процесс подразумевает, что для администрирующего образа загружены обновленные файлы установки. Подробную информацию см. в разделе Загрузка обновленных файлов установки для администрирующего образа.

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На экране Добро пожаловать выберите Администрирующий образ.
    На экране отображаются параметры создания администрирующего образа.
    Опция | Описание
    Создать новый образ с использованием параметров по умолчанию. | Создать образ при помощи параметров конфигурации, настроенных по умолчанию (иными словами, не используя параметры, заданные для имеющегося администрирующего образа).
    Создать новый образ с использованием параметров и файлов существующего образа. | Создать образ, используя параметры конфигурации, настроенные для существующего администрирующего образа. Нажмите Обзор, чтобы указать каталог установки существующего администрирующего образа.
  3. На экране Серийный номер отметьте серийный номер.
  4. На экране Суммарная информация (Готов к созданию образа) отметьте, что параметры администрирующего образа верны.
    Для получения подробной информации об отдельном администрирующем образе и о параметрах установки нажмите кнопку ИЗМЕНИТЬ, чтобы перейти на страницу параметров, а затем выберите Справка.
  5. Чтобы создать новую версию администрирующего образа, нажмите кнопку Создать сейчас.

Теперь можно обновить клиенты до этой новой версии администрирующего образа. Для получения дополнительной информации см. раздел Обновление клиентов с помощью администрирующих образов.

На уровень выше Обновление администрирующих образов до новой версии
Загрузка обновленных файлов установки для администрирующих образов
Обновление клиентов с помощью администрирующих образов


Обновление клиентов с помощью администрирующих образов

Менеджер установки SOLIDWORKS позволяет автоматически обновлять клиентские компьютеры, установленные с помощью администрирующего образа.

Обычно администрирующие образы располагаются в папках на сервере. Для поддержки автоматических обновлений клиентов администрирующий образ должен располагаться в папке общего использования.

После обновления администрирующего образа исходные и обновленные файлы будут сохранены в две разные папки. Чтобы воспользоваться обновленными файлами установки, отключите параметр общего использования для папки с исходным администрирующим образом и активируйте его для папки с обновленным образом.

При запуске программы SOLIDWORKS на клиентском компьютере, установленном с помощью исходного администрирующего образа, происходит автоматическое распознавание новой версии и обновление клиента.
Кроме того, когда SOLIDWORKS инициирует обновление, автоматически обновляются другие продукты, установленные с помощью администрирующего образа.
На уровень выше Обновление администрирующих образов до новой версии
Загрузка обновленных файлов установки для администрирующих образов
Обновление администрирующего образа

Отмена общего доступа для папки с исходным администрирующим образом

При обновлении администрирующего образа, доступ к которой осуществлялся из общей папки, необходимо отменить общий доступ для исходной папки.

  1. Перейдите в папку, где располагаются файлы исходного администрирующего образа.
  2. Нажмите правой кнопкой мыши папку и выберите Свойства.
  3. На вкладке Общие выберите параметр Отменить общий доступ к этой папке, затем нажмите кнопку ОК.

Теперь добавьте параметр общего доступа к обновленной папке администрирующего образа, как описано в Добавление параметра общего доступа к обновленной папке администрирующего образа.

Установка общего доступа для папки с обновленным администрирующим образом.

После создания папки с обновленным администрирующим образом и отключения общего доступа для папки с исходным администрирующим образом параметр общего доступа необходимо задать для вновь созданной папки. Это необходимо для повторной активации администрирующего образа.

  1. Перейдите в папку, где располагаются файлы обновленного администрирующего образа.
  2. Нажмите правой кнопкой мыши папку и выберите Свойства.
  3. На вкладке Совместное использование укажите параметры совместного использования, подходящие для Вашей организации или группы, и измените имя общего ресурса на имя, используемое в исходной папке администрирующего образа.
На компьютерах, установка на которых была выполнена из общей папки исходного администрирующего образа, при запуске программы SOLIDWORKS произойдет автоматическое обновление до новой версии.
Ограничения При создании администрирующего образа и его автоматическом развертывании через общий доступ программа SOLIDWORKS не выполняет обновление до нового пакета обновлений Service Pack при замене образа. SOLIDWORKS обновляется автоматически только при установке исходного образа вручную с помощью менеджера установки.

Например, если создать администрирующий образ для SOLIDWORKS <версия> SP1 и автоматически развернуть его с помощью параметров общего доступа, клиент будет устанавливать компоненты и работать в соответствии с ожиданиями. Позже можно создать новый образ для SP5 в той же папке, отключить общий доступ к образу SP1 и включить общий доступ к образу SP5 с тем же именем.

При открытии программы SOLIDWORKS на клиенте она не обнаруживает новый образ или не запускает обновление. Она открывает SP1. Даже сопоставление имени папки с исходным изображением не устраняет эту проблему.


Администрирование обновлений продуктов с помощью пакетов обновления

Пакеты обновления могут включать обновления, касающиеся надежности системы, совместимости программ, безопасности и т.д.

Обновления продуктов можно получать двумя способами.
  • Проверка наличия, скачивание и установка обновлений с помощью Менеджера установки SOLIDWORKS.

    Менеджер установки SOLIDWORKS можно запускать вручную или запрограммировать его на выполнение периодической проверки наличия обновлений.

  • Скачивание пакетов обновления вручную с веб-узла поддержки SOLIDWORKS.

    Пакеты обновления применяются как заплаты для существующей версии программного обеспечения. К примеру, SOLIDWORKS 2026 SP1.0 — это пакет обновления для SOLIDWORKS 2026 SP0.0. Эти пакеты обновления можно установить, используя SOLIDWORKS 2026 Installation Manager. Установить их при помощи Installation Manager для SOLIDWORKS 2025 невозможно.

    Для получения более подробных инструкций по скачиванию и установке пакетов обновления, см. документацию по установке версии SOLIDWORKS, которую необходимо обновить.

Содержание

  • Откат пакетов обновления в администрирующем образе

    Администрирующий образ можно откатить до пакета обновления, установленного ранее. Если программное обеспечение SOLIDWORKS было установлено с помощью дисков, то для восстановления пакета обновления потребуются оригинальные диски. Необходимо, чтобы копия более ранней версии администрирующего образа была сохранена.

На уровень выше Администрация множественных установок
Обновление администрирующих образов до новой версии
Удаление установки


Откат пакетов обновления в администрирующем образе

Администрирующий образ можно откатить до пакета обновления, установленного ранее. Если программное обеспечение SOLIDWORKS было установлено с помощью дисков, то для восстановления пакета обновления потребуются оригинальные диски. Необходимо, чтобы копия более ранней версии администрирующего образа была сохранена.

Администрирующие образы, прошедшие обновления, невозможно откатить до предыдущей версии пакета обновления. Администрирующие образы, созданные любым способом без использования Менеджера установки SOLIDWORKS, невозможно откатить до предыдущей версии. Клиенты, установленные из таких администрирующих образов, должны удаляться и устанавливаться повторно с помощью администрирующего образа, созданного в предыдущей версии.
  1. Удалите папку, содержащую текущий администрирующий образ. Для этого откройте окно «Командная строка» и введите команду:
    rmdir /s/q путь_к_текущему_администрирующему_образу
  2. Переместите резервную копию администрирующего образа в папку, из которой был удален текущий администрирующий образ. Для этого откройте окно «Командная строка» и введите команду:
    move путь_к_резервной_копии_администрирующего_образа путь_к_текущему_администрирующему_образу
    После отката администрирующего образа откат на клиентских компьютерах будет выполнен автоматически при следующем запуске программы SOLIDWORKS.
На уровень выше Администрирование обновлений продуктов с помощью пакетов обновления


SOLIDWORKS PDM и SOLIDWORKS Manage

SOLIDWORKS PDM представляет собой продукт для управления документацией на основе архитектуры "клиент-сервер", ранее известный как SOLIDWORKS Enterprise PDM. SOLIDWORKS PDM поставляется в двух типах:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

Для управления хранилищами файлов SOLIDWORKS PDM использует базу данных Microsoft SQL Server.

В этой таблице представлены определения доступных систем баз данных, серверных компонентов и параметров клиентов для каждого типа продукта.
 | PDM Standard | PDM Professional
Предназначение | Небольшие и средние сети офисов, в которых менее 20 одновременно работающих пользователей. | Крупные офисные сети, большое число параллельных пользователей
Ограничения | Меньшее из следующего: 1 сокет или 4 ядра, 1 ГБ ОЗУ, база данных размером 10 ГБ | Стандартные ограничения SQL: Меньшее из следующего: 4 сокета или 16 ядер, 128 ГБ ОЗУ, база данных размером 524 ПБ
Система управления базой данных | Microsoft SQL Server Express 2019 или более поздние версии, вплоть до 2022. | Microsoft SQL Server 2019 или более поздние версии, вплоть до 2022.
Требуется SolidNetWork License Manager? | Да | Да
В комплект поставки входит сервер архивации и сервер базы данных? | Да | Да
В комплект поставки входит серверы Web2 и WebAPI SOLIDWORKS PDM? | Нет | Да
Типы клиентов | Собственный | Собственный, на основе браузера
Клиентские дополнения для CAD Editor | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Microsoft Office Integration
Клиентские дополнения для Contributor | DraftSight | DraftSight, интеграция с Microsoft Office
Клиентские дополнения для Viewer |  | Интеграция Microsoft Office

Версия SOLIDWORKS Manage Professional предоставляет набор расширенных инструментов управления данными для SOLIDWORKS PDM Professional. Она содержит возможности для расширенного управления версиями, проектом, процессом и объектами. Интерактивные информационные панели и отчеты помогают отслеживать элементы, действия и ход выполнения относительно проектов.

SOLIDWORKS Manage Professional имеет аналогичную SOLIDWORKS PDM Professional архитектуру. Она использует архитектуру клиент-сервер вместе с базой данных Microsoft SQL Server для управления данными объекта и проекта. Существует три службы для базы данных, файлового сервера и функций веб-сервера, которые поддерживают полные версии клиентов и клиентов веб-браузера. Три службы могут быть размещены на одном или на отдельных серверах. Пользователи с лицензиями SOLIDWORKS Manage Professional Editor могут использовать дополнение SOLIDWORKS Manage для доступа к управлению данными непосредственно из SOLIDWORKS.

Можно использовать менеджер установки SOLIDWORKS для установки сервера и клиента версии SOLIDWORKS Manage Professional.

Для получения инструкций по установке SOLIDWORKS Manage Professional см. Руководство по установке SOLIDWORKS PDM/SOLIDWORKS Manage.

Содержание

  • Список компонентов PDM Server

  • Описание различий между клиентами PDM

    Перед установкой программного обеспечения клиента необходимо определить требуемые клиенты в зависимости от среды PDM.

  • Перед установкой PDM Server

    Перед установкой серверных компонентов PDM необходимо учесть следующие требования:

  • Установка сервера PDM с помощью Менеджера установки SOLIDWORKS

    При установке сервера PDM для продукта PDM Standard можно установить сервер архивации, сервер базы данных и клиент PDM CAD Editor на одном и том же компьютере. При этом нет необходимости выполнять установку клиента отдельно.

  • Установка клиента PDM при помощи Диспетчера установки SOLIDWORKS Installation Manager


Список компонентов PDM Server

В этой таблице представлены компоненты SOLIDWORKS PDM Server.

Сервер | Function | Установка
Microsoft SQL Server Express для PDM Standard | Управление данными в хранилищах SOLIDWORKS PDM. | Возможна установка с PDM Standard или использование ранее лицензированной и установленной версии.
Microsoft SQL Server для PDM Professional | Управление данными в хранилищах SOLIDWORKS PDM. | Требуется. Также можно использовать ранее лицензированную и установленную версию.
Клиент SolidNetWork License Manager | Управление лицензиями SOLIDWORKS PDM. | Должен быть установлен перед созданием новых хранилищ. Может быть установлен с серверными компонентами SOLIDWORKS PDM с помощью Менеджера установки SOLIDWORKS.
Сервер архивации | Управляет переносами файлов между клиентами и архивным хранилищем файлов; управление пользователями и их учетными данными. | Требуется. Устанавливается вместе с PDM Standard или Professional.
Сервер базы данных | Опрашивает базы данных PDM, проверяя наличие обновлений, управляет правилами импорта и экспорта данных, контролирует систему сообщений и планирует репликацию и холодное хранение. | Требуется. Устанавливается вместе с PDM Standard или Professional.
Сервер Web2 | Обеспечивает доступ к хранилищам файлов через Интернет посредством клиентов на основе браузера. | Дополнительно. Устанавливается только с PDM Professional.
Веб-сервер API | Пользователи EXALEAD OnePart могут использовать веб-сервер API для индексации и извлечения данных SOLIDWORKS PDM. | Дополнительно. Устанавливается только с PDM Professional.

Серверы архивации работают как службы в системной учетной записи компьютеров, на которых они установлены. На одном сервере архивации может размещаться несколько хранилищ файлов на одном компьютере.

При автономной установке сервер архивации, сервер базы данных, сервер лицензирования и веб-сервер API, а также базу данных SQL Express или SQL Server можно установить на одном компьютере.

В распределенной среде серверные компоненты можно разместить на разных компьютерах. SOLIDWORKS PDM Professional также поддерживает репликацию архивов хранилищ файлов и базы данных сервера SQL для повышения производительности в удаленных местоположениях. Для получения дополнительных сведений см. Руководство по репликации SOLIDWORKS PDM Professional.

На уровень выше SOLIDWORKS PDM и SOLIDWORKS Manage


Описание различий между клиентами PDM

Перед установкой программного обеспечения клиента необходимо определить требуемые клиенты в зависимости от среды PDM.

В этой таблице представлена обзорная информация по клиентам для SOLIDWORKS PDM Standard:
Тип клиента Standard | Описание
CAD Editor | Поддерживает работу с файлами SOLIDWORKS, DWG/DXF, Microsoft Word и Microsoft Excel. Все форматы файлов, которые обрабатывает плагин Microsoft Office, ведут себя в SOLIDWORKS PDM Standard одинаково, кроме предварительного просмотра.
Участник | Поддерживает работу с файлами SOLIDWORKS, DWG/DXF, Microsoft Word и Microsoft Excel.
Зритель | Обеспечивает доступ к файловым хранилищам в режиме "только чтение". Пользователь может перемещать файлы в рамках технологического процесса, но не может добавлять или изменять файлы (разрегистрировать, регистрировать, обновлять значения).
В этой таблице представлена обзорная информация по клиентам для SOLIDWORKS PDM Professional:
Тип клиента Professional | Описание
CAD Editor и веб-клиент | Поддерживает работу с файлами всех типов, включая файлы усовершенствованных форматов CAD для управления и просмотра, например SOLIDWORKS. Добавления CAD обеспечивают доступ к SOLIDWORKS PDM Professional из любого приложения CAD. Удаленные пользователи могут осуществлять поиск в хранилищах и работать с базовыми функциями через Интернет с помощью клиентов Web2.
Contributor и веб-клиент | Поддерживает работу с файлами всех типов, включая файлы CAD. Однако этот клиент не поддерживает дополнения CAD. Удаленные пользователи могут осуществлять поиск в хранилищах и работать с базовыми функциями через Интернет с помощью клиентов Web2.
Viewer | Обеспечивает доступ к файловым хранилищам в режиме "только чтение". Пользователь может перемещать файлы в рамках технологического процесса, но не может добавлять или изменять файлы (разрегистрировать, регистрировать, обновлять значения) либо использовать добавления CAD.
На уровень выше SOLIDWORKS PDM и SOLIDWORKS Manage


Перед установкой PDM Server

Перед установкой серверных компонентов PDM необходимо учесть следующие требования:

  • Получите полные административные права на компьютерах, на которых планируется установить серверы и клиенты.
  • Убедитесь, что сервер базы данных имеет доступ к серверу архивации через порт TCP 3030 и к серверу SQL через порт TCP 1433.
  • Если будет использоваться существующая база данных SQL Server Express или SQL Server, получите имя базы данных SQL Server, идентификатор учетной записи и пароль администратора или владельца базы данных SQL Server с правом доступа к базе данных в режиме "чтение/запись". Работа с пользователем tew невозможна.
  • Если на компьютере уже установлен клиент PDM, удалите его. Чтобы использовать и сервер PDM, и клиент PDM на одном компьютере, можно установить обе программы на странице Серверы в Менеджере установки SOLIDWORKS.
На уровень выше SOLIDWORKS PDM и SOLIDWORKS Manage


Установка сервера PDM с помощью Менеджера установки SOLIDWORKS

При установке сервера PDM для продукта PDM Standard можно установить сервер архивации, сервер базы данных и клиент PDM CAD Editor на одном и том же компьютере. При этом нет необходимости выполнять установку клиента отдельно.

При установке сервера PDM для продукта PDM Professional можно включить эти компоненты, а также сервер Web2 и веб-сервер API.

Установка сервера PDM и его компонентов:

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На странице приветствия выберите Установить компоненты сервера и выберите следующее.
    • Установить компоненты SOLIDWORKS PDM Server на этом компьютере.
    • Установить SolidNetWork License Manager на этом компьютере.

      Если на этом или другом компьютере установлен компонент SolidNetWork License Manager, этот параметр не отображается.

  3. Если отображается страница Параметры SolidNetWork License Manager, введите серийный номер и укажите расположение, а затем нажмите Далее.
  4. Следуйте инструкциям в системных предупреждениях. Нажмите кнопку Далее.
  5. На странице Сводка для SOLIDWORKS PDM Server нажмите Изменить.
  6. На странице Параметры SOLIDWORKS PDM Server выполните следующие действия.
    1. В списке Выбрать сервер, выберите SOLIDWORKS PDM Standard или Professional.
    2. В разделе Расположение установки нажмите Обзор, чтобы указать путь к файлу.
    3. В разделе Выбрать элементы:
      1. Выберите Сервер архивации, Сервер базы данных и Клиент, чтобы установить эти компоненты на одном и том же компьютере. Если вы работаете в распределенной среде, можно установить сервер архивации и сервер базы данных с помощью Менеджера установки на другом компьютере.
        • Если на компьютере уже установлен клиент PDM, необходимо отменить текущую установку и удалить ранее установленный клиент. Затем можно запустить Менеджер установки SOLIDWORKS для одновременной установки сервера и клиента PDM.
        • Компонент клиента SOLIDWORKS PDM, связанный с установкой сервера SOLIDWORKS PDM, включает в себя Проводник объектов, который нельзя исключить.
      2. При установке PDM Professional можно также выбрать Сервер Web2 и Веб-сервер API.
        При установке веб-сервера API можно указать для параметра Номер порта HTTP значение от 0 до 65535. По умолчанию используется значение 65453.
    4. В разделе SQL Server можно установить новый экземпляр инструментов базы данных, поставляемый с сервером PDM (SQL Server Express для PDM Standard). Также можно указать имя базы данных, имя пользователя и пароль для существующего экземпляра.
      Для SOLIDWORKS PDM Professional должна быть установлена полная версия SQL Server.
    5. Нажмите Назад в Сводку.
  7. На странице Суммарная информация примите условия лицензионного соглашения SOLIDWORKS и выберите Установить сейчас.

    После завершения работы менеджера установки SOLIDWORKS запускается инструмент настройки сервера архивации. Настройте сервер архивации, следуя инструкциям мастера.

Информацию об установке, настройке и устранении неполадок для сервера архивации, сервера базы данных, сервера Web2, а также баз данных SQL Server см. в соответствующих разделах Руководства по установке SOLIDWORKS PDM.

Содержание

  • Изменение установки SOLIDWORKS PDM Server

На уровень выше SOLIDWORKS PDM и SOLIDWORKS Manage


Изменение установки SOLIDWORKS PDM Server

Изменить установку SOLIDWORKS PDM Server и соответствующие компоненты можно в разделе Программы и компоненты на панели управления Windows. Нельзя изменить установку в Менеджере установки SOLIDWORKS (SLDIM), даже если он использовался для установки SOLIDWORKS PDM Server.

На уровень выше Установка сервера PDM с помощью Менеджера установки SOLIDWORKS


Установка клиента PDM при помощи Диспетчера установки SOLIDWORKS Installation Manager

Основная версия клиента SOLIDWORKS PDM должна совпадать с основной версией сервера SOLIDWORKS PDM. При установке или обновлении клиента SOLIDWORKS PDM убедитесь, что версии совпадают.

Установка клиента PDM:

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На странице приветствия выберите Установить на этом компьютере.
  3. На странице Серийный номер нажмите кнопку Далее.
    Для клиентов SOLIDWORKS PDM не требуется отдельный серийный номер.
  4. Следуйте инструкциям в системных предупреждениях. Нажмите кнопку Далее.
  5. На странице Суммарная информация в разделе "Продукты" выберите Изменить.
  6. На странице Выбор продуктов нажмите Выбрать другие пакеты или продукты.
  7. В диалоговом окне Выбрать предлагаемый пакет выберите версию SOLIDWORKS. Затем нажмите OK.
  8. На странице Выбор продуктов выберите Клиент SOLIDWORKS PDM. Затем выберите eDrawings, чтобы включить функцию предварительного просмотра PDM. При использовании SOLIDWORKS PDM Professional можно также выбрать Проводник объектов.
  9. На странице Сводка разверните узел Параметры SOLIDWORKS PDM и нажмите Изменить.
  10. На странице Параметры клиента SOLIDWORKS PDM выберите следующие значения и нажмите К странице "Суммарная информация":
    • Тип продукта PDM
    • Тип клиента PDM
    • Дополнения
  11. На странице Суммарная информация примите условия лицензионного соглашения SOLIDWORKS и выберите Установить сейчас.
Для создания и развертывания образов клиентов PDM администраторы могут также использовать Редактор параметров администрирующего образа. Для получения дополнительной информации см. Использование администрирующих образов.
На уровень выше SOLIDWORKS PDM и SOLIDWORKS Manage


SOLIDWORKS Electrical

Менеджер установки SOLIDWORKS позволяет установить все компоненты SOLIDWORKS Electrical в автономном режиме или режиме клиент/сервер.

SOLIDWORKS Electrical использует несколько компонентов. Во время установки необходимо выбрать эти компоненты в соответствии с типом установки.
  • SOLIDWORKS Electrical Schematic — приложение 2D для создания и управления электрическими схемами.
  • SOLIDWORKS Electrical 3D — дополнение SOLIDWORKS для интеграции 2D-схем с 3D-моделями. Программа SOLIDWORKS Electrical 3D позволяет управлять компоновкой электрических устройств и прокладывать провода, кабели и жгуты проводов.
  • Данные — данные группируются по всем данным, необходимым для работы программного обеспечения. Эти данные являются графическими (файлы, представляющие обозначения и основные надписи) или техническими (каталоги производителя и данные, связанные с обозначениями). Вы можете предоставить общий доступ к данным для всех пользователей.
  • Collaborative Server — утилита для управления процессом открытия и обновления электрических чертежей.
  • Приложение SOLIDWORKS Electrical требует использования базы данных Microsoft SQL Server. Можно создать новую базу данных или использовать существующую базу данных во время установки.

Тип установки

Все компоненты SOLIDWORKS Electrical можно установить на один и тот же компьютер. Это автономная установка. Все программные данные такие, как чертежи объектов и отчеты, хранятся на одной рабочей станции.

Компоненты SOLIDWORKS Electrical также можно установить как приложения с архитектурой "клиент-сервер". Используйте этот тип установки, если необходимо сохранить данные на сетевом сервере. Установка клиент/сервер позволяет нескольким пользователям работать над одним проектом. Клиентские системы должны поддерживать сетевой доступ к серверу с правами на чтение и запись для создания проектов, библиотек и символов.

Информация

Независимо от типа установки (автономная или клиент/сервер), для установки SOLIDWORKS Electrical необходимо запустить сеанс Windows в режиме полных прав.

На компьютере можно установить только одну версию SOLIDWORKS Electrical. При установке SOLIDWORKS и выборе SOLIDWORKS Electrical в качестве одного из продуктов для установки программа установки удаляет старую версию SOLIDWORKS Electrical.

При запуске Менеджера установки SOLIDWORKS он автоматически определяет существующие версии SOLIDWORKS Electrical, установленные на рабочей станции или сервере.

Перед установкой новой версии следует создать резервную копию существующей среды SOLIDWORKS Electrical. В среде SOLIDWORKS Electrical Schematic выберите Файл > Архивировать среду или в SOLIDWORKS Electrical 3D выберите SOLIDWORKS Electrical > Инструменты > Архивировать среду.

Содержание

  • Требования к установке программы SOLIDWORKS Electrical

  • Автономная установка или установка клиента/сервера

    Установить SOLIDWORKS Electrical можно в двух режимах. В автономном режиме программное обеспечение устанавливается на рабочую станцию. В режиме клиент/сервер пользователи совместно используют данные.

  • Настройка Collaborative Server

  • Настройка Microsoft SQL Server

  • Определение местоположения данных


Требования к установке программы SOLIDWORKS Electrical

Текущие системные требования см. в разделе Системные требования.

На уровень выше SOLIDWORKS Electrical
Автономная установка или установка клиента/сервера
Настройка Collaborative Server
Настройка Microsoft SQL Server
Определение местоположения данных


Автономная установка или установка клиента/сервера

Установить SOLIDWORKS Electrical можно в двух режимах. В автономном режиме программное обеспечение устанавливается на рабочую станцию. В режиме клиент/сервер пользователи совместно используют данные.

SOLIDWORKS Electrical всегда должен подключаться к экземпляру SQL Server.

На уровень выше SOLIDWORKS Electrical
Требования к установке программы SOLIDWORKS Electrical
Настройка Collaborative Server
Настройка Microsoft SQL Server
Определение местоположения данных

Установка в виде отдельного приложения

При первой установке НЕОБХОДИМО установить все компоненты на рабочую станцию.

  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • Данные программного обеспечения
  1. На вкладке Сводка нажмите Изменить в разделе Выбор продукта и выберите все компоненты SOLIDWORKS Electrical.
  2. Если необходимо изменить параметры установки, на вкладке Сводка нажмите Изменить в разделе Параметры Electrical. Можно создать новый экземпляр SQL Server или использовать существующий. Дополнительные сведения см. в отдельных главах о Data и Microsoft SQL Server в данной документации. Также можно использовать параметры по умолчанию.
  3. Нажмите Установить, чтобы продолжить.
Если программа SOLIDWORKS Electrical уже установлена на рабочей станции, менеджер установки SOLIDWORKS автоматически находит ее и предлагает обновить. Установите все компоненты, не меняя Параметры Electrical.

Установка типа клиент/сервер

Установка типа клиент/сервер позволяет обмениваться данными между несколькими пользователями.

На сервере необходимо установить следующие компоненты:
  • Collaborative Server
  • Данные программного обеспечения
  • SQL Server
На клиентских устройствах необходимо установить следующие компоненты:
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  1. На сервере установите компоненты сервера.
  2. На вкладке приветствия Менеджера установки SOLIDWORKS нажмите Установить компонент сервера.
  3. Выберите параметр SOLIDWORKS Electrical.
  4. На вкладке Сводка можно изменять параметры установки. Дополнительные сведения см. в отдельных главах о Data и Microsoft SQL Server в данной документации. Также можно использовать параметры по умолчанию.
  5. Нажмите Установить, чтобы продолжить.
  6. На клиентских устройствах установите приложения.
  7. На вкладке приветствия Менеджера установки SOLIDWORKS нажмите Установить на этот компьютер.
  8. На вкладке Общие нажмите Изменить в разделе Выбор продукта и снимите флажок Сервер Electrical.
  9. На вкладке Сводка нажмите Изменить в разделе Параметры Electrical и измените настройки для подключения к серверу.
  10. Нажмите Установить, чтобы продолжить.
Если программа SOLIDWORKS Electrical уже установлена на рабочей станции или сервере, менеджер установки SOLIDWORKS автоматически находит ее и предлагает обновить ее. Чтобы обновить программное обеспечение, используйте тот же процесс, что и при первой установке.


Настройка Collaborative Server

Collaborative Server — это служба Windows, которая должна быть всегда запущена и должна обеспечивать постоянную, бесперебойную, двустороннюю связь с клиентами посредством брандмауэров и средств поиска вирусов.

Чтобы настроить Collaborative Server в индивидуальном режиме или режиме сервера, укажите следующие параметры:
  • Имя компьютера (например, LOCALHOST или MyMachine) или его IP-адрес (например, 127.0.0.1 или 192.168.255.255).
  • Номер порта (по умолчанию 26666).

Collaborative Server можно настроить во время установки или позже с помощью команды Инструменты > Настройки приложения.

При установке клиента/сервера в целях обеспечения бесперебойной двусторонней связи убедитесь, что номер порта 26666 доступен и открыт на соответствующем компьютере, на который устанавливается Collaborative Server. В противном случае обратитесь к системному администратору, чтобы найти другой порт для SOLIDWORKS Electrical. Необходимо убедиться, что входящие подключения разрешены на сервере для порта SOLIDWORKS Electrical (26666).

На уровень выше SOLIDWORKS Electrical
Требования к установке программы SOLIDWORKS Electrical
Автономная установка или установка клиента/сервера
Настройка Microsoft SQL Server
Определение местоположения данных


Настройка Microsoft SQL Server

Убедитесь, что экземпляр базы данных SQL Server доступен для любого типа установки SOLIDWORKS Electrical. Существующую базу данных SQL Server можно использовать даже при условии, что она уже установлена в системе или же установить новый экземпляр в рамках установки SOLIDWORKS Electrical.

При установке нового экземпляра SQL Server программа установки SOLIDWORKS предоставляет бесплатную версию Microsoft SQL Express 2022. Эта версия поддерживает только 1 ЦПУ, 1 ГБ памяти и 10 ГБ данных. Ограничений по памяти и ЦПУ достаточно для поддержки 10 одновременно работающих пользователей.

При установке SQL Express 2022 убедитесь, что программное и аппаратное обеспечение сервера соответствует требованиям, представленным в разделе Системные требования.

Если на одном сервере более 10 одновременно работающих пользователей, рекомендуется приобрести и установить полную версию SQL Server. Используйте рабочий процесс, описанный для установки SOLIDWORKS Electrical с существующим экземпляром SQL Server.

Дополнительные сведения о SQL Express 2022 см. в документации к приложению Microsoft SQL Server.

На уровень выше SOLIDWORKS Electrical
Требования к установке программы SOLIDWORKS Electrical
Автономная установка или установка клиента/сервера
Настройка Collaborative Server
Определение местоположения данных

Управление данными в SOLIDWORKS Electrical

Во многих программах используется отдельная база данных, в которой содержатся все программные данные. Однако в случае с SOLIDWORKS Electrical все обстоит по-другому. Каждому проекту в приложении SOLIDWORKS Electrical назначается уникальный идентификационный номер, при этом для каждого проекта существует связанная база данных, которую можно определить по уникальному идентификационному номеру. Например, если в окне Менеджера проектов SOLIDWORKS Electrical найти проект с идентификационным номером 112, связанной базе данных будет присвоено имя "tew_project_data_112".

При назначении уникальной базы данных каждому проекту существенным образом сокращается время обработки. Кроме того, в случае критической ошибки базы данных это коснется только одного проекта, при этом целостность большей части программной информации будет сохранена.

Однако некоторые компании вводят санкции, ограничивающие создание новых баз данных. Для запуска приложения SOLIDWORKS Electrical не действуют ограничения на создание новых баз данных пользователями. Обратитесь к администратору системы или базы данных, чтобы убедиться в отсутствии параметров конфигурации, препятствующих созданию новых баз данных.

Новые экземпляры SQL Server

Для установки нового экземпляра SQL Server необходимы полные административные права на сервер, а также клиентские системы. Кроме того, необходимо убедиться, что клиенты обладают правом на чтение и запись базы данных для последующего создания и изменения проектов, библиотек, символов и других данных проекта.

При установке нового экземпляра SQL Server выберите имя, отличное от имени по умолчанию.

Существующие экземпляры SQL Server

Чтобы установить новые базы данных SOLIDWORKS Electrical или подключиться к установке SOLIDWORKS Electrical на существующем экземпляре SQL Server, необходимо создать учетную запись пользователя с полными административными правами на использование базы данных SQL Server.

Для надлежащего функционирования приложения SOLIDWORKS Electrical необходимо активировать SQL Server для проверки подлинности в смешанном режиме. Благодаря проверке подлинности в смешанном режиме можно использовать учетные данные Windows или SQL Server.

Чтобы подключиться к существующей базе данных SQL Server, можно воспользоваться проверкой подлинности с помощью Windows или SQL Server. Введите имя пользователя и пароль для имени входа Windows или SQL Server с полными административными правами SQL Server.

Невозможно использовать пользователь "tew" для подключения к SQL Server с целью установки. Обратитесь к администратору SQL Server или системному администратору для получения имени входа с допустимыми учетными данными для SQL Server.

Базы данных SOLIDWORKS Electrical

После установки SOLIDWORKS Electrical программа установки создает следующие базы данных в экземпляре SQL Server.

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


Определение местоположения данных

Чтобы расположить данные, выберите каталог для хранения программных данных таких, как детали, шаблоны, двухмерные и трехмерные символы. Это место должно быть выделенным каталогом. Однако не может быть корневым каталогом или тем же каталогом, который используется для хранения данных SOLIDWORKS.

Путь по умолчанию: C:\ProgramData\SOLIDWORKS Electrical.

В случае установки клиента/сервера необходимо предоставить общий доступ к каталогу данных.

Программа установки создает новую папку с именем Update в каталоге по умолчанию для хранения всех новых данных.

При первом запуске SOLIDWORKS Electrical программа автоматически объединяет данные, хранящиеся в папке Update, с существующими данными. В окне мастера Обновления данных выберите данные для добавления в приложение и базу данных SQL Server.

На уровень выше SOLIDWORKS Electrical
Требования к установке программы SOLIDWORKS Electrical
Автономная установка или установка клиента/сервера
Настройка Collaborative Server
Настройка Microsoft SQL Server


SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize предоставляет пакет автономных инструментов, объединяющих расширенные возможности отрисовки с функциями и рабочими процессами визуального проектирования для создания высокореалистичных изображений моделей 3D CAD.

Продукты SOLIDWORKS Visualize доступны в двух версиях:
  • Стандарт
  • Professional

Каждая лицензия SOLIDWORKS Professional и Premium с активной подпиской включает бесплатное рабочее место SOLIDWORKS Visualize Standard. Для автономной активации пользователей SOLIDWORKS необходим дополнительный серийный номер. Если серийный номер SOLIDWORKS Visualize неизвестен, обратитесь к администратору SOLIDWORKS или к реселлеру.

SOLIDWORKS Visualize также поддерживает типы лицензирования SolidNetWork Licensing (SNL), включая плавающие лицензии и автономную активацию.

С помощью Диспетчера установки SOLIDWORKS Installation Manager (SLDIM) выполните установку SOLIDWORKS Visualize как часть отдельной (Установить на этот компьютер) установки. Программу можно установить как автономное приложение, что является преимуществом при необходимости использования отдельных компьютеров для моделирования и отрисовки. Программа не использует лицензию SOLIDWORKS.

SOLIDWORKS Visualize Boost — это сервис, который позволяет передавать задания отрисовки с компьютера, на котором запущено приложение SOLIDWORKS Visualize Professional, на один или несколько компьютеров в сети. В результате готовые изображения становятся доступными быстрее, и во время отрисовки на компьютере можно выполнять другие задачи. Visualize Boost можно также установить как часть отдельной (Установить на этот компьютер) установки в SOLIDWORKS Installation Manager.

Каждое рабочее место SOLIDWORKS Visualize Professional с активной подпиской включает бесплатное рабочее место SOLIDWORKS Visualize Boost.
Visualize Boost — это дополнительный продукт только для Visualize Professional. Visualize Boost не работает с Visualize Standard.

Содержание

  • Системные требования для SOLIDWORKS Visualize

  • Установка SOLIDWORKS Visualize с помощью Менеджера установки SOLIDWORKS

  • Установка Visualize Boost с помощью Менеджера установки SOLIDWORKS


Системные требования для SOLIDWORKS Visualize

Для оптимальной производительности и настройки SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost перед установкой следуйте этим рекомендациям:
  • Перед установкой SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost удостоверьтесь в том, что для каждого продукта имеется отдельный серийный номер.
  • Убедитесь, что каждый компьютер, на котором установлено приложение SOLIDWORKS Visualize или SOLIDWORKS Visualize Boost, соответствует требованиям, указанным в разделе Системные требования.
  • Установите приложение SOLIDWORKS Visualize Boost на компьютерах, выделенных для отрисовки, в той же сети. Эти компьютеры должны отличаться от компьютеров, на которых запущена программа SOLIDWORKS Visualize Professional, чтобы разгрузить задачи отрисовки.
  • Если отсутствует подходящий графический процессор, SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost по умолчанию будут задействовать центральный процессор (ЦП). Дополнительные сведения о конкретных графических платах и драйверах см. в разделе Сертификация оборудования SOLIDWORKS.

Для поддержки графического процессора при работе с 3DS Stellar Physically Correct

Режим точной отрисовки Stellar:
  • Видеокарта NVIDIA® на основе как минимум микроархитектуры Maxwell™
  • Рекомендуемая версия драйвера 538.78 с поддержкой CUDA® 12.2
  • Минимум 4 ГБ видеопамяти
Режим быстрой отрисовки Stellar, требуется один из следующих параметров:
  • Графическая карта NVIDIA на основе как минимум микроархитектуры Turing® (с ядрами RT)
  • Или видеокарта AMD® на основе микроархитектуры RDNA® 2 или более поздней версии

Для поддержки графического процессора при работе с AMD ProRender

Режим точной отрисовки AMD ProRender™:
  • Графический процессор и драйвер, поддерживающие стандарт Vulkan®
  • Минимум 4 ГБ видеопамяти
На уровень выше SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost


Установка SOLIDWORKS Visualize с помощью Менеджера установки SOLIDWORKS

Установка SOLIDWORKS Visualize:

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На странице приветствия выберите Установить на этом компьютере.
  3. Выполните следующие операции:
    1. На странице Серийный номер разверните пункт Визуализация.
    2. Выберите SOLIDWORKS Visualize и введите серийный номер.
    3. Нажмите кнопку Далее.
  4. Следуйте инструкциям в системных предупреждениях. Нажмите кнопку Далее.
  5. На странице Суммарная информация примите условия лицензионного соглашения SOLIDWORKS и выберите Установить сейчас.
Для активации продукта следуйте инструкциям Мастера активации продукта.

После активации дважды нажмите на ярлык SOLIDWORKS Visualize на рабочем столе для запуска приложения или в меню Windows Пуск выберите SOLIDWORKS версия > SOLIDWORKS Visualize версия.

Содержание

  • Действия после установки

На уровень выше SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost


Действия после установки

После установки необходимо выполнить действия по настройке SOLIDWORKS Visualize.

Для получения дополнительной информации см. Начало работы с SOLIDWORKS Visualize в разделе SOLIDWORKS Visualize Справка.

Содержание

  • Создание папки содержания

  • Доступ к справке, учебным пособия, сведениям о системе и лицензировании

На уровень выше Установка SOLIDWORKS Visualize с помощью Менеджера установки SOLIDWORKS


Создание папки содержания

При первом запуске программы SOLIDWORKS Visualize предлагает выбрать расположение для создания папки Content.

Папка Content включает в себя следующие подпапки, предназначенные для хранения ресурсов проекта:
Подпапки | Хранящиеся элементы
Камеры | Стандартные камеры и камеры, сохраненные пользователем
Окружающие среды | Изображения с расширенным динамическим диапазоном (HDR)
Палитры | Изображения опорных плит
Изображения | Отрисовки и снимки
Внешние виды | Материалы Библиотеки внешних видов Содержание обновляется при добавлении в библиотеку новых внешних видов.
Модели | Файлы моделей По умолчанию SOLIDWORKS Visualize выполняет поиск в этой папке в первую очередь, когда используется команда Файл > Импорт для импорта модели.
Плиты | Стандартные двухмерные изображения, используемые в опорных плитах
Настройки проекта | Исходные файлы проекта в формате .SVPJ
Текстуры | Двухмерные текстуры, используемые во внешних видах
На уровень выше Действия после установки


Доступ к справке, учебным пособия, сведениям о системе и лицензировании

Через меню "Справка" можно получить доступ к документации, обновлениям программного обеспечения и средствам устранения неполадок.

Справка Visualize | Открывается онлайн-справка SOLIDWORKS Visualize.
Обучение Visualize | Открывается портал MySolidWorks, где можно перейти на страницу с учебными пособиями по SOLIDWORKS Visualize.
Примечания к выпуску | Отображаются примечания к выпуску для текущей версии.
Новые возможности | Отображаются сведения о новых функциях продуктов SOLIDWORKS.
Сведения о системе | Выполняется системная проверка на совместимость программного обеспечения SOLIDWORKS Visualize с аппаратным обеспечением компьютера. При необходимости отображается информация о требуемых обновлениях.
Проверить наличие обновлений | Проверяет сервер на наличие обновления SOLIDWORKS Visualize.
Активировать лицензию | (Лицензии, привязанные к узлу) Открывается мастер активации продуктов SOLIDWORKS, с помощью которого можно активировать продукт.
Деактивировать лицензию | (Лицензии, привязанные к узлу) Открывается мастер активация продуктов SOLIDWORKS, с помощью которого можно деактивировать продукт.
SolidNetWork License Manager | Открывается мастер активации продуктов SOLIDWORKS, с помощью которого можно деактивировать продукт.
О программе Visualize | Отображается номер версии и сведения о лицензировании текущей копии SOLIDWORKS Visualize.
На уровень выше Действия после установки


Установка Visualize Boost с помощью Менеджера установки SOLIDWORKS

Установка Visualize Boost выполняется с помощью Менеджера установки SOLIDWORKS. Для этого требуется отдельный серийный номер.

Visualize Boost следует устанавливать на компьютерах, которые не используются для работы программного обеспечения SOLIDWORKS Visualize Professional. Можно оптимизировать качество отрисовки, установив Visualize Boost на компьютерах с несколькими графическими процессорами (GPU).

Установка SOLIDWORKS Visualize Boost:

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На странице приветствия выберите Установить на этом компьютере.
  3. Выполните следующие операции:
    1. На странице Серийный номер разверните пункт Визуализация.
    2. Выберите SOLIDWORKS Visualize Boost и введите серийный номер.
    3. Нажмите кнопку Далее.
  4. Следуйте инструкциям в системных предупреждениях. Нажмите кнопку Далее.
  5. На странице Суммарная информация примите условия лицензионного соглашения SOLIDWORKS и выберите Установить сейчас.
Для активации продукта следуйте инструкциям Мастера активации продукта.

После активации откройте приложение, дважды нажав на ярлык SOLIDWORKS Visualize Boost на рабочем столе [image].

Содержание

  • Настройка Visualize Boost

    Основной компьютер Visualize Boost можно настроить в качестве координатора, а дополнительные компьютеры в кластере отрисовки — в качестве узлов.

На уровень выше SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost


Настройка Visualize Boost

Основной компьютер Visualize Boost можно настроить в качестве координатора, а дополнительные компьютеры в кластере отрисовки — в качестве узлов.

Visualize Boost позволяет отрисовывать изображения на одном компьютере или в кластере компьютеров. Настройка выполняется легко и интуитивно. Основной компьютер (координатор) управляет кластером и передает задания отрисовки из SOLIDWORKS Visualize. Дополнительные компьютеры (узлы) подключаются к координатору для содействия выполнению этих заданий в сети. В системе отрисовки на каждом компьютере кластера непрерывно работает экземпляр Visualize Boost.

Чтобы настроить Visualize Boost, выполните следующие действия.

  1. Откройте Visualize Boost:
    • дважды нажмите на ярлык Visualize Boost на рабочем столе [image].
    • В меню Windows Пуск выберите SOLIDWORKS < версия> > SOLIDWORKS Visualize Boost <версия>.
    После активации в окне Visualize Boost будут определены и отображены имя и IP-адрес лицензированного компьютера.
  2. В Visualize Boost нажмите Файл > Настройки.
  3. В диалоговом окне Настройки выполните следующие действия.
    1. Выберите один компьютер в качестве координатора. Оставьте поле Координатор пустым в ходе настройки всех остальных узлов.
    2. Примите действующие по умолчанию значения 8001 для параметра Порт Boost и 8002 для параметра Порт DStellar.
      Эти порты можно изменить в соответствии с требованиями к сети. Добавьте исключения брандмауэра для обмена данными между узлами. По всем вопросам обращайтесь к администратору сети.
  4. Необязательно: К дополнительным параметрам относятся следующие.
    Опция | Описание
    Язык | Компьютер автоматически использует язык операционной системы.
    Тема | Выберите значение фона Светлый или Темный для параметра Тема. Эта настройка оказывает воздействие на SOLIDWORKS Visualize, если этот продукт установлен на том же компьютере, что и Visualize Boost.
    Уведомления включены | Отображает сообщения от DStellar.Boost в области уведомлений Windows.
    Экспорт | Сохраняет настройки конфигурации Visualize Boost в файле .json.
    Импорт | Загружает существующие настройки в экземпляр Visualize Boost в файл .json.
  5. Нажмите Применить.
Для завершения настройки см. инструкции в разделе Работа с Visualize Boost.
На уровень выше Установка Visualize Boost с помощью Менеджера установки SOLIDWORKS


Администрирование лицензий

После завершения установки можно активировать лицензии SOLIDWORKS одним из следующих способов: активировать отдельные компьютеры (активация на компьютере) либо установить и активировать плавающие сетевые лицензии на сервере (лицензии SolidNetWork).

Как правило, для установки на отдельные компьютеры выполняется активация лицензий; однако программное обеспечение можно установить отдельно и затем управлять лицензиями с помощью SolidNetWork License Manager. С другой стороны, не смотря на то, что крупные пользователи обычно используют плавающие сетевые лицензии, можно внедрить установку с помощью администрирующего образа и затем активировать серийные номера с индивидуальных компьютеров.

Содержание

  • Администрирование индивидуальных лицензий

    Для активации на компьютере можно настроить отдельную лицензию.

  • Администрирование лицензий с помощью SolidNetWork License Manager

    SolidNetWork License Manager поддерживает несколько лицензионных клиентов, распределяя лицензии для клиентов в сети. При этом благодаря использованию плавающих лицензий, число пользователей может превышать число лицензий.


Администрирование индивидуальных лицензий

Для активации на компьютере можно настроить отдельную лицензию.

Как правило, администрирование индивидуальных лицензий заключается в активации и деактивации лицензий непосредственно в программе SOLIDWORKS.

Активация - это процесс лицензирования и регистрации автономных лицензий SOLIDWORKS (не лицензий SolidNetWork). Как правило, если лицензия на продукт не активирована, SOLIDWORKS пытается активировать ее при запуске продукта.

При покупке бессрочной лицензии SOLIDWORKS перед началом работы в SOLIDWORKS 2022 или более поздней версии раз в год требуется повторно активировать лицензию. Срок действия бессрочной лицензии не истекает, но она требует повторной активации. SOLIDWORKS предложит повторно активировать бессрочную лицензию до наступления даты повторной активации.

Можно деактивировать отдельные лицензии, выбрав в SOLIDWORKS [image] > Лицензии > Деактивировать.

На уровень выше Администрирование лицензий
Администрирование лицензий с помощью SolidNetWork License Manager

Активация лицензии

Прежде чем запустить продукт SOLIDWORKS на отдельном компьютере, необходимо активировать лицензию для данного компьютера.

Для активации необходим доступ в Интернет или к электронной почте. Для использования продуктов после активации подключение к Интернету не требуется. Если у вас нет доступа к электронной почте с компьютера, на котором используется этот продукт, можно сохранить файл активации и послать его с другого компьютера.

Данный процесс:
  • Активирует лицензии на все продукты SOLIDWORKS.
  • Позволяет переносить лицензионные права с одного компьютера на другой.
  • может выполняться немедленно (рекомендуется) или в течение 30 дней после установки;
  • Отменяет необходимость использования аппаратных ключей защиты. Однако если вы пользуетесь предыдущими версиями продуктов SOLIDWORKS, которые не используют процесс активации, вы должны использовать ключ аппаратной защиты.

Системные администраторы, имеющие дело с несколькими серийными номерами, могут использовать Редактор параметров администрирующего образа. Для получения дополнительной информации см. Редактор параметров администрирующего образа.

Чтобы активировать лицензию:

  1. Запустите SOLIDWORKS.
  2. Запустите функцию Активация продукта SOLIDWORKS одним из перечисленных ниже способов.
    • Если лицензия для данного компьютера еще не активирована, при запуске программы SOLIDWORKS автоматически отображается окно Активация продукта SOLIDWORKS.
    • Если окно Мастер активации продуктов SOLIDWORKS не отображается автоматически, начните активацию, выбрав [image] > Лицензии > Активировать.
  3. Выберите список Продукт, чтобы указать продукт, лицензию для которого требуется активировать.
  4. Укажите метод активации через Интернет или вручную с использованием электронной почты.
  5. Укажите адрес своей электронной почты.
  6. Нажмите кнопку Далее.
    • Активация через Интернет: Активация выполняется автоматически.
    • Эл. почта: Нажмите кнопку Сохранить, чтобы создать файл запроса, а затем отправьте его по адресу activation@solidworks.com. Получив сообщение электронной почты с файлом ответа, извлеките файл из сообщения и нажмите Открыть, чтобы загрузить его.
      При необходимости можно завершить и повторно запустить процедуру активации, чтобы открыть файл ответа.
  7. Нажмите кнопку Готово.
Редактор параметров администрирующего образа

Повторная активация лицензии

При наличии бессрочной коммерческой или образовательной лицензии для продуктов SOLIDWORKS 2022 и более поздних версий требуется раз в год повторно активировать эти лицензии. Мастер активации продуктов SOLIDWORKS отправит запрос на активацию перед наступлением даты повторной активации.

Чтобы повторно активировать лицензию, выполните следующие действия.

  1. Запустите SOLIDWORKS.
    Мастер активации продуктов SOLIDWORKS отправит запрос на повторную активацию. Для каждой лицензии продуктов SOLIDWORKS отображается следующее сообщение:
    • Истекает срок действия активации
    • Чтобы продолжить использование продукта (повторно активировать бессрочную лицензию, возобновить или повторно активировать временную или оценочную лицензию), требуется выполнить действие.
  2. Нажмите Повторно активировать, чтобы запустить мастер активации продуктов.

    Если вы не хотите повторно активировать лицензию сейчас, нажмите Напомнить позже. Например, в SOLIDWORKS нажмите [image] > Лицензии > Активировать, чтобы запустить мастер активации продуктов. См. Активация лицензии.

Перенос лицензии

Чтобы перенести лицензию SolidNetwork на новый или обновленный компьютер, сначала деактивируйте ее на сервере лицензионных ключей Dassault Systèmes SOLIDWORKS Corporation. Затем повторно активируйте ее на другом компьютере.

Если не удалось деактивировать лицензию на сервере Dassault Systèmes SOLIDWORKS Corporation (например, из-за сбоя жесткого диска), в большинстве случаев можно выполнить повторную активацию. Если она не решила проблему, обратитесь за помощью к своему реселлеру.

Чтобы перенести лицензию, выполните следующие действия.

  1. В программе SOLIDWORKS выберите [image] > Лицензии > Деактивировать и следуйте инструкциям.
  2. Чтобы повторно активировать лицензию, перейдите на новый или обновленный компьютер и активируйте лицензию, выполнив ту же последовательность действий, что и для исходной активации. Подробнее см. раздел Активация лицензии.


Администрирование лицензий с помощью SolidNetWork License Manager

SolidNetWork License Manager поддерживает несколько лицензионных клиентов, распределяя лицензии для клиентов в сети. При этом благодаря использованию плавающих лицензий, число пользователей может превышать число лицензий.

На данном рисунке проиллюстрирован обычный процесс установки лицензии SolidNetWork License.

На данном рисунке отображается:
  • Установка и активация программы SolidNetWork License Manager выполняются только на компьютере, предназначенном для установки этого приложения.
  • На клиентских компьютерах специальное дополнительное программное обеспечение SolidNetWork не устанавливается.

    Если при установке указан серийный номер лицензии SolidNetWork, менеджер установки SOLIDWORKS идентифицирует этот компьютер как лицензионного клиента SolidNetWork. Менеджер установки SOLIDWORKS запрашивает имя компьютера с установленным SolidNetWork License Manager и номер порта для подключения клиента к менеджеру лицензий.

  • Менеджер лицензий и все лицензионные клиенты должны иметь возможность взаимодействия с протоколами TCP/IP (Transmission Control Protocol/Internet Protocol).

Содержание

  • Установка обзора лицензий SolidNetWork

    Менеджер установки SOLIDWORKS используется для установки сервера SolidNetWork License Manager хотя бы на одном компьютере перед установкой клиентского ПО SOLIDWORKS на какие-либо компьютеры. Затем можно использовать мастер активации продукта для добавления и активации серийных номеров для бессрочных и срочных лицензий.

  • Запуск SolidNetWork License Manager

    SolidNetWork License Manager можно запустить в меню Пуск операционной системы Windows.

  • Обновление SolidNetWork License Manager

    Для основных выпусков SOLIDWORKS обновление менеджера лицензий включает в себя удаление устаревшей версии, установку новой версии и повторную активацию лицензии SolidNetWork.

  • Перенос лицензии SolidNetWork License

    Чтобы перенести лицензию SolidNetWork License на новый или обновленный компьютер, сначала деактивируйте ее на сервере лицензионных ключей Dassault Systèmes SolidWorks Corporation, затем активируйте ее на другом компьютере.

  • Удаление файлов лицензий SolidNetWork License

    Перед обновлением можно удалить файлы лицензий SolidNetWork, срок действия которых истек.

  • Заимствование и возврат лицензий SolidNetWork

    Пользователи могут заимствовать лицензии SolidNetWork для использования программного обеспечения SolidWorks из удаленного местоположения. Поскольку при заимствовании лицензия извлекается из пула свободных лицензий, чтобы она снова стала доступна, ее следует вернуть.

  • Управление доступом к версиям SOLIDWORKS

    Можно ограничить доступ пользователей к отдельным версиям SOLIDWORKS в окружении SolidNetWork. Эта функция позволяет управлять версиями SOLIDWORKS, которыми пользуются отдельные сотрудники, проектные группы и подразделения организации.

  • Контроль времени простоя лицензии

    С помощью SolidNetWork License Manager программа SOLIDWORKS может регистрировать время простоя. Таким образом, лицензии, которые не используются в течение определенного времени, возвращаются в пул свободных лицензий.

  • Использование временной лицензии

    Можно использовать временную лицензию "any", если лицензия SolidNetWork недоступна.

  • Использование лицензий SolidNetWork с приложениями

    С помощью SolidNetWork License Manager можно распространять лицензии на основные дополнения SOLIDWORKS.

  • Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License

    Пользователи лицензий SolidNetWork License могут управлять лицензиями SOLIDWORKS® Simulation в своем пуле лицензий, которые будут использоваться после добавления в SOLIDWORKS Simulation. Кроме того, можно обновить лицензию SOLIDWORKS Simulation, не выгружая дополнение, если требуется лицензия более высокого уровня для более сложных исследований.

  • Загрузка модулей Flow Simulation

    Пользователь лицензии SolidNetWork License может загрузить модули дополнений HVAC и Electronics Cooling для Flow Simulation двумя способами.

  • Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics

    При запуске исследований SOLIDWORKS Simulation, Plastics или Flow Simulation сетевые лицензии остаются активными и не выключаются из-за тайм-аута. SOLIDWORKS сохраняет лицензии во время процесса вычислений, который считается активностью.

  • Установка Менеджера лицензий и администрирующего образа на одном компьютере

    Можно настроить один сетевой компьютер в качестве менеджера лицензий, распределяющего лицензии SolidNetWork, и местоположения администрирующего образа, из которого пользователи смогут устанавливать программу SOLIDWORKS.

  • Удаление SolidNetWork License Manager

    При обновлении SolidNetWork License Manager необходимо удалить устаревшую версию менеджера лицензий перед установкой новой версии.

  • Система управления лицензиями FlexNet Publisher

    Лицензирование SolidNetWork основано на системе управления лицензиями FlexNet Publisher®.

На уровень выше Администрирование лицензий
Администрирование индивидуальных лицензий


Установка обзора лицензий SolidNetWork

Менеджер установки SOLIDWORKS используется для установки сервера SolidNetWork License Manager хотя бы на одном компьютере перед установкой клиентского ПО SOLIDWORKS на какие-либо компьютеры. Затем можно использовать мастер активации продукта для добавления и активации серийных номеров для бессрочных и срочных лицензий.

При установке клиентского ПО SOLIDWORKS на компьютер укажите серийный номер лицензии SolidNetWork. Менеджер установки SOLIDWORKS идентифицирует этот компьютер как лицензионного клиента SolidNetWork и запрашивает имя компьютера и номер порта сервера SolidNetWork License Manager. Ошибка отображается, если сервер SolidNetWork License Manager не установлен или имя либо номер порта указаны неверно.

Процесс активации

Прежде чем запустить SOLIDWORKS на отдельном компьютере, следует активировать лицензию SolidNetWork на компьютере с установленным сервером SolidNetWork License Manager.

Для активации требуется доступ к Интернету или электронной почте. Для использования продуктов после активации подключение к Интернету не требуется. Если у вас нет доступа к электронной почте с компьютера, на котором используется этот продукт, можно сохранить файл активации и послать его с другого компьютера.

Данный процесс:
  • Активирует компонент SOLIDWORKS SolidNetWork License Manager с лицензиями SolidNetWork для всех продуктов SOLIDWORKS.
  • Позволяет переносить лицензионные права SolidNetWork с одного компьютера, на котором установлен SolidNetWork License Manager, на другой.
  • Позволяет устанавливать и активировать лицензионные права SolidNetWork на одном компьютере с установленным SolidNetWork License Manager.
  • Должен быть выполнен до использования лицензий SolidNetWork.
  • отменяет необходимость использования аппаратных ключей защиты. При активации лицензии SolidNetWork для данной версии программы SOLIDWORKS выполняется активация лицензий SolidNetWork для предыдущих версий SOLIDWORKS. Хранить аппаратный ключ больше не требуется.

Содержание

  • Установка сервера SolidNetWork License Manager

    Сервер SolidNetWork License Manager поддерживает несколько лицензионных клиентов. Он распределяет лицензии для клиентов в сети.

  • Активация лицензий SolidNetWork

    Прежде чем запустить SOLIDWORKS на отдельном компьютере, следует активировать лицензию SolidNetWork License на компьютере с SolidNetWork License Manager.

  • Активация вручную с сервером SolidNetWork License Manager

    При установке или обновлении сервера SolidNetWork License Manager необходимо активировать или повторно активировать лицензию. Лицензию можно активировать или повторно активировать через Интернет или вручную.

  • Установка лицензионных клиентов SolidNetWork

  • Использование лицензий SolidNetWork License с брандмауэрами

    Если на компьютере используется брандмауэр, следует настроить порты для поддержки лицензий SolidNetWork License.

  • Повторная активация лицензии SolidNetWork License

    Повторная активация применяется к продуктам с лицензией SolidNetWork после обновления сервера SolidNetwork License Manager до версии 2022 или более поздней. Даже если установленные продукты относятся к более раннему выпуску, лицензии 2022 требуется повторно активировать раз в год.

  • Установка Менеджера лицензий для системы из трех компьютеров

    Менеджеры лицензий для системы из трех компьютеров используют три компьютера для обеспечения дополнительной стабильности. Если компьютер, управляющий лицензионным файлом, недоступен, один из двух других компьютеров его замещает.

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Установка сервера SolidNetWork License Manager

Сервер SolidNetWork License Manager поддерживает несколько лицензионных клиентов. Он распределяет лицензии для клиентов в сети.

При обновлении предыдущей версии сервера SolidNetWork License Manager, использовавшей аппаратные ключи для активации лицензии, удалите аппаратный ключ перед установкой новой версии сервера SolidNetWork License Manager.

  1. Запустите Менеджер установки SOLIDWORKS, как описано в разделе Скачивание установочного носителя.
  2. Для типа установки выберите Установить компоненты сервера и нажмите Установить SolidNetWork License Manager (распределение лицензий) на этом компьютере.
  3. На странице Сводка проверьте место установки и фоновый загрузчик, подтвердите свое согласие с условиями лицензии и нажмите Установить.
  4. В мастере активации продуктов SOLIDWORKS с сервера SolidNetWork License Manager добавьте серийный номер и активируйте хотя бы одну лицензию. См. раздел Добавление серийных номеров и активация лицензий SolidNetWork.
На уровень выше Установка обзора лицензий SolidNetWork
Активация лицензий SolidNetWork
Активация вручную с сервером SolidNetWork License Manager
Установка лицензионных клиентов SolidNetWork
Использование лицензий SolidNetWork License с брандмауэрами
Повторная активация лицензии SolidNetWork License
Установка Менеджера лицензий для системы из трех компьютеров


Активация лицензий SolidNetWork

Прежде чем запустить SOLIDWORKS на отдельном компьютере, следует активировать лицензию SolidNetWork License на компьютере с SolidNetWork License Manager.

Чтобы активировать лицензию SolidNetWork License, выполните следующие действия.

  1. Запустите SolidNetWork License Manager, выбрав Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Managerверсия.
  2. Необязательно: Если лицензия SolidNetWork еще не активирована, программа запросит активацию данной лицензии. Нажмите Да.
    Откроется мастер активации продуктов SOLIDWORKS.
  3. Необязательно: Если используется брандмауэр, выберите На этом сервере запущен брандмауэр.
  4. Введите номера портов на странице Сведения о сервере лицензий SolidNetWork и нажмите Далее.
  5. В поле Серийный номер: выберите определенные серийные номера или нажмите Выбрать все, чтобы выделить и активировать все серийные номера SOLIDWORKS.
    1. Выберите параметр, чтобы активировать Автоматически через Интернет (рекомендуется).
    2. В разделе Контактная информация укажите адрес электронной почты.
    В диалоговом окне Активация/реактивация выполнена отобразятся активированные продукты.
  6. Нажмите Готово.
На уровень выше Установка обзора лицензий SolidNetWork
Установка сервера SolidNetWork License Manager
Активация вручную с сервером SolidNetWork License Manager
Установка лицензионных клиентов SolidNetWork
Использование лицензий SolidNetWork License с брандмауэрами
Повторная активация лицензии SolidNetWork License
Установка Менеджера лицензий для системы из трех компьютеров


Активация вручную с сервером SolidNetWork License Manager

При установке или обновлении сервера SolidNetWork License Manager необходимо активировать или повторно активировать лицензию. Лицензию можно активировать или повторно активировать через Интернет или вручную.

В случае активации вручную:
  • Для корректной работы нового сервера SolidNetWork License Manager необходимо дважды пройти процедуру активации. В первый раз вы инициализируете лицензионную систему на сервере. Во второй раз вы активируете лицензию.
  • Для обновленного сервера SolidNetWork License Manager необходимо повторно активировать существующую лицензию. Если на сервере нет активированных лицензий, вместо этого необходимо выполнить активацию с помощью кнопки Изменить на вкладке "Администрирование сервера".
На уровень выше Установка обзора лицензий SolidNetWork
Установка сервера SolidNetWork License Manager
Активация лицензий SolidNetWork
Установка лицензионных клиентов SolidNetWork
Использование лицензий SolidNetWork License с брандмауэрами
Повторная активация лицензии SolidNetWork License
Установка Менеджера лицензий для системы из трех компьютеров


Установка лицензионных клиентов SolidNetWork

При установке ПО SOLIDWORKS CAD на компьютер необходимо указать серийный номер лицензии SolidNetWork. Менеджер установки SOLIDWORKS определяет компьютер в качестве лицензионного клиента SolidNetWork и запрашивает имя и номер компьютера SolidNetWork License Manager. Ошибка отображается, если сервер SolidNetWork License Manager не установлен или имя либо номер порта указаны неверно.

Чтобы установить SOLIDWORKS с лицензией SolidNetWork, выполните следующие действия.

  1. Запустите Менеджер установки SOLIDWORKS, как описано в разделе Скачивание установочного носителя.
  2. На странице приветствия выберите Установить на этом компьютере, если данная основная версия программы SOLIDWORKS на этом компьютере устанавливается впервые.
    Если выполняется обновление существующей версии и замена индивидуальной лицензии на лицензию SolidNetWork, выберите Изменить существующую индивидуальную установку (на этом компьютере). Для получения дополнительной информации см. Обновление индивидуальной лицензии до лицензии SolidNetWork .
  3. В диалоговом окне Добавление сервера введите адрес SolidNetWork License Manager в форму ниже:

    порт@имя_компьютера>

    Номер порта должен совпадать с номером порта компьютера, на котором установлен менеджер лицензий. По умолчанию используется 25734.

    Менеджер установки SOLIDWORKS проверяет, доступен ли компьютер с установленным SolidNetWork License Manager. Если Менеджер лицензий не еще установлен, проверка невозможна; однако установку лицензионного клиента по-прежнему можно продолжить.
  4. Завершите установку SOLIDWORKS, следуя инструкциям Менеджера установки SOLIDWORKS.
На уровень выше Установка обзора лицензий SolidNetWork
Установка сервера SolidNetWork License Manager
Активация лицензий SolidNetWork
Активация вручную с сервером SolidNetWork License Manager
Использование лицензий SolidNetWork License с брандмауэрами
Повторная активация лицензии SolidNetWork License
Установка Менеджера лицензий для системы из трех компьютеров


Использование лицензий SolidNetWork License с брандмауэрами

Если на компьютере используется брандмауэр, следует настроить порты для поддержки лицензий SolidNetWork License.

В программе брандмауэра необходимо добавить два порта лицензии SolidNetWork (например, SNL-in-port и SNL-out-port) в список исключений брандмауэра. Для получения дополнительной информации о настройке этих портов обратитесь к системному администратору.

Если брандмауэр Windows используется в поддерживаемой операционной системе, необходимо изменить настройку портов на компьютере с установленным SolidNetWork License Manager, а также изменить файл лицензии SolidNetWork для выдачи лицензий клиентским компьютерам.

Изменение портов компьютера с установленным Менеджером лицензий для брандмауэра Windows

  1. Нажмите Пуск и откройте меню Безопасность Windows.
  2. Выберите Брандмауэр и защита сети > Дополнительные параметры и нажмите Да, чтобы подтвердить изменения.
  3. В диалоговом окне Брандмауэр Защитник Windows с повышенной безопасностью выберите Правила для входящего трафика > Создать правило.
  4. В Мастер создания правила для нового входящего подключения выберите тип правила Порт и нажмите Далее.
  5. Введите номер порта в разделе Определенные локальные порты: (например, 80, 25734, 443), а затем нажмите Далее.
  6. Выберите Имя. Введите имя (например, SNL-in-port).
  7. Нажмите Готово.

Изменение настроек SolidNetWork License Manager для брандмауэра Windows

  1. Запустите SolidNetWork License Manager, выбрав Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Manager версия.
  2. На вкладке Администрирование сервера в разделе Лицензионный сервер выберите Стоп. Нажмите Да, чтобы подтвердить, а затем нажмите кнопку OK, чтобы выполнить остановку лицензионного сервера.
  3. В разделе Лицензионная информация выберите Изменить.
  4. В разделе Тип сервера выберите тип организации серверов в сети (Один или Сервер-тройка) и нажмите кнопку Далее.
  5. В разделе Сведения о сервере:
    1. Выберите параметр На этом сервере используется брандмауэр.
    2. Номер порта и номер порта демона поставщика должны содержать номера портов, указанные для брандмауэра Windows (подробнее см. в процедуре, описанной выше).
    3. Выберите Файл параметров и нажмите Обзор, чтобы найти файл. Нажмите Редактировать для изменения необходимых параметров.
    Файл параметров позволяет администратору лицензий управлять различными рабочими параметрами лицензирования FlexNet.

    Рекомендации Разместите файл параметров в каталоге установки SolidNetWork License Manager (SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt). Этот файл должен находиться в том же каталоге, что и файл sw_d.lic.

    Дополнительную информацию о файле параметров см. в Руководстве по администрированию лицензий FlexNet Publisher в каталоге установки SolidNetWork License Manager:

    C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

На уровень выше Установка обзора лицензий SolidNetWork
Установка сервера SolidNetWork License Manager
Активация лицензий SolidNetWork
Активация вручную с сервером SolidNetWork License Manager
Установка лицензионных клиентов SolidNetWork
Повторная активация лицензии SolidNetWork License
Установка Менеджера лицензий для системы из трех компьютеров


Повторная активация лицензии SolidNetWork License

Повторная активация применяется к продуктам с лицензией SolidNetWork после обновления сервера SolidNetwork License Manager до версии 2022 или более поздней. Даже если установленные продукты относятся к более раннему выпуску, лицензии 2022 требуется повторно активировать раз в год.

В течение 30 дней до даты повторной активации продукты SOLIDWORKS уведомят пользователей по сети об окончании срока действия лицензий. Администраторы должны быть осведомлены об истечении срока действия, чтобы вовремя выполнить повторную активацию лицензий.

Чтобы повторно активировать лицензию SolidNetWork, выполните следующие действия.

  1. Запустите сервер SolidNetWork License Manager, выбрав Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Manager версия.
  2. На вкладке Администрирование сервера в разделе Информация о лицензии нажмите Повторно активировать.

  3. В разделе Серийный номер установите значение Все для всех лицензий или введите номер лицензии для поиска определенной лицензии.

    В диалоговом окне Повторно активировать лицензии будут выделены красным цветом все лицензии, срок действия которых истекает в ближайшие 30 дней или которые нужно повторно активировать в течение этого периода. Звездочками будут отмечены лицензии, требующие обновления.

  4. Нажмите Повторно активировать.
На уровень выше Установка обзора лицензий SolidNetWork
Установка сервера SolidNetWork License Manager
Активация лицензий SolidNetWork
Активация вручную с сервером SolidNetWork License Manager
Установка лицензионных клиентов SolidNetWork
Использование лицензий SolidNetWork License с брандмауэрами
Установка Менеджера лицензий для системы из трех компьютеров


Установка Менеджера лицензий для системы из трех компьютеров

Менеджеры лицензий для системы из трех компьютеров используют три компьютера для обеспечения дополнительной стабильности. Если компьютер, управляющий лицензионным файлом, недоступен, один из двух других компьютеров его замещает.

Требования к использованию Менеджеров лицензий для системы из трех компьютеров:
  • Менеджеры лицензий для системы из трех компьютеров следует устанавливать только на стабильно работающих компьютерах, которые не планируется часто отключать.
  • Три компьютера, на которых установлен Менеджер лицензий, должны быть установлены в одной подсети. Нельзя настраивать Менеджеры лицензий для системы из трех компьютеров с низкоскоростными или коммутируемыми линиями связи.
  • Системный администратор должен определять, когда работа компьютера, на котором установлен Менеджер лицензий, замедляется, и перезагружать его как можно скорее.
    Ситуация, когда работают два компьютера, на которых установлен Менеджер лицензий, сложнее, чем, когда работает только один компьютер, поскольку в данном случае присутствуют два уязвимых звена.

Содержание

  • Установка исходного Менеджера лицензий для системы из трех компьютеров

    Данная процедура описывает процесс установки SolidNetWork License Manager на первый компьютер системы из трех компьютеров.

  • Установка Менеджера лицензий на следующие два компьютера системы из трех компьютеров

    Для установки программного обеспечения SolidNetWork License Manager на втором и третьем компьютерах в системе выполните следующие действия. Эта процедура практически идентична установке программного обеспечения на исходном компьютере, за исключением шагов 2(f) и 2(i).

На уровень выше Установка обзора лицензий SolidNetWork
Установка сервера SolidNetWork License Manager
Активация лицензий SolidNetWork
Активация вручную с сервером SolidNetWork License Manager
Установка лицензионных клиентов SolidNetWork
Использование лицензий SolidNetWork License с брандмауэрами
Повторная активация лицензии SolidNetWork License


Установка исходного Менеджера лицензий для системы из трех компьютеров

Данная процедура описывает процесс установки SolidNetWork License Manager на первый компьютер системы из трех компьютеров.

  1. С помощью Менеджера установки SOLIDWORKS установите SolidNetWork License Manager на первый компьютер системы, предназначенный для установки этого приложения.
    1. Запустите Менеджер установки SOLIDWORKS, как описано в разделе Скачивание установочного носителя.
    2. Для типа установки выберите Установить компоненты сервера и нажмите Установить SolidNetWork License Manager (распределение лицензий) на этом компьютере.
    3. На странице Сводка проверьте пункты SolidNetWork License Manager Расположение установки, Параметры скачивания, а затем нажмите Установить, чтобы завершить процесс в Менеджере установки SOLIDWORKS.
  2. С помощью SolidNetWork License Manager выполните настройку исходного компьютера с установленным менеджером лицензий для системы из трех компьютеров следующим образом.
    1. Запустите SolidNetWork License Manager. Нажмите Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Manager версия.

      Поскольку на данном компьютере запуск SolidNetWork License Manager выполняется впервые, появится запрос на активацию.

    2. Нажмите Нет.

      Появится вкладка "Администрирование сервера" SOLIDWORKS SolidNetWork License Manager.

    3. На вкладке "Администрирование сервера" в разделе Дополнительные параметры выберите Параметры.
    4. В разделе "Режим сервера SolidNetWork License" выберите Использовать файл лицензии и нажмите кнопку ОК.
    5. В разделе Лицензионная информация выберите Изменить.
      Появится мастер файла лицензий SolidNetWork License.
    6. В разделе Тип сервера выберите Сервер-тройка и нажмите кнопку Далее.
    7. На панели информации о сервере проверьте, что указаны правильные имя компьютера и номер порта для исходного компьютера с установленным Менеджером лицензий для системы из трех компьютеров и нажмите Далее.

      Убедитесь, что адрес сетевой интерфейсной карты (NIC) совпадает со сведениями в файле лицензии, полученном от SOLIDWORKS, и что номер порта для исходного компьютера с установленным менеджером лицензий указан верно. Адрес NIC также называется MAC-адресом (адрес управления доступом к среде передачи). Затем нажмите Далее.

      Чтобы найти адрес NIC, откройте окно командной строки и введите следующее:

      ipconfig /all

      Кроме того, если на компьютере используется брандмауэр, может потребоваться задать дополнительные требования. Подробнее см. раздел Использование лицензий SolidNetWork с брандмауэрами.

    8. На странице Информация о партнерском сервере-тройке введите имя компьютера и идентификатор хоста для двух других компьютеров системы и нажмите Далее.
      Это даст возможность клиентским компьютерам получить лицензию с двух других компьютеров, если Менеджер лицензий на одном компьютере системы будет недоступен.
    9. На странице Лицензии выберите Прочитать, чтобы перейти к файлу лицензии SolidNetWork License и открыть его.
      Лицензии отобразятся в окне Лицензионного помощника SolidNetWork. Для данного компьютера используется файл лицензии, полученный от реселлера или службы поддержки клиентов Dassault Systèmes.
    10. Нажмите Готово.
    11. Нажмите OK, чтобы выйти, а затем Готово, чтобы закрыть SolidNetWork License Manager.
На уровень выше Установка Менеджера лицензий для системы из трех компьютеров
Установка Менеджера лицензий на следующие два компьютера системы из трех компьютеров
Использование лицензий SolidNetWork License с брандмауэрами


Установка Менеджера лицензий на следующие два компьютера системы из трех компьютеров

Для установки программного обеспечения SolidNetWork License Manager на втором и третьем компьютерах в системе выполните следующие действия. Эта процедура практически идентична установке программного обеспечения на исходном компьютере, за исключением шагов 2(f) и 2(i).

Предполагается, что хотя бы один Менеджер лицензий для системы из трех компьютеров установлен на другом компьютере системы.

  1. С помощью Менеджера установки SOLIDWORKS установите SolidNetWork License Manager на компьютер системы, предназначенный для установки данного приложения.
    1. Запустите Менеджер установки SOLIDWORKS, как описано в разделе Скачивание установочного носителя.
    2. Для типа установки выберите Установить компоненты сервера и нажмите Установить SolidNetWork License Manager (распределение лицензий) на этом компьютере.
    3. На странице Сводка проверьте пункты SolidNetWork License Manager Расположение установки, Параметры скачивания, а затем нажмите Установить, чтобы завершить процесс в Менеджере установки SOLIDWORKS.
  2. С помощью SolidNetWork License Manager выполните настройку компьютера, предназначенного для установки менеджера лицензий для системы из трех компьютеров, следующим образом.
    1. Запустите SolidNetWork License Manager. Нажмите Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Manager версия.
      Поскольку на данном компьютере запуск SolidNetWork License Manager выполняется впервые, появится запрос на активацию.
    2. Нажмите Нет.
      Появится вкладка SolidNetWork License Manager "Администрирование сервера".
    3. В разделе Дополнительные параметры выберите пункт Параметры.
      Появится диалоговое окно Дополнительные параметры.
    4. В разделе "Режим сервера SolidNetWork License" выберите Использовать файл лицензии и нажмите кнопку ОК.
      Диалоговое окно Дополнительные параметры закроется.
    5. В разделе Лицензионная информация выберите Изменить.
      Появится мастер файла лицензий SolidNetWork License.
    6. В разделе Тип сервера выберите Сервер-тройка, Синхронизировать информацию сервера/лицензии и нажмите кнопку Далее.
    7. На экране Информация о сервере-тройке введите имя компьютера и идентификаторы хостов. Затем нажмите Далее.
      Это даст возможность клиентским компьютерам получить лицензию с двух других компьютеров, если Менеджер лицензий на одном компьютере системы недоступен.
    8. На странице Лицензии выберите Прочитать, чтобы перейти к файлу лицензии SolidNetWork License и открыть его.
      Лицензии отобразятся в окне мастера Файл лицензии SolidNetWork License.
    Файл лицензий создается первым компьютером системы, на который устанавливается менеджер лицензий. Как правило, лицензионный файл находится в папке \licenses\sw_d.lic. Например: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\licenses\sw_d.lic
    1. Нажмите Готово.
      Отобразится предупреждение мастера "Файл лицензии SolidNetWork License".
    2. Нажмите кнопку OK, чтобы закрыть Лицензионного помощника SolidNetWork, а затем нажмите Готово для выхода из SolidNetWork License Manager.

Повторите процедуру для третьего компьютера.

На уровень выше Установка Менеджера лицензий для системы из трех компьютеров
Установка исходного Менеджера лицензий для системы из трех компьютеров


Запуск SolidNetWork License Manager

SolidNetWork License Manager можно запустить в меню Пуск операционной системы Windows.

В Windows нажмите Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Manager версия.

Можно использовать тот же путь из меню Пуск в Windows, чтобы открыть Клиент SolidNetWork License Manager версия.

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Обновление SolidNetWork License Manager

Для основных выпусков SOLIDWORKS обновление менеджера лицензий включает в себя удаление устаревшей версии, установку новой версии и повторную активацию лицензии SolidNetWork.

Менеджер лицензий для более новой версии программы также может выдавать лицензии для клиентских компьютеров, на которых установлена предыдущая версия программы.

  1. Запустите SolidNetWork License Manager, выбрав Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Manager версия.
  2. На вкладке Использование лицензий проверьте, что на сетевых клиентских компьютерах не запущена программа SOLIDWORKS.
  3. Удалите устаревшую версию Менеджера лицензий. Для получения дополнительной информации см. Удаление SolidNetWork License Manager.
  4. Установите новую версию менеджера лицензий и повторно активируйте лицензию SolidNetWork на компьютере с установленным менеджером лицензий. Для получения дополнительной информации см. Установка сервера SolidNetWork License Manager.

При обновлении SolidNetWork License Manager на компьютере, на котором также используется приложение SOLIDWORKS, перед установкой новых пакетов обновления для приложения SOLIDWORKS на данный компьютер рекомендуется выполнить обновление SolidNetWork License Manager.

При обновлении Менеджера лицензий на компьютере, на котором установлены администрирующие образы, перед обновлением администрирующих образов выполните обновление Менеджера лицензий. Для получения дополнительной информации см. Установка Менеджера лицензий и администрирующего образа на одном компьютере.

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Перенос лицензии SolidNetWork License

Чтобы перенести лицензию SolidNetWork License на новый или обновленный компьютер, сначала деактивируйте ее на сервере лицензионных ключей Dassault Systèmes SolidWorks Corporation, затем активируйте ее на другом компьютере.

Если не удалось деактивировать лицензию на сервере Dassault Systèmes SOLIDWORKS Corporation (например, из-за сбоя жесткого диска), во многих случаях можно выполнить повторную активацию. Если она не решила проблему, обратитесь за помощью к своему реселлеру.

Чтобы переместить лицензию SolidNetWork, выполните следующие действия.

  1. Запустите сервер SolidNetWork License Manager, выбрав Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Manager версия.
  2. На вкладке Администрирование сервера в разделе Информация о лицензии нажмите Изменить. Откроется мастер активации продуктов SOLIDWORKS.
  3. В разделе Что вы хотите сделать? выберите Перенос лицензий продукта на новый/обновленный компьютер и нажмите Далее.
  4. В списке Серийный номер: выберите серийные номера или нажмите Выбрать все, чтобы активировать все серийные номера SOLIDWORKS.
    1. Выберите параметр Автоматически через Интернет (рекомендуется).
    2. В разделе Контактная информация (обязательно): укажите адрес электронной почты.
  5. Появится окно сообщения Деактивация выполнена.
    Будет выполнена деактивация лицензии.
  6. Нажмите Готово.
На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Удаление файлов лицензий SolidNetWork License

Перед обновлением можно удалить файлы лицензий SolidNetWork, срок действия которых истек.

  1. Запустите SolidNetWork License Manager, выбрав Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Manager.
  2. На вкладке Администрирование сервера в разделе Информация о лицензии выберите Изменить, а затем нажмите Далее.
  3. На странице Активация/деактивация продукта SOLIDWORKS выберите файлы лицензии SolidNetWork, срок действия которых истек, и нажмите Удалить.
  4. Нажмите Готово и OK, чтобы выйти.
На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Заимствование и возврат лицензий SolidNetWork

Пользователи могут заимствовать лицензии SolidNetWork для использования программного обеспечения SolidWorks из удаленного местоположения. Поскольку при заимствовании лицензия извлекается из пула свободных лицензий, чтобы она снова стала доступна, ее следует вернуть.

Заимствованные лицензии действительны только для текущего пользователя и компьютера, для которых они были получены; их нельзя переносить.

Лицензия предоставляется на период времени до 30 дней (или на срок, определенный системным администратором). На это время лицензия извлекается из пула свободных лицензий.

Заимствование и возврат лицензий не работают, если используется лицензия SOLIDWORKS.

Системный администратор может настроить процесс заимствования, чтобы:
  • определить пользователей или группы, которым разрешено заимствовать лицензии;
  • задать число лицензий, которые невозможно заимствовать.

Для получения дополнительных сведений см. каталог_установки_Менеджера_лицензий_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

Содержание

  • Заимствование лицензий SolidNetWork License

  • Возврат заимствованной лицензии SolidNetWork License

    При заимствовании лицензия SolidNetWork License удаляется из пула доступных лицензий. Чтобы она снова стала доступна, ее следует вернуть.

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Заимствование лицензий SolidNetWork License

SolidNetWork License Manager следует запускать из меню Пуск. Для заимствования лицензий необходимо подключиться к SolidNetWork License Manager.

Эти шаги могут различаться в зависимости от конфигурации системы. Для получения дополнительных инструкций и параметров см. соответствующие документы Microsoft Windows.
  1. Запустите SolidNetWork License Manager на клиентском компьютере, выбрав Пуск > Инструменты SOLIDWORKS версия > Клиент SolidNetWork License Manager версия.
  2. На вкладке Заимствование лицензий:
    1. Выберите дату в поле Заимствовать до.
    2. В разделе Доступные лицензии для продуктов выберите продукты для заимствования и нажмите Заимствовать.
    3. В диалоговом окне Выбор продукта, выберите продукт из списка и нажмите OK для подтверждения.
    4. В нижней части диалогового окна нажмите Обновить.
      В столбце Заимствовать до отображается дата возвращения лицензий.
  3. Нажмите на кнопку OK.

На вкладке "Использование лицензии" можно также просмотреть, сколько всего лицензий, бесплатные лицензии и лицензии, используемые пользователем, а также сроки заимствования.

Выберите Использовать только заимствованные лицензии (более быстрый запуск), если вы работаете удаленно и приложения SOLIDWORKS медленно открываются.

Этот параметр блокирует запросы к серверам лицензий, которые в некоторых средах выполняются медленно. Приложения могут запускаться быстрее, если пропускать запросы, но при этом будут использоваться только заимствованные лицензии.

Чтобы этот параметр стал активным, перезапустите приложения.

На уровень выше Заимствование и возврат лицензий SolidNetWork
Возврат заимствованной лицензии SolidNetWork License


Возврат заимствованной лицензии SolidNetWork License

При заимствовании лицензия SolidNetWork License удаляется из пула доступных лицензий. Чтобы она снова стала доступна, ее следует вернуть.

  1. Запустите SolidNetWork License Manager на клиентском компьютере, выбрав Пуск > Инструменты SOLIDWORKS версия > Клиент SolidNetWork License Manager версия.
  2. На вкладке Заимствование лицензий:
    1. В разделе "Заимствованные лицензии для продуктов" выберите продукты для возврата и нажмите Вернуть.
    2. Выберите Обновить. Столбец Заимствовано до становится пустым, указывая на то, что лицензии возвращены.
  3. Нажмите на кнопку OK.

На вкладке "Использование лицензии" можно также просмотреть, сколько всего лицензий.

Лицензии, срок действия которых истек, возвращать не нужно. Лицензии будут возвращены в пул лицензий в SolidNetWork License Manager в полночь даты истечения срока действия, с этого момента приложения для удаленной системы запускаться не будут.
На уровень выше Заимствование и возврат лицензий SolidNetWork
Заимствование лицензий SolidNetWork License


Управление доступом к версиям SOLIDWORKS

Можно ограничить доступ пользователей к отдельным версиям SOLIDWORKS в окружении SolidNetWork. Эта функция позволяет управлять версиями SOLIDWORKS, которыми пользуются отдельные сотрудники, проектные группы и подразделения организации.

Для управления доступом с помощью файла параметров FlexNet:

  1. В каталоге установки SolidNetWork License Manager создайте текстовый файл:
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. В файле лицензий добавьте элемент управления версиями SOLIDWORKS, используя следующий синтаксис рядом с SOLIDWORKS:
    :SWVERSION=xx где xx — версия SOLIDWORKS, управление которой требуется осуществлять
  3. Для управления несколькими версиями SOLIDWORKS добавьте строку для каждой нужной версии.

    Поддерживаются не все параметры FlexNet. Поддерживаются следующие параметры фильтров версий:

    ВКЛЮЧИТЬ | Запуск определенной версии разрешен только для указанного пользователя/группы.
    INCLUDE_BORROW | Запуск определенной версии разрешен только для указанного пользователя/группы.
    EXCLUDE | Блокировка запуска определенной версии (переопределений INCLUDE) для указанного пользователя/группы.
    EXCLUDE_BORROW | Блокировка заимствования определенной версии (переопределений INCLUDE_BORROW) указанным пользователем/группой.
    Примеры.
    1 | INCLUDE solidworks:SWVERSION=xx USER jane
    INCLUDE_BORROW solidworks:SWVERSION=xx USER jane
    Только пользователь jane может запускать или заимствовать указанную версию SOLIDWORKS. Другие пользователи могут получить доступ к другим версиям, если это разрешено.
    2 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=xx GROUP chicago
    EXCLUDE solidworks USER don
    Группа chicago не может использовать определенную версию. Использование любой версии SOLIDWORKS ограничено для пользователя don.
    3 | EXCLUDE swinspection_std:SWVERSION=xx HOST machine1
    Запрещает пользователям на компьютере machine1 запускать указанную версию SOLIDWORKS Inspection.

    Для получения дополнительных сведений о FlexNet см. Руководство по администрированию лицензий FlexNet Publisher в каталоге установки SolidNetWork License Manager (\Docs\flexuser\fnp_LicAdmin.pdf).

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Контроль времени простоя лицензии

С помощью SolidNetWork License Manager программа SOLIDWORKS может регистрировать время простоя. Таким образом, лицензии, которые не используются в течение определенного времени, возвращаются в пул свободных лицензий.

  1. В каталоге установки SolidNetWork License Manager создайте текстовый файл:
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. Добавьте следующую строчку в файл:
    TIMEOUTALL seconds

    где секунды – минимальное допустимое время, выраженное числом, большим или равным 900 (15 минут).

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Использование временной лицензии

Можно использовать временную лицензию "any", если лицензия SolidNetWork недоступна.

По умолчанию SolidNetWork License Manager может активировать только один сервер за раз. Для работы в среде испытаний можно приобрести файл временной лицензии через отдел технической поддержки и загрузить лицензию "any" в SolidNetWork License Manager на другом сервере. При работе с автономным сервером можно использовать те же инструкции для загрузки лицензии, не требующей активации.

Используя файл лицензии "any", пользователь подтверждает свое согласие на внедрение традиционной лицензии при получении лицензии SolidNetWork от корпорации Dassault Systèmes SOLIDWORKS Corporation. Требуется соблюдать лицензионные ограничения.

Чтобы использовать лицензию "any":

  1. Запустите SolidNetWork License Manager, выбрав Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Manager версия.
  2. При запросе на активацию нажмите Нет.
  3. На вкладке "Администрирование сервера" нажмите Дополнительные параметры > Параметры.
  4. В разделе "Режим лицензирования на сервере SolidNetWork" нажмите Использовать файл лицензии и OK.
  5. На вкладке "Администрирование сервера" в разделе Информация о лицензии нажмите Изменить.
    Отобразится диалоговое окно Лицензионный помощник SolidNetWork.
  6. В разделе Тип сервера выберите Один и нажмите кнопку Далее.
  7. Выберите Идентификатор ключа и введите Any или Адрес NIC для указания информации о сервере. Затем нажмите Далее.

    Нажмите Отмена при появлении следующего сообщения: Не удалось прочитать идентификатор ключа,

    Если на компьютере используется брандмауэр, может потребоваться задать дополнительные требования. Для получения дополнительной информации см. Использование лицензий SolidNetWork License с брандмауэрами.
  8. В разделе "Лицензии" нажмите Прочесть, чтобы прочесть файл лицензии.
  9. В диалоговом окне Чтение перейдите к файлу SNL_ANY.txt или SNL_(NIC Card Number).txt, предоставленному отделом технической поддержки, и нажмите Открыть. Затем нажмите OK.
    Лицензионный помощник SolidNetWork перечисляет лицензии из текстового файла.
    Нажмите Удалить, чтобы удалить записи временных лицензий, срок действия которых истек.
  10. Нажмите Готово, чтобы закрыть Лицензионный помощник SolidNetWork.
  11. Активируйте лицензию "any":
    1. На вкладке "Администрирование сервера" нажмите Дополнительные параметры > Параметры.
    2. В разделе "Режим лицензионного сервера SolidNetWork" выберите Использовать файл лицензии и нажмите кнопку OK.
    3. На вкладке "Администрирование сервера" нажмите Изменить > Активировать/деактивировать лицензии на продукт.
    4. Выберите Серийный номер, введите контактную информацию и выберите способ активации. Следуйте инструкциям при выборе активации вручную.
    5. Нажмите Готово для подтверждения активации.
На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Использование лицензий SolidNetWork с приложениями

С помощью SolidNetWork License Manager можно распространять лицензии на основные дополнения SOLIDWORKS.

  • Равное количество лицензий SOLIDWORKS и лицензий для добавлений SOLIDWORKS не требуется.
  • Чтобы получить лицензию на приложение, следует сначала получить лицензию на программу SOLIDWORKS.
  • Чтобы заимствовать лицензию на добавление, необходимо сначала заимствовать обе лицензии: лицензию на программу SOLIDWORKS и лицензию на продукт SOLIDWORKS, в который входит нужное добавление. По умолчанию заимствуется лицензия SOLIDWORKS Standard. Для поддержки дополнений необходимо заимствовать лицензию SOLIDWORKS Professional, SOLIDWORKS Premium или SOLIDWORKS Ultimate.
  • Чтобы освободить лицензию на приложение:
    • В SOLIDWORKS выберите Инструменты > Дополнения и снимите флажок текущего дополнения.
    • Выйдите из программы SOLIDWORKS.
На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License

Пользователи лицензий SolidNetWork License могут управлять лицензиями SOLIDWORKS® Simulation в своем пуле лицензий, которые будут использоваться после добавления в SOLIDWORKS Simulation. Кроме того, можно обновить лицензию SOLIDWORKS Simulation, не выгружая дополнение, если требуется лицензия более высокого уровня для более сложных исследований.

  1. Чтобы использовать специальную лицензию SOLIDWORKS Simulation, выполните следующие действия.
    1. В SOLIDWORKS выберите Инструменты > Дополнения. Затем в диалоговом окне Дополнение выберите SOLIDWORKS Simulation.
    2. В SOLIDWORKS Simulation (CommandManager) нажмите на стрелку вниз [image], чтобы отобразить список лицензий на сервере, который поддерживает Simulation.

    3. Выберите соответствующую лицензию SOLIDWORKS Simulation.
  2. Чтобы проверить или изменить текущую лицензию SOLIDWORKS Simulation, нажмите на стрелку вниз [image] в SOLIDWORKS Simulation (CommandManager).

    Используемая лицензия помечена флажком. Если доступны дополнительные типы лицензий, можно выполнить обновление.
    Понизить уровень лицензии SOLIDWORKS Simulation невозможно. Отключите дополнение SOLIDWORKS Simulation и добавьте лицензию на более низком уровне.
  3. Необязательно: Чтобы отключить дополнение, нажмите SOLIDWORKS Simulation (CommandManager) или отмените выбор в меню Инструменты > Дополнения.
В следующих случаях по-прежнему учитывается порядок лицензий:
  • При запуске SOLIDWORKS Simulation.
  • Если дополнение SOLIDWORKS Simulation добавлено в меню Инструменты > Дополнения.
  • Если дополнение SOLIDWORKS Simulation выбрано без указания лицензии в раскрывающемся списке.
На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Загрузка модулей Flow Simulation

Пользователь лицензии SolidNetWork License может загрузить модули дополнений HVAC и Electronics Cooling для Flow Simulation двумя способами.

Первый способ позволяет задать поведение дополнений по умолчанию при загрузке Flow Simulation. Параметр Автоматически загружать модули дополнения Flow Simulation при наличии находится на вкладке Клиент SolidNetWork License Manager > Порядок лицензий. Снимите этот флажок, если дополнения Flow Simulation не требуются. Модули дополнений HVAC и Electronics Cooling не загружаются при добавлении Flow Simulation существующими способами.

Второй способ позволяет переопределить поведение по умолчанию и включить модули дополнений HVAC и Electronics Cooling при загрузке Flow Simulation. Нажмите на стрелку вниз [image] в SOLIDWORKS Flow Simulation (панель инструментов "Дополнения" SOLIDWORKS®) или в SOLIDWORKS Flow Simulation с одним или обоими загружаемыми модулями дополнений.

Без этих способов лицензии модулей дополнений используются независимо от того, нужны они или нет, и могут быть недоступны другим пользователям в сети.

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics

При запуске исследований SOLIDWORKS Simulation, Plastics или Flow Simulation сетевые лицензии остаются активными и не выключаются из-за тайм-аута. SOLIDWORKS сохраняет лицензии во время процесса вычислений, который считается активностью.

Периоды бездействия, определяемые параметром ТАЙМ-АУТ, вступают в силу только после завершения вычислений в исследованиях.

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Установка Менеджера лицензий и администрирующего образа на одном компьютере

Можно настроить один сетевой компьютер в качестве менеджера лицензий, распределяющего лицензии SolidNetWork, и местоположения администрирующего образа, из которого пользователи смогут устанавливать программу SOLIDWORKS.

Клиентские компьютеры могут получить лицензии из Менеджера лицензий и затем установить программу SOLIDWORKS с компьютера, на котором он установлен.

Для выполнения этой настройки Менеджер лицензий и администрирующий образ должны быть установлены на одном компьютере. Сначала установите Менеджер лицензий, а затем создайте и разверните администрирующий образ.
Для получения дополнительной информации см.:
  • Установка сервера SolidNetWork License Manager
  • Внедрение на нескольких клиентах
На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Удаление SolidNetWork License Manager
Система управления лицензиями FlexNet Publisher


Удаление SolidNetWork License Manager

При обновлении SolidNetWork License Manager необходимо удалить устаревшую версию менеджера лицензий перед установкой новой версии.

  1. Запустите SolidNetwork License Manager, выбрав Пуск > Инструменты SOLIDWORKS версия > Сервер SolidNetWork License Manager версия.
  2. Убедитесь, что ни на одном из подключенных к сети клиентских компьютеров не запущена программа SOLIDWORKS.
    На вкладке Использование лицензий отображаются клиенты, на которых запущена программа SOLIDWORKS.
  3. Если требуется перенести лицензию SolidNetWork на другой компьютер, деактивируйте лицензию на этом компьютере до удаления SolidNetWork License Manager.
    Информацию о переносе лицензий SolidNetWork см. в разделе Перенос лицензии SolidNetWork.
  4. На вкладке Администрация сервера в разделе Лицензионный сервер выберите Стоп.
  5. Нажмите кнопку OK, чтобы выйти из Менеджера лицензий.
  6. В ОС Windows откройте Панель управления > Программы и компоненты.
  7. Выберите SOLIDWORKS SolidNetWork License Manager, нажмите Удалить и подтвердите удаление.
  8. В Проводнике файлов удалите папку SOLIDWORKS SolidNetWork License Manager.
    (Как правило, эта папка находится в папке Program Files (x86) в каталоге установки SOLIDWORKS.)

Теперь можно установить новую версию Менеджера лицензий. Дополнительные сведения см. в разделе Установка сервера SolidNetWork License Manager.

Если компьютер с SolidNetWork License Manager обладает аппаратным ключом, извлеките аппаратный ключ перед установкой новой версии SolidNetWork License Manager.
На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Система управления лицензиями FlexNet Publisher
Установка сервера SolidNetWork License Manager


Система управления лицензиями FlexNet Publisher

Лицензирование SolidNetWork основано на системе управления лицензиями FlexNet Publisher®.

Дополнительную информацию о системе управления лицензиями FlexNet Publisher см. в Руководстве по администрированию лицензий FlexNet Publisher в каталоге установки SolidNetWork License Manager: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

Для получения последней информации о системе управления лицензиями FlexNet Publisher обратитесь в Flexera® Software.

Версию FlexNet можно проверить, просмотрев журнал на сервере лицензий. Откройте сервер менеджера лицензий SolidNetwork License Manager Server и нажмите Администрирование сервера > Просмотреть журнал. В журнале в начале списка в скобках указана версия лицензирования FlexNet.

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Установка обзора лицензий SolidNetWork
Запуск SolidNetWork License Manager
Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Удаление файлов лицензий SolidNetWork License
Заимствование и возврат лицензий SolidNetWork
Управление доступом к версиям SOLIDWORKS
Контроль времени простоя лицензии
Использование временной лицензии
Использование лицензий SolidNetWork с приложениями
Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License
Загрузка модулей Flow Simulation
Тайм-аут из-за неактивности для SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation и SOLIDWORKS Plastics
Установка Менеджера лицензий и администрирующего образа на одном компьютере
Удаление SolidNetWork License Manager


Устранение неполадок

Ознакомление с этими темами поможет в выявлении и устранении проблем, связанных с установкой.

Содержание

  • Использование лицензий в сетевом окружении

  • Файлы журнала Менеджера установки SOLIDWORKS

    Файлы журнала Менеджера установки SOLIDWORKS помогают выявлять и устранять проблемы, связанные с установкой.

  • Папка загрузки Менеджера установки SOLIDWORKS

    Менеджер установки SOLIDWORKS может загрузить необходимые файлы установки в указанную Вами папку. Данная статья дает ответы на часто задаваемые вопросы о папке загрузки.

  • Устранение неполадок с лицензиями SolidNetWork License

    Если не удается установить SolidNetWork License Manager, возможны следующие причины.

  • Устранение неполадок, возникающих при обновлении программы

    Если во время обновления программы SOLIDWORKS до новой версии возникают проблемы, возможны следующие причины.

  • Проверка видеокарт при установке и обновлении

    После установки или обновления SOLIDWORKS запустите программу SOLIDWORKS Rx и убедитесь, что на компьютере установлена поддерживаемая видеокарта и соответствующий драйвер.


Использование лицензий в сетевом окружении

Это диалоговое окно открывается, когда на сервере отсутствуют лицензии для продукта.

Щелкните стрелку в поле Продукт , чтобы отобразить все продукты, доступные для выбора. В их число входит программное обеспечение SOLIDWORKS и все приобретаемые приложения.

Число лицензий — это общее количество приобретенных лицензий.

Свободные лицензии — это количество лицензий, которые в настоящий момент не используются.

Поле Кто использует лицензии содержит информацию о каждом пользователе, который в настоящий момент использует лицензию.

На уровень выше Устранение неполадок
Файлы журнала Менеджера установки SOLIDWORKS
Папка загрузки Менеджера установки SOLIDWORKS
Устранение неполадок с лицензиями SolidNetWork License
Устранение неполадок, возникающих при обновлении программы
Проверка видеокарт при установке и обновлении


Файлы журнала Менеджера установки SOLIDWORKS

Файлы журнала Менеджера установки SOLIDWORKS помогают выявлять и устранять проблемы, связанные с установкой.

Эти файлы журнала хранятся вместе с файлами журналов других приложений SOLIDWORKS.

  • C:\Users\username\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

При запуске Менеджера установки из системной учетной записи журналы хранятся в этой папке:
  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version
Чтобы просмотреть каталоги файлов журнала, необходимо настроить параметры папки Windows для отображения скрытых файлов и папок.

Если данные приложения находятся на диске, отличном от C:, настройте путь к каталогу соответствующим образом.

Этот каталог содержит файл SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt , общий журнал работы Менеджера установки SOLIDWORKS.

Более подробная информация о журнале установки содержится в подкаталоге Другие журналы.

На уровень выше Устранение неполадок
Использование лицензий в сетевом окружении
Папка загрузки Менеджера установки SOLIDWORKS
Устранение неполадок с лицензиями SolidNetWork License
Устранение неполадок, возникающих при обновлении программы
Проверка видеокарт при установке и обновлении


Папка загрузки Менеджера установки SOLIDWORKS

Менеджер установки SOLIDWORKS может загрузить необходимые файлы установки в указанную Вами папку. Данная статья дает ответы на часто задаваемые вопросы о папке загрузки.

Вопрос Ответ
Как установить файлы в этой папке?

Запустите setup.exe. Возможно, Вам придется загрузить некоторые файлы, если Вы выберете установку ранее незагруженных объектов.

Не следует выполнять установку с помощью msiexec (см. ниже).
Можно установить файлы MSI вручную из этой папки, используя msiexec или какую-либо другую программу?

Нет. С помощью Менеджера установки нельзя загрузить некоторые файлы, которые потребуются при запуске msiexec.
Можно ли выбирать одну и ту же папку загрузки для каждой устанавливаемой мной версии?

Папки скачивания относятся к определенной версии. Менеджер установки SOLIDWORKS автоматически создает в указанной папке подпапку, относящуюся к соответствующей версии.

Некоторых продукты загружены мной вручную с веб-сайта корпорации Dassault Systèmes SOLIDWORKS. Можно ли установить это с помощью Менеджера установки?
Скачанные вручную файлы можно использовать с помощью Менеджера установки SOLIDWORKS. Однако лучше запустить Менеджер установки SOLIDWORKS, выбрав вариант для скачивания файлов. В Менеджере установки SOLIDWORKS отображаются необходимые файлы на основе устанавливаемых продуктов с предоставлением ссылок для скачивания каждого файла. Этот вариант можно использовать, когда страница скачивания не работает (чаще всего по причине ограничений скачивания, установленных полномочным сервером).
Если отображается диалоговое окно с запросом на сохранение или запуск файлов во время скачивания или установки, всегда указывайте Сохранить.
Могут ли загруженные мною файлы использоваться другими пользователями?

Да. Для этого загрузите файлы в общедоступный сетевой ресурс. Каждый клиент сможет запустить Менеджер установки SOLIDWORKS с этого ресурса для проведения локальной установки.

Дальнейшее скачивание не потребуется, пока пользователь не выберет несколько элементов для установки, которые не были выбраны ранее во время первоначальной установки, или если компьютер, с которого выполняется скачивание файлов для установки, имеет набор требований, отличный от набора требований компьютера, на который выполняется скачивание файлов.

Если вы скачиваете файлы для других пользователей, но не устанавливаете их, выберите параметр Только скачать при установке. Этот параметр позволяет выбирать продукты вне зависимости от того, какие из них пользователь может установить на своем компьютере. Однако пользователь не сможет использовать этот вариант для скачивания пакетов или создания администрирующих образов.
Как узнать, когда станет доступна новая версия продуктов SOLIDWORKS?
Вы будете извещены о наличии новых версий в следующих случаях:
  • при запуске функции Проверить наличие обновлений ( Пуск > Менеджер установки SOLIDWORKS > Проверить наличие обновлений)
  • При использовании фонового загрузчика SOLIDWORKS
  • при выборе установленной версии SOLIDWORKS в Windows Установка и удаление программ и нажатии кнопки Изменить;
  • при запуске более ранней версии Менеджера установки (sldIM.exe) из папки скачивания.
В этих случаях можно выбрать скачивание более новой версии. Будут выполнены скачивание и запуск более новой версии Менеджера установки SOLIDWORKS, а не установочных файлов. После запуска более новой версии Менеджера установки SOLIDWORKS можно выбрать параметры установки. Менеджер установки SOLIDWORKS определяет необходимые установочные файлы, которые не были скачаны ранее, и предложит скачать эти файлы.
Менеджер установки SOLIDWORKS не разрешает выбрать другой пакет обновления продукта для установки.

Каждая версия Менеджера установки SOLIDWORKS предназначена для установки только определенной версии продуктов SOLIDWORKS. Если вы хотите установить другой пакет обновления, вы должны запустить соответствующую версию Менеджер установки SOLIDWORKS. Процедуру поиска последней доступной версии см. в предыдущем пункте.
Менеджер установки SOLIDWORKS не позволяет выполнять загрузку файлов.

Если из-за ограничений полномочного сервера с помощью приложений нельзя загрузить файлы, Менеджер установки SOLIDWORKS не может выполнить загрузку файлов автоматически.

Файлы можно загрузить вручную и затем установить их с помощью Менеджера установки SOLIDWORKS. В Менеджере установки SolidWorks выберите параметр для загрузки отдельных файлов (например, Провести загрузку вручную на странице Параметры загрузки). На основе выбранного продукта и системных требований веб-страница отображается в отдельном окне, содержащем ссылки для загрузки всех необходимых фалов вручную.
Не все продукты SOLIDWORKS обновляются до последнего пакета обновлений. Почему функция «Проверить наличие обновлений» сообщает, что установлена последняя версия?

Параметр Проверить наличие обновлений сообщает об установке (или запуске) последней версии Менеджера установки SOLIDWORKS.

Если необходимо обновить все продукты до последних версий, в окне Панель управления > Программы > Программы и компоненты выберите последнюю установленную версию SolidWorks и нажмите Изменить.
Можно ли скопировать DVD в папку загрузки?

Да, но установка может дать сбой, если Вы не скопируете все содержимое каждого DVD, выпущенного для соответствующей платформы. Менеджер установки SOLIDWORKS выполняет поиск файлов swdata*.id для определения версии. При отсутствии этих файлов Менеджер установки не сможет распознать скопированные пользователем установочные файлы и потребует скачать их.
На уровень выше Устранение неполадок
Использование лицензий в сетевом окружении
Файлы журнала Менеджера установки SOLIDWORKS
Устранение неполадок с лицензиями SolidNetWork License
Устранение неполадок, возникающих при обновлении программы
Проверка видеокарт при установке и обновлении


Устранение неполадок с лицензиями SolidNetWork License

Если не удается установить SolidNetWork License Manager, возможны следующие причины.

На уровень выше Устранение неполадок
Использование лицензий в сетевом окружении
Файлы журнала Менеджера установки SOLIDWORKS
Папка загрузки Менеджера установки SOLIDWORKS
Устранение неполадок, возникающих при обновлении программы
Проверка видеокарт при установке и обновлении

Доступ к файлам журнала лицензий SolidNetWork

При возникновении ошибки лицензии ее возможные причины см. в файле Каталог_установки_Менеджера_SNL\lmgrd.log.

Не удалось получить лицензию SOLIDWORKS. Не удалось связаться с лицензионным сервером.

Обычно эта проблема возникает в результате неправильной настройки портов.

  • Настройки портов компьютера с установленным Менеджером лицензий SolidNetWork и клиентского компьютера могут не совпадать.
  • Для различных версий SolidNetWork License Manager могут быть не заданы дополнительные настройки портов.
  • Убедитесь, что клиентский компьютер может точно решать проблемы и проводить маршруты к серверу, предоставляя имя сервера.
Для получения подробной информации о настройках портов для Менеджеров лицензий и клиентов SolidNetWork см. раздел Использование лицензий SolidNetWork License с брандмауэрами.
Использование лицензий SolidNetWork License с брандмауэрами


Устранение неполадок, возникающих при обновлении программы

Если во время обновления программы SOLIDWORKS до новой версии возникают проблемы, возможны следующие причины.

На уровень выше Устранение неполадок
Использование лицензий в сетевом окружении
Файлы журнала Менеджера установки SOLIDWORKS
Папка загрузки Менеджера установки SOLIDWORKS
Устранение неполадок с лицензиями SolidNetWork License
Проверка видеокарт при установке и обновлении

Изменение или исправление перемещенного источника

При установке SOLIDWORKS Менеджер установки SOLIDWORKS запоминает расположение источников установки (диск, образ диска в сети и т. д.). Ожидается, что источники будут доступны в одном месте при изменении или ремонте.

Если источник был перемещен или удален, или носитель изменился, Менеджер установки SOLIDWORKS выводит сообщение об ошибке. Однако вы можете продолжить процесс обновления путем перехода в другое расположение, если оно содержит те же файлы и структуру папок.


Проверка видеокарт при установке и обновлении

После установки или обновления SOLIDWORKS запустите программу SOLIDWORKS Rx и убедитесь, что на компьютере установлена поддерживаемая видеокарта и соответствующий драйвер.

Для проверки видеокарт при установке или обновлении:

  1. После завершения установки и при отображении страницы с кнопкой Готово перейдите в раздел Проверка системы и нажмите Запустить диагностику системы.

    Запустится программа SOLIDWORKS Rx и начнет диагностику.

  2. SOLIDWORKS Rx проверяет, поддерживается ли текущая видеокарта и соответствующий драйвер.
    Если видеокарта поддерживается, а драйвер нет, отобразится статусное сообщение со ссылкой на обновленный драйвер.

При каждом десятом запуске программы SOLIDWORKS будет отображаться сообщение Проверка системы с предложением провести повторную диагностику. Чтобы отключить уведомления, нажмите правой кнопкой мыши на значок SOLIDWORKS Resource Monitor [image] в области уведомлений Windows и выберите Закрыть графические уведомления.

Видеокарту и драйвер можно проверить в любое время. Для этого нажмите правой кнопкой мыши на значок SOLIDWORKS Resource Monitor в области уведомлений Windows. Через меню также можно выполнить следующие действия:
  • Вызвать Справку для SOLIDWORKS Resource Monitor
  • Запустить диагностику системы
  • Закрыть графические уведомления
  • Закрыть уведомления о подписке
  • Просмотр сертифицированных графических драйверов
На уровень выше Устранение неполадок
Использование лицензий в сетевом окружении
Файлы журнала Менеджера установки SOLIDWORKS
Папка загрузки Менеджера установки SOLIDWORKS
Устранение неполадок с лицензиями SolidNetWork License
Устранение неполадок, возникающих при обновлении программы


Справка Менеджера установки SOLIDWORKS

Менеджер установки SOLIDWORKS является отдельным приложением, которое устанавливает и обновляет продукты SOLIDWORKS.

Менеджер установки SOLIDWORKS является основным инструментом для скачивания, установки, изменения, обновления, восстановления и удаления программного обеспечения SOLIDWORKS.

Менеджер установки SOLIDWORKS можно запустить следующим образом:
  • С диска SOLIDWORKS DVD, из общей папки или папки загрузки (при установке новой версии)
  • Со страницы Установка и удаление программ панели управления (при изменении или удалении существующей версии)
  • При проверке в процессе запланированного или выполняемого вручную обновления (во время удаления, загрузки и установки новых версий)

Каждая версия SOLIDWORKS имеет собственную особую версию Менеджера установки SOLIDWORKS.

Содержание

  • SOLIDWORKS Фоновый загрузчик

    Фоновый загрузчик SOLIDWORKS автоматически скачивает файлы при помощи фоновых процессов (например, в случае обнаружения новой версии пакета обновления), благодаря чему пользователь во время скачивания может заниматься другими делами. По завершении скачивания пользователь может решить, выполнить ли установку немедленно, отложить установку или удалить скачанные файлы.

  • Определение параметров Менеджера установки

    Эти параметры включают настройки записи журнала, доступа в Интернет и языка, используемого в Менеджере установки.

  • Проверить результаты обновлений

    При проверке обновлений выполняется поиск последних версий SOLIDWORKS.

  • Месторасположение администрирующего образа

    Указывает месторасположение администрирующего образа.

  • Параметры загрузки

    Укажите сведения для выполнения загрузки, такие как местоположение загружаемых файлов, способ загрузки и необходимость установки этих файлов.

  • Параметры загрузки файлов Менеджера установки SOLIDWORKS

    Вы выбрали загрузить последнюю версию Менеджера установки SOLIDWORKS. На этом экране можно указать место и способ загрузки.

  • Загрузка файлов установки продукта

    Укажите, куда и каким образом загрузить отсутствующие файлы для указанного продукта.

  • Статус загрузки

    Менеджер установки SOLIDWORKS загружает, проверяет и извлекает все файлы во время процесса загрузки.

  • Результаты загрузки

    Здесь указывается состояние загрузки: успешное завершение, ошибка или отмена.

  • Ошибки установки/Отмена установки

    При установке обнаружена ошибка или она была отменена.

  • Установка завершена

    Менеджер установки SOLIDWORKS завершил свою работу.

  • Местоположение установки

  • Параметры обновления

    На компьютере установлена одна или несколько более ранних основных версий SOLIDWORKS. Можно создать новую установку, которая будет работать с более ранней версией, или можно выполнить обновление, которое удалит старую версию.

  • Ход выполнения установки

    Этот экран отображает ход выполнения установки.

  • Тип установки

    Можно указать операцию установки, которую необходимо выполнить. Например, создание новой установки, изменение или исправление существующей установки, создание администрирующего образа, установка продуктов для сервера администрирования или скачивание файлов для совместного использования и установки на другие компьютеры.

  • Установка и управление для нескольких компьютеров

    Менеджер установки SOLIDWORKS обеспечивает следующие инструменты для установки и управления несколькими компьютерами, на которых установлена программа SOLIDWORKS.

  • Загрузка вручную

    Вы выбрали загрузку файлов вручную (или загрузка вручную задана при последнем запуске Менеджера установки SOLIDWORKS).

  • Доступные более новые версии

    Менеджер установки обнаружил более новую версию продуктов SOLIDWORKS. Вы можете установить версию, содержащуюся на исходном DVD или в исходной загрузке, или можно загрузить и установить более новую версию.

  • Новые версии не доступны

    Новые версии не доступны для загрузки. Продолжите установку указанной версии.

  • Обнаружены процессы

    Менеджер установки SOLIDWORKS обнаружил на этом компьютер процессы, которые могут препятствовать установке.

  • Выбор продуктов

    Можно указать компоненты продукта для установки, изменения, скачивания и удаления.

  • Продукты для загрузки

    Выберите продукты SOLIDWORKS для загрузки в указанное месторасположение.

  • Продукты для исправления

    Если задан параметр Исправить эту установку, на экране отображаются те продукты SOLIDWORKS с номерами версий, которые можно исправить с помощью данной версии Менеджера установки SOLIDWORKS.

  • Серийные номера

    Серийные номера связывают ваш компьютер с приобретенными продуктами SOLIDWORKS.

  • Установка сервера

    При использовании этого параметра отобразится список устанавливаемых серверов с результатами установки.

  • Сводка

    В Менеджере установки SOLIDWORKS имеется вся информация, необходимая для выполнения операции установки.

  • Предупреждения проверки системы

    При проверке системы обнаружены ошибки, которые могут повлиять на дальнейший процесс установки. В большинстве случаев можно будет продолжить установку с помощью Менеджера установки SOLIDWORKS.

  • Параметры Отверстия под крепеж/Toolbox

    В случае установки SOLIDWORKS Toolbox, в состав SOLIDWORKS будет включена стандартная библиотека типов отверстий и оборудования.

  • Установка продуктов

    Если выбрать Удалить или Отменить установку на панели управления, на экране отобразятся продукты SOLIDWORKS (с номерами версий), которые можно удалить с помощью данной версии Менеджера установки SOLIDWORKS. Можно выбрать вариант отмены установки: стандартная, по выбору и полная.


SOLIDWORKS Фоновый загрузчик

Фоновый загрузчик SOLIDWORKS автоматически скачивает файлы при помощи фоновых процессов (например, в случае обнаружения новой версии пакета обновления), благодаря чему пользователь во время скачивания может заниматься другими делами. По завершении скачивания пользователь может решить, выполнить ли установку немедленно, отложить установку или удалить скачанные файлы.

Фоновый загрузчик SOLIDWORKS включается по умолчанию при установке SOLIDWORKS.

При запуске Менеджера установки SOLIDWORKS для выполнения установки или загрузки файлов работа Фонового загрузчика SOLIDWORKS приостанавливается. В частности, будет приостановлена загрузка любых файлов, запрещены запуск новых загрузок и изменение выбранной папки загрузки

Во время установки можно отключить фоновый загрузчик. На странице "Сводка" в разделе "Параметры скачивания" снимите флажок Использовать фоновый загрузчик для будущих пакетов обновления.

Если включено, этот значок появляется в области уведомлений на панели задач Windows:

Нажмите на этот значок, чтобы выполнить следующие операции:
  • Помощь с Фоновым загрузчиком
  • Приостановка скачивания
  • Продолжить скачивание
  • Отмена скачивания
  • Параметры установки
  • Изменить настройки скачивания
  • Проверить наличие обновлений
  • Автоматически проверять наличие обновлений
  • Автоматически скачивать обновления
  • Отключить Фоновый загрузчик

Помощь с Фоновым загрузчиком

Открывает раздел справки по фоновому загрузчику в Руководстве по установке SOLIDWORKS.

Приостановка/Продолжение загрузки

Если скачивание выполняется в фоновом режиме, нажмите Приостановка скачивания, чтобы приостановить скачивание данного фала. Скачивание можно возобновить позднее, нажав Продолжить скачивание.

Отмена загрузки

Позволяет остановить выполняемую загрузку и удалить любые файлы, которые уже были загружены при помощи Фонового загрузчика.
Возобновить отмененную загрузку невозможно.

Параметры установки

По завершении скачивания можно выбрать следующие действия:
  • Установить сейчас: Скачанные файлы устанавливаются.
  • Напомнить потом: Скачанные файлы не устанавливаются, однако настраивается сообщение с напоминанием.
  • Удалить скачанные файлы: Скачанные файлы не устанавливаются, а удаляются. (Этот параметр полезен, если пользователь передумал устанавливать скачанные файлы).

Изменить настройки скачивания

Изменение расположения файлов, скачиваемых при помощи Фонового загрузчика.

Этот параметр недоступен, если загрузка выполняется или приостановлена.
Также можно указать Количество дней между проверками обновлений.

Проверить наличие обновлений

Запускает средство Проверить наличие обновлений в Менеджере установки SOLIDWORKS.

Автоматически проверять наличие обновлений

Периодически запускает средство Проверить наличие обновлений, уведомляя пользователя о том, что обновления доступны для скачивания.

Автоматически загружать обновления

Периодически запускает средство Проверить наличие обновлений, скачивающее доступные обновления.

Отключение и повторное включение Фонового загрузчика SOLIDWORKS

Вы можете отключить Фоновый загрузчик, нажав на значок на панели задач Windows и выбрав Отключить фоновый загрузчик.

Чтобы снова включить фоновый загрузчик, нажмите Пуск > Менеджер установки SOLIDWORKS > Фоновый загрузчик SOLIDWORKS.

На уровень выше Справка Менеджера установки SOLIDWORKS


Определение параметров Менеджера установки

Эти параметры включают настройки записи журнала, доступа в Интернет и языка, используемого в Менеджере установки.

Чтобы определить параметры Менеджера установки перед установкой программного обеспечения, выполните следующие действия.

  1. В Менеджере установки нажмите правой кнопкой мыши на значок SOLIDWORKS в строке заголовка и выберите:
    Опция | Описание
    Уровень записи установки в журнал Установка уровня регистрации: Высокий, Средний или Низкий. Более высокие уровни собирают больше данных для поиска и устранения неисправностей, но могут замедлить установку. По умолчанию выбрано значение Низкая (самая быстрая), что обеспечивает наилучшую производительность и стабильность.

    При Создать журналы установок Windows (Медленно) эти журналы сохраняются в той же папке, что и другие журналы установки.
    Параметры Администрирующего образа | Выберите Использовать короткие имена файлов (формат 8.3) или Использовать полные имена папок и файлов.
    Сбор журналов установки | Определяет место хранения журналов установки. Менеджер установки хранит эти файлы в IM_Logs.zip.
    Отключить доступ к Интернету
    Язык | Установка языка, используемого для Менеджера установки. По умолчанию используется английский язык.
  2. Нажмите Закрыть.
На уровень выше Справка Менеджера установки SOLIDWORKS


Проверить результаты обновлений

При проверке обновлений выполняется поиск последних версий SOLIDWORKS.

Если у вас есть полномочия администратора на компьютере, можно запустить Проверить наличие обновлений вручную:
  • В Windows выберите Пуск > Менеджер установки SOLIDWORKS > Проверить наличие обновлений
  • В SOLIDWORKS выберите [image] > Проверить наличие обновлений
Функция "Проверить наличие обновлений" недоступна на клиентах, установленных с помощью администрирующих образов.

Доступные новые версии

Менеджер установки SOLIDWORKS обнаружил более новую версию продуктов SOLIDWORKS. Можно выполнить обновление до более новой версии, выбрав Менеджер установки SOLIDWORKS для этой версии.

С помощью этой более поздней версии можно загрузить файлы установки для продуктов, указанных в установке. Вы можете сделать загруженные файлы общими для других пользователей, которые используют для процесса установки Менеджер установки SOLIDWORKS.

Эти загружаемые файлы предназначены только для Менеджера установки SOLIDWORKS.
Доступны эти параметры:
  • Если доступны несколько версий, то вы сможете выбрать нужную вам версию в списке.
  • Для получения более подробной информации об этой версии выберите Отметить, чтобы просмотреть, что включено в это обновление.
При нажатии кнопки Далее загружается и запускается выбранная версия Менеджера установки SOLIDWORKS.

Нет доступных новых загрузок/Не удалось проверить наличие новых версий

Менеджер установки не нашел более позднюю версию продуктов SOLIDWORKS, потому что устанавливается последняя версия или потому что не удалось установить подключение к сайту SOLIDWORKS для проверки.

На уровень выше Справка Менеджера установки SOLIDWORKS


Месторасположение администрирующего образа

Указывает месторасположение администрирующего образа.

При создании администрирующего образа используются следующие параметры.
Местоположение нового образа | Это местоположение каталога, в котором Менеджер установки SOLIDWORKS создаст новый образ. | Этот каталог не должен содержать существующий администрирующий образ. Администрирующий образ должен находиться в папке, которую можно совместно использовать для развертывания клиента.
Приблизительный объем свободного места на диске, необходимый для создания образа | Это дополнительное пространство, которое необходимо для администрирующего образа. | Проверьте наличие на диске установки необходимого для образа свободного пространства.
Создать образ из | Это местоположение папки, из которой выполняется установка продуктов SOLIDWORKS. Этот параметр появляется, если задан параметр Только установка. Для получения дополнительной информации см. Параметры загрузки.
На уровень выше Справка Менеджера установки SOLIDWORKS


Параметры загрузки

Укажите сведения для выполнения загрузки, такие как местоположение загружаемых файлов, способ загрузки и необходимость установки этих файлов.

Менеджер установки SOLIDWORKS поддерживает электронное распределение программного обеспечения (ESD). Если вы не производите установку с DVD-диска SOLIDWORKS, вы получите запрос на указание источника устанавливаемых вами продуктов SOLIDWORKS.

Для получения ответов на вопросы о папке скачивания см. Папка загрузки Менеджера установки SOLIDWORKS.

Что необходимо сделать?

Выберите один из следующих вариантов:

Загрузить и установить/загрузить и создать образ

По завершении загрузки Менеджер установки SOLIDWORKS запустит установку с использованием загруженных файлов.

Только загрузить. Файлы можно загрузить один раз, а затем использовать их на нескольких компьютерах.

Менеджер установки SOLIDWORKS не запустит установку после завершения скачивания.

Как правило, этот параметр необходимо указать, если файлы загружаются для создания установочного набора файлов, который будет использоваться на нескольких компьютерах.

Если задан этот параметр, отобразится запрос на выбор одного из двух наборов файлов для скачивания.
  • Файлы для ДАННОГО компьютера: Будут скачаны только те файлы, которые отсутствуют в установочном наборе файлов на данном компьютере.
    Объем скачанных данных будет меньше, поскольку в пакет будут включены только следующие файлы:
    • файлы продуктов, выбранных на странице "Выбор продуктов";
    • обязательные для установки на данном компьютере файлы, которые еще не были установлены.

    Однако при попытке установки загруженного установочного набора файлов на другом компьютере может оказаться, что некоторых файлов не хватает (поскольку установочный набор файлов на другом компьютере может отличаться от текущего). Эти загруженные файлы можно использовать для установки на другой компьютер, однако в ходе установки, возможно, потребуется загрузить дополнительные файлы, чтобы установить полный установочный набор файлов.

  • Файлы для использования на ЛЮБЫХ компьютерах: Будет скачан полный установочный набор файлов, который можно использовать для установки данной версии на любом компьютере.

    Объем загружаемого пакета будет больше, поскольку он содержит полный набор файлов, который можно использовать для установки данной версии продукта на любом компьютере.

    Если для загрузки определен ограниченный набор программных продуктов, при выборе этого параметра ограничение игнорируется и загружаются все программы данной версии.

    В пакет загрузки будут включены все файлы, необходимые для создания администрирующего образа, а не только те, которые требуются для индивидуальной установки.

Только установка/Только создание образа. У меня уже есть все необходимые для установки файлы.

Менеджер установки SOLIDWORKS не скачивает файлы, а использует файлы из выбранного каталога.

Нажмите кнопку Обзор, чтобы перейти в другой каталог. Например, можно перейти к установочному DVD-диску или папке скачивания, если там находятся все необходимые файлы.

Если вы получили сообщения об ошибке, в котором говорится о том, что папке не полная, и вы ожидали, что все файлы установки будут содержаться в указанном расположении, возможными объяснениями могут быть:
  • Вы выбрали компонент для установки, который не был ранее загружен или был выбран по умолчанию.
  • Файлы были загружены на компьютер с другими системными требованиями.
  • Вы ранее провели установку клиента и теперь создаете администрирующий образ, который требует большего набора файлов.

Можно перейти в папку, содержащую все файлы (например, на DVD-диске), или выбрать один из вариантов загрузки.

Куда скачать необходимые файлы?

Это местоположение папки загрузки.

В некоторых случаях этот параметр может отображаться, но быть неактивным. Например, если выбран параметр Только установка, Менеджер установки SOLIDWORKS выполнит установку скачанных файлов из каталога, указанного для этого параметра, отдельная папка скачивания использоваться не будет.

Независимо от того, выполняется ли загрузка файлов или они уже имеются на компьютере, все файлы должны быть в одной папке загрузки.

Приблизительный размер скачивания

Необходимый объем свободного пространства на диске зависит от того, какие компоненты выбраны для установки. При этом неважно, загружаются ли новые файлы или используются файлы из предыдущего сеанса.

Например, при восстановлении предыдущей загрузки Менеджер установки SOLIDWORKS обрабатывает только те файлы, которые еще не были загружены. Загрузка может занять меньше времени, чем было заявлено ранее.

Если загрузка файла выполнена в предыдущем сеансе, его размер не учитывается при приблизительной оценке. Поэтому приблизительный объем может быть выше реального размера пакета загрузки.

Как выполнять скачивание?

Провести загрузку вручную

В некоторых случаях прокси-сервер может запрещать автоматическую загрузку из Менеджера установки SOLIDWORKS.

При выборе этого параметра можно загрузить файлы с веб-страницы вручную, а затем продолжить операции установки в Менеджере установки SOLIDWORKS. Эта веб-страница настроена с помощью Менеджера установки SOLIDWORKS для загрузки только тех файлов, которые необходимы для выполнения установки.

Использование Фонового загрузчика SOLIDWORKS

Для выполнения данной операции загрузки или для загрузки дальнейших версий пакетов обновления по мере их доступности можно использовать Фоновый загрузчик SOLIDWORKS.

Фоновый загрузчик SOLIDWORKS позволяет автоматически обнаруживать и скачивать новые версии пакетов обновления в фоновом режиме. По завершению процесса пользователь уведомляется о том, что файлы скачаны и готовы к установке. Для получения дополнительной информации см. SOLIDWORKS Фоновый загрузчик.

На уровень выше Справка Менеджера установки SOLIDWORKS


Параметры загрузки файлов Менеджера установки SOLIDWORKS

Вы выбрали загрузить последнюю версию Менеджера установки SOLIDWORKS. На этом экране можно указать место и способ загрузки.

Для получения ответов на вопросы о папке скачивания см. Папка загрузки Менеджера установки SOLIDWORKS.

Этот экран открывается только в случае проблем с папкой загрузки по умолчанию (например, при отсутствии доступа для записи или сетевого доступа). Как правило, для продолжения можно указать другую папку загрузки.

Каталог загрузки

Перейдите к месторасположению для файлов Менеджера установки SOLIDWORKS.

Будет показан размер пакета загрузки и требуемый объем свободного пространства. Необходимый объем включает дополнительный объем, необходимый для распаковки некоторых загрузок, и превышает объем самой загрузки.

На уровень выше Справка Менеджера установки SOLIDWORKS


Загрузка файлов установки продукта

Укажите, куда и каким образом загрузить отсутствующие файлы для указанного продукта.

Менеджер установки SOLIDWORKS загружает, проверяет и извлекает все файлы во время процесса загрузки.

Выход из этого экрана отменяет оставшуюся часть процедуры установки.

Для получения более подробной информации о последствиях отмены и инструкций для завершения прерванных установок см. Ошибки установки/Отмена установки.

Каталог загрузки

Перейдите в месторасположение загруженных файлов.

Отображаются размер пакета загрузки и требуемое пространство. Требуемый объем свободного пространства определяется с учетом места, необходимого для распаковки, и превышает фактический размер пакета загрузки.

Для получения ответов на вопросы о папке загрузки см. Папка загрузки Менеджера установки SOLIDWORKS.

На уровень выше Справка Менеджера установки SOLIDWORKS
Ошибки установки/Отмена установки
Папка загрузки Менеджера установки SOLIDWORKS


Статус загрузки

Менеджер установки SOLIDWORKS загружает, проверяет и извлекает все файлы во время процесса загрузки.

Чтобы отменить загрузку после ее запуска, выберите параметр Отмена.

При отмене или сбое загрузки на экране Отмена загрузки или Неполадка загрузки отображается список незагруженных файлов. Можно возобновить загрузку или закрыть приложение.

Для получения ответов на вопросы о папке загрузки см. Папка загрузки Менеджера установки SOLIDWORKS.
На уровень выше Справка Менеджера установки SOLIDWORKS


Результаты загрузки

Здесь указывается состояние загрузки: успешное завершение, ошибка или отмена.

Неполадка загрузки/Загрузка отменена

Если отображается сообщение Неполадка загрузки, Менеджер установки обнаружил проблемы, препятствующие загрузке.

Если отображается сообщение Загрузка отменена, процесс загрузки был отменен до завершения.

Чтобы продолжить:

Повторить/Возобновить автоматические загрузки | Чтобы возобновить автоматическую загрузку с того места, где она была отменена, выберите этот параметр и нажмите Повторить загрузку или Возобновить загрузку.
Загрузить отдельные файлы в веб-браузере | В некоторых случаях прокси-сервер может запрещать автоматическую загрузку из Менеджера установки SOLIDWORKS. | При выборе этого параметра можно загрузить файлы с веб-страницы вручную, а затем продолжить операции установки в Менеджере установки SOLIDWORKS. Эта веб-страница настроена с помощью Менеджера установки SOLIDWORKS для загрузки только тех файлов, которые необходимы для выполнения установки.

Загрузка завершена

Экран «Загрузка завершена» отображается при завершении загрузки, если выбран параметр Только загрузить.

Нажмите кнопку Готово, чтобы выйти из Менеджера установки SOLIDWORKS.

Не следует устанавливать эти продукты вручную. Для установки загруженных файлов всегда используйте Менеджер установки SOLIDWORKS.
На уровень выше Справка Менеджера установки SOLIDWORKS


Ошибки установки/Отмена установки

При установке обнаружена ошибка или она была отменена.

Если возникла ошибка или отмена:
  • Продукты, установленные до возникновения ошибки или отмены установки, остаются на компьютере.
  • Установка продуктов, устанавливаемых во время отмены установки, если возможно, откатывается так, чтобы не оставалось частично установленных продуктов.
  • Установка или отмена установки оставшихся продуктов выполняться не будет. Список отобразится в разделе Попытка не была сделана.

    Чтобы возобновить установку или отмену установки этих продуктов, щелкните предоставленную ссылку.

Менеджер установки SOLIDWORKS сначала выполнит установку всех обязательных компонентов, не установленных на компьютере, например .NET framework.

Содержание

  • Восстановление после неудачной или отмененной установки

    Если во время установки возникнет ошибка или отмена, можно восстановить процесс установки с этого момента, если запустить его повторно.

  • Исправление установки

    При возникновении неполадок в установленном продукте SOLIDWORKS можно воспользоваться Менеджером установки SOLIDWORKS для исправления установки.

  • Обращение к реселлеру SOLIDWORKS

    Если не удается провести изменение или исправление установки, обратитесь к реселлеру SOLIDWORKS, собрав информацию, отображаемую на этом экране. Возможно, вам потребуется предоставить ZIP-файл, содержащий файлы журнала Менеджера установки SOLIDWORKS.

На уровень выше Справка Менеджера установки SOLIDWORKS


Восстановление после неудачной или отмененной установки

Если во время установки возникнет ошибка или отмена, можно восстановить процесс установки с этого момента, если запустить его повторно.

  1. Запишите сообщение об ошибке и код продукта для неудавшейся установки, как показано на экране Ошибки установки или Отмена установки.
    Если программа запрашивает исходный файл и вы не изменяете существующую установку SOLIDWORKS, возможно, установка или компьютер повреждены. Обратитесь к своему реселлеру SOLIDWORKS.
  2. Перезагрузите компьютер.
  3. Чтобы убедиться, что не запущены никакие продукты SOLIDWORKS, в Windows нажмите Ctr+Alt+Del, чтобы открыть диспетчер задач.
  4. Если на вкладке Процессы в разделе Имя образа отображается один из следующих процессов, выберите их и нажмите кнопку Завершить процесс.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. Если программа уже установлена, и Вы пытаетесь ее изменить или удалить, попробуйте исправить установку. Для получения дополнительных сведений см. раздел Исправление установки.
  6. В Windows откройте Пуск > Панель управления > Программы и компоненты.
  7. Выберите неисправную версию SOLIDWORKS.
    Если нет записи о версии SOLIDWORKS, которую вы пытаетесь установить, повторите процесс установки.
  8. Выполните одно из следующих действий:
    • Чтобы повторить попытку, нажмите кнопку Изменить и выберите все продукты, пропущенные во время установки или установка которых не удалась.

    • Чтобы опустить неудавшиеся установки, нажмите на кнопку Изменить и выберите все продукты, пропущенные во время установки. Удалите продукт, установка которого не удалась.

    • Чтобы отменить установку, нажмите на кнопку Удалить и выберите любые установленные продукты.
    При этом предыдущая версия обновляемых продуктов не восстанавливается.
На уровень выше Ошибки установки/Отмена установки
Исправление установки
Обращение к реселлеру SOLIDWORKS


Обращение к реселлеру SOLIDWORKS

Если не удается провести изменение или исправление установки, обратитесь к реселлеру SOLIDWORKS, собрав информацию, отображаемую на этом экране. Возможно, вам потребуется предоставить ZIP-файл, содержащий файлы журнала Менеджера установки SOLIDWORKS.

  1. Найдите файлы журнала. Для ОС Windows:
    C:\Users\имя_пользователя\AppData\Roaming\SOLIDWORKS\Installation Logs\установленная_версия\.
    Если папку найти не удается, возможно, она скрыта. В Проводнике Windows выберите Инструменты > Параметры папки. На вкладке Вид, в разделе Дополнительные параметры, выберите значение Показывать скрытые файлы, папки и дски для параметра Скрытые файлы и папки.
  2. Заархивируйте содержимое всей папки, включая и содержимое подпапок.
На уровень выше Ошибки установки/Отмена установки
Восстановление после неудачной или отмененной установки
Исправление установки


Установка завершена

Менеджер установки SOLIDWORKS завершил свою работу.

Может отображаться один или несколько этих параметров.

Новые возможности

Для индивидуальных установок при завершении процесса установки отображается документ, описывающий новые функциональности в SOLIDWORKS и его добавлениях.

Для установок с помощью администрирующего образа документ отображается на клиентских компьютерах при завершении ими установок.

SOLIDWORKS Программа отзывов клиентов

Информация по быстродействию программы посылается корпорации SOLIDWORKS с целью улучшения продукта. Процесс является прозрачным и конфиденциальным. Выберите один из указанных ниже вариантов.
  • Да, я хочу участвовать
  • Нет, спасибо
  • Напомнить потом
Дополнительную информацию см. на веб-сайте программы улучшения качества программного обеспечения.

Создание администрирующего образа завершено

По завершению создания администрирующего образа можно нажать Настройка образа для настройки параметров образа с помощью Редактора параметров администрирующего образа.

Чтобы просмотреть инструкции по использованию Редактора параметров, нажмите Показать мне, как установить этот образ на компьютере клиента.

Дополнительные сведения о настройке администрирующего образа с помощью Редактора параметров см. в разделе Редактор параметров администрирующего образа.

Нажмите Настройка образа, чтобы запустить Редактор параметров и настроить параметры администрирующего образа.
Можно запустить Редактор параметров позже, дважды нажав sldAdminOptionEditor.exe в папке SOLIDWORKS Admin.

Содержание

  • Проверка наличия обновлений SOLIDWORKS

    Если у вас есть полномочия администратора компьютера, то проверку на наличие обновлений можно выполнять вручную с помощью Менеджера установки SOLIDWORKS. Можно также настроить автоматическую проверку обновлений.

  • Программа улучшения качества программного обеспечения SOLIDWORKS

    При установке SOLIDWORKS можно задать параметр отправки информации о производительности в корпорацию SOLIDWORKS, которая поможет улучшить продукт.

На уровень выше Справка Менеджера установки SOLIDWORKS
Редактор параметров администрирующего образа


Проверка наличия обновлений SOLIDWORKS

Если у вас есть полномочия администратора компьютера, то проверку на наличие обновлений можно выполнять вручную с помощью Менеджера установки SOLIDWORKS. Можно также настроить автоматическую проверку обновлений.

  1. Запустите Менеджер установки SOLIDWORKS, выполнив одно из следующих действий:

    • В приложении SOLIDWORKS нажмите Справка > Проверить наличие обновлений.

    • В ОС Windows выберите Пуск > Все программы > Менеджер установки SOLIDWORKS > Проверить наличие обновлений.

    Можно также нажать Пуск > Менеджер установки SOLIDWORKS > Фоновый загрузчик SOLIDWORKS. В области уведомлений Windows нажмите правой кнопкой мыши на пункт Фоновый загрузчик SOLIDWORKS и выберите Проверить наличие обновлений.
    В окне Менеджера установки SOLIDWORKS отобразятся сведения о том, доступны ли обновления.
  2. Если да, то выберите их загрузку или установку.
  3. Чтобы задать автоматические периодические проверки на наличие обновлений, по завершении обработки, выполняемой Менеджером установки SOLIDWORKS, выберите Проверять наличие обновлений каждые __ дней и задайте периодичность проверок.
На уровень выше Установка завершена
Программа улучшения качества программного обеспечения SOLIDWORKS


Программа улучшения качества программного обеспечения SOLIDWORKS

При установке SOLIDWORKS можно задать параметр отправки информации о производительности в корпорацию SOLIDWORKS, которая поможет улучшить продукт.

SOLIDWORKS использует информацию для нахождения тенденций использования продукта и его качества. Нашей целью является доставка продукта высочайшего качества, и журналы эффективности играют важную роль в этом процессе.

Процесс очень простой. Информация, содержащаяся в файлах журнала, является конфиденциальной. Эта информация не используется для иных целей, и никто не будет связываться с Вами по этому поводу.

Дополнительную информацию см. на веб-сайте Программы улучшения обслуживания клиентов.

На уровень выше Установка завершена
Проверка наличия обновлений SOLIDWORKS


Местоположение установки

В случае установки без создания администрирующего образа применимы следующие параметры.
Установить выбранные продукты в | Это расположение папки, в которую выполняется установка SOLIDWORKS. При обновлении или изменении установки все файлы необходимо устанавливать в существующую папку установки. В этом случае невозможно изменить расположение существующей установки SOLIDWORKS.
Приблизительный объем свободного пространства, необходимый для установки | Это дополнительное пространство, которое необходимо для продуктов, выбранных для установки или изменения. | Проверьте наличие на диске установки необходимого свободного пространства.
Установить из | Это расположение папки, из которой выполняется установка SOLIDWORKS. Этот параметр появляется, если задан параметр Только установка. Дополнительные сведения см. в разделе Параметры скачивания.
Перед изменением папки установки обратитесь к системному администратору SOLIDWORKS.

Местоположение администрирующего образа

При создании администрирующего образа используются следующие параметры.
Местоположение нового образа | Это расположение каталога, в котором Менеджер установки SOLIDWORKS создаст новый образ. | Этот каталог не должен содержать существующий администрирующий образ.
Приблизительный объем свободного места на диске, необходимый для создания образа | Это дополнительное пространство, которое необходимо для администрирующего образа. | Проверьте наличие на диске установки необходимого для образа свободного пространства.
Создать образ из | Это расположение папки, из которой выполняется установка продуктов SOLIDWORKS. Этот параметр появляется, если задан параметр Только установка. Дополнительные сведения см. в разделе Параметры скачивания.
Расположение существующего образа | При обновлении существующего администрирующего образа менеджер установки SOLIDWORKS создает новый образ с использованием параметров существующего образа. Существующий образ не изменяется. Этот параметр показывает расположение исходного образа, указанного на экране приветствия.

Отказ от использования путей с указанием версии

Если в названии каталога установки указать номер версии (например, C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2025\), а затем обновить установку до версии SOLIDWORKS 2026 каталог установки SOLIDWORKS 2026 будет иметь имя SOLIDWORKS 2025.

На уровень выше Справка Менеджера установки SOLIDWORKS
Параметры загрузки


Параметры обновления

На компьютере установлена одна или несколько более ранних основных версий SOLIDWORKS. Можно создать новую установку, которая будет работать с более ранней версией, или можно выполнить обновление, которое удалит старую версию.

Создайте новую установку SOLIDWORKS версия.

Если вы решите создать новую установку, можно выбрать, какие продукты SOLIDWORKS будут установлены.

Для каждого выбранного продукта будет создана новая установка этой основной версии. На компьютере остаются все более ранние основные версии, кроме SOLIDWORKS Electrical и SOLIDWORKS PDM Client.

Если удалить продукт, новая версия не будет установлена.

Создание новой установки может быть полезным в том случае, если требуется доступ к более ранней версии SOLIDWORKS даже после установки более поздней версии. Например, те или иные файлы используются вами совместно с другими пользователями, у которых установлена более ранняя версия. При этом вы избегаете несовместимости версий, если работа с этими файлами выполняется на компьютере с более поздней версией программы.

Обновить SolidWorks предыдущая_основная_версия до SolidWorks текущая_основная_версия.

Если вы решите выполнить обновление, можно выбрать, какие продукты SOLIDWORKS будут обновлены. Для каждого выбранного продукта будет создана новая установка, а более старые версии удалены.

Если отменить выбор продукта, то новая версия не устанавливается, а на компьютере остаются более ранние версии.

Примечания о SOLIDWORKS Electrical и SOLIDWORKS PDM Client

На компьютере можно установить только одну версию SOLIDWORKS Electrical. Если создается новая установка SOLIDWORKS и SOLIDWORKS Electrical выбирается в качестве одного из продуктов для установки, то прежняя версия SOLIDWORKS Electrical будет удалена.

Перед установкой новой версии следует создать резервную копию существующей среды SOLIDWORKS Electrical. В среде SOLIDWORKS Electrical Schematic выберите Файл Архивировать среду или в SOLIDWORKS Electrical 3D выберите SOLIDWORKS Electrical > Инструменты > Архивировать среду.

Основная версия клиента SOLIDWORKS PDM должна совпадать с основной версией сервера SOLIDWORKS PDM. Если вы не планируете обновлять сервер SOLIDWORKS PDM, не выбирайте клиент SOLIDWORKS PDM для обновления.

Чтобы удалить продукт, используйте в Windows команду Установка и удаление программ. Для получения дополнительной информации см. Удаление установки.
На уровень выше Справка Менеджера установки SOLIDWORKS
Удаление установки


Ход выполнения установки

Этот экран отображает ход выполнения установки.

Чтобы отменить установку после ее начала, нажмите кнопку Отмена.

Для получения более подробной информации о последствиях отмены и инструкций для завершения прерванных установок см.Ошибки установки.

На уровень выше Справка Менеджера установки SOLIDWORKS


Тип установки

Можно указать операцию установки, которую необходимо выполнить. Например, создание новой установки, изменение или исправление существующей установки, создание администрирующего образа, установка продуктов для сервера администрирования или скачивание файлов для совместного использования и установки на другие компьютеры.

Если на компьютере уже установлена последняя версия программы SOLIDWORKS, вам будут предоставлены параметры для ее изменения или исправления.

Индивидуальный

Устанавливает продукты SOLIDWORKS на данном компьютере.

Параметр появляется, только если данная версия не установлена на компьютере.

Изменение индивидуальной установки

Используя этот параметр, можно изменить существующую установку SOLIDWORKS на данном компьютере.

Параметр появляется, только если данная версия установлена на компьютере.
К изменениям относятся следующие действия:
  • добавление или удаление компонентов продукта SOLIDWORKS;
  • установка другого пакета SOLIDWORKS (например, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS Ultimate и др.);
  • изменение серийного номера SOLIDWORKS.
    Если вы уже указали серийный номер SOLIDWORKS при предварительной установке, Менеджер установки SOLIDWORKS не будет запрашивать его повторно. Чтобы изменить серийный номер, необходимо выбрать этот параметр.

Исправление индивидуальной установки

Этот параметр позволяет исправить существующую установку SOLIDWORKS на данном компьютере.

Параметр появляется, только если данная версия установлена на компьютере.
Исправление проверяет, что все файлы присутствуют и правильно зарегистрированы, и устраняет все обнаруженные ошибки. Созданные Вами данные не затрагиваются.
  • Чтобы исправить продукт, убедитесь, что он выбран.
  • Очистите все окна выбора для продуктов, которые не нуждаются в исправлении.
Можно исправить индивидуальную установку. Невозможно исправить установку с помощью администрирующего образа; необходимо выполнить установку повторно, используя администрирующий образ.

Администрирующий образ

Создание или обновление администрирующих образов для развертывания на нескольких компьютерах

Для получения сведений об установке SOLIDWORKS на нескольких клиентах с использованием администрирующих образов см. раздел Использование администрирующих образов.

При создании или обновлении администрирующих образов:
  • для настройки нового или обновленного образа можно использовать параметры установки существующего образа. Можно также использовать параметры установки SOLIDWORKS по умолчанию.
  • При обновлении существующего изображения:
    • Менеджер установки SOLIDWORKS создает новую копию изображения, даже если выполняется обновление. Исходный образ не изменяется.
    • Обновленный образ можно создать с использованием файлов существующего образа. При этом объем загружаемых данных будет меньше.
    Если образ, для которого можно применить пакет обновления, не указан, придется загрузить полный набор файлов.

Серверные продукты

К серверам SOLIDWORKS относятся SOLIDWORKS Electrical, SOLIDWORKS PDM и SolidNetWork License Manager.

Для SOLIDWORKS Electrical и SOLIDWORKS PDM можно установить средства клиента и сервера на один и тот же компьютер или на разные компьютеры.

Для получения подробной информации об установке этих серверов см. соответствующие разделы справки.

Скачивание и предоставление общего доступа ко всем файлам

Этот параметр позволяет загрузить файлы установки для выбранных продуктов SOLIDWORKS. При этом установка не выполняется.

Этот параметр не будет отображаться, если установка выполняется с DVD-диска.
Содержимое скачанных файлов совпадает с содержимым файлов на установочных DVD-дисках SOLIDWORKS. При выборе этого параметра скачивается полный набор файлов установки, независимо от того, что некоторые файлы могут быть уже установлены на компьютере. Затем можно скопировать файлы на портативное устройство или в сетевой каталог и использовать их для установки программного обеспечения SOLIDWORKS на другие компьютеры. Можно также использовать этот метод для установки сервера, с помощью которого пользователи смогут провести установки.
Данный способ отличается от создания администрирующего образа.
На уровень выше Справка Менеджера установки SOLIDWORKS
Использование администрирующих образов
Администрирование лицензий с помощью SolidNetWork License Manager
SOLIDWORKS Electrical


Установка и управление для нескольких компьютеров

Менеджер установки SOLIDWORKS обеспечивает следующие инструменты для установки и управления несколькими компьютерами, на которых установлена программа SOLIDWORKS.

Администрирующие образы SOLIDWORKS

Если Вы устанавливаете программу SOLIDWORKS на нескольких компьютерах, можно создать администрирующий образ и затем распространить программу на другие компьютеры.

SOLIDWORKS PDM

SOLIDWORKS PDM Standard представляет собой продукт для управления документацией на основе той же архитектуры, что и SOLIDWORKS Enterprise PDM. Поставляется в двух версиях: Standard и Professional. Для управления хранилищами файлов SOLIDWORKS PDM использует базу данных Microsoft SQL Server.

SolidNetWork License Manager

SolidNetWork License Manager обеспечивает работу пользователей, даже если их количество превышает количество лицензий, путем передачи лицензий в использование. В то время, когда клиентская лицензия не используется, она становится доступна для другого пользователя SOLIDWORKS.

Кроме того, можно использовать SolidNetWork License Manager для распространения основных приложений SOLIDWORKS (например, FeatureWorks).

На уровень выше Справка Менеджера установки SOLIDWORKS


Загрузка вручную

Вы выбрали загрузку файлов вручную (или загрузка вручную задана при последнем запуске Менеджера установки SOLIDWORKS).

Щелкните ссылку, чтобы открыть автоматически созданную веб-страницу с полным списком файлов для загрузки.

Необходимо выполнить загрузку в папку, указанную на странице «Сводка». Невозможно начать установку, пока все файлы не будут загружены в эту папку.

По завершении выполнения загрузки вручную нажмите кнопку Далее, чтобы продолжить.

Если необходимо выполнить загрузку автоматически, можно указать другой параметр. Для этого необходимо вернуться на страницу «Сводка» и изменить параметры загрузки.

На уровень выше Справка Менеджера установки SOLIDWORKS


Доступные более новые версии

Менеджер установки обнаружил более новую версию продуктов SOLIDWORKS. Вы можете установить версию, содержащуюся на исходном DVD или в исходной загрузке, или можно загрузить и установить более новую версию.

Если установка выполняется через загрузку

Выберите один из следующих вариантов:
  • Продолжить установку версия.

    Выберите этот параметр для продолжения установки версии, содержащейся в исходном скачивании.

  • Скачать и установить новую версию: версия.

    Выберите этот параметр, чтобы скачать и установить новую версию. Если имеется несколько новых версий, можно выбрать версию для скачивания и установки.

Если установка выполняется с DVD

В разделе Хотите использовать более новую версию? выберите один из следующих параметров.
  • Нет, продолжить установку версии с данного DVD. Можно выполнить обновление позже.

    Выберите этот параметр для продолжения установки с помощью текущего Менеджера установки.

    После завершения установки можно проверить наличие и установить обновления с помощью Менеджера установки. Для проверки обновлений выберите Пуск > Менеджер установки SOLIDWORKS > Проверить наличие обновлений.
    Пункт Проверить наличие обновлений доступен, только если вы обладаете полномочиями администратора компьютера.

    Преимущество состоит в том, что объем скачиваемых данных будет меньше. Недостатки заключаются в том, что это двухэтапный процесс, и скачанные файлы принадлежат определенной версии (и не могут быть отправлены другим пользователям, которые используют другие версии).

  • Да, провести установку с использованием этого DVD, затем скачать и обновить до версия.

    Выберите этот параметр, чтобы скачать и запустить более позднюю версию Менеджера установки для установки продуктов SOLIDWORKS для этой версии.

    При наличии небольшого пакета обновления для версии DVD Менеджер установки сначала выполнит установку исходной версии с диска DVD, а затем установит пакет обновления. При этом объем скачиваемых данных будет меньше.

    Такие же результаты будут, если выбрать продолжение установки с DVD-диска, а затем позднее установить пакет обновления.

    Преимущество заключается в том, что эта процедура выполняется в один этап.

На уровень выше Справка Менеджера установки SOLIDWORKS


Новые версии не доступны

Новые версии не доступны для загрузки. Продолжите установку указанной версии.

Для продолжения установки нажмите кнопку Далее.

На уровень выше Справка Менеджера установки SOLIDWORKS


Обнаружены процессы

Менеджер установки SOLIDWORKS обнаружил на этом компьютер процессы, которые могут препятствовать установке.

  • Чтобы продолжить установку, выполните одно из следующих действий:
    • Завершите эти процессы (например, с помощью диспетчера задач Microsoft Windows), а затем нажмите кнопку Повторить.
    • Нажмите кнопку Игнорировать, чтобы продолжить, не завершая процессов.
  • Чтобы остановить установку, нажмите кнопку Отмена.
На уровень выше Справка Менеджера установки SOLIDWORKS


Выбор продуктов

Можно указать компоненты продукта для установки, изменения, скачивания и удаления.

В списке продуктов:
  • В списке продуктов перечислены все продукты пакета, указанного над этим списком.
  • Для просмотра спроецированного действия определенного компонента щелкните его имя (не флажок). Планируемое действие по установке появится в поле сведений под списком продуктов.
  • Можно установить флажок рядом с компонентом продукта, чтобы изменить действие по установке для данного компонента. (Например, установка флажка при установке или удалении компонента означает, что отмеченный компонент необходимо установить или удалить, а снятие флажка означает, что компонент не следует устанавливать или удалять.)
  • Если выполняется изменение установки, при изменении выбранного продукта слева от компонентов отобразится звездочка (*).
  • Если компонент содержит необязательные для установки подкомпоненты, рядом с ним отображается значок +. Для просмотра доступных подкомпонентов компонента нажмите на значок +.
  • Если компонент уже был развернут для просмотра подкомпонентов, рядом с ним отобразится значок -. Чтобы свернуть список подкомпонентов, нажмите на значок -.

Если применяется пакет обновления, невозможно выбрать функции SOLIDWORKS, отображающиеся под SOLIDWORKS (например, FeatureWorks). Это объясняется тем, что нельзя добавить или удалить элемент при выполнении данного типа обновления.

Действия Менеджера установки SOLIDWORKS определяются набором правил сосуществования продуктов. Для получения дополнительной информации см. Правила сосуществования продуктов.

Менеджер установки SOLIDWORKS по умолчанию выбирает следующие компоненты:
  • Если выполняется модернизация или обновление, Менеджер установки SOLIDWORKS выбирает продукты, установленные на компьютере в данный момент.
  • В противном случае Менеджер установки выбирает все продукты, на которые пользователь имеет право.
Чтобы сократить время установки и скачивания и необходимый объем свободного пространства на диске, разверните список компонентов продукта и снимите флажки для компонентов, которые вам не требуются.

Если SOLIDWORKS Installation Manager не удалось проверить, на какие продукты пользователь имеет право, можно нажать Выбрать другие пакеты или продукты, чтобы выбрать другой пакет продуктов (например, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS Ultimate) для установки или изменения. Менеджер установки отображает все продукты SOLIDWORKS на носителе установки, которые совместимы с выбранным вами пакетом. Можно выбирать любые приобретенные продукты или продукты, на оценку которых пользователь имеет право.

Поиск SOLIDWORKS

Поиск в SOLIDWORKS — это мощный инструмент для полнотекстового поиска в документах SOLIDWORKS. Поиск отображает предварительный просмотр, месторасположение и имя файла.

После установки Поиск SOLIDWORKS индексирует документы SOLIDWORKS для убыстрения последующего поиска. По умолчанию индексируются только файлы SOLIDWORKS.

Языковая поддержка

Разверните продукт SOLIDWORKS и компонент Языки, чтобы узнать, какие языки можно установить.

Параметр Языки ограничивает иностранные языки, устанавливаемые для продуктов SOLIDWORKS. Это не повлияет на установки других продуктов. Например, eDrawings® и SOLIDWORKS PDM устанавливают все языки.

Требуемый объем свободного пространства

Менеджер установки SOLIDWORKS дает отчет об общем размере установки или общем размере загрузки в нижней части страницы.

  • Если выбран параметр Только загрузить, отображается размер пакета загрузки. Объем скачивания является общим объемом пространства на диске, необходимого для всех скачиваемых файлов (не включая дополнительное место, необходимое для распаковки файлов после завершения процесса скачивания). Это число является приблизительным.
    Общий размер скачивания включает все файлы, необходимые для установки. Если некоторые файлы уже были скачаны в текущую папку скачивания, они не будут скачиваться повторно. В результате фактический объем скачивания может быть меньше, чем указанный общий объем, или вам не придется скачивать файлы.
  • В противном случае отображается объем установки. Объем установки - это изменение в использовании дискового пространства, возникающее после завершения процесса установки. Из-за сжатия файлов эти показатели являются приблизительными.

    При обновлении или удалении существующей установки, объем установки может быть равен нулю.

    В это число не входит объем свободного пространства, необходимого для загрузки или извлечения файлов, если это требуется для установки.

    Если загрузка файлов необходима и все файлы загружаются на один диск, необходимый объем свободного пространства на диске может значительно превышать объем установки.

    Чтобы сократить объем загрузки или время установки для следующих модификаций, не удаляйте загруженные файлы после установки. Последующие обновления и заплаты обычно нуждаются в наличии полного набора файлов предыдущей установки.

На уровень выше Справка Менеджера установки SOLIDWORKS
Правила сосуществования продуктов


Продукты для загрузки

Выберите продукты SOLIDWORKS для загрузки в указанное месторасположение.

Доступные для загрузки продукты определяются введенным Вами серийным номером:

  • Действие, которое должно быть произведено над каждым из компонентов, отображается справа от объекта.
  • Если компонент содержит необязательные для установки субкомпоненты, после компонента отобразится значок +. Для просмотра доступных субкомпонентов компонента щелкните на значок +.
  • Если компонент уже был развернут для просмотра субкомпонентов, после него отобразится значок -. Чтобы свернуть список субкомпонентов, щелкните на значок -.
  • Установите флажок слева от каждого компонента, чтобы выбрать, каким образом он будет обработан Менеджером установки SOLIDWORKS.
Диспетчер установки SOLIDWORKS выполняет загрузку всех компонентов продуктов, на установку которых пользователь имеет право, если не указано иное. Чтобы уменьшить время загрузки и требование к количеству свободного места на диске, разверните список компонентов продукта и выберите "Не загружать" для компонентов, которые не нужны.

Если Менеджеру установки SOLIDWORKS не удалось проверить, на какие продукты пользователь имеет право, можно выбрать пакет SOLIDWORKS для установки. Менеджер установки указывает все продукты SOLIDWORKS, совместимые с выбранным вами пакетом.

Если SOLIDWORKS Installation Manager не удалось проверить, на какие продукты пользователь имеет право, можно нажать Выбрать другие пакеты или продукты, чтобы выбрать другой пакет продуктов (например, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS Ultimate) для установки или изменения. Менеджер установки отображает все продукты SOLIDWORKS на носителе установки, которые совместимы с выбранным вами пакетом. Можно выбирать любые приобретенные продукты или продукты, на оценку которых пользователь имеет право.

Языковая поддержка

Параметр "Языки" ограничивает иностранные языки, устанавливаемые для продуктов SOLIDWORKS. Это не повлияет на установки других продуктов. Например, eDrawings® устанавливает все языки.

Требуемый объем свободного пространства

В зависимости от выбранных Вами продуктов, отображается необходимый для загрузки объем свободного места. Объем загрузки является общим объемом пространства на диске, необходимого для всех загружаемых файлов (не включая дополнительное место, необходимое для распаковки файлов после завершения процесса загрузки). Это число является приблизительным.

Чтобы сократить объем загрузки или время установки следующих обновлений и пакетов, не удаляйте загруженные файлы после установки. Последующие обновления и заплаты обычно нуждаются в наличии полного набора файлов предыдущей установки.
На уровень выше Справка Менеджера установки SOLIDWORKS


Продукты для исправления

Если задан параметр Исправить эту установку, на экране отображаются те продукты SOLIDWORKS с номерами версий, которые можно исправить с помощью данной версии Менеджера установки SOLIDWORKS.

Исправление проверяет, что все файлы присутствуют и правильно зарегистрированы, и устраняет все обнаруженные ошибки. Созданные Вами данные не затрагиваются.
  • Чтобы исправить продукт, убедитесь, что он выбран.
  • Очистите все окна выбора для продуктов, которые не нуждаются в исправлении.

Чтобы начать исправление выбранных продуктов, нажмите кнопку Исправить.

Можно исправить индивидуальную установку. Невозможно исправить установку с помощью администрирующего образа; необходимо выполнить установку повторно, используя администрирующий образ.
На уровень выше Справка Менеджера установки SOLIDWORKS


Серийные номера

Серийные номера связывают ваш компьютер с приобретенными продуктами SOLIDWORKS.

Если продукты SOLIDWORKS уже установлены на компьютере, их серийные номера отображаются по умолчанию.
  • Введите серийный номер SOLIDWORKS, если он не отображается.
  • Если серийные номера продуктов не включены в лицензию SOLIDWORKS, введите их в соответствующие поля.

Если имеется соединение с Интернетом, серийные номера определяют продукты, которые вы можете использовать, в процессе установки.

Поскольку существует множество способов приобретения продуктов SOLIDWORKS, некоторые серийные номера могут принадлежать двум или нескольким продуктам. Например, серийный номер SOLIDWORKS дает возможность установить SOLIDWORKS Simulation без ввода отдельного серийного номера SOLIDWORKS Simulation. Кроме того, для некоторых продуктов серийный номер не требуется. В случае возникновения вопросов, касающихся серийных номеров, обратитесь к своему реселлеру.

На уровень выше Справка Менеджера установки SOLIDWORKS


Установка сервера

При использовании этого параметра отобразится список устанавливаемых серверов с результатами установки.

Статус установки сервера

Установка серверов выполняется внешним приложением установки. Если окно приложения закрыто, для завершения установки необходимо перейти в него.

Нажмите кнопку Отмена, чтобы остановить установку серверов.

Установка сервера завершена

Внешнее приложение установки успешно завершило процесс установки.

Выберите Готово или Далее.
  • При установке других административных приложений (например, включенных в администрирующий образ SOLIDWORKS), эта процедура установки будет продолжена.
  • Если устанавливались только серверы, Менеджер установки SOLIDWORKS будет закрыт.

Отмена или сбой установки сервера

В случае ошибки или отмены установки сервера после ее начала, отобразится список неустановленных серверов.

Выберите Закрыть или Далее.
  • Если задана установка других административных приложений, Менеджер установки SOLIDWORKS возобновит работу.
  • Если устанавливались только серверы, Менеджер установки SOLIDWORKS будет закрыт.

Дополнительная информация

Чтобы узнать больше об установке, настройке и использовании SolidNetWork License Manager, см. Администрирование лицензий с помощью SolidNetWork License Manager.

На уровень выше Справка Менеджера установки SOLIDWORKS


Сводка

В Менеджере установки SOLIDWORKS имеется вся информация, необходимая для выполнения операции установки.

Чтобы продолжить, выполните следующие действия. | Нажмите действие Сейчас, чтобы начать операцию установки (например, Установить, Создать, Загрузить, Изменить).
Чтобы изменить параметры установки, выполните следующие действия. | Нажмите кнопку ИЗМЕНИТЬ [image] рядом с тем разделом, который требуется изменить (например, Продукты, Расположение установки, Параметры Toolbox).
Чтобы отменить установку, выполните следующие действия. | Нажмите Отмена, чтобы выйти из менеджера установки SOLIDWORKS без изменения компонентов установки.
Чтобы вернуться на предыдущую страницу, выполните следующее. | Нажмите Назад, чтобы вернуться на предыдущую страницу менеджера установки SOLIDWORKS.
Чтобы получить сведения об определенном наборе параметров установки (например, Продукты, Месторасположение установки, Параметры Toolbox и т. д.):
  1. Нажмите кнопку ИЗМЕНИТЬ [image] рядом с разделом, о котором требуется получить информацию.
  2. На открывшейся странице сведений выберите Справка, чтобы получить информацию об этих параметрах установки.
На уровень выше Справка Менеджера установки SOLIDWORKS


Предупреждения проверки системы

При проверке системы обнаружены ошибки, которые могут повлиять на дальнейший процесс установки. В большинстве случаев можно будет продолжить установку с помощью Менеджера установки SOLIDWORKS.

Далее приведен список предупреждений, которые могут появляться на данном этапе, а также рекомендации по продолжению установки.

Проблемы с проверкой серийного номера

Менеджеру установки не удалось проверить наличие новых версий, так как не удалось проверить серийный номер. Если серийный номер введен правильно и Интернет-соединение установлено, возможно, на нашем сервере возникли временные проблемы. Повторите попытку позже.

Проверка серийного номера: Менеджеру установки не удалось проверить ваш серийный номер для определения продуктов, на установку которых Вы имеете право. Вы сможете выбрать продукты для установки, но не сможете загрузить установочные файлы. Для проведения установки Вам понадобятся ранее загруженный набор файлов или исходные файлы на DVD.

Разрешение:
  • Проверьте подключение к Интернету. Для проверки серийного номера требуется успешное подключение к Интернету
  • Проверьте, правильно ли указан серийный номер продукта, который вы пытаетесь установить.
  • В некоторых случаях для успешной установки требуется наличие действующей подписки на абонентские услуги на момент выпуска версии. За дополнительной информацией обратитесь к своему реселлеру SOLIDWORKS.
  • В большинстве случаев Вы сможете продолжить установку, используя для этого файлы на DVD или ранее загруженный набор файлов.

Доступные более новые версии

Доступные более новые версии

Доступные новые версии

Более новая версия продукта доступна для загрузки.

Разрешение: Во время проверки наличия обновлений вам может быть предложено установить более новую версию, доступную для загрузки с веб-сайта SOLIDWORKS. Вы можете продолжить установку, используя ранее указанную версию, либо загрузить и установить вместо нее более позднюю версию.

Используется самая последняя версия

Эта новейшая доступная версия. Нажмите Далее, чтобы продолжить.

Нет доступных новых загрузок

Разрешение: Это сообщение может появиться во время проверки наличия обновлений при установке или изменении приложений. Это означает, что Вы устанавливаете (или уже установили) самую позднюю из имеющихся версий.

Проблемы с подключением к Интернету

Подключение к Интернету: Менеджер установки не может установить соединение с сервером SOLIDWORKS для определения продуктов, на установку которых вы имеете право. Вы сможете выбрать продукты для установки, но не сможете загрузить установочные файлы. Вам понадобятся исходные файлы на DVD или ранее загруженный набор файлов.

Не удалось проверить наличие новых версий

Менеджеру установки не удалось проверить наличие более новых версий, т.к. ему не удалось подсоединиться к серверу.

Разрешение:
  • Проверьте подключение к Интернету.
  • Вы сможете продолжить установку, используя для этого файлы на DVD или ранее загруженный набор файлов.

На уровень выше Справка Менеджера установки SOLIDWORKS


Параметры Отверстия под крепеж/Toolbox

В случае установки SOLIDWORKS Toolbox, в состав SOLIDWORKS будет включена стандартная библиотека типов отверстий и оборудования.

Чтобы узнать больше о настройке, обновлении и использовании SOLIDWORKS Toolbox выберите в SOLIDWORKS Справка, см. раздел Toolbox.

Перед использованием SOLIDWORKS Toolbox убедитесь, что приложение настроено в соответствии с политикой компании или группы. Во многих случаях группа отвечает за настройку и обслуживание центрального компонента Toolbox. Узнайте у администратора SOLIDWORKS, каким образом следует задать настройки Toolbox во время установки программы SOLIDWORKS.

Выбранные параметры SOLIDWORKS Toolbox можно изменить и после установки. В SOLIDWORKS нажмите Инструменты > Параметры. На вкладке Параметры системы нажмите Отверстие под крепеж/Toolbox.

В следующих разделах описаны все параметры, которые могут появиться на экране при работе в любой из конфигураций. Фактический набор отображаемых параметров Toolbox зависит от того, какие конфигурации SOLIDWORKS и Toolbox ранее существовали на данном компьютере, а также от настроек Менеджера установки SOLIDWORKS, заданных на данный момент.

Создайте новую версию Toolbox новая-версия

Создание новой версии SOLIDWORKS Toolbox на данном компьютере.

При создании новой версии на экране "Выбор продуктов" разверните SOLIDWORKS > SOLIDWORKS Toolbox и выберите стандарты для поддержки Toolbox. По умолчанию выбираются все стандарты.

Любые компоненты Toolbox, уже существующие на данном компьютере, изменены не будут.

Создать ссылку или обновить существующий Toolbox

Использование существующего компонента Toolbox. Нажмите кнопку Обзор, чтобы указать местоположение Toolbox, которое требуется использовать для данной установки.

  • Если компонент Toolbox настроен для версии предыдущего основного выпуска SOLIDWORKS, он будет обновлен до этой версии. Любые настройки, выполненные для данного компонента Toolbox, будут сохранены в обновленном компоненте Toolbox.
    При обновлении Toolbox до новой основной версии SOLIDWORKS это приложение не будет поддерживаться на компьютерах, на которых установлены более ранние версии SOLIDWORKS.
  • Если компонент Toolbox настроен для данной версии SOLIDWORKS (например, указан Toolbox совместного пользования в сети, который уже обновлен), этот компонент уже не обновляется.
  • Если обновление Toolbox выполняется в среде SOLIDWORKS PDM, требуются дополнительные операции. Для получения дополнительной информации см. Примечания о настройке SOLIDWORKS Toolbox.

Этот параметр отображается во всех сценариях установки, за исключением создания администрирующего образа.

Обновить предыдущая версия Toolbox

Скопируйте компонент Toolbox, настроенный для версии предыдущего основного выпуска, в новую папку и обновите эту копию до данной версии.

Этот параметр отображается в том случае, если на компьютере установлена предыдущая версия основного выпуска SOLIDWORKS, однако вы не хотите обновлять установку до этого выпуска.
Цель использования данного параметра – обновление Toolbox для установленной предыдущей версии основного выпуска SOLIDWORKS, минуя компьютеры пользователей, использующих более раннюю версию Toolbox.

Если обновление Toolbox выполняется в среде SOLIDWORKS PDM, требуются дополнительные операции. Для получения дополнительной информации см. Примечания о настройке SOLIDWORKS Toolbox.

Обновить установленную версию Toolbox предыдущая-версия

Обновление Toolbox до более поздней версии.
При обновлении Toolbox до новой основной версии SOLIDWORKS это приложение не будет поддерживаться на компьютерах, на которых установлены более ранние версии SOLIDWORKS.

Этот параметр отображается в том случае, если предыдущая версия основного выпуска SOLIDWORKS обновляется до этой версии, а компонент Toolbox, настроенный для данного выпуска, найден на данном компьютере.

Если обновление Toolbox выполняется в среде SOLIDWORKS PDM, требуются дополнительные операции. Для получения дополнительной информации см. Примечания о настройке SOLIDWORKS Toolbox.

Использовать установленную версию Toolbox текущая-версия

Менеджер установки SOLIDWORKS обнаружил на компьютере компонент Toolbox, настроенный для данной версии основного выпуска SOLIDWORKS.

При выборе этого параметра в программе SOLIDWORKS будет использоваться данный компонент Toolbox. Обновление не выполняется.

Этот параметр отображается в том случае, если на компьютере установлена предыдущая версия основного выпуска SOLIDWORKS, однако компонент Toolbox настроен для данной версии. Это может иметь место в том случае, если Toolbox с общим доступом создан на компьютере, на котором все еще используется более ранняя версия SOLIDWORKS.

Укажите расположение Toolbox для клиентского компьютера

Указание сетевой папки или каталога в качестве месторасположения Toolbox по умолчанию, если клиенты устанавливаются из администрирующего образа.
Если в указанном местоположении содержится компонент Toolbox, настроенный для версии предыдущего основного выпуска SOLIDWORKS, то в момент установки клиента этот компонент Toolbox обновляется с помощью Менеджера установки SOLIDWORKS.

Этот параметр отображается при создании нового администрирующего образа.

Обновить или использовать Toolbox, на который ссылается существующий образ на клиентском компьютере

Использование расположения Toolbox, указанного в обновляемом администрирующем образе.
Если в указанном местоположении содержится компонент Toolbox, настроенный для версии предыдущего основного выпуска SOLIDWORKS, то в момент установки клиента этот компонент Toolbox обновляется с помощью Менеджера установки SOLIDWORKS.

Выберите другое расположение Toolbox для клиентского компьютера

Указание другого месторасположения Toolbox, отличного от указанного в обновляемом администрирующем образе.
Если в указанном местоположении содержится компонент Toolbox, настроенный для версии предыдущего основного выпуска SOLIDWORKS, то в момент установки клиента этот компонент Toolbox обновляется с помощью Менеджера установки SOLIDWORKS.

Содержание

  • Примечания о настройке SOLIDWORKS Toolbox

    SOLIDWORKS Toolbox — это мощный комплексный пакет программных средств. В этом разделе обобщаются некоторые понятия, необходимые для настройки Toolbox с помощью Менеджера установки SOLIDWORKS.

  • Формат UNC

    Формат Uniform (или Universal) Naming Convention (Единое соглашение об именовании) указывает, какой синтаксис имен файлов должен использоваться для описания общей папки с файлами.

На уровень выше Справка Менеджера установки SOLIDWORKS
Примечания о настройке SOLIDWORKS Toolbox


Примечания о настройке SOLIDWORKS Toolbox

SOLIDWORKS Toolbox — это мощный комплексный пакет программных средств. В этом разделе обобщаются некоторые понятия, необходимые для настройки Toolbox с помощью Менеджера установки SOLIDWORKS.

Дополнительная информация о SOLIDWORKS Toolbox

Чтобы узнать больше о настройке, обновлении и использовании SOLIDWORKS Toolbox выберите в SOLIDWORKS [image] Справка, см. раздел Toolbox.

Использование общего приложения Toolbox

При установке Toolbox данные Toolbox можно сохранить на локальном компьютере или в общей сетевой папке. Рекомендуется хранение данных Toolbox в сетевой папке. При использовании общей папки все пользователи SOLIDWORKS будут иметь доступ к одному набору данных крепежей.

При первой установке перейдите к новой общей папке, в которой требуется выполнить установку Toolbox.

Обновление существующего компонента Toolbox

При обновлении Toolbox до новой основной версии SOLIDWORKS это приложение не будет поддерживаться на компьютерах, на которых установлены более ранние версии SOLIDWORKS.

Если на других компьютерах сохраняется более ранняя основная версия и требуется приложение Toolbox для этой версии, необходимо сделать копию этого приложения и обновить ее. При установке новой версии SOLIDWORKS будет выполнено обновление копии Toolbox, а для более ранних установленных версий SOLIDWORKS будет использоваться предыдущая версия Toolbox.

Настройка доступа к Toolbox

После установки при открытии компонентов Toolbox SOLIDWORKS проверяет настройку Toolbox и предлагает варианты улучшения доступа и производительности.

Для доступа к общей сетевой установке Toolbox (рекомендуется) следует использовать путь UNC к серверу, на котором установлено это приложение. Для получения дополнительной информации см. Формат UNC.

Администратор может создать пароль для Toolbox и задать разрешения и настройки для всей рабочей группы. Ограничение доступа к конфигурации и задание стандартных настроек обеспечивает стабильность данных Toolbox.

Обновление Toolbox в среде SOLIDWORKS PDM

При обновлении программного обеспечения SOLIDWORKS элемент Toolbox также обновляется, если добавляются детали. Если корневая папка Toolbox находится в хранилище SOLIDWORKS PDM, перед обновлением SOLIDWORKS необходимо подготовить данную папку.

Чтобы выполнить обновление в первой системе, необходимо с помощью команды Получить последнюю версию загрузить файлы Toolbox в локальный кэш и отменить регистрацию файла базы данных Toolbox. В остальных обновляемых системах требуется только загрузить файлы Toolbox.

Перед обновлением:
  • Убедитесь в наличии недавней полной резервной копии базы данных и архива хранилища.
  • Проверьте, что у деталей Toolbox не отменена регистрация и они не используются в сборках, у которых отменена регистрация в данный момент.

Для обновления Toolbox выполните следующие действия.

  1. В Проводнике файлов войдите в хранилище в качестве пользователя с полными правами (на регистрацию и отмену регистрации, добавление, удаление).
  2. Нажмите правой кнопкой мыши папку Toolbox и выберите Получить последнюю версию, чтобы скопировать в локальный кэш все файлы Toolbox и базу данных Toolbox.
    Если вы используете удаленный сервер архивации, это может занять несколько минут.
  3. Разрегистрируйте файл базы данных Toolbox (SWBrowser.mdb) или (swbrowser.sldedb) из \Toolbox_folder_name\lang\your_lang.
  4. Чтобы выполнить обновление, запустите менеджер установки SOLIDWORKS.
  5. На экране Суммарная информация убедитесь, что установка Параметры Toolbox находится в хранилище.

    Если это не так, выберите Изменить, Создать ссылку или обновить существующий Toolbox и перейдите в месторасположение Toolbox в хранилище.

  6. После завершения обновления в Проводнике файлов зарегистрируйте папку Toolbox для добавления новых или обновленных файлов в хранилище, чтобы другие пользователи могли работать с Toolbox.
  7. При обновлении перейдите в папку Toolbox в хранилище и убедитесь в наличии следующих файлов и папок:
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      Если их нет, обратитесь к своему реселлеру.

  8. Обновите остальные компьютеры, которые используют интеграцию SOLIDWORKS PDM с Toolbox.
    1. С помощью Проводника файлов войдите в хранилище от имени пользователя, обладающего разрешением на чтение папки Toolbox.
    2. Правой кнопкой мыши щелкните папку Toolbox и выберите Получить последнюю версию, чтобы скопировать файлы Toolbox в локальный кэш.
    3. Чтобы выполнить обновление, запустите менеджер установки SOLIDWORKS.

      Программа установки обнаруживает, что средство Toolbox уже обновлено.

Дополнительные сведения о конфигурации Toolbox в SOLIDWORKS PDM см. в разделе Настройка Toolbox в справке инструмента администрирования SOLIDWORKS PDM.

На уровень выше Параметры Отверстия под крепеж/Toolbox
Формат UNC


Формат UNC

Формат Uniform (или Universal) Naming Convention (Единое соглашение об именовании) указывает, какой синтаксис имен файлов должен использоваться для описания общей папки с файлами.

\\server\volume\path

Пример:

\\Disk_Server\SOLIDWORKS\AdminImage

На уровень выше Параметры Отверстия под крепеж/Toolbox
Примечания о настройке SOLIDWORKS Toolbox


Установка продуктов

Если выбрать Удалить или Отменить установку на панели управления, на экране отобразятся продукты SOLIDWORKS (с номерами версий), которые можно удалить с помощью данной версии Менеджера установки SOLIDWORKS. Можно выбрать вариант отмены установки: стандартная, по выбору и полная.

При стандартной отмене установки удаляются программные папки и файлы продукта SOLIDWORKS. Во время стандартной отмены установки по умолчанию выполняется удаление всех продуктов SOLIDWORKS выбранного выпуска.

При отмене установки по выбору удаляются один или несколько из следующих элементов: программные файлы и папки, разделы реестра и папки данных, такие как SOLIDWORKS Toolbox, а также файлы и папки из исходной папки загрузки.

При полной отмене установки удаляются каталоги установки, разделы реестра и папки данных.

Порядок отмены установки продукта
  1. На экране Отмена установки убедитесь, что выбран требуемый продукт.

    При удалении всех продуктов удаляется и менеджер установки SolidWorks.

  2. Отмените выбор продуктов, которые Вы не хотите удалять.

    В случае сохранения любого продукта Менеджер установки SOLIDWORKS не удаляется.

  3. Выберите для выполнения полную установку или настраиваемую пользователем.
    1. Нажмите кнопку Изменить в разделе Дополнительные параметры.

      Откроется экран Дополнительные параметры. Флажок "Файлы и папки программ" установлен.

    2. Выберите один или несколько параметров, чтобы выполнить отмену установки по выбору, или все параметры, чтобы выполнить полную отмену установки.
    3. Нажмите Назад в Сводку.
    4. На экране Сводка разверните Дополнительные параметры, чтобы отобразить удаляемые объекты и метод отмен установки.
  4. Выберите Удалить объект.
При нажатии кнопки Удалить объекты Менеджер установки SOLIDWORKS немедленно запустит процесс удаления продуктов.
На уровень выше Справка Менеджера установки SOLIDWORKS


Установка

SOLIDWORKS Design Augmented обеспечивает доступ ко всем сервисам и приложениям 3DEXPERIENCE, которые вы можете использовать в соответствии с вашей ролью.

Лицензирование

3DEXPERIENCE Platform применяет лицензирование именованного пользователя. Лицензия назначается, когда администратор предоставляет вам роль. Роль определяет, какие сервисы и приложения 3DEXPERIENCE вы имеете право использовать. Лицензию можно использовать на любом устройстве. Лицензия не привязана к конкретному компьютеру.

Дополнительные сведения см. в разделе Основные принципы лицензирования DS.

Программа запуска 3DEXPERIENCE

При первой установке SOLIDWORKS Design Augmented платформа 3DEXPERIENCE platform предлагает скачать и установить 3DEXPERIENCE Launcher. Launcher (программа запуска) — это фоновая служба, которая помогает исходным приложениям, таким как SOLIDWORKS Design Augmented, получать доступ к платформе. После установки на панели задач Windows отображается значок программы запуска [image].

Дополнительные сведения см. в разделе Программа запуска 3DEXPERIENCE. Для доступа к разделу поддержки пользователей Dassault Systèmes требуются учетные данные 3DEXPERIENCE.


SOLIDWORKS Visualize Boost

SOLIDWORKS Visualize Boost — это приложение, которое позволяет передавать задания отрисовки с компьютера, на котором запущено приложение SOLIDWORKS Visualize Professional, на один или несколько компьютеров в сети.

В результате готовые изображения становятся доступными быстрее, и во время отрисовки в фоновом режиме можно выполнять другие задачи. Отрисовку изображений можно выполнить на одном компьютере или в кластере нескольких компьютеров под управлением Visualize Boost.

Каждая активная подписка SOLIDWORKS Visualize Professional включает одну дополнительную лицензию SOLIDWORKS Visualize Boost.

Увеличение производительности, например, ускорение отрисовки, зависит от мощности компьютеров Visualize Boost. Компьютеры с более качественными графическими процессорами обеспечат лучшие результаты.


Обновление индивидуальной лицензии до лицензии SolidNetWork

Можно выполнить обновление компьютера с индивидуальной лицензии SOLIDWORKS до лицензии SolidNetWork, указав серийный номер лицензии SolidNetWork в Менеджере установки SOLIDWORKS.

Если программа SOLIDWORKS на компьютере не установлена, можно указать лицензию SolidNetWork, введя серийный номер лицензии SolidNetWork при установке с помощью Менеджера установки SOLIDWORKS.

Если программа SOLIDWORKS установлена и выполняется обновление индивидуальной лицензии до лицензии SolidNetWork, можно изменить установку для клиентского компьютера и при запуске Менеджера установки SOLIDWORKS вместо серийного номера индивидуальной лицензии указать серийный номер лицензии SolidNetWork. Для получения дополнительных сведений см. раздел Изменение установки.
Если программа SOLIDWORKS установлена с помощью администрирующего образа, параметр изменения будет недоступен. Внести изменения в административный образ можно с помощью редактора параметров администрирующего образа, затем удалить клиента и перезапустить установку.


Работа с Visualize Boost

Чтобы включить функцию передачи отрисовки, необходимо подключить SOLIDWORKS Visualize к Visualize Boost после его настройки.

Для подключения Boost в SOLIDWORKS Visualize нужно указать значения IP-адрес координатора и Порт Boost.

Оставьте Visualize Boost и SOLIDWORKS Visualize открытыми на время выполнения следующих действий.

Чтобы подключить SOLIDWORKS Visualize к Visualize Boost, выполните следующие действия.

  1. Откройте Visualize Boost, дважды нажав на ярлык на рабочем столе [image].
  2. Дважды нажмите на IP-адрес координатора в Visualize Boost, чтобы скопировать его в буфер обмена.
  3. В SOLIDWORKS Visualize нажмите Инструменты > Параметры > Boost и нажмите CTRL+V, чтобы вставить IP-адрес координатора.
  4. Повторите шаги 2 и 3, чтобы скопировать Порт Boost из Visualize Boost в SOLIDWORKS Visualize.
    В Visualize Boost и SOLIDWORKS Visualize Boost должен быть указан один и тот же Порт Boost.
    В SOLIDWORKS Visualize появится элемент управления Статус Boost.
  5. Нажмите OK для закрытия диалогового окна Параметры.
  6. Для подключения к Boost нажмите на элемент управления Статус Boost [image] или отключите [image] в этих интерфейсах:
    • Дисплей HUD
    • Страница "Качество мастера отрисовки"
    • Вкладка Инструменты Параметры Boost

Подробные сведения о конфигурации Boost см. в разделе SOLIDWORKS Visualize Boost.


Инициализация нового сервера лицензий SolidNetWork

Чтобы инициализировать новый сервер лицензий SolidNetWork, выполните следующие действия.

  1. После установки и открытия сервера SolidNetWork License Manager нажмите Да при появлении запроса на активацию.
  2. В диалоговом окне Сведения о сервере лицензий SolidNetWork проверьте поля Брандмауэр и Порты и нажмите Далее.
  3. В мастере активации продукта выберите Серийные номера, которые необходимо активировать, выберите Вручную по электронной почте в качестве способа активации и введите Адрес электронной почты.

    Для ручного способа необходимо создать файл запроса и отправить его по электронной почте на адрес activation@solidworks.com. После получения электронного письма с ответным файлом, содержащим лицензию, извлеките файл и нажмите Открыть, чтобы загрузить его на сервер.

    Вы можете закрыть и заново запустить мастер активации продукта, чтобы открыть и загрузить ответный файл.

  4. При появлении сообщения об успешной инициализации нажмите OK, в мастере активации продукта нажмите Готово.


Активация нового сервера SolidNetWork License Manager вручную

После инициализации сервера SolidNetWork License Manager откройте сервер SolidNetWork License Manager и создайте второй запрос для завершения активации.

Чтобы вручную активировать новый сервер SolidNetWork License Manager, выполните следующие действия.

  1. Выполните одну из следующих операций.
    • Если отображается запрос на активацию, нажмите Да.
    • Если запрос не отображается, нажмите кнопку Изменить на вкладке Администрирование сервера.
    В разделе "Дополнительные параметры" по умолчанию выбран режим Использовать активацию.
  2. Проверьте поля Брандмауэр и Порты в диалоговом окне "Сведения о сервере лицензий SolidNetWork" и нажмите Далее.
  3. В окне мастера активации продукта выберите Серийные номера, которые необходимо активировать, укажите Адрес электронной почты и выберите Вручную по электронной почте в качестве способа активации.
  4. Следуйте инструкциям по созданию файла запроса и отправьте его по электронной почте на адрес activation@solidworks.com. Когда вы получите ответный файл с лицензией, нажмите Открыть, чтобы загрузить файл.
  5. Нажмите Готово после завершения активации.


Ручная активация обновленного сервера SolidNetWork License Manager

После обновления сервера SolidNetWork License Manager с помощью менеджера установки SOLIDWORKS откройте сервер SolidNetWork License Manager.

Для ручной активации обновленного сервера SolidNetWork License Manager:

  1. на вкладке Администрирование сервера в разделе Информация о лицензии нажмите Повторно активировать.
    Если лицензии были деактивированы до удаления и обновления сервера SolidNetWork License Manager, нажмите Изменить на вкладке Администрирование сервера. Опция Повторно активировать доступна только при наличии активированных лицензий на сервере.

    Перейдите к шагу 3.

  2. В диалоговом окне Повторно активировать выберите установленные серийные номера для просмотра связанных лицензий и нажмите Повторно активировать.
  3. Проверьте поля Брандмауэр и Порты в диалоговом окне Сведения о сервере лицензий SolidNetWork и нажмите Далее.
  4. В окне мастера активации продукта выберите Серийные номера, которые необходимо активировать, укажите Адрес электронной почты, и выберите Вручную по электронной почте в качестве способа активации.
    Активация вручную — это легко. Инструкции в мастере активации продукта помогут с ней справиться.
  5. Нажмите Готово после завершения активации.