Очереди IDM
У IDM имеется две основных очереди: очередь разовой загрузки и очередь синхронизации. Также, Вы можете создать любое число дополнительных очередей.
Вы можете запланировать время запуска и остановки обработки очередей загрузки/синхронизации, или Вы можете запустить или остановить обработку очередей вручную. В главном списке загрузки IDM имеется столбец "О" (от «Очередь»), который показывает, к очереди какого типа принадлежит загрузка.
Иконка с тремя желтыми файлами означает, что загрузка принадлежит к основной очереди разовой загрузки, иконка с тремя зелеными файлами указывает на принадлежность к основной очереди синхронизации. Иконка с двумя желтыми или двумя зелеными файлами говорит о том, что загрузка принадлежит к дополнительной очереди разовой загрузки или синхронизации соответственно. Если для очереди запланировано начало обработки, то на ее иконке будет присутствовать небольшой символ часиков.
В поле "Категории" главного окна IDM имеется узел "Очереди", который демонстрирует список очередей.
Когда Вы выбираете очередь в списке, в основном перечне загрузки IDM отображаются только те файлы, что принадлежат к выбранной очереди. Для очередей в этом списке имеется простое и удобное контекстное меню.
Для демонстрации контекстного меню Вы можете либо нажать правой кнопкой мыши на очередь, либо нажать на клавиатуре кнопку отображения контекстного меню.
Когда Вы добавляете новый файл для загрузки, IDM по умолчанию помещает его в главную очередь разовой загрузки, и удаляет его из очереди, когда загрузка завершена.
Вы можете добавить или переместить файлы из одной очереди в другую следующими способами:
  • используя соответствующий пункт контекстного меню в основном списке загрузки
  • используя в главном окне IDM перетаскивание из главного списка загрузки в список очередей
  • используя в окне Планировщика IDM перетаскивание из списка файлов в список очередей. Учтите, что уже загруженные файлы не будут помещены в очереди разовой загрузки - только в очереди синхронизации
Запуск и остановка обработки очередей
После запуска обработки очереди, IDM начинает загружать один или несколько файлов из очереди одновременно. Вы можете указать количество одновременно загружаемых файлов в соответствующем поле на вкладке "Планировщик->Файлы в очереди" индивидуально для каждой очереди
Вы можете запустить или остановить обработку очередей следующими способами:
  • используя кнопки Запуск и Остановка в основной панели инструментов IDM для запуска или остановки обработки основных очередей
  • используя выпадающее меню возле кнопок Запуск и Остановка в основной панели инструментов для запуска или остановки остальных очередей. Когда Вы нажмете на кнопку выпадающего меню, IDM отобразит список очередей, доступных для выбора

  • используя такие пункты основного меню IDM, как "Загрузка->Запустить очередь->Запустить очередь [Название соответствующей очереди]" и "Загрузка->Остановить очередь->Остановить очередь [Название соответствующей очереди]"
  • используя пункты "Запустить" и "Остановить" контекстного меню очереди в списке очередей поля "Категории"
  • используя кнопки Запустить и Остановить в диалоге "Планировщик"
  • путем планирования времени запуска и остановки обработки очередей в диалоге "Планировщик"


Планировщик
Чтобы открыть диалог "Планировщик", Вы можете нажать кнопку Очередь, или выбрать пункт головного меню "Загрузка->Планировщик", или же нажать "Изменить", "Расписание", "Создать новую очередь" в контекстном меню списка очередей в окне "Категории".

Здесь Вы можете просмотреть список очередей и выбрать любую из них. Каждая из выбранных очередей будет содержать индивидуальную информацию на вкладках "Расписание" и "Файлы в очереди". Вы можете вручную запустить очередь, нажав кнопку Запустить. Или же можете наметить время, как для запуска обработки очереди, так и для ее остановки.
IDM обрабатывает очередь загрузки и удаляет файлы из очереди, когда загрузка завершена. Чтобы задать очередь такой разовой загрузки Вы должны выбрать пункт "Разовая загрузка".
Когда IDM обрабатывает очередь синхронизации, он производит проверку, были ли файлы из очереди изменены на сервере и, если изменения производились, IDM загрузит обновленные файлы и заменит ими старые. Чтобы задать очередь синхронизации Вы должны выбрать пункт "Периодическая синхронизация". Переключение между пунктами "Разовая загрузка" и "Синхронизация" доступно только для дополнительных пользовательских очередей.
При следующей синхронизации будет можно запустить многократную обработку очереди через интервал, заданный в минутах/часах. Планировщик будет периодически обрабатывать очередь до времени, указанного в "Закончить загрузку в" или до конца дня, если время завершения не задано.
Можно остановить любую очередь в указанное время, если Вы отметите пункт "Закончить загрузку в" и укажете время. Заметьте, что очередь будет остановлена независимо от состояния поля "Начать загрузку в".
Если IDM не может загрузить файл, он помещает его в конец очереди и запускает загрузку следующего файла. Если файл, который IDM не удалось загрузить, останется один в очереди, то IDM будет повторять попытки загрузки этого файла с интервалом 30 секунд между повторами, пока, в конечном итоге, файл не будет загружен.
Иногда в очереди встречаются файлы, которые не могут быть загружены вообще, например, если они были удалены с сайта. В этом случае, IDM будет пытаться их загрузить неопределенно долго. Если Вы желаете ограничить число попыток загрузки для таких файлов и, возможно, хотите, чтобы IDM проделал некоторые действия по завершении загрузки остальных файлов очереди, Вам нужно отметить пункт "Количество попыток загрузки файла в случае неудачи" и указать желаемое число попыток.
Существует возможность запланировать некоторые действия по завершении загрузки очереди. Чтобы завершить Ваше модемное соединение, отметьте пункт "Отключить модем от сети по завершении". Если Вы выберете пункт "Выключить компьютер по завершении", Ваш компьютер будет выключен по завершении обработки очереди. Используйте опцию "Принудительно завершать процессы" осторожно, так как это может привести к потери данных сторонними приложениями. Также, Вы можете открыть файл или выполнить команду по окончании обработки очереди. Если необходимо запустить несколько файлов, Вы можете создать bat-файл и прописать его в "Открыть по завершении следующий файл".
Заметьте, что вышеописанные действия не будут инициированы, если обработку очереди остановить вручную.
На вкладке "Файлы в очереди" Вы можете просмотреть и изменить порядок файлов в очереди.

Вы можете изменить порядок загрузки одного или нескольких файлов с помощью кнопок со стрелками или при помощи перетаскивания. Вы, также, можете удалить задания по загрузке с помощью кнопки удаления. В дальнейшем, Вы сможете добавить файл в очередь загрузки в главном окне программы, нажав на имени файла правой кнопкой мыши и выбрав "Добавить в очередь". Или же другими способами.
При помощи перетаскивания Вы можете переместить файл в другую очередь из списка очередей в левой части окна. Учтите, что уже загруженные файлы не будут помещены в очереди разовой загрузки - только в очереди синхронизации.
После запуска обработки очереди, IDM начинает загружать один или несколько файлов из очереди одновременно. Вы можете указать количество одновременно загружаемых файлов в соответствующем поле для каждой очереди индивидуально.
Существуют сайты, которые не позволяют устанавливать более одного соединения для одного компьютера. Если Вы хотите загрузить несколько файлов с такого сайта, Вам придется создать отдельную очередь для этого сайта и установить для нее "Загружать" 1 "файла(ов) одновременно". Также, необходимо добавлять подобные сайты в список исключений IDM на вкладке "Опции->Соединение", чтобы всегда загружать один файл используя только одно соединение.
Ограничения по загрузке
Если Вы хотите определить квоты загрузки для Вашего интернет-соединения, Вам необходимо задать ограничения по загрузке. Это полезно для соединений, у которых задана некая равновесная политика доступа (такие как Direcway, Direct PC, Hughes и пр.). Скажем, Вы установили 40МБ/час (или не более 150МБ каждые 4 часа). IDM загрузит максимум, доступный ему по квоте и, затем, продолжит загрузку автоматически в более позднее время. Подобным образом Вы сможете загрузить большие файлы на максимально возможной скорости.

Сохранение настроек Планировщика
Изменения наполнения и расположения очередей сохраняются немедленно. Остальные изменения сохранятся, когда Вы нажмете кнопку Применить или, независимо от кнопки Применить, если Вы перемещаетесь между очередями или когда Вы закрываете диалог "Планировщик". Вы должны воспользоваться кнопкой Применить, если хотите сохранить изменения и при этом все еще видеть ту же самую очередь в том же самом окне.