Начало загрузки

Начало загрузки с помощью IDM.
Есть несколько способов начала загрузки с помощью Internet Download Manager.
1) IDM перехватывает загрузки из Internet Explorer, MSN Explorer, AOL, Opera, Mozilla и Netscape и многих других браузеров.
Этот метод самый простой. Если Вы нажимаете на загрузочной ссылке в Internet Explorer или в другом браузере, IDM перехватит и ускорит эту загрузку. В этом случае Вам не нужно делать ничего особенного, просто работать в Интернет, как Вы обычно это делаете. IDM перехватит загрузку из Internet Explorer, если тип загружаемого файла соответствует списку расширений в IDM. Список расширений файлов для загрузки при помощи IDM может быть отредактирован в диалоге "Опции->Общее". Если IDM перехватил загрузку, он покажет следующий диалог:
Если Вы нажмете кнопку Загрузить позже, файл будет добавлен в список загрузки, но процесс загрузки не начнется. Если Вы нажмете кнопку Начать загрузку, IDM начнет загрузку файла немедленно. IDM позволяет Вам сортировать Ваши загрузки по категориям. IDM предлагает категорию и заданную по умолчанию папку для сохранения загруженного файла согласно его типу. Вы можете редактировать категории, удалять и добавлять новые категории в Основном окне IDM. Если Вы хотите увидеть содержимое ZIP-файла перед загрузкой, Вы можете нажать кнопку Предосмотр.

Если Вы будете удерживать клавишу CTRL при нажатии мышью на ссылке в Internet Explorer, IDM перехватит любую загрузку (для этого Вы должны включить опцию "Использовать CTRL для принудительной загрузки с помощью IDM" в диалоге "Опции->Общее").

Если Вы будете удерживать клавишу ALT при нажатии мышью на ссылке, IDM не будет перехватывать загрузку и позволит Internet Explorer загрузить этот файл (для этого Вы должны включить опцию "Использовать ALT для запрета загрузки ссылок с помощью IDM" в диалоге "Опции->Общее").

Если Вы не хотите, чтобы IDM перехватывал загрузку из браузера, выключите интеграцию в браузер в настройках IDM. После отключения интеграции в диалоге "Опции->Общее" не забудьте перезапустить браузер.

Запомните, что если у Internet Download Manager возникли проблемы с загрузкой файла, Вы должны удерживать ALT при нажатии мышью на ссылке, чтобы позволить браузеру самому загрузить файл.

2) IDM следит за буфером обмена на предмет поиска "правильных" URL (веб-адресов).
IDM следит за буфером обмена на предмет поиска URL по специальным типам расширений. Как только веб-адреса попадают в буфер обмена, IDM отображает диалог начала загрузки.
Если Вы нажмете кнопку OK, IDM начнет загрузку.
3) Интеграция IDM в меню IE по нажатию правой кнопки мыши.
Если Вы нажмете правой кнопкой мыши на ссылке в Internet Explorer, Вы увидите в контекстном меню пункт "Загрузить с помощью IDM". Вы можете загрузить конкретные ссылки или все ссылки выделенного текста на веб-странице.
Эта возможность загрузки файлов полезна, когда IDM не может начать загрузку автоматически. Просто выберите этот пункт меню для запуска загрузки ссылки с помощью IDM. Вы можете также выделить участок текста в Internet Explorer и нажать "Загрузить с помощью IDM" для добавления всех ссылок в выделенном тексте в IDM.
4) Вы можете вручную ввести URL в IDM, нажав кнопку "Добавить":
Подробнее смотрите в разделе Основное окно справки о программе.
5) Перетаскивание ссылок из Internet Explorer в основное окно IDM или загрузочную корзину
Загрузочная корзина - это окно, принимающее гиперссылки из браузеров Internet Explorer, Netscape, Mozilla, AOL или Opera. Вы можете перетащить ссылку из своего браузера в это окно для начала загрузки с помощью IDM.
Если хотите скрыть данное окно, просто закройте его. Позже, если захотите, Вы сможете восстановить его снова, нажав в главном меню "Задачи-> Показывать корзину".
6) Вы можете начать загрузку из командной строки, воспользовавшись соответствующими параметрами
Вы можете запустить IDM из командной строки со следующими параметрами:
idman /s
или idman /d URL [/p локальный_путь] [/f локальное_имя_файла] [/q] [/h] [/n] [/a]
Параметры:
/d URL - загрузка файла
Пример IDMan.exe /d "http://www.internetdownloadmanager.com/path/File Name.zip"
/s - запуск очереди из Планировщика
/p локальный_путь - задание локального пути для сохранения файла
/f локальное_имя_файла - задание локального имени для сохранения файла
/q - IDM будет закрыт по завершении загрузки. Этот параметр работает только для первой копии
/h - IDM прервет Ваше соединение по завершении загрузки
/n - переключение в "тихий" режим, когда IDM не задает ни каких вопросов
/a - передает файл, указанный в /d в очередь загрузки, но не начинает загрузку
Параметры /a, /h, /n, /q, /f локальное_имя_файла, /p локальный_путь работают только, если указанный файл загружен через /d URL
Примеры
C:\>idman.exe /n /d http://www.tonec.com/download/idman403.exe


Интеграция в браузеры
Если Вы хотите изменить параметры Интеграции в браузер, Вам необходимо открыть Опции IDM нажав кнопку Опции на Панели инструментов IDM.
Вкладка "Общее"
Вкладка "Общее" может использоваться для изменения параметров интеграции IDM в систему: автоматический запуск, интеграция в браузеры, отслеживание попадающих в буфер обмена URL. IDM по умолчанию интегрируется в Internet Explorer, Opera, Mozilla, Netscape и множество других популярных браузеров.
IDM поддерживает базовый и расширенный тип интеграции в браузеры. При базовой интеграции в браузеры Вы можете проверить, какой тип интеграции использует конкретный браузер. Для этого выберите браузер и нажмите кнопку Детали. Добавить браузер для базовой интеграции Вы можете с помощью кнопки Добавить браузер. IDM определит версию браузера и произведет интеграцию в него.
IDM имеет специальный модуль (IEMonitor.exe) для отслеживания нажатий в браузерах на основе IE (MSN Explorer, Avant, MyIE, некоторые версии AOL, пр.), работающий отдельно от основного процесса IDM. Данный модуль может быть вкл./откл. с помощью опции "Отслеживать нажатия в браузерах на основе IE".
Расширенная интеграция в браузеры может быть применена для интеграции IDM в приложения использующие протоколы FTP или HTTP. Если у Вас возникли проблемы при использовании расширенной интеграции в браузеры, Вы можете отключить ее, перейдя к базовой интеграции.
Если Вам необходимо интегрировать IDM в новый браузер или какое-нибудь приложение, использующее протоколы загрузки HTTP или FTP, пожалуйста, включите опцию "Обнаруживать новые приложения". Тогда, когда Вы запустите это приложение и попробуете загрузить файл, имеющий расширение, соответствующее списку автоматической загрузки, IDM перехватит загрузку от этого приложения и добавит приложение к списку браузеров.
Настройка специальных клавиш позволит Вам установить различные клавиши для принудительной загрузки или предотвращения оной с помощью IDM. После нажатия кнопки Клавиши откроется диалог "Использование специальных клавиш". Вы можете выбрать комбинацию из одной или более клавиш, подходящих для Вашего браузера. Знайте, что IDM может быть интегрирован в Opera и СТАРЫЕ браузеры, основанные на Mozilla, с помощью плагинов. Но данная интеграция не поддерживает специальные клавиши принудительной загрузки или ее предотвращения. Если Вы хотите использовать данные специальные клавиши, воспользуйтесь расширенной интеграцией в браузеры.